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Preface
Autodesk Inventor 2016

Autodesk Inventor, developed by Autodesk Inc., is one of the world’s fastest growing solid modeling
software. It is a parametric feature-based solid modeling tool that not only unites the 3D parametric features
with 2D tools but also addresses every design-through-manufacturing process. The adaptive technology of
this solid modeling tool allows you to handle extremely large assemblies with tremendous ease. Based
mainly on the feedback of the users of solid modeling, this tool is known to be remarkably user-friendly and
it allows you to be productive from day one.

This solid modeling tool allows you to easily import the AutoCAD, AutoCAD Mechanical, Mechanical
Desktop, and other related CAD files with an amazing compatibility. Moreover, the parametric features and
assembly parameters are retained when you import the Mechanical Desktop files in Autodesk Inventor.

The drawing views that can be generated using this tool include orthographic view, isometric view,
auxiliary view, section view, detailed view, and so on. You can use predefined drawing standard files for
generating the drawing views. Moreover, you can retrieve the model dimensions or add reference
dimensions to the drawing views whenever you want. The bidirectional associative nature of this software
ensures that any modification made in the model is automatically reflected in the drawing views. Similarly,



any modifications made in the dimensions in the drawing views are automatically reflected in the model.

Autodesk Inventor 2016 for Designers textbook is written with the intention of helping the readers
effectively use the Autodesk Inventor 2016 solid modeling tool. The mechanical engineering industry
examples and tutorials are used in this textbook to ensure that the users can relate the knowledge of this
book with the actual mechanical industry designs. The salient features of this textbook are as follows:

* Tutorial Approach
The author has adopted the tutorial point-of-view and the learn-by-doing approach throughout the
textbook. This approach guides the users through the process of creating the models in the tutorials.

* Real-World Projects as Tutorials The author has used about 54 real-world mechanical engineering
projects as tutorials in this book. This enables the readers to relate these tutorials to the real-world
models in the mechanical engineering industry. In addition, there are about 40 exercises that are also
based on the real-world mechanical engineering projects.

* Coverage of All Autodesk Inventor Modules All modules of Autodesk Inventor are covered in this
book including the Presentation module for animating the assemblies, the Sheet Metal module for
creating the sheet metal components, the Weldment module for creating weldments, and Mold design
module for creating mold.

* Tips and Notes
Additional information on various topics is provided to the users in the form of tips and notes.

* Heavily Illustrated Text The text in this book is heavily illustrated with about 1300 line diagrams and
screen capture images.

* Learning Objectives The first page of every chapter introduces in brief the topics that are covered in that
chapter. This helps the users to easily refer to a topic.

* Command Section
In every chapter, the description of a tool begins with the command section that gives a brief
information of various methods of invoking that tool.

* Self-Evaluation Test, Review Questions, and Exercises Every chapter ends with Self-Evaluation Test so
that the users can assess their knowledge of the chapter. The answers to the Self-Evaluation Test are given
at the end of the chapter. Also, the Review Questions and Exercises are given at the end of each chapter and
they can be used by the Instructors as test questions and exercises.



Formatting Conventions Used in the Textbook Please refer to the following list for the

formatting conventions used in this textbook.
+ Names of tools, buttons, options, panels, tabs, and Ribbon are written in boldface.

» Names of dialog boxes, drop-downs, drop-down lists, list boxes, areas, edit boxes, check boxes, and radio
buttons are written in boldface.

 Values entered in edit boxes are written in boldface.

* Names and paths of the files are written in italics.
* The methods of invoking a tool/option from the Ribbon, Quick Access Toolbar, Application Menu are
enclosed in a shaded box.

Ribbon: Get Started > Launch > New Quick Access Toolbar: New Application Menu: New
Example: The Extrude tool, the Finish Sketch button, the Modify panel, the Sketch tab, and so on.

Example: The Revolve dialog box, the Start 2D Sketch drop-down of Sketch panel in the Model tab, the
Placement drop-down in the Hole dialog box, the Distance edit box of the Extrude dialog box, the
Extended Profile check box in the Rib dialog box, the Drilled radio button in the Hole dialog box, and so
on.

Example: Enter 5 in the Radius edit box.

Example: C:\Inventor2016\c03, c03tut03.prt, and so on

Naming Conventions Used in the Textbook Tool

If you click on an item in a toolbar or a panel of the Ribbon and a command is invoked to create/edit an
object or perform some action, then that item is termed as tool.



For example:
To Create: Line tool, Dimension tool, Extrude tool To Edit: Fillet tool, Draft tool, Trim Surface tool
Action: Zoom All tool, Pan tool, Copy Object tool

If you click on an item in a toolbar or a panel of the Ribben and a dialog box is invoked wherein you can
set the properties to create/edit an object, then that item is also termed as tool, refer to Figure 1.

For example:
To Create: Create iPart tool, Parameters tool, Create tool To Edit: Styles Editor tool, Document
Settings tool

ECIPEEN sketch  Inspect  Tools Manage  View  Environments BIM  GetStated  Vault  AutodeskA360 €8+
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Figure 1 Various tools in the Ribbon

Button
The item in a dialog box that has a 3d shape like a button is termed as Button. For example, OK button,
Cancel button, Apply button, and so on.

Dialog Box
The naming conventions used for the components in a dialog box are mentioned in Figure 2.
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Figure 2 The components in a dialog box

A drop-down is one in which a set of common tools are grouped together. You can identify a drop-down
with a down arrow on it. These drop-downs are given a name based on the tools grouped in them. For
example, Arc drop-down, Fillet/Chamfer drop-down, Work Axis drop-down, and so on; refer to Figure 3.
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Figure 3 The Arc, Fillet/Chamfer, and Work Axis drop-downs

Drop-down List

A drop-down list is the one in which a set of options are grouped together. You can set various parameters
using these options. You can identify a drop-down list with a down arrow on it. For example, Extents drop-
down list, Color Override drop-down list, and so on, refer to Figure 4.

T

fd *Alumingn =
H*Aluminum Cast | i
-Numinum Frame - Anodized Di' :
nhluminum Frame - Painted Wh:
B american Cherry

B andircba

H sndiroba - Matural

W 2nodized - Black
.Anodized - Blue

i Anodized - Blue-Gray
Il Anodized - Bronze
E.ﬁ.nndizad - Dark Bronze
W Anodized - Dark Gray

& Anodized - Gray

M Anodized - Gray Textured
il Anodized - Light Gray

B Anodized - Red

Figure 4 The Extents and Color Override drop-down lists

Options

Options are the items that are available in shortcut menu, Marking Menu, drop-down list, dialog boxes, and
so on. For example, choose the New Sketch option from the Marking Menu displayed on right-clicking in
the drawing area; choose the Background Image option from the Background drop-down list; choose the
Front option from the Orientation area, refer to Figure 5.
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Figure 5 Options in the shortcut menu, Background drop-down list, and the Style Type area

Free Companion Website

It has been our constant endeavor to provide you the best textbooks and services at affordable price. In this
endeavor, we have come out with a Free Companion website that will facilitate the process of teaching and
learning of Autodesk Inventor 2016. If you purchase this textbook, you will get access to the files on the
Companion website.

To access the files, you need to register by visiting the Resources section at www.cadcim.com. The
following resources are available for the faculty and students in this website:

Faculty Resources
* Technical Support You can get online technical support by contacting techsupport@cadcim.com.

* Instructor Guide Solutions to all review questions and exercises in the textbook are provided in this link
to



help the faculty members test the skills of the students.

* PowerPoint Presentations The contents of the book are arranged in PowerPoint slides that can be used
by the faculty
for their lectures.

« Part Files
The part files used in illustration, tutorials, and exercises are available for free download.

Student Resources

* Technical Support You can get online technical support by contacting techsupport@cadcim.com.

* Part Files
The part files used in illustrations and tutorials are available for free download.

* Additional Students Projects Various projects are provided for the students to practice.

Note that you can access the faculty resources only if you are registered as faculty at
www.cadcim.com/Registration.aspx

If you face any problem in accessing these files, please contact the publisher at sales@cadcim.com or the
author at stickoo@purduecal.edu or tickoo525@gmail.com.

Stay Connected

You can now stay connected with us through Facebook and Twitter to get the latest information about our
text books, videos, and teaching/learning resources. To stay informed of such updates, follow us on
Facebook (www.facebook.com/cadcim) and Twitter (@cadcimtech). You can also subscribe to our You
Tube channel (www.youtube.com/cadcimtech) to get the information about our latest video tutorials.



Chapter 1
Introduction

Learning Objectives

 Understand how to open a new part file in Autodesk Inventor.
 Understand various terms used in sketching environment.

* Understand the usage of various hotkeys.

* Customize hotkeys.

» Modify the color scheme in Autodesk Inventor.

INTRODUCTION TO AUTODESK INVENTOR 2016

Welcome to the world of Autodesk Inventor. If you are new to the world of
three-dimensional (3D) design, then you have joined hands with thousands of
people worldwide who are already working with 3D designs. If you are already
using any other solid modeling tool, you will find this solid modeling tool more
adaptive to your use. You will find a tremendous reduction in the time taken to
complete a design using this solid modeling tool.

Autodesk Inventor is a parametric and feature-based solid modeling tool. It
allows you to convert the basic two-dimensional (2D) sketch into a solid model
using very simple, but highly effective modeling options. This solid modeling
tool does not restrict its capabilities to the 3D solid output, but also extends them
to the bidirectional associative drafting. This means that you only need to create
the solid model. Its documentation, in the form of the drawing views, is easily
done by this software package itself. You just need to specify the required view.



This solid modeling tool can be specially used at places where the concept of
“collaborative engineering” is brought into use. Collaborative engineering is a
concept that allows more than one user to work on the same design at the same
time. This solid modeling package allows more than one user to work
simultaneously on the same design.

As a product of Autodesk, this software package allows you to directly open the
drawings of the other Autodesk software like AutoCAD, Mechanical Desktop,
AutoCAD LT, and so on. This interface is not restricted to the Autodesk
software only. You can easily import and export the drawings from this software
package to any other software package and vice versa.

To reduce the complicacies of design, this software package provides various
design environments. This helps you capture the design intent easily by
individually incorporating the intelligence of each of the design environments
into the design. The design environments that are available in this solid
modeling tool are discussed next.

Part Module

This is a parametric and feature-based solid modeling environment and is used to
create solid models. The sketches for the models are also drawn in this
environment. All applicable constraints are automatically applied to a sketch
while drawing. You do not need to invoke an extra command to apply them.
Once the basic sketches are drawn, you can convert them into solid models using
simple but highly effective modeling options. One of the major advantages of
using Autodesk Inventor is the availability of the Design Doctor. The Design
Doctor is used to calculate and describe errors, if any, in the design. You are also
provided with remedy for removing errors such that the sketches can be
converted into features. The complicated features can be captured from this
module and can later be used in other parts. This reduces the time taken to create
the designer model. These features can be created using the same principles as
those for creating solid models.

Assembly Module

This module helps you create the assemblies by assembling multiple components
using assembly constraints. This module supports both the bottom-up approach



as well as the top-down approach of creating assemblies. This means that you
can insert external components into the Assembly module or create the
components in the Assembly module itself. You are allowed to assemble the
components using the smart assembly constraints and joints. All the assembly
constraints and joints can be added using a single dialog box. You can even
preview the components before they are actually assembled. This solid modeling
tool supports the concept of making a part or a feature in the part adaptive. An
adaptive feature or a part is the one that can change its actual dimensions based
upon the need of the environment.

Presentation Module

A major drawback of most solid modeling tools is their limitation in displaying
the working of an assembly. The most important question asked by the
customers in today’s world is how to show the working of any assembly. Most
of the solid modeling tools do not have an answer to this question. This is
because they do not have proper tools to display an assembly in motion. As a
result, the designers cannot show the working of the assemblies to their clients or
they have to take the help of some other software packages such as 3D Studio
MAX, 3D Studio VIZ. However, this software package provides a module called
the Presentation module using which you can animate the assemblies created in
the Assembly module and view their working. You can also view any
interference during the operation of the assembly. The assemblies can be
animated using easy steps.

Drawing Module

This module is used for the documentation of the parts or assemblies in the form
of drawing views. You can also create drawing views of the presentation created
in the Presentation module. All parametric dimensions, added to the
components in the Part module during the creation of the parts are displayed in
the drawing views in this module.

Sheet Metal Module

This module is used to create a sheet metal component. When you invoke a sheet
metal file, the Sketching environment is active by default. You can draw the
sketch of the base sheet in this module and then proceed to the sheet metal



module to convert it into a sheet metal component.

Mold Design Module

This module is used to create mold design by integrated mold functionality and
content libraries using the intelligent tools and catalogs provided in mold design
module. In this module, you can quickly generate accurate mold design directly
from digital prototypes.

GETTING STARTED WITH AUTODESK INVENTOR

Install Autodesk Inventor on your system; the shortcut icon of Autodesk
Inventor Professional 2016 will automatically be created on the desktop.
Double-click on this icon to start Autodesk Inventor.

When Autodesk Inventor is started for the first time, the system prepares itself
by loading all the required files and then the initial interface of Autodesk
Inventor will be displayed, as shown in Figure 1-1.
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Figure 1-1 Initial interface of Autodesk Inventor

By using the tools available in the initial interface of Autodesk Inventor, you can
view the recent enhancements and information related to Autodesk Inventor
2016, start new file, open an exiting file, set a project, and so on. To view the
enhancements and related information, choose the Whats New tool available in



the Get Started tab of the Ribbon. You will learn more about the Ribbon and
respective tabs and tools available in it later in this chapter.

To start a new file, choose the New tool from the Launch panel of the Get
Started tab in the Ribbon; the Create New File dialog box will be displayed, as
shown in Figure 1-2. This dialog box is used to start a new file of Autodesk
Inventor. Choose the Metric tab from the Create New File dialog box and then
double-click on the Standard (mm).ipt template to open the default metric
template. As a result, a new part file with the default name, Partl.ipt, will be
opened, refer to Figure 1-3 and you can start working in this file. The figure also
displays various components of the interface.
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Figure 1-2 The Create New File dialog box

Alternatively, to start a new part file, you can choose the New Part button from
the New area in the initial interface of Autodesk Inventor, refer to Figure 1-1.



Note that on choosing this button, the part file will be invoked with the default
template.

It is evident from Figure 1-3 that the screen of Autodesk Inventor is quite user-
friendly. Apart from the components shown in Figure 1-3, you are also provided
with various shortcut menus which are displayed on right-clicking in the
drawing area. The type of the menu and its options depend on where or when you are trying to
access the menu. For example, when you are inside any command, the options displayed in the shortcut
menu will be different from the options displayed when you are not inside any command. The different

types of shortcut menus will be discussed when they are used in the textbook.
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Figure 1-3 Components of Autodesk Inventor interface

Quick Access Toolbar

This toolbar is common to all the design environments of Autodesk Inventor.
However, some of these options will not be available when you start Autodesk
Inventor for the first time. You need to add them using the down arrow given on
the right of the Quick Access Toolbar, as shown in Figure 1-4. Some of the
important options in this toolbar are discussed next.
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Figure 1-4 The Quick Access Toolbar

Select

Select tools are used to set the selection priority. If you choose the down arrow
on the right of the active select tool, a selection drop-down list will be displayed,
refer to Figure 1-5. The Select Bodies tool is chosen to set the selection priority
for bodies. If this tool is chosen, you can select any individual body in the
model. If you choose the Select Features tool, you can select any feature in the
model. The Select Faces and Edges tool is chosen to set the priority for faces
and edges. The Select Sketch Features tool is chosen to set the priority for the
sketched entities. The Select Groups and Select Wires tools will be activated in
their respective environments when the different groups and wires become
available.

31! Select Bodies

! Select Groups

% Select Features

(! Select Face and Edges
@ Select Sketch Features

Select Wires

Figure 1-5 Selection drop-down list

Return

This tool is activated in the sketching environment and is used to exit from the
sketching environment. Once you have finished drawing a sketch, choose this
tool to proceed to the Part module. In the Part module, you can convert the



sketch into a feature using the required tools.

Note

If the Return tool is not available in the Quick Access Toolbar, you need to add
it. To do so, choose the down arrow on the right of the Quick Access Toolbar; a
flyout is displayed. Next, choose the Return option from the flyout.

Update/Local Update

This tool is chosen to update a design after modifying.

Appearance Override

You can use this drop-down list to apply different types of colors or styles to the
selected features or component to improve its appearance. It is much easier to
identify different components, parts, and assemblies when proper color codes are
applied to them.

MATERIAL DROP-DOWN
You can use the options in this drop-down list to apply different types of
materials to the selected features or component.

RIBBON AND TABS

You might have noticed that there is no command prompt in Autodesk Inventor.
The complete designing process is carried out by invoking the commands from
the tabs in the Ribbon. The Ribbon is a long bar available below the Quick
Access Toolbar. You can change the appearance of the Ribbon as per your
need. To do so, right-click on it; a shortcut menu will be displayed. Choose
Ribbon Appearance from this shortcut menu to invoke a cascading menu. Next,
choose the required option from the cascading menu.

Autodesk Inventor provides you with different tabs while working with various
design environments. This means that the tabs available in the Ribbon while
working with the Part, Assembly, Drawing, Sheet Metal, and Presentation
environments will be different.

In addition to the default tools available in a tab, you can also customize the tab
by adding more tools. To do so, choose the Customize button from the Options



panel of the Tools tab in the Ribbon; the Customize dialog box will be
displayed. Make sure that the Ribbon tab of the dialog box is chosen. Next,
select the All commands option from the Choose commands from drop-down
list, if not selected by default; a list of all the commands/tools will be displayed
on the left hand side in the dialog box. Next, select the required tool to be added
from the list and then from the Choose tab to add custom panel to drop-down
list, select the required tab to which the selected tool is to be added. Next, choose
the Add button which is represented as double arrows and then choose the
Apply button to add the tool. Similarly you can add multiple tools to the
required tab of the Ribbon. Once you are done, close the OK button to exit the
dialog box.

Tip. In Autodesk Inventor, the messages and prompts are displayed at the Status
Bar which is available at the lower left corner of the Autodesk Inventor window.

Sketch Tab

This is one of the most important tabs in the Ribbon. All the tools for creating
the sketches of the parts are available in this tab. Most of the tools of the tab will
be available on invoking the sketching environment. The Sketch tab is shown in
Figure 1-6.
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Figure 1-6 The Sketch tab
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Inventor Precise Input Toolbar

Inventor provides you with the Inventor Precise Input toolbar to enter precise
values for the coordinates of the sketcher entities. This toolbar is also available
in the Drawing and Assembly modules. The Inventor Precise Input toolbar is
shown in Figure 1-7. Note that this toolbar is not available by default. You will
learn more about this toolbar in chapter 2.

Inventor Precise Input =]
o A 2 [XV Indicate a point location by typing X and ¥ values. vl X v

Figure 1-7 The Inventor Precise Input toolbar



3D Model Tab

This is the second most important tab provided in the Part module. Once the
sketch is completed, you need to convert it into a feature using the modeling
commands. This tab provides all the modeling tools that can be used to convert a
sketch into a feature. The tools in the 3D Model tab are shown in Figure 1-8.
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Figure 1 8 The 3D Model tab

The Start 2D Sketch button in the Sketch panel of the 3D Model tab is used to
invoke the sketching environment to draw 2D sketch. As the first feature in most
of the designs is a sketched feature, therefore you first need to create the sketch
of the feature to be created. Once you have completed a sketch, you can choose
either the Finish Sketch button from the Exit panel of the Sketch tab in the
Ribbon or the Return button from the Quick Access Toolbar.

Sheet Metal Tab

This tab provides the tools that are used to create sheet metal parts. This toolbar
will be available only when you are in the sheet metal environment. You can
switch from the Modeling environment to the Sheet Metal environment by
choosing the Convert to Sheet Metal tool from the Convert panel of the 3D
Model tab in the Ribbon. If the Convert panel is not available in the 3D Model
tab, you need to customize to add it. You will learn more about customizing later
in this book. The tools in the Sheet Metal tab are shown in Figure 1-9.
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Figure 1 9 The Sheet Metal tab

Assemble Tab

This tab will be available only when you open any assembly template (with
extension .iam) from the Create New File dialog box. This tab provides you all



the tools that are required for assembling components. The tools in the
Assemble tab are shown in Figure 1-10.
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Figure 1-10 The Assemble tab

Place Views Tab

This tab provides the tools that are used to create different views of the

components. This tab will be available only when you are in the Drafting

environment. The tools in the Place Views tab are shown in Figure 1-11.

Annotate  Sketch  Tools Manage View Environments  GetStated Vault  Autodesk 360 =

EASORE BRE RS o 5

Projected Auxiliary Section Detail Overlay Draft | Break Break Out Slice Crop | Horizontal | Start | New Sheet
v Sketch

Create Modify Sketch Sheets

Figure 1-11 The Place Views tab

Presentation Tab

This tab provides the tools that are used to create different presentation views of
the components. This tab will be available only when you open any presentation
template (with extension .ipn) in the Create New File dialog box. The tools in
the Presentation tab are shown in Figure 1-12.
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Figure 1-12 The Presentation tab

Tools Tab

This tab contains tools that are mainly used for setting the preferences and
customizing the Autodesk Inventor interface. This tab is available in almost all
the environments. The tools in the Tools tab are shown in Figure 1-13.
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Figure 1-13 The Tools tab

View Tab

The tools in this tab enable you to control the view, orientation, appearance, and
visibility of objects and view windows. This tab is available in almost all the
environments. The tools in the View tab are shown in Figure 1-14.
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Figure 1-14 The View tab

The tools of a particular tab are arranged in different panels in the Ribbon.
Some of the panels and tools have an arrow on the right, refer to Figure 1-15.
These arrows are called down arrows. When you choose these down arrows,
some more tools will be displayed in the drop-downs, see Figure 1-15.
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Figure 1-15 More tools displayed on choosing the down arrow on the right of a tool in the Ribbon

Navigation Bar
The Navigation Bar is located on the right of the graphics area and contains
tools that are used to navigate the model in order to make the designing process
easier and quicker. The navigation tools also help you to control the view and

orientation of the components in the drawing window. The Navigation Bar is
shown in Figure 1-16.
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Figure 1-16 The Navigation Bar

Browser Bar

The Browser Bar is available below the Ribbon, on the left in the drawing
window. It displays all the operations performed during the designing process in
a sequence. All these operations are displayed in the form of a tree view. You
can undock the Browser Bar by dragging it. The contents of the Browser Bar



are different for different environments of Autodesk Inventor. For example, in
the Part module, it displays various operations that were used in creating the
part. Similarly, in the Assembly module, it displays all the components along
with the constraints that were used to assemble them.

UNITS FOR DIMENSIONS

In Autodesk Inventor, you can set units at any time by using the Document
Settings dialog box. You can invoke this dialog box by choosing the Document
Settings tool from the Options panel in the Tools tab. After invoking this dialog
box, choose the Units tab in the dialog box; various areas related to the units will
be displayed. The options in the Units area are used to set the units. To set the
unit for linear dimension, select the required unit from the Length drop-down.
Similarly, to set the unit for angular dimension, select the required unit from the
Angle drop-down. Next, choose the OK button to apply the specified settings
and close the dialog box. If you want to apply the specified settings without
closing the dialog box, choose the Apply button. If you choose the Apply
button, the OK button is replaced by Close. Now, you can choose the Close
button to close the dialog box.

IMPORTANT TERMS AND THEIR DEFINITIONS

Before you proceed further in Autodesk Inventor, it is very important for you to
understand the following terms widely used in this book.

Feature-based Modeling

A feature is defined as the smallest building block that can be modified
individually. In Autodesk Inventor, the solid models are created by integrating a
number of building blocks. Therefore, the models in Autodesk Inventor are a
combination of a number of individual features. These features understand their
fit and function properly. As a result, these can be modified whenever required.
Generally, these features automatically adjust their values if there is any change
in their surroundings.

Parametric Modeling

The parametric nature of a software package is its ability to use the standard
properties or parameters to define the shape and size of a geometry. The main
function of this property is to derive the selected geometry to a new size or shape



without considering its original size or shape. For example, a line of 20 mm that
was initially drawn at an angle of 45 degrees can be derived to a line of 50 mm
and its orientation can be changed to 90°. This property makes the designing
process very easy as now you can draw a sketch with some relative dimensions
and then can use this solid modeling tool to drive to the required actual values.

Bidirectional Associativity

As mentioned earlier, this solid modeling tool does not restrict its capabilities to
the 3D solid output. It is also capable of highly effective assembly modeling,
drafting, and presentations. There exists a bidirectional associativity between all
these environments of Autodesk Inventor. This link ensures that if any
modification is made in the model in any the environments, it is automatically
reflected in the other environments as well.

Adaptive

This is a highly effective property that is included in the designing process of
this solid modeling tool. In any design, there are a number of components that
can be used in various places with a small change in their shape and size. This
property makes the part or the feature adapt to its environment. It also ensures
that the adaptive part changes its shape and size as soon as it is constrained to
other parts. This considerably reduces the time and effort required in creating
similar parts in the design.

Design Doctor

The Design Doctor is one of the most important parts of the designing process
used in the Autodesk Inventor software. It is a highly effective tool to ensure that
the entire design process is error free. The main purpose of the Design Doctor is
to make you aware of any problem in the design. The Design Doctor works in
the following three steps:

Selecting the Model and Errors in the Model

In this step, the Design Doctor selects the sketch, part, assembly, and so on and
determines the errors in it.

Examining Errors
In this step, it examines the errors in the selected design. Each of the errors is
individually examined.



Providing Solutions for Errors

This is the last step of the working of the Design Doctor. Once it has
individually examined each of the errors, it suggests solutions for them. It
provides you with a list of methods that can be utilized to remove the errors from
the design.

Constraints

These are the logical operations that are performed on the selected design to
make it more accurate or to define its position with respect to some other design.
There are four types of constraints in Autodesk Inventor. All these types are
explained next.

Geometric Constraints

These logical operations are performed on the basic sketching entities to relate
them to the standard properties like collinearity, concentricity, perpendicularity,
and so on. Autodesk Inventor automatically applies these geometric constraints
to the sketcher entities at the time of their creation. You do not have to use an
extra command to apply these constraints on to the sketcher entities. However,
you can also manually apply these geometric constraints on to the sketcher
entities. There are twelve types of geometric constraints.

Perpendicular Constraint
This constraint is used to make the selected line segment normal to another
line segment.

Parallel Constraint
This constraint is used to make the selected line segments parallel.

Coincident Constraint
This constraint is used to make two points or a point and a curve coincident.

Concentric Constraint
This constraint forces two selected curves to share the same center point. The
curves that can be made concentric are arcs, circles, or ellipses.



Collinear Constraint
This constraint forces two selected line segments or ellipse axes to be placed
in the same line.

Horizontal Constraint
This constraint forces the selected line segment to become horizontal.

Vertical Constraint
This constraint forces the selected line segment to become vertical.

Tangent
This constraint is used to make the selected line segment or curve tangent to
another curve.

Equal
This constraint forces the selected line segments to become equal in length. It
can also be used to force two curves to become equal in radius.

Smooth
This constraint adds a smooth constraint between a spline and another entity
so that at the point of connection, the line is tangent to the spline.

Fix
This constraint fixes the selected point or curve to a particular location with
respect to the coordinate system of the current sketch.

Symmetric
This constraint forces the selected sketched entities to become symmetrical
about a sketched line segment which may or may not be a center line.

Assembly Constraints

The assembly constraints are the logical operations performed on the
components in order to bind them together to create an assembly. These
constraints are applied to reduce the degrees of freedom of the components.
There are five types of assembly constraints which are discussed next.

Mate



The Mate constraint is used to make the selected faces of different
components coplanar. The model can be placed facing the same direction or
the opposite direction. You can also specify some offset distance between the
selected faces.

Angle
The Angle constraint is used to place the selected faces of different
components at some angle with respect to each other.

Tangent
The Tangent constraint is used to make the selected face of a component
tangent to the cylindrical, circular, or conical faces of the other component.

Insert

The Insert constraint forces two different circular components to share the
orientation of the central axis. It also makes the selected faces of the circular
components coplanar.

Symmetry

The Symmetry constraint is used to make two selected components
symmetric to each other about a symmetric plane so that both components
remain equidistant from the plane.

Assembly Joints

The assembly joints are the logical operations performed on the components in
order to join them together to create an assembly. These joints allow motion
between the connected components or in the assembly. There are seven types of
assembly joints which are discussed next.

Automatic

The Automatic joint is used to automatically apply best suitable type of joints
between the connecting components of the assembly. The type of joint to be
applied automatically will depend upon the selected geometry.

Rigid
The Rigid joint removes all the degrees of freedom from the component. As a
result, the components after applying rigid joints can not move in any



direction. The Rigid joint is used to fix two parts rigidly. All the DOFs
between the selected parts get eliminated and act as a single component when
any motion will be applied to any of the direction.

Rotational
The Rotational joint allows the rotational motion of a component along the
axis of a cylindrical component.

Slider

The Slider joint allows the movement of a component along a specified path.
The component will be joined to translate in one direction only. You can
specify only one translation degree of freedom in slider joint. Slider joint are
used to simulate the motion in linear direction.

Cylindrical

The Cylindrical joint allows a component to translate along the axis of a
cylindrical component as well as rotate about the axis. You can specify one
translation degree of freedom and one rotational degree of freedom in the
Cylindrical joint.

Planar

The Planar joint is used to connect the planar faces of two components. The
components can slide or rotate on the plane with two translation and one
rotational degree of freedom.

Ball

The Ball joint is used to create a joint between two components such that both
the components remain in touch with each other and at the same time the
movable component can freely rotate in any direction. To create a ball joint
between two components, you need to specify one point from each
component. The joints thus created will generate three undefined rotational
DOFs and restrict the other three DOFs at a common point.

Motion Constraints

The motion constraints are the logical operations performed on the components
that are assembled using the assembly constraints. There are two types of motion
constraints that are discussed next.



Rotation
The Reotation constraint is used to rotate one component of the assembly in
relation to the other component.

Rotation-Translation
The Rotation-Translation constraint is used to rotate the first component
with respect to the translation of the second component.

Transitional Constraints

The transitional constraints are also applied on the assembled components and
are used to ensure that the selected face of the cylindrical component maintains
contact with the selected faces of the other component when you slide the
cylindrical component.

UCS to UCS Constraint

This constraint is used to constrain two components together by their UCSs.

Consumed Sketch

A consumed sketch is a sketch that is utilized in creating a feature using tools
such as Extrude, Revolve, Sweep, Loft, and so on.

STRESS ANALYSIS ENVIRONMENT

In Autodesk Inventor Professional, you are provided with stress analysis
environment which is an analysis tool to execute the static and model stress
analysis. You can calculate the displacement and stresses developed in a
component with the effect of material and various loading conditions applied on
a model. A component fails when the stress applied on it goes beyond a
permissible limit. Figure 1-17 shows the Displacement plot of leaf spring
designed in Autodesk Inventor and analyzed using the analysis tools.
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Figure 1-17 The resultant model with Displacement Select other behavior
While working on the complicated models, sometimes you may need to select
the entities that are not visible in the current view or are hidden behind other
entities. To do so, Autodesk Inventor provides you with the Select Other feature
automatically displayed when you hover thecursor at a point where more than
one entity is available. To select any entity, click on the down arrow; a flyout
will be displayed. Select the desired entity from the flyout; the selected entity
will be displayed in blue. Figure 1-18 shows theSelect Other flyout displayed in
the modelling environment. You can use this tool in all the modes
and environments of Autodesk Inventor.
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| 2. Earve | |
3. Curve Dﬁ

Figure 1-18 Selecting the entities from the Select Other flyout

HOTKEYS

As mentioned earlier, there is no command prompt in Autodesk Inventor.
However, you can use the keys on the keyboard to invoke some tools. The keys



that can be used to invoke the tools are called hotkeys. Remember that the
working of the hotkeys will be different for different environments. The use of
hotkeys in different environments is given next.

Part Module

The hotkeys that can be used in the Part module and their functions are given
next.

Hotkey Function

E Invokes the Extrude tool
R Invokes the Revolve tool
H Invokes the Hole tool

CTRL+SHIFT+L (Invokes the Loft tool
CTRL+SHIFT+S [Invokes the Sweep tool

F Invokes the Fillet tool
CTRL+SHIFT+K (Invokes the Chamfer tool
CTRL+SHIFT+M|Invokes the Mirror tool
CTRL+SHIFT+R [Invokes the Rectangular Pattern tool
CTRL+SHIFT+O (Invokes the Circular Pattern tool

F6 Invokes the Home view
] Invokes the Work Plane tool
/ Invokes the Work Axis tool

. Invokes the Work Point tool
CTRL+W Invokes the SteeringWheels

The following hotkeys are used in the Sketching environment:

HotkeyFunction

L Invokes the Line tool

D Invokes the Dimension tool




X Invokes the Trim tool
F7 Invokes the Slice Graphics tool

F8 Displays all constraints

F9 Hides all constraints

Assembly Module

In addition to the hotkeys of the part modeling tool, the following hot keys can
also be used in the Assembly module:

HotkeyFunction

P Invokes the Place tool

N Invokes the Create tool

C Invokes the Constraint tool

\Y Invokes the Move Component tool
G Invokes the Rotate Component tool

Drawing Module

The hotkeys that can be used in the Drawing module are given next.
HotkeyFunction

B Invokes the Balloon tool

D Invokes the Dimension tool

0] Invokes the Ordinate Set tool

F Invokes the Feature Control Frame tool

In addition to these keys, you can also use some other keys for the ease of
designing. Note that you will have to hold some of these keys down and use
them in combination with the pointing device. These hotkeys are given next.

Hotkey Function
F1 Invokes the Help command




F2 Invokes the Pan tool

F3 Invokes the Zoom tool

F4 Invokes the Free Orbit tool

F5 Previous view

SHIFT+F5 Next view

ESC Aborts the current command
SPACEBAR Invokes the recently used tool

T (In Presentation module)|Invokes the Tweak Components tool

Customizing Hotkeys

You can customize the settings of hotkeys. To do so, choose the Customize tool
from the Options panel of the Tools tab in the Ribbon; the Customize dialog
box will be displayed. Next, choose the Keyboard tab; a list of all the available
commands will be displayed, as shown in Figure 1-19. The options

corresponding to the Keyboard tab are discussed next.
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Figure 1-19 The Customize dialog box displaying various commands in
the Keyboard tab

Categories
Select the required category of command from this drop-down list; the
commands related to the selected category will be listed in the list box.

Filter

You can further shortlist the displayed commands from this drop-down list. If
you select the All option, all the commands related to the selected category will
be displayed. If you select the Assigned option, then the commands to which the
hotkeys are assigned will be displayed. Similarly, if you select the Unassigned
option, then the commands to which the hotkeys are not assigned will be
displayed.

List Box

The list box has four columns: Keys, Command Name, Type, and Category.
The Key column displays the hotkeys assigned to the commands. The name of
the command, its type, and category will be listed in the Command Name,
Type, and Category columns, respectively. To assign hotkeys to a tool, click in
the Keys column that is associated to the command; an edit box will be
displayed. In this edit box, enter the shortcut key that you want to assign. To
accept the settings, click on the tick-mark provided at the right side of this edit
box. Else, click on the cross-mark provided next to the tick-mark.

Reset All Keys
The Reset All Keys button is used to remove all the customized hotkeys and
restore the default hotkeys.

Copy to Clipboard
Choose this button to copy the contents of the Keyboard tab and paste them to
other document.

Import
Choose this button to restore the customized settings from the .xml format. Note
that before importing the file, all the Autodesk Inventor files must be closed.



Export
Choose this button to save the customized settings in the .xml format. Make sure
that all the Autodesk Inventor files are closed before choosing this button.

Close

Choose this button to close the Customize dialog box.

CREATING THE SKETCH

After starting Autodesk Inventor, you can start creating model in the Part
environment. But before creating the model, you need to create its sketch in the
Sketching environment. To do so, choose the Start 2D Sketch tool from the
Sketch drop-down in the Sketch panel of the 3D Model tab, see Figure 1-20. On
choosing this tool, the Sketching environment is invoked and you can create 2D
sketches. If you choose the Start 3D sketch tool from the Sketch panel, you can
create 3D sketches.

Z &

Start Extrude
2D Sketch ‘[“

17; Start 2D Sketch

|
& Start 3D Sketch

Figure 1-20 Tools in the Sketch drop-down

MARKING MENU

Marking menu is a type of menu that consists of tools and options which are
commonly used in Autodesk Inventor software in different environments.
Marking menu replaces the conventional right-click context menu. The Marking
menu consists of different tools in different environments. For example, in the
Sketching environment, the Marking menu consists of commonly used tools
such as Create Line, Two Point Rectangle, Done [ESC], Trim, General
Dimensions, and so on. In the Modeling environment, it consists of tools and
options such as Extrude, Fillet, Hole, New Sketch, and so on.



You can invoke a tool in Marking menu by using two modes: Marking mode and
Menu mode. To invoke the Marking menu using the Menu mode, right-click
anywhere in the graphic window; all the menu items surrounding the cursor will
be displayed. After invoking the Marking menu, you can choose the desired tool
or option from it. To do so, move the cursor toward the desired tool; the tool is
highlighted along with a marker ray. Next, choose the highlighted tool to invoke
it.

The other mode, Marking mode, is also known as gesture behavior. It helps you
to mark a trail and choose the desired tool. To choose a tool in the Marking
mode, right-click and drag the cursor immediately in the direction of the desired
tool.

Figure 1-21 shows a Marking menu invoked in the Sketching environment and
Figure 1-22 shows a Marking menu which is invoked in the Modeling
environment.

Tip. You can modify the tools listed in the Marking Menu. You can also turn the
Marking Menu feature on or off using the options in the User Interface flyout in
the Windows panel of the View tab in the Ribbon.

COLOR SCHEME

Autodesk Inventor allows you to use various color schemes to set the
background color of the screen and for displaying the entities on the screen. Note
that this book uses the Presentation color scheme with a single color
background. To change the color scheme, choose the Application Options tool
from the Options panel of the Tools tab in the Ribbon; the Application
Options dialog box will be displayed. Choose the Colors tab to display the
predefined colors. Next, select the Presentation option from the Color scheme
list box in the Colors tab. Select 1 Color from the drop-down list in the
Background area, refer to Figure 1-23. Choose Apply to apply the color scheme
to the Autodesk Inventor environment, and then choose Close. Note that all the
files you open henceforth will use this color scheme.



Figure 1-21 Marking menu available in the sketching environment
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Figure 1-21 Marking menu available in the sketching environment
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Figure 1-22 Marking menu available in the modeling environment
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Figure 1-23 The Application Options dialog box with the required options set
in the Colors tab

Answer the following questions and then compare them to those given at the
end of this chapter:

1. You can invoke the Line tool by using the hotkey.
2. Press to invoke the recently used tool.
3. Choose the button from the Customize dialog box to restore the

customized settings in the .xml format.

4. When you start a new session of Autodesk Inventor Professional 2016, only
the Start a new file button will be available in the Quick Launch area of the
Open dialog box. (T/F)



5. The Inventor Precise Input toolbar is used to specify the precise values for
the coordinates of the sketcher entities. (T/F)

6. The tools in the 3D Model tab enable you to control the view, orientation,
appearance, and visibility of objects and view windows. (T/F)

Answer the following questions:

1. You can use the drop-down list to apply different types of colors
or styles to the selected feature or component to improve its appearance.

2. You can invoke the Analyze Interference tool from the Assembly module by
pressing the key.

3. The button is used to draw a 2D sketch in the Sketching
environment and is chosen by default when you start a new file in the Part
module.

4. There are twelve types of geometric constraints in Autodesk Inventor. (T/F)
5. Design Doctor works in five steps. (T/F)

6. You can invoke the Trim tool by pressing the X key. (T/F)

Answers to Self-Evaluation Test
1. L, 2. SPACEBAR, 3. Import, 4. T, 5. T, 6. F









Chapter 2
Drawing Sketches for Solid Models

Learning Objectives

After completing this chapter, you will be able to: « Start a new template file to
draw sketches.

* Set up the sketching environment.

* Use various drawing display tools.

* Understand the sketcher environment in the Part module.

* Get acquainted with sketcher entities.

* Specify the position of entities by using dynamic input.

* Draw sketches by using various sketcher entities.

* Delete sketched entities.

THE SKETCHING ENVIRONMENT

Most of the designs created in Autodesk Inventor consist of sketched and placed
features. A sketch is a combination of a number of two-dimensional (2D) entities
such as lines, arcs, circles, and so on. The features such as extrude, revolve, and
sweep that are created by using 2D sketches are known as sketched features. The
features such as fillet, chamfer, thread, and shell that are created without using a
sketch are known as placed features. In a design, the base feature or the first
feature is always a sketched feature. For example, the sketch shown in Figure 2-
1 is used to create the solid model shown in Figure 2-2. In this figure, the fillets
and chamfers are the placed features.

Figure 2-1 The basic sketch for the solid model
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Figure 2-2 A solid model created using the sketched and placed features

Once you have drawn the basic sketch, refer to Figure 2-1, you need to convert it
into a solid model using solid modeling tools.

You can create sketches in Sketching environment. This environment of
Autodesk Inventor can be invoked at any time in the Part module or in the
Assembly module. Unlike other solid modeling programs, here you just need to
invoke the Start 2D Sketch tool and specify the plane to draw sketch; the
Sketching environment will be invoked. You can draw a sketch in this
environment and then proceed to the part modeling environment for converting
the sketch into a solid model. The options in the Sketching environment will be
discussed later in this chapter.

Initial Interface of Autodesk Inventor when you start Autodesk

Inventor, the initial interface is displayed with the Get Started tab chosen by
default, as shown in Figure 2-3. The Launch panel of this tab contains options



such as New, Open, Projects, and Open Samples. These options will be
discussed later. By choosing the Home option from the My Home panel, you
can start and open the recent file. The Team Web option allows you to attach
any required website or HTML file for easy access. You can access the
Autodesk help by using the Help option and can navigate to the previous page
with the help of the Back option. By choosing the What’s New option from the
New Feature panel of the Ribbon, you can view all the enhancements in
Autodesk Inventor 2016. You can watch the introductory videos, import files
from other CAD Systems, and access resources from the web in the Videos and
Tutorials panel of the Get Started tab of the Ribbon.

The initial interface of inventor consists of the New and Recent Documents
areas and various tabs. Using the options in the New area, you can start new part,
assembly, drawing, and presentation file. On choosing the Configure Default
Template button from this area, the Configure Default Template dialog box
will be invoked, as shown in Figure 2-4. You can choose measurement units and
drawing standards from this dialog box. The area on the right side of the New
area consists of the Projects, Shortcuts, and File Details tabs. You can click on
the Projects tab to set the active project file. Similarly, click on the Shortcuts
tab to create shortcuts for fast access to project locations, files, and folders. The
File Details tab is used to view the file information. The Filter option in the
Recent Documents area is used to filter the project and file types according to
user’s requirements.

Note
If any of the panels is not available by default in the Get Started tab of the
Ribbon, you need to customize the Ribbon to add them.
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Figure 2-3 The initial interface of Autodesk Inventor 2016
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Figure 2-4 The Configure Default Template dialog box

Starting a New File

[ In Autodesk Inventor, you can start a new file by choosing the New tool
from the Launch panel in the Get Started tab of the intial interface. On doing
so, the Create New File dialog box will be displayed, refer to Figure 2-5.
Alternatively, you can start a new file by choosing the New tool from the Quick
Access Toolbar or by choosing the Start a new file button from the Open
dialog box. You will learn more about the Open dialog box later in this chapter.

The options in the Create New File dialog box are used to select a template file
for starting a design. You can select a template of English, Metric, or Mold



Design standard. To start a new metric part file, select the Metric option that is
available under the Template node of the dialog box, as shown in Figure 2-5.
The templates that are available on selecting the Metric option are discussed
next.
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Figure 2-5 The Create New File dialog box with the Metric node selected

.ipt Templates
Select any .ipt template to start a new part file for creating a solid model or a
sheet metal component.

.iam Templates

Select a .iam template to start a new assembly file for assembling various parts.
Note that if you select the Weldment.iam template, the Weldment module of
Autodesk Inventor will be started.

.ipn Templates Select a .ipn template to start a new presentation file
for animating the assembly. The Presentation module marks the basic
difference between the Autodesk Inventor and other design tools. This
module allows you to animate the assemblies created in the Assembly
module. For example, you can create a presentation in the
Presentation module that shows a Drill Press Vice assembly in
motion.



.idw Templates

Select a .idw template to start a new drawing file for generating the drawing
views. You can use the drawing templates of various standards that are provided
in this tab, such as ANSI, ISO, DIN, GB, JIS, GOST, and BSI.

.dwg Templates
Select a .dwg template for creating AutoCAD drawing files. You can use the
drawing templates of standards such as JIS, ISO, GB, DIN, BSI, and ANSI.

The Project File drop-down list in the Create New File dialog box displays the
active project in which the new file has been started. The Projects dialog box
can be invoked by choosing the Projects button from the Create New File
dialog box.

The Open Dialog Box

The Open dialog box is used to open an existing file. To invoke this dialog box,
choose the Open tool from the Launch panel of the Get Started tab. Figure 2-6
shows the Open dialog box. The options in the Open dialog box are used to
open existing files. You can browse and select the file that you want to open
from the list displayed in the dialog box. The preview of the selected file is
displayed in the preview window located at the lower left portion in this dialog
box, as shown in Figure 2-7. By default, you can open any file created in
Autodesk Inventor. This is because, the Files of type drop-down list displays
the Autodesk Inventor Files (*.iam; .idw; .dwg; .ipt; .ipn, and *.ide) option,
By default. You can also open the files created in other solid modeling programs
such as AutoCAD, Pro/ENGINEER and Creo Parametric, Alias, Catia V5,
SolidWorks, NX, and so on by selecting the respectiveoptions from the Files of
type drop-down list.



L Open (i)
(%l :\_:t#“k 560 I Look in: [ Desktop - @ T @
o ioranes
] Content Center Files = _ ! = Y
= 4] ,‘ ]33 e &,—
Libraries rotation menuscript kavita Coemputer MNetwork  c15_cat_v5-...
r N B n
8 & &t 8 B
CATIA last_page_s... Mew folder ppt catia sigil
V5-6R2014_... v5G6r2014
Preview not available
File name: -
Fies of type: | Autodesk Inventor Files ("iam,” dwg;"idw:"ipt " ipn."ide) |
Project File: [Default.ipy =] [ projects... |
Quick Launch
»
@ S = o) e
Figure 2-6 The Open dialog box
I Open [nEsal
) Auttocesk A300 Lookin:  J, TEST - Q& A
T Libraries )
("] Content Center Files Mame Date modified Type ke
By assembly 1 WT/NT3PM  AutodeskInventor.. | |
Fafiga-20 7/7/2011 7:33 PM Autodesk Inventor... |=|
Bafiga-22 1/7/2011 7:33 PM Autodesk Inventor.., |
@fig 15-1 and 15-2 7/11/2011 6:49 PM Autodesk Inventor,..
i[fig15-8 7/11/2011 6:50 PM  Autodesk Inventor..,
ig15-9 7/11/2011 6:51 PM - Autodesk Inventor..,
@fig 15-10 7/11/2011 651 PM - Autodesk Inventor...
tﬂfig 15-11 7/11/2011 6:51 PM Autodesk Inventor...
@fig 15-12 7/1/20116:51 PM Autodesk Inventor.,  _
:_Il.. Sod ool o e e S > g :
File name: fig 15-8 v
Flesof type: | Aodesk Invertor Fies (iam. dwa: idw."int”n.ide) 7]
Project Fle: [Default.py v [ Projects... |
Quick Launch
l
D \' i h" l Find ... ‘ l Options. . ‘ [ Open ] I Cancel ‘

Figure 2-7 The Open dialog box showing the preview of the selected file

In addition to open an existing file, you can also start new files and setup a
project by using the Open dialog box. To open an existing file, choose the Start
a new file button from this dialog box. Note that on starting a new session in
Autodesk Inventor, the Start a new file button will be active in the Quick
Launch area of the Open dialog box. Choose this button; the Create New File



dialog box will be displayed, as shown in Figure 2-8.
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Figure 2-8 The Create New File dialog box

By using the Open dialog box, you can also invoke the Project dialog box to
setup a new project. To invoke the Project dialog box, choose the Project
button available on the right of the Project File drop down list in the Open
dialog box. You will learn more about setting a project later in this chapter.

Setting a New Project In Autodesk Inventor, a project
defines all the files related to a design project you are
working on. You can create new projects or retrieve the
previously created projects by choosing the Projects tool
from the Launch panel in the Get Started tab of initial
interface of Autodesk Inventor. When you choose the
Projects tool, the Projects dialog box will be displayed,
as shown in Figure 2-8. All the project folders will be
displayed in the upper half of the dialog box and the
options regarding the selected project folder will be
displayed in the lower half of the dialog box. To add



another project folder to this list, choose the New button;
the Inventor project wizard dialog box will be
displayed. The New Vault Project radio button is
selected by default in this dialog box. Choose the Next
button from the Inventor project wizard dialog box.
Specify the name of the project in the Name text box and
the location in the Project (Workspace) Folder text box.
You can also choose the Browse for project location
button to specify the location of the project. Next, choose
the Finish button. Once you have specified the project
folder, it will be added to the upper part of the Projects
dialog box and its location will be displayed. When you
select a project, the options related to it will be shown in
the lower part of the dialog box. The Projects dialog box
with various projects is shown in Figure 2-9. Choose the
Done button to close the Projects dialog box.
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Figure 2-9 The Projects dialog box

To view help about topics, press F1; the Autodesk Inventor Help window will
be displayed. In this window, you will find help topics explaining how to use a
particular tool or option of Autodesk Inventor.

Import DWG

In Autodesk Inventor, you can import AutoCAD files. To do so, choose Open >
Import DWG from the Application Menu; the Import dialog box will be
displayed. Browse to the desired folder and import the required AutoCAD file.

INVOKING THE SKETCHING ENVIRONMENT

To invoke the Sketching environment, choose the Start 2D Sketch button from
the Sketch panel in the 3D Model tab; three different planes namely XY, YZ,
and XZ will be displayed in the graphics window, as shown in Figure 2-10.
Select the required plane from the graphic window to invoke the Sketching
environment.

Figure 2-10 Three different planes displayed in the graphics window



Introduction to the Sketching Environment

The initial interface appearance in the Sketching environment of a Standard
(mm).ipt file after selecting the XY plane as the sketching plane is shown in
Figure 2-11. By default, the Ribbon is placed at the top of the graphics window,
refer to Figure 2-11. You can move this Ribbon anywhere in the graphics
window. To do so, right-click on the Ribbon; a shortcut menu will be displayed.
Choose the Undock Ribbon option from the shortcut menu; the Ribbon will be
undocked. Now, you can drag the Ribbon anywhere in the graphics window. It
is recommended to place (dock) the Ribbon at the top of the graphics window so
that you can use the space efficiently. To do so, right-click on the Ribbon and
choose Docking Position > Top from the shortcut menu. Alternatively, double-
click on the title bar of the Ribbon to dock it.
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Figure 2-11 Initial interface appearance in the sketching environment

SETTING UP THE SKETCHING ENVIRONMENT

It is very important to first set up the sketching environment. This has to be done
before you start drawing a sketch. Setting up the sketching environment includes
modifying the grids of a drawing. It is unlikely that the designs that you want to
create consist of small dimensions. You will come across a number of designs
that are large. Therefore, before starting a drawing, you need to modify the grid
settings. These settings will depend on the dimensions of the design. The process
of modifying the grid settings of a drawing is discussed next.

Modifying the Document Settings of a Sketch Before
sketching, you may need to modify the settings of the
Sketching environment as per your requirement. You can
change the snapping distance, grid spacing, and various
attributes related to line display of the sketching
environment. You must have noticed that the drawing
window in the sketching environment consists of a
number of light and dark lines that are normal to each



other. These normal lines are called Grid lines. The Grid
lines help you locate an entity, thereby helping you to
draw a sketch correctly or modify an existing sketch
precisely.

You can modify the document settings of a sketch. To do so, choose the
Document Settings tool from the Options panel of the Tools tab; the Partl
Document Settings dialog box will be displayed. In this dialog box, choose the
Sketch tab to display the options related to the Sketching environment, refer to
Figure 2-12. The options under this tab are discussed next.
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Figure 2-12 The Partl Document Settings dialog box with the Sketch tab chosen

Snap Spacing Area



The options under this area are used to specify the snap distances.

X Edit box
This edit box is used to specify the snap spacing in the X direction.

Y Edit box
This edit box is used to specify the snap spacing in the Y direction.

Grid Display Area

The options in this area are used to control the number of major and minor lines.
The minor lines are the light lines that are displayed inside the dark gray lines.
The dark gray lines are called the major lines.

Snaps per minor
This spinner is used to specify the number of snap points between each minor
line.

Major every minor lines
This spinner is used to specify the number of minor lines between two major
lines.

Line Weight Display Options Area

The options in the Line Weight Display Options area allow you to control the
line weight in the sketching environment. The Display Line Weights check box
is selected by default and displays the sketches with the set line weights. If this
check box is cleared, then the differences in the line weights will not be
displayed in the sketch. The Display True Line Weights radio button, if
selected, displays the line weights on screen as they would appear on paper when
printed. The Display Line Weights by Range (millimeter) radio button, if
selected, displays the line weights according to the values entered.

Note

You will have to increase the drawing display area after increasing the grid spacing.

Tip.
You can also turn off the display of the major and minor grid lines and the axes. To turn off the display of
the grid line and the axes, choose the Application Options tool from the Options panel; the Application

Options dialog box will be displayed. Next, choose the Sketch tab and clear the Grid lines, Minor grid



lines, and Axes check boxes from the Display area.

SKETCHING ENTITIES GETTING ACQUAINTED
WITH THE SKETCHING ENTITIES IS AN
IMPORTANT PART OF LEARNING AUTODESK
INVENTOR. THE MAJOR PART OF A DESIGN IS
CREATED USING THE SKETCH ENTITIES.
THEREFORE, THIS SECTION CAN BE
CONSIDERED AS ONE OF THE MOST IMPORTANT
SECTIONS OF THE BOOK. IN AUTODESK
INVENTOR, THE SKETCHED ENTITIES ARE OF
TWO TYPES: NORMAL AND CONSTRUCTION.
THE NORMAL ENTITIES ARE USED TO CREATE A
FEATURE AND BECOME A PART OF IT, BUT THE
CONSTRUCTION ENTITIES ARE DRAWN JUST
FOR REFERENCE AND SUPPORT, AND CANNOT
BECOME A PART OF THE FEATURE. BY
DEFAULT, ALL THE DRAWN ENTITIES ARE
NORMAL ENTITIES. TO DRAW CONSTRUCTION
ENTITIES, CHOOSE THE CONSTRUCTION TOOL
FROM THE FORMAT PANEL OF THE SKETCH
TAB. ALL THE ENTITIES DRAWN AFTER
CHOOSING THE CONSTRUCTION TOOL WILL BE
THE CONSTRUCTION ENTITIES. DESELECT THIS
TOOL BY CHOOSING IT AGAIN TO DRAW
NORMAL ENTITIES.



POSITIONING ENTITIES BY USING DYNAMIC
INPUT IN AUTODESK INVENTOR, YOU CAN
SPECIFY THE POSITION OF SKETCHING ENTITIES
BY USING THE DYNAMIC INPUT WHICH
CONSISTS OF TwWO COMPONENTS: POINTER
INPUT AND THE DIMENSION INPUT. THE
POINTER INPUT IS DISPLAYED WHEN YOU
INVOKE THE SKETCHING TOOLS SUCH AS LINE,
RECTANGLE, ARC, AND IT DISPLAYS THE
COORDINATES OF THE CURRENT LOCATION OF
THE CURSOR. AS YOU MOVE THE CURSOR, THE
COORDINATES CHANGE DYNAMICALLY. WHEN
YOU SPECIFY THE FIRST POINT, THE POINTER
INPUT IS DISPLAYED. THE POINTER INPUT IS
DISPLAYED IN THE FORM OF CARTESIAN
COORDINATES (X AND Y). IF YOU SPECIFY THE
SECOND POINT OR THE SUBSEQUENT POINTS OF
ENTITIES, THE DIMENSION INPUT WILL BE
DISPLAYED. THE DIMENSION INPUT IS
DISPLAYED IN THE FORM OF POLAR
COORDINATES (LENGTH AND ANGLE).

To specify the position of sketching entities dynamically, invoke the required
sketching tool and then move the cursor in the graphics window; the location of
the cursor will be displayed in the cartesian coordinate in the Pointer Input. Press
the TAB key and enter the X and Y coordinate values in the Pointer Input to
specify the first point; you will be prompted to specify the endpoint or second
point of the entity. Alternatively, you can specify the first point of the entity by



clicking in the graphics window. On doing so, the Pointer Input will be modified
to the Dimension Input and the polar coordinate input fields will be displayed.
To specify the endpoint or second point of the entity, enter the length and angle
values in the input fields. To toggle between the length and angle input fields,
use the TAB key. If you specify input values by using the Dimension Input and
then use the TAB key, lock icons will be displayed on the right of the input
fields. The lock icons indicate that the values defined are constrained. Figure 2-
13 shows the Pointer Input of a line and Figure 2-14 shows the Dimension Input
of the endpoint of a line of length 20 mm at an angle of 45 degrees.

| x] 4.005 mm] v| 5.879 mm|

|
Figure 2-13 Pointer Input of a line

20,000 mm li 3

Figure 2-14 Dimension Input of the endpoint of a line of length 20 mm at 45 degrees

If some sketched entities exist in the drawing window and you start creating new
entities in the drawing window, an appropriate constraint symbol will be
displayed near the cursor. You can control the display of the Pointer Input and
Dimension Input by using the Application Options dialog box. This dialog box
can be invoked by choosing the Application Options tool from the Options
panel of the Tools tab. To control the display of Pointer Input and Dimension



Input, choose the Sketch tab in the Application Options dialog box. Clear the
Enable the Heads-Up Display (HUD) check box from the Sketch tab and
choose the OK button from this dialog box. As a result, the display of Pointer
Input and Dimension Input will be turned off and now you cannot enter the input
values of the entities dynamically.

The sketcher entities in Autodesk Inventor are discussed next.

Drawing Lines

>

Ribbon: Sketch > Create > Line/Spline drop-down > Line "™ Lines are the
basic and one of the most important entities in the sketching environment.

As mentioned earlier, you can draw either normal lines or construction

lines. A line is defined as the shortest distance between two points. The two
points are the start point and the endpoint of the line. Therefore, to draw a

line, you need to define these two points. The parametric nature of
Autodesk Inventor allows you to draw the initial line of any length or at any
angle by just picking the points on the screen. After drawing the line, you

can drive it to a new length or angle by using parametric dimensions. You
can also create the line of actual length and angle directly by using the

Inventor Precise Input toolbar. Both the methods of drawing the lines are
discussed next.

Drawing a Line by Picking Points in the Drawing Window This is a
very convenient method to draw lines and is used extensively while
sketching. When you invoke the Line tool from the Create panel, the
cursor (which was initially an arrow) is replaced by crosshairs with a
yellow circle at the intersection. Alternatively, you can choose the
Create Line tool from the Marking Menu which is displayed when
you right-click anywhere in the graphics window. On doing so, you
are prompted to select the start point of the line or drag off the
endpoint for the tangent arc. In addition, the coordinates of the current
location of the cursor are displayed in the Pointer Input and also at the
lower right corner of the Autodesk Inventor window. The point of
intersection of the X and Y axes (black lines among grid lines) is the



origin point. If you move the cursor close to the origin, it will snap to
the origin automatically. To draw a line, specify a point anywhere in
the drawing window; the Pointer Input will display both length and
angle values as zero. Move the cursor; a rubber-band line will start
from the specified point and the length and angle values will change
accordingly in the Pointer Input. One end of this rubber-band line is
fixed at the point specified in the drawing window and the other end is
attached to the yellow circle in crosshairs. As you move the cursor
after specifying the start point of the line, the Pointer Input will
display the length and angle of the current location of the line. Click at
the required position in the drawing window. Alternatively, enter the
required length and angle values in the Pointer Input to specify the
endpoint of the line. You can use the TAB key to toggle between the
length and angle values in the Pointer Input.

After specifying the endpoint of the line, a line is drawn and a new rubber-band
line starts. The start point of the new rubber-band line is the endpoint of the last
line and you are again prompted to specify the endpoint of the line. You can
continue specifying the endpoints to draw continuous lines.

When you draw entities in Autodesk Inventor, valid constraints are applied
automatically to the entities. Therefore, when you draw continuous lines, the
horizontal, vertical, perpendicular, and parallel constraints are automatically
applied to them. The symbol of the applied constraint is displayed on the line
while drawing it. You can exit the Line tool by pressing the ESC key.
Alternatively, you can exit the Line tool by right-clicking anywhere in the
graphics window; a Marking Menu will be displayed. Next, choose OK from the
Marking Menu. Figures 2-15 and 2-16 display the Perpendicular Constraint and
Parallel Constraint, respectively being applied to the lines while they are being
drawn.
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Figure 2-15 Drawing a line using the Perpendicular Constraint

Figure 2-16 Drawing a line using the Parallel Constraint

Note

The default screen appearance in the Sketching environment can be modified for
clarity. To do so, choose the Application Options tool from the Options panel of
the Tools tab; the Application Options dialog box will be displayed. In the
dialog box, choose the Colors tab and then select the Presentation option from
the Color scheme list box. Next, select 1 Color from the Background drop-down
list, and then choose the Apply button from the Application Options dialog box.
The default appearance of the screen is changed in the Sketching environment.

In Inventor, you can close a sketch that has two or more than two lines. To do so,
if you have drawn two or more than two continuous lines in the drawing area
then on selecting the Close option from the Marking menu; a line joining the
endpoint of the current line and the start point of the first line will be created and
the sketch will be closed. Figure 2-17 shows the Close option being chosen from
the Marking menu to close the sketch and Figure 2-18 shows the closed sketch
created. Note that the Close option will not be displayed in the Marking menu
once you terminate the creation of continuous lines.
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Figure 2-17 Choosing the Close option from the Marking Menu

Figure 2-18 Closed sketch created

Drawing a Line by using the Inventor Precise Input toolbar This is
another method of drawing lines in Autodesk Inventor. In this method,
you use the Inventor Precise Input toolbar to define the coordinates
of the start point and the endpoint of lines. To display the Inventor
Precise Input toolbar for the line, first invoke the Line tool. Next,
click on the down arrow displayed at bottom of the Create panel in
the Sketch tab; the Create panel will expand. Choose the Precise
Input tool from this panel. As mentioned earlier, the origin of the
drawing lies at the intersection of the X and Y axes. The X and Y
coordinates of this point are 0, 0. You can take the reference of this
point to draw lines. There are two methods to define the coordinates
using this toolbar. Both the methods are discussed next.



Specifying Coordinates with respect to the Origin The system that define the
coordinates with respect to the origin of the drawing is termed as the absolute
coordinate system. By default, the origin lies at the intersection of the X and Y
axes. All the points in this system are defined with respect to this origin. To
define the points, you can use the following four methods.

Defining the Absolute X and Y Coordinates: In this method, you will
define the X and Y coordinates of the new point with respect to the origin.
To invoke this method, select the Indicate a point location by typing X
and Y values option from the drop-down list in the Inventor Precise Input
toolbar. The exact X and Y coordinates of the point can be entered in the X
and Y edit boxes provided in this toolbar.

Defining the Absolute X Coordinate and the Angle from the X Axis: In
this method, you will define the absolute X coordinate of a point with
respect to the origin and the angle that this line makes with the positive X
axis. The angle will be measured in the counterclockwise direction from the
positive X axis. To invoke this method, select the Specify a point using X
coordinate and angle from X axis option from the drop-down list. The X
coordinate of the new point and the angle can be defined in the respective
edit boxes in the Inventor Precise Input toolbar.

Defining the Absolute Y Coordinate and the Angle from the X Axis: In
this method, you will define the absolute Y coordinate of a point with
respect to the origin and the angle that this line makes with the positive X
axis. To invoke this method, select the Specify a point using Y coordinate
and angle from X axis option from the drop-down list. The Y coordinate of
the new point and the angle can be defined in the respective edit boxes in
the Inventor Precise Input toolbar.

Specifying the Distance from the Origin and the Angle from the X Axis:
In this method, you will define the distance of the point from the origin and
the angle that this line makes with the X axis. To invoke this method, select
the Specify a point using distance from the origin and angle from X axis
option from the drop-down list. The distance and the angle can be defined in
the respective edit boxes.



Specifying Coordinates with respect to the Last Point This system of
specifying the coordinates with respect to the previous point is termed as the
relative coordinate system. Note that this system of defining the points cannot
be used for specifying the first point (the start point of the line). All absolute
coordinate methods for specifying a point with respect to the origin can also
be used with respect to the last specified point by choosing the Precise Delta
button along with the respective method. This button will be available only
after you specify the start point of the first line. The Reset To Origin button
moves the triad to the origin of the sketch (0,0,0). The Precise Redefine
button is used to enter a point relative to the coordinate origin.

Note

1. While drawing continuous lines, when you move the cursor close to the start
point of the first line, the color of yellow circle changes to green and the cursor
snaps to the start point. On selecting the point at this stage, the loop will be
closed and you will exit the current line chain.

2. To draw center lines, first choose the Centerline tool from the Format panel
and then create lines. Alternatively, select the required entities from the drawing
window and then choose the Centerline tool; the selected entities will become
center lines.

Restarting a Line

To restart a line, right-click in the graphics window and choose Restart from the
Marking Menu; the start point of the line is cancelled and you are prompted to
select the start point of the line.

Drawing Circles

In Autodesk Inventor, you can draw circles by using two methods. You can draw
a circle by defining the center and the radius of the circle or by drawing a circle
that is tangent to three specified lines. Both these methods of drawing the circle
are discussed next.

Drawing a Circle by Specifying the Center Point and Radius Ribbon:
Sketch > Create > Circle drop-down > Circle Center Point This is the
default method of drawing circles. In this method, you need to define



the center point and radius of a circle. To draw a circle using this
method, choose the Circle Center Point tool from the Create panel,

refer to Figure 2-19; you will be prompted
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Figure 2-19 Tools in the Circle drop-down

to select the center of the circle. Specify the center point of the circle in the
drawing window; you will be prompted to specify a point on the circle. Click at
the required location in the drawing window to specify a point on the
circumference of the circle. This point will define the radius of the circle.
Alternatively, enter the required value in the Pointer Input to specify the
diameter of the circle. You can also specify the center and the radius using the
Inventor Precise Input toolbar. Figure 2-20 shows a circle drawn by using the
center and the radius.

Drawing a Circle by Specifying Three Tangent Lines Ribbon: Sketch
> Create > Circle drop-down > Circle Tangent

The second method of drawing circles is used to draw it tangent to three selected
lines. To draw a circle using this method, choose the Circle Tangent tool from
the Draw panel, refer to Figure 2-19; you will be prompted to select the first,
second, and third line, sequentially. As soon as you specify the third line, a circle
tangent to all the three specified lines will be drawn, as shown in Figure 2-21.

Figure 2-20 Circle drawn using the center point and radius
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Figure 2-21 Circle drawn using three tangent lines

Drawing Ellipses

Ribbon: Sketch > Create > Circle drop-down > Ellipse To draw an ellipse
choose the Ellipse tool from the Create panel; you will be prompted to
specify the center of the ellipse. Select a point to specify the center of the
ellipse; you will be prompted to specify the first axis point. Specify a point
to define the first axis of the ellipse; you will be prompted to select a point
on the ellipse. Select a point on the ellipse; the ellipse will be created. You

can also specify these points using the Inventor Precise Input toolbar.
However, remember that you cannot use the relative options

for defining the points of the ellipse. Therefore, if you use the Inventor
Precise Input toolbar for drawing the ellipse, all the values will be specified
from the origin. However, you can redefine the origin by choosing

the Precise Redefine button and placing it at the point that you want to
define at the origin. Figure 2-22 shows an ellipse drawn in the
Sketchingenvironment.

Figure 2-22 An ellipse drawn in the Sketching environment



Drawing Arcs
Autodesk Inventor provides three methods for drawing arcs. These methods are
discussed next.

Drawing an Arc by Specifying Three Points Ribbon: Sketch > Create
> Arc drop-down > Arc Three Point This is the default method of
drawing arcs. To create an arc with three points, choose the Arc
Three Point tool from the Create panel, see Figure 2-23, and then
specify three points. The first point is the start point of the arc, the
second point is the endpoint of the arc, and the third point is a point on
the arc. You can define these points by specifying them in the drawing
window or by using the Inventor Precise Input toolbar. You can also
use the Pointer Input for specifying the second and the third point of
the arc. Figure 2-24 shows an arc drawn using this method.
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Figure 2-23 Tools in the Arc drop-down

Drawing an Arc Tangent to an Existing Entity Ribbon: Sketch >

Create > Arc drop-down > Arc Tangent

This method is used to draw an arc that is tangent to an existing open entity. The
open entity can be an arc or a line. To draw an arc using this method, choose the
Arc Tangent tool from the Create panel (see Figure 2-23); you will be
prompted to select the start point of the arc. The start point of the arc must be the
start point or endpoint of an existing open entity. Once you specify the start
point, a rubber-band arc will start from it. Note that this arc is tangent to the
selected entity. Now, you will be prompted to specify the endpoint of the arc.
Click on the drawing window to specify the endpoint of the arc. Alternatively,
enter the radius and the angle values in the Pointer Input to specify the endpoint



of the arc. Here, it is very important to mention that the Inventor Precise Input
toolbar or the Pointer Input cannot be used to select the start point of this arc.
However, you can use this toolbar to specify the endpoint of this arc. Figure 2-25
shows an arc drawn tangent to the line.
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Figure 2-24 Drawing the three points arc
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Figure 2-25 Drawing the tangent arc

Drawing a Tangent/Normal Arcs by Using the Line Tool You can also
draw a tangent or a normal arc when the Line tool is activated. At
least a line or an arc should be drawn before drawing an arc using this
method. To do so, draw a line or an arc and then invoke the Line tool;
you are prompted to select the start point of the line. Move the cursor
close to the point from where you want to start the tangent or normal
arc, the yellow circle in the cursor turns green. Select the point at this
stage; the green circle in the cursor turns gray. Press the left mouse
button and drag the mouse; four construction lines appear at the start
point displaying the normal and tangent directions. If you drag along



the tangent direction, a tangent arc is drawn. But if you drag along the
normal direction, an arc normal to the selected entity is drawn.

Drawing an Arc by Specifying the Center, Start, and End points
Ribbon: Sketch > Create > Arc drop-down > Arc Center Point This
method is used to draw an arc by specifying the center point, start
point, and endpoint of the arc. To draw an arc using this method,
choose the Arc Center Point tool from the Create panel (see Figure
2-23). On doing so, you will be prompted to specify the center point
of the arc. Once you specify the center point of the arc, you will be
prompted to specify the start point and then the endpoint of the arc,
refer to Figure 2-26. You can also specify the start point and endpoint
of the arc by using the Pointer Input. In case of start point, you need to
specify the radius and angle of the arc from the center point. Whereas,
in case of endpoint, you need to specify the arc length in terms of
angle value. You can use the TAB key to toggle between the input
values of the Pointer Input. As you define the center point and the
start point, the radius of the arc will be defined automatically. So, the
third point is just used to define the arc length. An imaginary line is
drawn from the cursor to the center of the arc. The point at which the
arc intersects the imaginary line will then be taken as the endpoint of
the arc, see Figure 2-27. You can also use the Inventor Precise Input
toolbar to specify these three points of the arc.
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Figure 2-26 The arc created by specifying the center, start, and end points




Figure 2-27 The imaginary line created while drawing the center point arc

Drawing Rectangles
In Autodesk Inventor, rectangles can be drawn by using variousO methods that
are discussed next.

Drawing a Rectangle by Specifying Two Opposite Corners Ribbon:
Sketch > Create > Rectangle/Slot drop-down > Rectangle Two Point
This is the default method used to draw a rectangle specifying its

two opposite corners. To draw a rectangle by using this method,
choose the Rectangle Two Point tool from the Create panel,

see Figure 2-28; you will be prompted to specify the first corner of the
rectangle and the Pointer Input will be displayed. Click at the required
location to specify the first corner of the rectangle. Once you specify
the first corner, you will be prompted to specify the opposite corner of
the rectangle and the Pointer Input will be modified. Click

to specify the second corner or enter the length and height of

the rectangle in the Pointer Input. Figure 2-29 shows a rectangle
drawn using the Rectangle Two Point tool
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Figure 2-28 Tools in the’RectangIe/Slot drop-down

Drawing a Rectangle by Specifying Three Points on a Rectangle
Ribbon: Sketch > Create > Rectangle/Slot drop-down > Rectangle
Three Point You can draw a rectangle by specifying its three points.
In this method, the first two points are used to define the length and
angle of one of the sides of the rectangle and the third point is used to
define the length of the other side. To create a rectangle by using this
method, choose the Rectangle Three Point tool from the
Rectangle/Slot drop-down of the Create panel of the Sketch tab, see
Figure 2-28; you will be prompted to specify the first corner of the
rectangle. Once you specify it, you will be prompted to specify the
second corner of the rectangle. Both these corners are along the same
direction. As a result, you can use these points to define the length of
one side of the rectangle. After specifying the second corner, you will
be prompted to specify the third corner. This corner is used to define
the length of the other side of the rectangle. Note that if you specify
the second corner at a certain angle, then the resultant rectangle will
also be inclined. You can also specify the first, second, and third
points of the rectangle by using the Pointer Input. In case of second
point, you need to specify the length and angle of rectangle in the
input value fields of the Pointer Input. Whereas, in case of endpoint,
you need to specify the height of the rectangle. You can use the TAB
key to toggle between the input values of the Pointer Input. You can



also specify the three points for drawing the rectangle using the
Inventor Precise Input toolbar. Figure 2-30 shows an inclined
rectangle drawn by using the Three Point Rectangle tool.
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Figure 2-29 Drawing a rectangle using two points
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Figure 2-30 An rectangle draw using the Three-Point Rectangle tool

Drawing a Rectangle by Specifying its Two Points Ribbon: Sketch >
Create > Rectangle/Slot drop-down > Rectangle Two Point Center
You can also draw a rectangle by specifying its two points. In this
method, the first point is used to define the center of the rectangle and
the second point is used to define the length and width of the
rectangle. To create a rectangle by using this method, choose the
Rectangle Two Point Center tool from the Rectangle/Slot drop-
down of the Create panel in the Sketch tab, refer to Figure 2-28; you
will be prompted to specify the center of the rectangle. Click in the



Graphics window to specify it and move the cursor toward left or
right; the Pointer Input will be displayed. Enter the length and width
of the rectangle in the Pointer Input. Figure 2-31 shows a rectangle
drawn using the Rectangle Two Point Center tool.

Drawing a Rectangle by Specifying Three Different Points on a
Rectangle Ribbon: Sketch > Create > Rectangle/Slot drop-down >
Rectangle Three Point Center You can also draw a rectangle by
specifying its three points. In this method, the first point is used to
define the center of the rectangle, the second point is used to define
the length and orientation of the rectangle, and the third point is used
to define the width of the rectangle. To create a rectangle by this
method, choose the Rectangle Three Point Center tool from the
Rectangle/Slot drop-down in the Create panel of the Sketch tab,
refer to Figure 2-28; you will be prompted to specify the center of the
rectangle. Click at the required location to specify the center; Pointer
Input will be displayed. Now, move the cursor and click to specify the
first corner point and orientation of the rectangle. Again, move the
cursor to specify the second corner point of the rectangle. Figure 2-32
shows a rectangle drawn using the Rectangle Three Point Center
tool.

Figure 2-31 Drawing a rectangle by using the Rectangle Two Point Center tool



Figure 2-32 Drawing a rectangle by using the Rectangle Three Point Center
tool

Drawing Polygons
Ribbon: Sketch > Create > Rectangle/Slot drop-down > Polygon The polygons

drawn in Autodesk Inventor are regular polygons. A regular polygon is a
multi-sided geometric figure in which the length of all sides and the angle

between them are same. In Autodesk Inventor, you can draw a polygon with
the number of sides ranging from 3 to 120. When you invoke
the Polygon tool, the Polygon dialog box will be displayed, as shown in

Figure 2-33, and you will be prompted to select the center of the polygon.
The options in this dialog box are discussed next.
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Figure 2-33 The Polygon dialog box

Inscribed

This is the first button in the Polygon dialog box and is chosen by default. This
option is used to draw an inscribed polygon. An inscribed polygon is the one that
is drawn inside an imaginary circle such that its vertices touch the circle. Once
you have specified the polygon center, you will be prompted to specify a point
on the polygon. In case of an inscribed polygon, the point on the polygon
specifies one of its vertices, see Figure 2-34.



Circumscribed

This is the second button in the Polygon dialog box and is used to draw a
circumscribed polygon. A circumscribed polygon is the one that is drawn outside
an imaginary circle such that its edges are tangent to the imaginary circle. In
case of a circumscribed polygon, the point on the polygon is the midpoint of one
of the polygon edges, see Figure 2-35.

Number of Sides This edit box is used to specify the number of sides
of the polygon. The default value is 6. You can enter any value
ranging from 3 to 120 in this edit box.

Note

The rectangles and polygons are a combination of individual lines. All the lines
can be separately selected or deleted. However, when you select one of the lines
and drag, the entire rectangle or polygon will be considered as a single entity.
As a result, the entire object will be moved or stretched.

Center of
polygon

Figure 2-34 Drawing a six-sided inscribed polygon
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polygon

Figure 2-35 Drawing a five-sided circumscribed polygon



Drawing Slots

In Autodesk Inventor, you can draw linear or arched slots by using the Slot tools
available in the Rectangle/Slot drop-down of the Create panel in the Ribbon,
refer to Figure 2-36.The methods of drawing slots are discussed next.

Drawing a Center to Center Slot
Ribbon: Sketch > Create > Rectangle/Slot drop-down > Slot Center To Center
To create a center to center slot, choose the Slot Center to Center tool from

the Rectangle/Slot drop-down; you will be prompted to specify the start
center point. Click in the graphics window to specify the start center point,
you will be prompted to specify the end center point. Now, you can specify
the end point by specifying distance in dynamic prompt or by clicking in the
graphics window to specify the point. Specify the end center point; you will
be prompted to specify the diameter or width of the slot. Specify the width
or diameter in the dynamic prompt; the slot will be created. This type of

slot is called the linear slot. Figure 2-37 shows a Center to Center Slot
created.
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Figure 2-36 The Slot drop-down

Drawing an Overall Slot Ribbon: Sketch > Create > Rectangle/Slot
drop-down > Slot Overall To create an Overall Slot, choose the Slot
Overall tool from the Rectangle/Slot drop-down; you will be
prompted to specify the start point. Click in the graphics window to



specify the start point; you will be prompted to specify the end point.
Now, you can specify the end point by specifying the distance in
dynamic prompt or clicking in the graphics window. Specify the end
point; you will be prompted to specify the diameter or width of the
slot. Specify the width or diameter in the dynamic prompt; the slot
will be created. This type of slot is also called the linear slot. Figure 2-
38 shows an Overall Slot created.
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Figure 2-37 Center to Center Slot
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Figure 2-38 Overall slot

Drawing a Center Point Slot Ribbon: Sketch > Create >
Rectangle/Slot drop-down > Slot Center Point To create a Center
Point Slot, choose the Slot Center Point tool from
the Rectangle/Slot drop-down; you will be prompted to specify the
center point of the slot. Click in the graphics window to specify the
center point of the slot; you will be prompted to specify the second
point. You can specify the distance of the second point either by using
the dynamic prompt or clicking in the graphics window. Specify the
second point; you will be prompted to specify the diameter or width of
the slot. Specify the width or diameter in the dynamic prompt; the slot



will be created. This type of slot is also called a linear slot. Figure 2-
39 shows a Center Point Slot created.
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Figure 2-39 Center Point Slot created

Center point

Drawing a Three Point Arc Slot Ribbon: Sketch > Create >
Rectangle/Slot drop-down > Slot Three Point Arc To create a Three
Point Arc slot, choose the Slot Three Point Arc tool from
the Rectangle/Slot drop-down; you will be prompted to specify the
start point of the center arc. Click in the graphics window to specify
the start point of center arc; you will be prompted to specify the end
point. Now you can specify the end point either by specifying length
in the dynamic prompt or by clicking in the graphics window; you
will be prompted to specify the third point of the center arc. Specify
the third point; you will be prompted to specify the diameter or width
of the slot. Specify the width or diameter in the dynamic prompt; the
slot will be created. This type of slot is called the arc slot. Figure 2-40
shows a Three Point Arc slot created.

Figure 2-40 Three Point Arc Slot created

Drawing a Center Point Arc Slot Ribbon: Sketch > Create >



Rectangle/Slot drop-down > Slot Center Point Arc To create a Center
Point Arc slot, choose the Slot Center Point Arc tool from
the Rectangle/Slot drop-down; you will be prompted to specify the
center of the Center Point Arc. Specify the center; you will be
prompted to specify the start point of the arc. Specify the start point
by entering angle value in the dynamic prompt; you will be prompted
to specify the end point. Specify the end point by entering angle value
in the dynamic prompt; you will be prompted to specify the diameter
or width of the slot. Specify the width or diameter in
the dynamic prompt; the slot will be created. This type of slot is also
called the arc slot. Figure 2-41 shows a Center Point Arc slot created.
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Figure 2-41 Center Point Arc Slot created

Placing Points

Ribbon: Sketch > Create > Point In Autodesk Inventor, you can place the
sketched points in a sketch by using the Point tool. To place a point, choose
the Point tool from the Create panel of the Sketch tab; you will be prompted
to select the center point. Specify the center point; a point will be placed.

You can specify the location of a point in the sketch by picking a point from
the graphics window or by entering the value in the Inventor Precise Input

toolbar.

Creating Fillets

Ribbon: Sketch > Create > Fillet/Chamfer drop-down > Fillet Filleting is
defined as the process of l‘OllndiIlg the sharp corners of a sketch. This is done to reduce

the stress concentration in the model and for smooth handling. Using the Fillet tool, you can round

the corners of the sketch by creating_an arc tangent to both the selected_entities. The portions of the




selected entities that comprise the sharp corners are trimmed when the fillet is created. When you

invoke this tool from the Fillet/Chamfer drop-down, refer to Figure 2-42, the 2D Fillet dialog box

will be displayed with the default fillet radius, as shown in Figure 2-43, and vou will be prompted to

select the lines or the arcs to be filleted. If you have already created some fillets, their radius values

will be stored as preset values. You can select these preset values from the list that is displayed when
you choose the arrow provided on the right of the edit box.

You can create any number of fillets of similar or dissimilar radii. If the Equal
button in the 2D Fillet dialog box is chosen, the dimension of the fillet will be
placed only on the first fillet and not on the other fillets created by using the
same sequence, see Figure 2-44. On modifying the dimension of the first fillet,
all instances of fillet will be modified. To create fillets of independent radii
values, deactivate the Equal button before creating fillets. The fillets thus
created will show individual dimensions, see Figure 2-45. As a result, you can
modify the dimension of one fillet without affecting the other. You can fillet two
parallel or perpendicular lines, intersecting lines or arcs, non-intersecting lines or
arcs, and a line and an arc.
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Figure 2-42 Tools in the Fillet’Chamfer drop-down
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Figure 2-43 The 2D Fillet dialog box
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Figure 2-44 Rectangle filleted using the same radius with the Equal button chosen
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Figure 2-45 Rectangle filleted using different radii with the Equal button deactivated

Creating Chamfers Ribbon: Sketch > Create >
Fillet/Chamfer drop-down > Chamfer Chamfering is
defined as the process of beveling the sharp corners of a
sketch. This is the second method of reducing

stress concentration. To chamfer sketched entities, choose
the Chamfer tool from the Create panel (see Figure 2-
42); the 2D Chamfer dialog box will be displayed, as
shown in Figure 2-46. Also, you will be prompted to
select the lines to be chamfered. Select the lines; the
chamfer will be created. The options in the 2D
Chamfer dialog box are discussed next.
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Figure 2-46 The 2D Chamfer dialog box

Create Dimensions

The Create Dimensions button is chosen to show the dimensions of the chamfer
on the sketch. When you chamfer two lines, the dimensions of the chamfer are
shown in the sketch. If you choose this button again, the chamfer dimensions
will not be displayed in the sketch when you create another chamfer.

Equal
The Equal button is chosen to create multiple chamfers with the same
parameters. This button is enabled only if the Create Dimensions button is
chosen.

Equal Distance The Equal Distance button is chosen to create an
equal distance chamfer. The distance of the vertex along the

two selected edges is the same. As a result, a 45-degree chamfer is
created using this method. The distance value is specified in

the Distance edit box. If the Create Dimensionbutton is chosen,
two dimensions of the same value will be shown in the sketch, as
shown in Figure 2-47
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Figure 2-47 Chamfer with dimension values



Unequal Distances

The Unequal Distances button is chosen to create a chamfer with two different
distances. The distance values are specified in the Distancel and Distance?2 edit
boxes. The distance value specified in the Distancel edit box is measured along
the edge selected first. Similarly, the value in the Distance2 edit box is measured
along the edge selected next. Figure 2-48 shows a chamfer created by using the
Unequal Distances button.

Distance and Angle

The Distance and Angle button is chosen to create a chamfer by specifying a
distance and an angle. On choosing this button, the distance needs to be
specified in the Distance edit box and the angle in the Angle edit box. The
specified angle is measured from the first edge selected to chamfer, see Figure 2-
49.
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Figure 2-48 The chamfer created using the Unequal Distances button
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Figure 2-49 The chamfer created using the Distance and Angle button

Tip.

1. If multiple chamfers are created with same values, the dimension value is
displayed only at the first instance. At the remaining chamfers, the dimension
will be displayed as fx of the value, which means the function of the original
value.

2. You can also select the vertex to create a fillet or chamfer. The two entities
forming the selected vertex will be filleted or chamfered using the current
parameters.

Drawing Splines
Autodesk Inventor provides various methods for drawing splines. These methods

are discussed next.

Drawing a Spline by Using the Spline Interpolation Tool Ribbon:
Sketch > Create > Line/Spline drop-down > Spline Interpolation To
draw a spline, choose the Spline Interpolation tool from the
Line/Spline drop-down of the Create panel, refer to Figure 2-50; you
will be prompted to specify the first point of the spline. Specify the
first point; you will be prompted to specify the next point of the
spline. This process will continue until you terminate the spline
creation. To end the spline at the current point, double-click in

the drawing window or right-click to display the Marking Menu and
choose Create. Note that if you choose Cancle(ESC) from

the Marking Menu, the spline will not be drawn. You can also end the
spline creation by pressing the ENTER key. Note that after creating a
spline, the square and diamond points will be displayed on the spline
along with the tangent handles, as shown in Figure 2-51. You can drag
these square and diamond points to modify the shape of the spline. To
exit the command, press the ESC key or choose Cancle(ESC) from



the Marking Menu.
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Figure 2-50 Tools in the Line/Spline drop-down

You can undo the last drawn spline segment while drawing a spline. This can be
done by choosing the Back option from the Marking Menu which is displayed
when you right-click anywhere in the graphics window. You can also draw a
spline tangent to an existing entity. To draw the tangent spline, select the point
where the spline should be tangent. Next, hold the left mouse button and drag it;
a construction line will be drawn, displaying the possible tangent directions for
the spline. Drag the mouse in the required direction to draw the tangent spline
and release the left mouse button. Figure 2-52 shows a spline drawn tangent to
an existing line.

Tip. Autodesk Inventor allows you to invoke the last used tool by right-clicking
anywhere in the drawing window and choosing the Repeat option (name of the
last used tool) from the Marking menu. For example, the Repeat Line option
will be available in the Marking Menu, if the line tool was the last used tool.
Alternatively, you can press the SPACEBAR key to invoke the last used tool.



Figure 2-51 A spline drawn by specifying different points
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Figure 2-52 A spline drawn tangent to a line

Drawing a Spline by Specifying Control Vertices Ribbon: Sketch >
Create > Line/Spline drop-down > Spline Control Vertex To draw a
spline, choose the Spline Control Vertex tool from

the Line/Spline drop-down in the Create panel, see Figure 2-53; you
will be prompted to specify the first point of the spline. Specify the
start point; you will be prompted to specify the next point of the
spline. This process willcontinue until you terminate the spline
creation. To end the spline at the current point, double-click in

the drawing window or right-click to display the Marking Menu and
choose Create. Note that if you choose Cancel (ESC) from the
Marking Menu, the spline will not be drawn. You can also end the
spline creation by pressing the ENTER key. Note that after creating a
spline, the control vertices will be displayed on the spline along with
the tangent handles, as shown inFigure 2-54. You can drag these



control vertices to modify the shape of the spline. These control
vertices act as poles for controlling the shape of the splines. Figure 2-
55 shows a spline drawn tangent to a line. To exit the command, press
the ESC key on the keyboard or choose OK from the Marking menu.
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Figure 2-53 Spline Control Vertex tool to be chosen in the Line/Spline drop-
down

Figure 2-54 A spline drawn by specifying different control vertices



Figure 2-55 A spline drawn tangent to a line

Creating a Smooth Curve between the Two Existing
Curves Ribbon: Sketch > Create > Line/Spline drop-
down > Bridge Curve In Autodesk Inventor, you can
create a smooth (G2) continuous curve between two
existing curves. The existing curves can be arcs, lines,
splines, or projected curves. To create a smooth curve,
choose the Bridge Curve tool from the Line/Spline
drop-down in the Create panel of the Sketch tab, refer to
Figure 2-53; you will be prompted to select the curves
one after the other. Select the two curves; a smooth G2
continuous curve, known as bridge curve, will be created
between the selected curves. The profile of the bridge
curve depends on the position of the points selected on
the existing curves. Figure 2-56 shows two points
selected on the two curves and the resulting bridge curve.
Figure 2-57 shows two different points selected on the
curves shown in Figure 2-56 and the resulting bridge
curve.
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Figure 2-56 Bridge curve created between two points selected on two curves
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Figure 2-57 Bridge curve created between two different points on the curves shown in Figure 2-56

DELETING SKETCHED ENTITIES

To delete a sketched entity, first ensure that no drawing tool is active. If any of
them is active, press the ESC key for deactivating. Now, select the entity you
want to delete using the left mouse button and then right-click to display the
Marking Menu. Choose the Delete option from this Marking Menu. You can
also press the DELETE key to delete the selected entities. To delete more than
one entity, you can use a window or a crossing as discussed next.

Deleting Entities by Using a Window

A window is defined as a box created by pressing and holding the left mouse
button and dragging the cursor from left to right in the drawing window. The
window has a property that all the entities that lie completely inside the window



will be selected. The box defined by the window consists of continuous lines.
All the selected entities will be displayed in cyan color. After selecting the
entities, right-click and choose Delete from the Marking menu or press the
DELETE key to delete all the selected entities.

Deleting Entities by Using a Crossing A crossing is
defined as a box created by pressing and holding down
the left mouse button and dragging the cursor from right
to left in the drawing window. The crossing has a
property that all entities that lie completely or partially
inside the crossing or the entities that touch the crossing
will be selected. The box defined by the crossing consists
of dashed lines. Once the entities are selected, right-click
and choose Delete from the Marking menu.

Tip. You can add or remove an entity from the selection set by pressing the
SHIFT or the CTRL key and then selecting the entity by using the left mouse
button. If the entity is already in the current selection set, it will be removed
from the selection set. If not, it will be added to the set.

FINISHING A SKETCH

After creating the required sketch, you need to save it. But before you save the
sketch, you need to finish the sketch and come out of the sketching environment.
To do so, choose the Finish Sketch tool from the Exit panel of the Sketch tab;
the sketch will be finished and you will switch to the Home view. You can also
exit the sketching environment by choosing the Finish 2D Sketch option from
the Marking menu. The Home view enables you to view and create the modeling
features with ease. After switching to the Modeling environment, you can save
the document.



UNDERSTANDING THE DRAWING DISPLAY
TOOLS

The drawing display tools or navigation tools are an integral part of any design
software. These tools are extensively used during the design process. These tools
are available in the Navigation Bar located on the right in the graphics window
and in the Navigate panel of the View tab. Some of the drawing display tools in
Autodesk Inventor are discussed next. The rest of these tools will be discussed in
the later chapters.

Zoom All

Ribbon: View > Navigate > Zoom drop-down > Zoom All

Navigation Bar: Zoom flyout > Zoom All The Zoom All tool is used to
increase the drawing display area to display all the sketched entities in the
current display.

Zoom

Ribbon: View > Navigate > Zoom drop-down > Zoom

Navigation Bar: Zoom flyout > Zoom The Zoom tool is used to interactively
zoom in and out of the drawing view. When you choose this tool, the default
cursor is replaced by a zoom cursor. You can zoom in the drawing by pressing
the left mouse button and dragging the cursor down. Similarly, you can zoom
out the drawing by pressing the left mouse button and then dragging the cursor
up. You can exit this tool by choosing another tool or by pressing ESC. You can
also choose Done [Esc] from the Marking menu, which is displayed on right-
clicking. You can also zoom in the drawing by rolling the scroll wheel of the
mouse in the downward direction. Similarly, you can zoom out the drawing by
rolling the scroll wheel in the upward direction.

Tip. If you need to increase the drawing display area then zoom out the drawing
by using the Zoom tool after increasing the grid spacing.

Z.oom Window



Ribbon: View > Navigate > Zoom drop-down > Zoom Window

Navigation Bar: Zoom flyout > Zoom Window The Zoom Window tool is
used to define an area to be magnified and viewed in the current drawing.
The area is defined using two diagonal points of a box (called window) in
the drawing window. The area inscribed in the window will be magnified

and displayed on the screen.

Tip.
1. The size of the dimension text always remains constant even if you magnify the
area that includes some dimensions.

2. To switch to the previous view, right-click in the drawing window and then
choose Previous View from the shortcut menu or press the F5 key. You can
restore nine previous views in the current sketching environment by using this
option.

Z.oom Selected

Ribbon: View > Navigate > Zoom drop-down > Zoom Selected

Navigation Bar: Zoom flyout > Zoom Selected When you choose the Zoom
Selected tool, you will be prompted to select an entity to zoom. Select an
entity from the drawing area; it will magnified to the maximum extent and
will be placed at the center of the drawing window. This tool can also be
invoked by pressing the END key.

Pan

Ribbon: View > Navigate > Pan

Navigation Bar: Pan The Pan tool is used to drag the current view in the
drawing window. This option is generally used to display the contents of the
drawing that are outside the display area without actually changing the
magnification of the current drawing. It is similar to holding the drawing
and dragging it across the drawing window. You can also invoke the Pan
tool by pressing and holding the middle scroll wheel of the mouse.




Orbit

Ribbon: View > Navigate > Orbit drop-down > Orbit
Navigation Bar: Orbit flyout > Orbit The Orbit tool is used to rotate a model
freely about any axis. It is useful when you want to rotate a model to any

position. It is a transparent tool as it can be invoked inside any other

command. You can invoke this tool by choosing the Orbit tool from the
Navigate panel in the View tab. On doing so, an arcball will be displayed.

This arcball is a circle with four small lines placed such that they divide the
arcball into quadrants. The orbit axis is parallel to the screen and if you
rotate an object by dragging the mouse pointer outside the arcball, the
object will rotate about the orbit axis. Figure 2-58 shows the model to be
rotated and Figure 2-59 shows the same model rotated about the vertical
axis by using the Orbit tool.

Selected face

Figure 2-58 Position 1: Default view of the model



Selected face

Figure 2-59 Position 2: Model rotated about the vertical axis

Note
While working with the Orbit Tool the viewport adjusts for better visibility and understanding.

Constrained Orbit Ribbon: View > Navigate > Orbit
drop-down > Constrained Orbit

Navigation Bar: Orbit flyout > Constrained Orbit The
Constrained Orbit tool is used to visually maneuver
around the 3D objects to obtain different views. This is
one of the most important tool used for advanced 3D
viewing. Figures 2-60 and 2-61 show the default view of
the model, and the view after one complete rotation,
respectively. When the Constrained Orbit tool is
invoked, the cursor changes and looks like a sphere
encircled by two arc-shaped arrows. This cursor is known
as the Orbit mode cursor. You can click and drag the
mouse to rotate the model freely. You can move the Orbit
mode cursor horizontally, vertically, and diagonally. In



this case, the axis is normal to the top and bottom faces of
the ViewCube. This is also a transparent tool as it can be
invoked inside any other tool.

Tip. 1. Press and hold the SHIFT key and the middle mouse button to
temporarily enter the Constrained Orbit mode.

Selected
face

Figure 2-60 Position 1: Default view of the model

Selected face

Figure 2-61 Position 2: Model after a complete rotation

TUTORIALS

Although Autodesk Inventor is parametric in nature yet in this chapter you will
use the Inventor Precise Input toolbar and the Dynamic Input method to draw
objects. This is to ensure that you are comfortable while using various drawing
options in Autodesk Inventor. In the later chapters, you will use the parametric
feature of Autodesk Inventor to size or draw the entities as per the desired



dimension values.

Note

You can also choose the tools displayed by default in the Status Bar at the
bottom of the graphics window.

Tutorial 1

In this tutorial, you will draw the sketch of the model shown in Figure 2-62. The
sketch to be drawn is shown in Figure 2-63. Do not dimension it, as the
dimensions are given only for reference. (Expected time: 30 min)

Figure 2-62 Model for Tutorial 1
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Figure 2-63 Sketch of the model

The following steps are required to complete this tutorial: a. Start a new
Autodesk Inventor session and then start a new metric part file.

b. Invoke the Line tool and draw the sketch by specifying the coordinates of the
points in the Dynamic Input.



c. Save the sketch with the name Tutoriall and close the file.

Starting Autodesk Inventor
1. Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop
of your computer; a new session of Autodesk Inventor is started.

2. Choose the New tool from the Launch panel of the Ribbon; the Create New
File dialog box is displayed.

3. Choose Metric and then double-click on the Standard (mm).ipt icon to start
a standard metric template; a new metric standard part file starts.

4. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

5. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

6. Now, select the YZ plane as the sketching plane from the graphics window;
the Sketching environment is invoked and the YZ plane becomes parallel to
the screen.

Note 1. If the orientation of the ViewCube is not the same as the orientation of
the selected plane (Top/Front) then click on the down arrow available next to
the ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.

2. If by default the Grid lines are not displayed in the sketching environment,
choose the Application Options button from the Options panel of the Tools tab;
the Application Options dialog box will be invoked. Now, select the Grid lines
check box from the Display area of the Sketch tab.

3. For the purpose of accuracy, Grid lines are kept ON in all the tutorials.

Drawing the Sketch As mentioned earlier, Autodesk Inventor is parametric in
nature. Therefore, you can draw the sketch from any point in the drawing



window. In this tutorial, Dynamic Input has been used to enter dimensions while
drawing the sketch.

1. Choose the Line tool from the Create panel in the Sketch tab. Alternatively,
choose the Create Line tool from the Marking Menu that is displayed on
right-clicking in the drawing / Graphics window. On doing so, you are
prompted to select the first point for the line. Next, choose Precise Input from
the expanded Create panel of the Sketch tab; the Inventor Precise Input
toolbar is displayed. Double-click on the title bar of this toolbar to dock it. If
required, you can also leave this toolbar floating on the screen.

Initially, the Precise Input button is not enabled. This button is enabled only
when you invoke a sketching tool. Since all initial settings are configured, you
can now start drawing the sketch.

When you invoke the Line tool, the cursor is replaced by a drawing cursor that
has a yellow circle at the intersection of crosshairs. When you move the
crosshair in the drawing window, this circle snaps to the point that is closer to
it. Also, coordinates of the current location of the cursor are displayed at the
status bar.

2. To specify the first point, enter 0 in both the X and Y edit boxes of the
Inventor Precise Input toolbar and then press ENTER; you are prompted to
specify the endpoint of the line.

3. In the Inventor Precise Input toolbar, enter -3 and 3 in the X and Y edit
boxes, respectively. Next, press ENTER to define the endpoint of the line. On
doing so, the first line of the sketch is drawn and you are prompted to select
the endpoint of the line.

You will notice that the dimensions of the sketch are very small but the drawing
display area is large. Therefore, you need to modify the drawing display area
by using the drawing display tools. To do so, you can use the Zoom tool.

Tip.
You can use the TAB key to switch from the X edit box to the Y edit box and vice versa in the Inventor

Precise Input toolbar.



4. Choose the Zoom tool from the Navigation Bar; the drawing cursor is
changed to an arrow cursor.

5. Move the cursor to the top of the drawing window, press and hold the left
mouse button and then drag the cursor downward till the display is adjusted.

6. Right-click to display the shortcut menu, and then choose Done to exit the
Zoom tool.

7. Again, right-click in the graphics window and then choose Cancel (ESC)
from the Marking Menu to exit the Line tool. Also, close the Inventor
Precise Input toolbar.

8. Invoke the Line tool again. From this step onward, you will use the Dynamic
Input to create lines in this tutorial. Select the end point of the first line that
was created with the help of the Inventor Precise Input toolbar. Move the
cursor toward left, and enter 0.5 in the length input field and 180 in the angle
input field and then press ENTER. Use the TAB key to toggle between the
input fields.

9. Now, you need to create the third line between points 3 and 4, refer to Figure
2-64. To do so, move the cursor downward in the graphics window. Enter 3 in
the length input field, press TAB to switch to the angle input field, and enter
90 and then press ENTER; a line is created between the 3 and 4 points.

10. Move the cursor toward left in the graphics window. Enter 2 in the length
input field, press TAB to switch to the angle input field, and enter 90 in it, and
then press ENTER; a line is created between points 4 and 5, refer to Figure 2-
64.

11. Move the cursor downward in the graphics window. Enter 1 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 5 and 6, refer to Figure 2-64.
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Figure 2-64 Sketch for Tutorial 1

12. Move the cursor toward right in the graphics window. Enter 3 in the length

input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 6 and 7.

13. Move the cursor downward in the graphics window. Enter 0.75 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 7 and 8, refer to Figure 2-64.

14. Move the cursor toward right in the graphics window. Enter 0.5 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 8 and 9, refer to Figure 2-64.

15. Move the cursor upward in the graphics window. Enter 0.25 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 9 and 10, refer to Figure 2-64.

16. Move the cursor toward right in the graphics window. Enter 4 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 10 and 11, refer to Figure 2-64.

17. Move the cursor downward in the graphics window. Enter 0.25 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line is created between points 11 and 12, refer to Figure 2-64.

18. Move the cursor toward right in the graphics window. Enter 0.5 in the length
input field, press TAB and enter 90 in the angle input field and then press
ENTER; a line connecting points 12 and 13 is created, refer to Figure 2-64.



19. Move the cursor upward in the graphics window. Enter 0.75 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line connecting points 13 and 14 is created, refer to Figure 2-64.

20. Move the cursor toward right in the graphics window. Enter 3 in the length
input field and 90 in the angle input field and then press ENTER; a line
connecting points 14 and 15 is created, refer to Figure 2-64.

21. Move the cursor upward in the graphics window. Enter 1 in the length input
field, press TAB, and enter 90 in the angle input field and then press ENTER,;
a line connecting points 15 and 16 is created, refer to Figure 2-64.

22. Move the cursor toward left in the graphics window. Enter 2 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line connecting points 16 and 17 is created, refer to Figure 2-64.

23. Move the cursor upward in the graphics window. Enter 3 in the length input
field, press TAB, and enter 90 in the angle input field and then press ENTER;
a line connecting points 17 and 18 is created, refer to Figure 2-64.

24. Move the cursor toward left in the graphics window. Enter 0.5 in the length
input field, press TAB, and enter 90 in the angle input field and then press
ENTER; a line connecting points 18 and 19 is created, refer to Figure 2-64.

25. Now, to close the geometry, click on the point 1 that you created with the
help of the Inventor Precise Input toolbar.

26. Next, right-click in the Graphics window and choose Cancel (ESC) from the
Marking menu displayed to exit the Line tool.

Note
The method of applying additional constraints and using them to fully constrain
the sketch will be discussed in Chapter 3.

Saving the Sketch
Remember that you cannot save a sketch in the Sketching environment. This is
because the Sketching environment is just a part of the Part module in



Autodesk Inventor. This environment is used only for drawing the sketches of
features. Therefore, you need to exit the Sketching environment to save the
sketch for further use. The sketches in the Part module are saved in the .ipt
format.

. Right-click in the graphics window and then choose the Finish 2D Sketch
button from the Marking Menu displayed; the Sketching environment is closed
and you switch to the Part modeling environment. Now, choose the Home
button of the ViewCube; the current orientation of the sketch is changed to
Isometric. Also, notice that the 3D Model tab is activated in place of the
Sketch tab. The options in the 3D Model tab are used to create features. The
options under this tab will be discussed in later chapters.

2. Choose Save from Quick Access Toolbar; the Save As dialog box is
displayed.

3. Create a new folder with the name Inventor_2016 in the C drive of your
computer. In this folder, create another folder with the name c02.

4. Enter Tutoriall as the file name in the File name edit box, refer to Figure 2-
65, and then choose the Save button from the Save As dialog box to save the
sketch.
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Figure 2-65 The Save As dialog box

5. Choose Close > Close from the Application Menu to close this file.

Tutorial 2

In this tutorial, you will draw the sketch for the model shown in Figure 2-66.
The sketch to be drawn is shown in Figure 2-67. Do not dimension it, as the
dimensions are given only for reference. (Expected time: 30 min)

Figure 2-66 Model for Tutorial 2
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Figure 2-67 Dimensioned sketch for Tutorial 2

The following steps are required to complete this tutorial:

a. Start a new metric standard part file.

b. Draw the outer loop by specifying the length and angle lines by using the
Dynamic Input method, refer to Figure 2-68.

c. Draw the inner closed loop by using the Dynamic Input method, refer to
Figure 2-69.

d. Save the sketch with the name Tutorial2.ipt and close the file.

Starting a New File
1. Choose the New tool from the Launch panel of the Get started tab ; the Create New
File dialog box is displayed. In this dialog box, choose Metric, and then double-click on the Standard

(mm).ipt icon to start a standard metric template.

Drawing the Sketch

As evident from Figure 2-66, the sketch consists of two nested loops: inner loop
and outer loop. While extruding a nested loop, the inner loop can be subtracted
from the outer loop. In this way, a cavity will be created automatically in the
model when you extrude the sketch. This reduces the time and effort required
in creating the inner cavity as another feature. Therefore, you can draw both
the loops together for this tutorial.

1. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the



sketching plane.

2. Choose the Home button of the ViewCube; the current orientation of the
sketch plane is changed 3. Now, select the XY plane as the sketching plane
from the graphics window; the Sketching environment is invoked and the XY
plane becomes parallel to the screen.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.

4. Choose the Line tool from the Create panel. Next, move the cursor and click
when the cursor displays -40 and -25 in the Pointer Input or press the TAB key
and then enter the X and Y coordinate values in the Pointer Input. As you
specify the first point, you are prompted to specify the endpoint of the line and
the Pointer Input is changed to Dimension Input.

5. Enter 80 in the length input field of the Dimension Input and press the TAB
key; the angle input field becomes active. Enter 0 and then press ENTER; the
first line is created and the Dimension Input is displayed again.

6. Move the cursor up and then enter 10 in the length input field of the
Dimension Input. Next, press the TAB key and enter 90 in the angle input
field and then press ENTER; the second line is created and the Dimension
Input is displayed again.

7. Move the cursor toward the left and then enter 15 in the length input field.
Next, press the TAB key and enter 90 in the angle input field. Next, press
ENTER; the third line is created and the Dimension Input is displayed again.

8. Move the cursor up and then enter 30 in the length input field. Next, press the
TAB key and enter 90 in the angle input field. Next, press ENTER; the fourth
line is created and the Dimension Input is displayed again.

9. Move the cursor toward the right and then enter 15 in the length input field.
Next, press the TAB key and enter 90 in the angle input field. Next, press



ENTER; the fifth line is created and the Dimension Input is displayed again.

10. Move the cursor up and then enter 10 in the length input field. Next, press
the TAB key and enter 90 in the angle input field. Next, press ENTER; the
sixth line is created and the Dimension Input is displayed again.

11. Move the cursor toward the left and then enter 80 in the length input field.
Next, press the TAB key and enter 90 in the angle input field. Next, press
ENTER; the seventh line is created and the Dimension Input is displayed
again.

12. Move the cursor down and then enter 10 in the length input field. Next, press
the TAB key and enter 90 in the angle input field. Next, press ENTER; the
eighth line is created and the Dimension Input is displayed again.

13. Move the cursor toward the right and then enter 15 in the length input field.
Next, press the TAB key and enter 90 in the angle input field. Next, press
ENTER; the ninth line is created and the Dimension Input is displayed again.

14. Move the cursor down and then enter 30 in the length input field. Next, press
the TAB key and enter 90 in the angle input field. Next, press ENTER; the
tenth line is created and the Dimension Input is displayed again.

15. Move the cursor toward the left and then enter 15 in the length input field.
Next, press the TAB key and enter 90 in the angle input field. Next, press
ENTER; the eleventh line is created and the Dimension Input is displayed
again.

16. Move the cursor down and then enter 10 in the length input field. Next, press
the TAB key and enter 90 in the angle input field. Next, press ENTER; the
twelfth line is created and the Dimension Input is displayed again.

17. Right-click to display the Marking Menu and choose OK from it to exit the
Line tool. The sketch of the outer loop is shown in Figure 2-68. You need to
arrange the positions of dimensions in the sketch by dragging them to view the
sketch clearly.



Next, you need to draw the inner loop. You can draw the loop by using the Two
Point Rectangle tool.

18. Choose the Rectangle Two Point tool from the Sketch > Create >
Rectangle/Slot drop-down; you are prompted to specify the first corner of the
rectangle.

19. Press the TAB key and then enter -15 and -10 in the Pointer Input.
Alternatively, move the cursor and click when the cursor displays -15 and -10
in the Pointer Input. As you click to specify the first corner, you are prompted
to specify the opposite corner of the rectangle and the Pointer Input is changed
to Dimension Input.

20. Move the cursor diagonally upward in the right direction and enter 30 and 20
in the horizontal and vertical input fields of the Dimension Input, respectively,
and then press ENTER.

21. Next, right-click on the graphics window; a Marking Menu is displayed.
Choose Cancel (ESC) from the Marking Menu; the sketch is created, as
shown in Figure 2-69.
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Figure 2-68 Sketch of the outer loop
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Figure 2-69 Completed sketch for Tutorial 2

Note

The angular dimensions have not been shown in Figures 2-68 and 2-69 for
clarity of sketches. You can control the display of the linear and angular
dimensions of the sketch. To do so, choose Application Options from the
Options panel of the Tools tab; the Application Options dialog box is displayed.
In the Sketch tab of the Application Options dialog box, choose the Settings
button; the Constraint Settings dialog box is displayed. Clear the Create
dimensions from input values check box in the Dimensions area of the
Constraint Settings dialog box and then choose OK. Next, choose the Apply and
Close buttons from the Application Options dialog box to turn off applying
dimensions automatically during sketching.

Saving the Sketch

Next, you need to save the sketch. As mentioned earlier, you cannot save the
sketch in the sketching environment. First, you need to exit the Sketching
environment and then save it.

1. Choose the Finish Sketch button from the Exit panel; the Sketching
environment is closed and you will switch to the Home view of the part

modeling environment.

2. Choose the Save tool and save the sketch with the name Tutorial? at the
location given below: C:\Inventor_2016\c02

3. Choose Close > Close from the Application Menu to close this file.



Tutorial 3

In this tutorial, you will draw the sketch for the model shown in Figure 2-70.
The sketch of the model is shown in Figure 2-71. Do not dimension the sketch as
the dimensions are given only for reference. (Expected time: 30 min)

Figure 2-70 Model for Tutorial 3

Figure 2-71 Sketch for Tutorial 3

The following steps are required to complete this tutorial:

a. Start a new metric standard part file.

b. Draw the sketch by using the Arc and Line tools, refer to Figure 2-71.
c. Save the sketch with the name Tutorial3 and close the file.

Starting a New File



1. Choose the New tool from the Launch panel of the Get Started tab to invoke
the Create New File dialog box.

2. Start a new metric standard part file by double-clicking on Standard
(mm).ipt in the Metric.

3. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

4. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

5. Now, select the YZ plane as the sketching plane from the Graphics window;
the Sketching environment is invoked and the YZ Plane becomes parallel to
the screen.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.

Drawing the Sketch
The upper arc of the sketch can be drawn by specifying its center, start, and
endpoint. Therefore, you need to use the Center Point Arc tool to draw it.

1. Choose the Center Point Arc tool from the Sketch > Create > Arc drop-
down; you are prompted to specify the center of the arc.

2. Press the TAB key and enter 0 in the X coordinate edit field of the Dynamic
Input. Again, press TAB and enter 15 in the Y coordinate edit field. Next,
press ENTER to specify the center of the arc; the center of the arc is created
and you are prompted to specify the start point of the arc.

3. Enter 12 in the length input field. Next, press TAB and enter 180 in the angle
input field of the Dynamic Input and press ENTER.



The first point on the arc is defined. Now, you need to specify the endpoint of
the arc.

4. As you are trying to draw the upper arc, you need to move the mouse cursor in
the counterclockwise direction and enter 180 in the angle input field and press
ENTER. The upper arc is drawn.

Next, you need to draw lines in the sketch.

5. Choose the Line tool from the Create panel; you are prompted to specify the
start point of the line.

6. Move the cursor close to the start point of the arc; the yellow circle snaps to
the endpoint of the arc and turns green indicating that the cursor has snapped
to the endpoint of the arc. Press the left mouse button to select this point as the
start point of the line.

7. Move the cursor toward left in the graphics window. Enter 12 in the length
input field, press the TAB key, and then enter 180 in the angle input field in
the Dynamic Input; the line between points 2 and 3 is created. Refer to Figure
2-72 for point numbers.

Figure 2-72 Sketch showing different points for Tutorial 3

8. Move the cursor downward in the graphics window. Enter 30 in the length



input field and 90 in the angle input field in the Dynamic Input; a line between
points 3 and 4 is created.

9. Move the cursor toward right in the graphics window. Enter 12 in the length
input field and 90 in the angle input field of the Dynamic Input; a line is
created between points 4 and 5.

Now, you need to draw the lower arc of the sketch. You can use the Line tool to
draw the arc.

10. Move the cursor close to the endpoint of the last line until the yellow circle
snaps to that point. When the yellow circle snaps to the endpoint, it turns gray.
Now, press and hold the left mouse button and drag the mouse through a small
distance in the upward direction. On doing so, four imaginary lines are
displayed, showing the four directions in which you can draw the arc.

11. As you need to draw the arc normal to the line, drag the cursor vertically
upward along the vertical imaginary line to a small distance and then drag the
cursor close to the right endpoint of the upper arc; the cursor snaps to the
endpoint of the arc and turns green.

12. Move the cursor downward, you will notice a point where both the vertical
and horizontal imaginary lines intersect each other, see Figure 2-73. This point
is the endpoint of the lower arc. The cursor automatically snaps to that point.
Do not release the left mouse button until the entire process is completed.

13. When the cursor snaps to the intersection of the imaginary lines, release the
mouse button to complete the lower arc.

Note
1. In Figure 2-72, the major and minor grid lines, and the triad have not been
displayed for a better display of the sketch and the imaginary lines.

2. While using the temporary tracking option to draw lines, you do not need to
press and hold the left mouse button and drag it. You just need to click once to



select the endpoint of the line after you get the intersection point of the
imaginary lines, refer to Figure 2-73.
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Figure 2-73 Use of the temporary tracking option to draw an arc

Next, you need to draw the remaining lines to complete the sketch.

14. Move the cursor toward right in the graphics window. Enter 12 in the length
input field and 0 in the angle input field in the Dynamic Input; a line between
points 7 and 8 is created.

15. Move the cursor upward in the graphics window. Enter 30 in the length input
field and 90 in the angle input field in the Dynamic Input; a line between
points 8 and 9 is created.

16. Move the cursor toward left in the graphics window. Enter 12 in the length
input field and 90 in the angle input field in the Dynamic Input; a line between

points 9 and 10 is created.

17. Exit the Line tool.



The final sketch for Tutorial 3 is shown in Figure 2-74.

Figure 2-74 Final sketch for Tutorial 3

Note
In Figure 2-74, the automatic applied dimensions have not been shown for
clarity of sketches.

Saving the Sketch

1. As it is not possible to save the file in the Sketching environment, therefore
you need to exit the Sketching environment and then save the file. To do so,
right-click anywhere in the graphics window; a Marking Menu will be
displayed. Choose the Finish 2D Sketch option from the Marking menu; the
Sketching environment is closed and you switch to the part modeling
environment. Now, choose the Home button of ViewCube; the current
orientation of the sketch is changed to Isometric.

2. Choose the Save button from Quick Access Toolbar and save this sketch
with the name Tutorial4 at the location given below.

C:\Inventor_2016\c02

3. Choose Close > Close from the Application Menu to close this file.

Tutorial 4



In this tutorial, you will draw the basic sketch of the revolved solid model shown
in Figure 2-75. The sketch for creating this model is shown in Figure 2-76. Do
not dimension the sketch as the dimensions are given only for reference. Use
Dynamic Input to draw the feature. (Expected time: 30 min) The following
steps are required to complete this tutorial:

a. Start a new metric standard part file.

b. Invoke the Line tool and draw the sketch with the help of Dynamic Input.

c. Save the sketch with the name Tutorial4 and close the file.

d. Draw fillets

Figure 2-75 Revolved model for Tutorial 4
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Figure 2-76 Sketch for the revolved model

Starting a New File
1. Choose the New tool from the Launch panel of the Get Started tab to invoke



the Create New File dialog box.

2. Choose Metric to display the standard metric templates. Double-click on
Standard (mm).ipt to start a new metric part file.

3. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

4. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

5. Now, select the YZ plane as the sketching plane from the graphics window;
the Sketching environment is invoked and the YZ Plane becomes parallel to
the screen.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.

Drawing the Sketch

1. Choose the Line tool from the Create panel in the Sketch tab or from the
Marking Menu. On doing so, you are prompted to select the first point of the
line to be created. In the Dynamic Input, press TAB and enter 0 in the X
coordinate field. Next, press TAB, and enter 0 in the Y coordinate field and
press ENTER.

2. Now, you need to draw the line 1. Move the cursor toward left, enter 22 in the
length input field, and enter 180 in the angle input field of the Dynamic Input;
the line 1 is drawn.

3. Move the cursor upward in the graphics window. Next, enter 4 in the length
input field, press TAB, and enter 90 in the angle input field; the line 2 is
drawn, as shown in Figure 2-77.
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Figure 2-77 Sketch after drawing the lines

4. Move the cursor toward left in the Graphics window. Next, enter 14 in the
length input field, press TAB, and enter 90 in the angle input field in the
Dynamic Input; line 3 is drawn.

5. Move the cursor upward in the graphics window. Next, enter 6 in the length
input field, press TAB, and enter 90 in the angle input field in the Dynamic
Input; line 4 is drawn.

6. Move the cursor toward the left in the graphics window. Next, enter 8 in the
length input field, press TAB, and enter 90 in the angle input field in the
Dynamic Input; line 5 is drawn.

7. Move the cursor upward in the graphics window. Next, enter 6 in the length
input field, press TAB, and enter 90 in the angle input field in the Dynamic
Input; line 6 is drawn.

8. Move the cursor toward the right in the graphics window. Next, enter 40 in the
length input field, press TAB, and enter 90 in the angle input field; line 7 is
drawn.

9. Move the cursor upward in the graphics window. Next, enter 9 in the length
input field, press TAB, and enter 90 in the angle input field; line 8 is drawn.



10. Move the cursor toward left in the graphics window. Next, enter 16 in the
length input field, press TAB, and enter 90 in the angle input field; line 9 is
drawn.

11. Move the cursor upward in the graphics window. Next, enter 5 in the length
input field, press TAB, and then enter 90 in the angle input field; line 10 is
drawn.

12. Move the cursor toward the right in the graphics window. Next, enter 20 in
the length input field, press TAB, and enter 90 in the angle input field; line 11
is drawn.

13. Move the cursor downward in the graphics window. Next, enter 30 in the
length input field and 90 in the angle input field; line 12 is drawn.

14. The initial sketch is drawn. Exit the Line tool by choosing OK from the
Marking menu.

Drawing Fillets

1. Choose the Fillet tool from the Sketch > Create > Fillet/Chamfer drop-
down; the 2D Fillet dialog box is displayed. Enter 1.5 in the Radius edit box
of this dialog box. Do not press ENTER.

2. Select the line 8 and then line 9, refer to Figure 2-76; a fillet is created
between these lines and the radius of the fillet is displayed in the sketch.

3. Similarly, select lines 7 and 8 and then lines 4 and 5 to create a fillet between
these lines. Next, right-click, and choose OK from the Marking Menu to exit
the Fillet tool after creating all fillets.

As all the lines are filleted with the same radius value, the radius of the fillet is
not displayed on other fillets. This completes the sketch. The final sketch for
this tutorial after filleting all the sketches is shown in Figure 2-78.



Figure 2-78 Final sketch after filleting

Note
In Figure 2-78, the display of axes and grids have been turned off for a better
visibility of the lines of the sketch.

Saving the Sketch
1. Choose the Finish 2D Sketch button from the Marking Menu.

2. Choose the Save button from Quick Access Toolbar and save this sketch
with the name Tutorial4 at the location given below.

C:\Inventor_2016\c02

3. Choose Close > Close from the Application Menu to close this file.

Answer the following questions
and then compare them to those given at the end of
this chapter:

1. In Autodesk Inventor, the two types of sketching entities that can be drawn are
and

2. In the Sketching environment, the tool is used to place a sketch
point or a center point.

3. Filleting is defined as the process of the sharp corners and sharp




edges of models.

4. You can toggle between the length and angle input fields by using the
key.

5. You can use the toolbar to precisely enter coordinates of the
points in the graphics window.

6. You can also delete the sketched entities by pressing the key.

7. In Autodesk Inventor, rectangles are drawn as the combination of
entities.

8. You can undo the last drawn spline segment when you are still inside the

spline drawing option by choosing from the Marking Menu
displayed.

9. You can exit the Line tool by pressing the key or by
choosing from the menu.

10. Most of the designs created in Autodesk Inventor are a combination of
sketched features and placed features. (T/F)

11. Whenever you start a new file in the Part module, the Sketching
environment is invoked by default. (T/F)

12. You cannot turn off the display of grid lines. (T/F)

13. You cannot draw an arc while the Line tool is active. (T/F

Answer the following questions:

1. Which of the following tools in the Tools tab is used to invoke additional
toolbars?

(a) Application Options (b) Customize (c) Document Setting (d) None of
these

2. Which of the following drawing display options is used to interactively zoom
in and out a drawing?



(a) Zoom All (b) Pan (c) Zoom (d) Zoom Window
3. Which of the following keys is used to restore the previous view?

(a) F5 (b) F6
(c) F7 (d) F4

4. Which of the following drawing display options prompts you to select an
entity whose magnification has to be increased?

(a) Zoom (b) Pan (c) Zoom Selected (d) None of these

5. In most of the designs, generally the first feature or the base feature is the
placed feature. (T/F)

6. You can invoke the options related to sheet metal parts from the .ipt file. (T/F)

7. You can change the current project directory and the project files by choosing
Projects from the Open dialog box. (T/F)

8. You can specify the position of entities dynamically by using the Dynamic
Input. (T/F)

9. In Autodesk Inventor, you can save a file in the Sketching environment. (T/F)

10. In Autodesk Inventor, you can start a new file by using the Open dialog box.
(T/F)

Exercise 1

Draw the basic sketch of the model shown in Figure 2-79. The sketch to be
drawn is shown in Figure 2-80. Do not dimension it as the dimensions are given
only for reference. (Expected time: 30 min)
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Figure 2-79 Model for Exercise 1
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Figure 2-80 Sketch for Exercise 1
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Exercise 2

Draw the basic sketch of the model shown in Figure 2-81. The sketch to be
drawn is shown in Figure 2-82. Do not dimension it as the dimensions are given
only for reference.

(Expected time: 45 min)

Figure 2-81 Model for Exercise 2
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Figure 2-82 Sketch for Exercise 2

Exercise 3

Draw the sketch of the model shown in Figure 2-83. The sketch to be drawn is
shown in Figure 2-84. Do not dimension it as the dimensions are given only for
reference.

(Expected time: 45 min)

Figure 2-83 Model for Exercise 3




Figure 2-84 Sketch for Exercise 3

Exercise 4

Draw the sketch of the model shown in Figure 2-85. The sketch to be drawn is
shown in Figure 2-86. Do not dimension it as the dimensions are given only for
reference.

(Expected time: 45 min)

Figure 2-85 Model for Exercise 4

} B i
1 | I
} 1/ N/ !
a M
% N »,I;;
\ —t/ 1o

Figure 2-86 Sketch for Exercise 4



Answers to Self-Evaluation Test 1. normal, construction, 2. Point, 3. rounding,
4. TAB, 5. Inventor Precise Input, 6. DELETE, 7. individual, 8. Back, 9.
ESC, Cancel (ESC), Marking menu, 10. T, 11. F, 12. F, 13. F






Chapter 3

Adding Constraints and Dimensions to
Sketches

Learning Objectives

After completing this chapter, you will be able to:

» Add geometric constraints to a sketch.

* Control the constraint inference.

* View and delete constraints from a sketch.

» Dimension a sketch.

* Modify the dimensions of a sketch.

* Measure distances, angles, loops, and areas in a sketch.

ADDING GEOMETRIC CONSTRAINTS TO A
SKETCH CONSTRAINTS ARE APPLIED TO THE
SKETCHED ENTITIES TO DEFINE THEIR SIZE AND
POSITION WITH RESPECT TO OTHER ELEMENTS.
ALSO, THEY ARE USEFUL FOR CAPTURING THE
DESIGN INTENT. AS MENTIONED IN CHAPTER 1,
THERE ARE TWELVE TYPES OF GEOMETRIC
CONSTRAINTS THAT CAN BE APPLIED TO THE
SKETCHED ENTITIES. THESE CONSTRAINTS
RESTRICT THEIR DEGREES OF FREEDOM AND
MAKE THEM STABLE. MOST OF THESE
CONSTRAINTS GET AUTOMATICALLY APPLIED



TO THE ENTITIES WHILE DRAWING. HOWEVER,
SOMETIMES YOU MAY NEED TO APPLY SOME
ADDITIONAL CONSTRAINTS TO THE SKETCHED
ENTITIES. THESE CONSTRAINTS ARE DISCUSSED
NEXT.



Perpendicular Constraint
Ribbon: Sketch > Constrain > Perpendicular Constraint The Perpendicular

constraint forces the selected entity to become perpendicular to the specified
entity. The entities to which the constraints can be applied are lines and
ellipse axes. To apply this constraint, choose the Perpendicular Constraint
tool from the Constrain panel of the Sketch tab; you will be prompted to
select the first line or an ellipse axis. After selecting the first entity, you will
be prompted to select the second line or ellipse axis. On selecting the second
entity, the selected entities will become perpendicular. Figure 3-1 shows two
lines before and after adding this constraint. Similarly, you can also apply
the Perpendicular Constraint between two arcs.




Parallel Constraint
Ribbon: Sketch > Constrain > Parallel Constraint The Parallel constraint
forces the selected entity to become parallel to the specified entity. The
entities to which this constraint can be applied are lines and ellipse axes. To
ly this constraint, choose the Parallel Constraint tool from the Constrain
panel of the Sketch tab; you will be prompted to select the first line or an
ellipse axis. After you select an entity, you will be prompted to select the
second line or an ellipse axis. On selecting the second entity, the two entities
will become parallel. Figure 3-2 shows two lines before and after adding this

constraint.
First
entit ty /

Second
entity

Before addi ‘;C‘ adding
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Figure 3-1 Lines before and after applying the Perpendicular Constraint
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Figure 3-2 Applying the Parallel Constraint



Tangent Constraint

Ribbon: Sketch > Constrain > Tangent The Tangent constraint forces the
selected line segment or curve to become tangent to another curve. To apply
this constraint, choose the Tangent tool from the Constrain panel of the
Sketch tab; you will be prompted to select the first curve. After you select
the first curve, you will be prompted to select the second curve. The curves
that can be selected are lines, circles, ellipses, or arcs. Figures 3-3 and 3-4
show the Tangent constraint applied between a line and a circle, and

between an ellipse and arc, respectively.

First
curve

Second ~

curve

7/ C

Before adding After adding
constraint constraint

Figure 3-3 Applying the Tangent constraint between line and circle
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Figure 3-4 Applying the Tangent constraint between ellipse and arc



Coincident Constraint
Ribbon: Sketch > Constrain > Coincident Constraint The Coincident

constraint forces two points or a point and a curve to become coincident. To
apply this constraint, choose the Coincident Constraint tool from the
Constrain panel of the Sketch tab; you will be prompted to select the first
curve or point. After you select the first curve or point, you will be

prompted to specify the second curve or point. Note that either the first or
the second entity selected should be a point. The points include sketch
points, endpoints of a line or an arc, or center points of circles, arcs, or
ellipses.




Concentric Constraint
Ribbon: Sketch > Constrain > Concentric Constraint The Concentric

constraint forces two curves to share the same location of center points. The

curves that can be made concentric include arcs, circles, and ellipses. When

you invoke this constraint, you will be prompted to select the first arc,
circle, or ellipse. After making the first selection, you will be prompted to

select the second arc, circle, or ellipse. Select the second entity to be made
concentric with the first entity.




Note

If you apply a constraint that overconstrains a sketch, the Autodesk Inventor
Professional - Create Constraint message box will be displayed informing that
adding this constraint will over-constrain the sketch, refer to Figure 3-5. A
sketch is said to be overconstrained if the number of dimensions or constraints
in it exceeds the number that can be applied to the sketch.

Autodesk Inventor Professional - Create Constraint

----- @Adding this constraint will over-constrain the sketch

| prompts >> | [ Cancel |

Figure 3-5 The Autodesk Inventor Professional - Create Constraint message box




Collinear Constraint
Ribbon: Sketch > Constrain > Collinear Constraint The Collinear constraint

forces the selected line segments or ellipse axes to be placed in the same line.
When you invoke this constraint, you will be prompted to select the first line
or ellipse axis. After making the first selection, you will be prompted to

select the second line or ellipse axis. Select the entity to be made collinear
with the first entity.

Tip. To select an ellipse axis, move the cursor close to the ellipse. The minor or
the major axis, whichever the cursor is close to, will get highlighted. When the
required axis is highlighted, select it using the left mouse button.



Horizontal Constraint
Ribbon: Sketch > Constrain > Horizontal Constraint The Horizontal Constraint

forces the selected line segment, ellipse axis, or two points to become
horizontal, irrespective of their original orientation. When you invoke this
constraint, you will be prompted to select a line, an ellipse axis, or the first
point. If you select a line or an ellipse axis, it will become horizontal. If you
select a point, you will be prompted to select the second point. The points, in
this case, can also include the center points of arcs, circles, or ellipses.




Vertical Constraint

Ribbon: Sketch > Constrain > Vertical Constraint The Vertical constraint is
similar to the Horizontal constraint, with the difference that this constraint
forces the selected entities to become vertical.

Tip. You can use the Horizontal or Vertical constraint to line up arcs, circles, or
ellipses in the horizontal or vertical direction by selecting their center points.

Equal Constraint Ribbon: Sketch > Constrain > Equal
The Equal constraint can be used for line segments or
curves. If you select two line segments, this constraint
will force the length of one of the selected line segments
to become equal to the length of the other selected line
segment. In case of curves, this constraint will force the
radius of one of the selected curves to become equal to
that of the other selected curve. Note that if the first
selection is a line, the second selection also be a line.
Similarly, if the first selection is a curve, the second
selection also needs to be a curve.



Fix Constraint
Ribbon: Sketch > Constrain > Fix The Fix constraint is used to fix the
orientation or location of the selected curve or point with respect to the

coordinate system of the current drawing. If you apply this constraint to a
line or an arc, you cannot move them from their current locations.
However, you can change their length by selecting one of their endpoints
and then dragging it. If you apply this constraint to a circle or an ellipse,
you cannot edit either of these entities by dragging. Once you apply this
constraint to an entity, its color changes.

Symmetric Constraint Ribbon: Sketch > Constrain >
Symmetric This constraint is used to force two selected
sketched entities to become symmetrical about a single
sketched line segment. On invoking this constraint, you
will be prompted to select the first sketched element.
Note that you can select only one entity at a time to apply
this constraint. Once you have selected the first sketched
entity, you will be prompted to select the second sketched
element. Select the second sketched entity; you will be
prompted to select the symmetry line. Select the
symmetry axis (an axis about which the selected entities
need to be symmetric); the second selected entity will
become symmetric to the first entity. After you have
applied this constraint to one set of entities, you will
again be prompted to select the first and second sketched
entities. However, this time you will not be prompted to
select the line of symmetry. The last line of symmetry
will be automatically selected to add this constraint.
Similarly, you can apply this constraint to other entities.



If the line of symmetry is different for applying the symmetric constraint to
different entities in the sketch, you will have to restart the process of applying
this constraint by right-clicking and then choosing the Restart option from the
Marking Menu. This is because the first symmetry line is used to apply this
constraint to all the sets of entities you select. However, if you restart applying
this constraint, you will be prompted to select the line of symmetry again.

Smooth Constraint Ribbon: Sketch > Constrain > Smooth
(G2) This constraint is used to apply curvature continuity
between a spline and an entity connected to it. The
entities that can be selected to apply this constraint
include a line, arc, or another spline. Note that these
entities should be connected to the spline.



Note
In Autodesk Inventor, you can apply the Perpendicular, Tangent, and Smooth
(G2) constraints between different type of splines.

VIEWING THE CONSTRAINTS APPLIED TO
A SKETCHED ENTITY RIBBON: SKETCH >
CONSTRAIN > SHOW CONSTRAINTS YOU
CAN VIEW ALL THE CONSTRAINTS THAT
ARE APPLIED TO THE ENTITIES OF A
SKETCH BY CHOOSING THE SHOW
CONSTRAINTS TOOL FROM
THE CONSTRAIN PANEL. WHEN YOU
INVOKE THIS TOOL AND MOVE THE
CURSOR CLOSE TO A SKETCHED ENTITY,
IT WILL BE HIGHLIGHTED AND
CONSTRAINTS WILL BE DISPLAYED
AFTER A PAUSE. THESE CONSTRAINTS
SHOW THE SYMBOLS OF ALL THE
CONSTRAINTS THAT ARE APPLIED TO
THE ENTITY. FIGURE 3-6 SHOWS THE
CONSTRAINTS APPLIED TO THE LINES.
YOU CAN MOVE A CONSTRAINT BY
SELECTING AND DRAGGING IT. IN THE
CASE OF COINCIDENT CONSTRAINT, THE



CONSTRAINT APPLIED ON A POINT IS
HIGHLIGHTED IN YELLOW. TO VIEW
SYMBOLS, MOVE THE CURSOR OVER
THE HIGHLIGHTED YELLOW POINT; THE
COLOR OF THE POINT WILL CHANGE,
REFER TO FIGURE 3-6.

Figure 3-6 Constraints applied to the sketch entities

If you move the cursor close to a constraint, it will be highlighted and the entities
to which the constraint is applied is also highlighted. For example, if you take
the cursor close to a perpendicular constraint, the vertical line will also be
highlighted along with the horizontal line, suggesting that the two lines are
perpendicular to each other.

Tip. You can display all the constraint, applied to the entities. To do so, choose
the Show All Constraints button from the status bar, which is available at the
bottom of the graphics window; separate symbols will be displayed showing the
constraints on all entities. Similarly, to hide all constraints, choose the Hide All
Constraints button from the status bar.



CONTROLLING CONSTRAINTS AND APPLYING
THEM AUTOMATICALLY WHILE SKETCHING
RIBBON: SKETCH > CONSTRAIN > CONSTRAINT
SETTINGS YOU CAN CONTROL AND SELECT THE
CONSTRAINTS THAT NEED TO BE APPLIED
AUTOMATICALLY AS WELL AS SELECT THE
GEOMETRY TO WHICH THEY WILL BE APPLIED.
YOU CAN DO SO BY USING THE CONSTRAINTS
SETTING DIALOG BOX. TO INVOKE THIS
DIALOG BOX, CHOOSE THE CONSTRAINTS
SETTINGS TOOL FROM THE CONSTRAIN PANEL
OF THE SKETCH TAB. THIS DIALOG BOX
DISCUSSED NEXT.

Constraints Settings Dialog box While drawing the
sketch, by default, all the possible constraints get
automatically applied to the sketching entities. However,
you can also specify the constraints that need to be
applied automatically and the geometry to which they
will be applied while sketching. To do so, choose the
Constraint Settings tool from the Constrain panel of the
Sketch tab; the Constraint Settings dialog box will be
displayed, as shown in Figure 3-7. The options in this
dialog box are discussed next.
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Figure 3-7 The Constraint Settings dialog box




General
The General tab is selected by default. The options in this tab are discussed
next.



Constraints

In this area, three check boxes are available. If you select the Display
constraints on creation check box, Autodesk Inventor allows you to display
the constraints applied during the creation of sketch. If you select the Show
constraints for selected objects check box, Autodesk Inventor allows you to
show the constraints for the selected object. If you select the Display
coincident constraints in sketch check box, Autodesk Inventor allows you to
display the coincident constraints in the sketch.



Dimension

This area is used to apply the Dimensions constraints to the sketch. In this
area, two check boxes are available. These check boxes are used to apply
dimensions during the creation of sketch.



Overconstrained Dimensions

This area is used to control the over defined dimensions applied to the sketch.
In this area, two radio buttons are available. If you select the Apply driven
dimensions radio button, you will able to apply the over defined dimension to
the sketch. In this case over defined dimension is considered as the reference
dimension. If you select the Warn of overconstrained condition radio
button, you will not able to apply the over defined dimensions to the sketch. In
this case, a warning massage will be displayed.



Interface
In the Interface tab, two areas are available. The options in this tab are
discussed next.



Constraint Interface Priority
This area is used to set up the constraints interface priority. You need to select
the appropriate radio button to set up the priority.



Selection for Constraint Inference

In this area, nine check boxes corresponding to nine constraints are available.
All check boxes are selected by default. However, if you need to clear all the
constraints, choose the Clear All button. You can manually select or clear the
required constraint by selecting the corresponding check box provided on the
right of the constraint symbols. The selected constraints will be applied
automatically to the geometry while sketching.



Relax Mode
In this tab, the Enable Relax Mode check box is available. If you select this
check box, you will be able to remove the constraints from the geometry while
dragging the sketch. In this case, you can remove only that constraint whose
respective check box is selected in the Constraints to remove in relax
dragging area.

Scope of Constraint Inference Ribbon: Sketch >

Constrain > Constraint Inference Scope

The Constraint Inference Scope tool is used to set the geometry to which the
constraint is applied while drawing. You can invoke this tool from the Constrain
panel of the Sketch tab. On invoking this tool, the Constraint Inference Scope
dialog box will be displayed. In this dialog box, the Geometry in current
command radio button is selected by default. As a result, the constraint is
applied to the current geometry. If you select the Select check box, the Select
button will be activated automatically. You can use this button to select the
geometry to which the constraints will be applied. If you select the All Geometry
radio button, the constraint will be applied to all the active sketches.



DELETING GEOMETRIC CONSTRAINTS

Autodesk Inventor allows you to delete the constraints applied to the selected
entities. To delete constraints, first you need to invoke the constraint box by
using the Show Constraints tool. Once the constraints are displayed, exit
the Show Constraints tool by pressing the ESC key. Next, move the cursor over the
constraint that you want to delete; it will be highlighted in red. Click the left
mouse button to select the constraint. Next, move the cursor away and right-
click, and then choose Delete from the Marking menu, see Figure 3-8. The
selected constraint will be deleted. Similarly, you can delete
all unwanted constraints from the sketch.
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Figure 3-8 Choosing the Delete option from the Marking Menu



Note
The total number of constraints and dimensions required to fully constraint
a sketch is displayed at the lower right corner of the graphics window.

Tip. When you move the cursor close to the constraint, its references will be
highlighted in the sketch. For example, if you move the cursor over the
Perpendicular constraint, the lines on which this constraint is applied will be
highlighted. This allows you to confirm that the constraint selected is correct.

ADDING DIMENSIONS TO SKETCHES RIBBON:
SKETCH > CONSTRAIN > DIMENSION AFTER
DRAWING A SKETCH AND ADDING
CONSTRAINTS TO IT, DIMENSIONING IS THE
NEXT MOST IMPORTANT STEP IN CREATING A
DESIGN. AS MENTIONED EARLIER, AUTODESK
INVENTOR IS A PARAMETRIC SOLID MODELING
PACKAGE. THE PARAMETRIC PROPERTY
ENSURES THAT IRRESPECTIVE OF ITS ORIGINAL
SIZE, THE SELECTED ENTITY IS DRIVEN BY THE
SPECIFIED DIMENSION VALUE. THEREFORE,
WHENEVER YOU MODIFY OR APPLY DIMENSION
TO AN ENTITY, IT IS FORCED TO CHANGE ITS
SIZE WITH RESPECT TO THE SPECIFIED
DIMENSION VALUE. THE TYPE OF DIMENSION
TO BE APPLIED VARIES ACCORDING TO THE
TYPE OF ENTITY SELECTED. FOR EXAMPLE, IF
YOU SELECT A LINE SEGMENT, LINEAR



DIMENSIONS WILL BE APPLIED AND IF YOU
SELECT A CIRCLE, DIAMETER DIMENSIONS
WILL BE APPLIED. NOTE THAT ALL THESE
TYPES OF DIMENSIONS CAN BE APPLIED USING
THE SAME DIMENSIONING TOOL. TO EDIT THE
DIMENSION, DOUBLE-CLICK ON THE
DIMENSION; THE EDIT DIMENSION EDIT BOX
WILL BE DISPLAYED, REFER TO FIGURE 3-9.
ENTER THE DESIRED VALUE IN THE EDIT BOX
TO MODIFY THE DIMENSIONS. THE SELECTED
ENTITY WILL BE DRIVEN TO THE DIMENSION
VALUE DEFINED IN THIS EDIT BOX. YOU CAN
ENTER A NEW VALUE FOR THE DIMENSION OR
CHOOSE THE BUTTON ON THE RIGHT OF THIS
EDIT BOX TO ACCEPT THE DEFAULT VALUE.

If you do not want to edit the dimensions after they have been placed, invoke the
Dimension tool and then right-click to display the Marking Menu, refer to

Figure 3-10. Clear the check mark on the left of the Edit Dimension option by
choosing it again. When you place a dimension now, the Edit Dimension edit
box will not be displayed. To edit the dimension value in this case, click on it

after placing, if the Dimension tool is still active. If the tool is not active,
double-click on the dimension; the Edit Dimension edit box will be displayed.
Enter the new dimension value in this edit box. The dimensioning techniques
available in Autodesk Inventor are discussed next.

Edit Dimension : d0 =)

Figure 3-9 The Edit Dimension edit box
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Figure 3-10 Choosing Edit Dimension from the Marking Menu

Linear Dimensioning The linear dimensions are defined
as the dimensions that specify the

shortest distance between two points. You can apply
linear dimensions directly to a line or select two points or
entities to apply the linear dimension between them. The
points that you can select include the endpoints of lines,
splines, or arcs, or the center points of circles, arcs,

or ellipses. You can dimension a vertical or

a horizontal line by directly selecting it. As soon as you
select it, the dimension will be attached to the cursor.
You can place the dimension at any desired location. To
place the dimension between two points, select the points
one by one. After selecting the second point, right-

click to display the Marking menu, as shown in Figure 3-
11. You can choose the dimension type from this menu as
per your requirement.
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Figure 3-11 Marking menu displaying various options to dimension two points

If you choose Horizontal, the horizontal dimension will be placed between the
two selected points. If you choose Vertical, the vertical dimension will be
placed between the two selected points. If you choose Aligned, the aligned
dimension will be placed between the two selected points. Figure 3-12 shows the
linear dimensioning of lines and Figure 3-13 shows the linear dimensioning of
two points.

Figure 3-12 Linear dimensioning of lines



Figure 3-13 Linear dimensioning of two points

You can also apply a horizontal or vertical dimension to an inclined line, see
Figure 3-14. To apply these dimensions, select the inclined line and then right-
click; a Marking Menu similar to the one shown in Figure 3-11 will be
displayed. In this menu, choose Horizontal to place the horizontal dimension
and Vertical to place the vertical dimension.

3.000
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Horizontal dimension of an _\-”"@f‘;“fi’?‘ dimension of an
inclined line nclined line

Figure 3-14 Linear dimensioning of an inclined line

Aligned Dimensioning The aligned dimensions are used
to dimension the lines that are not parallel to the X or Y-
axis. This type of dimension measures the actual distance



of the aligned lines or the lines drawn at a certain angle.
To apply the aligned dimension, select the inclined line
and then right-click; a Marking Menu will be displayed,
refer to Figure 3-11. Choose the Aligned option from the
Marking Menu; the aligned dimension of the selected line
will be attached to the cursor. Next, click in the graphics
window to specify the location of the aligned dimension.
You can also apply the aligned dimension between two
points. The points include the endpoints of lines, splines,
or arcs or the center points of arcs, circles, or ellipses. To
apply the aligned dimension between two points, invoke
the Dimension tool. Next, select the two points and right-
click; a Marking Menu will be displayed. Choose the
Aligned option from the Marking Menu. Figures 3-15
and 3-16 show the aligned dimensions applied to various
objects.

Tip. Alternatively, to apply the aligned dimension, choose the Dimension tool
from the Ribbon and then select the aligned entity to be dimensioned. Next,
move the cursor away from the line and then click again on the same line. Now,
click on the drawing window to place the aligned dimension.
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Figure 3-15 Aligned dimension of a line

Figure 3-16 Aligned dimension between two points

Angular Dimensioning The angular dimensions are used
to dimension angles. You can select two line segments or
use three points to apply the angular dimensions. You can
also use angular dimensioning to dimension an arc. All
these options of angular dimensioning are discussed next.

Angular Dimensioning Using Two Line Segments You can directly
select two line segments to apply angular dimensions. To do so,
invoke the Dimension tool of the Constrain panel of Sketch tab. You
can also invoke General Dimension from the Marking Menu and
then select a line segment using the left mouse button. Instead of
placing the dimension, select the second line segment. Next, place the
dimension to measure the angle between the two lines. While placing
the dimension, you need to be careful about the point where you place
the dimension. This is because depending on the location of the
placement of dimension with respect to the lines, the vertically
opposite angles will be displayed. Figure 3-17 shows the angular
dimension between two lines and Figure 3-18 shows the dimension of
the vertically opposite angle between two lines. Also, depending on
the location of the dimension, the major or minor angle value will be
displayed. Figure 3-19 shows the major angle dimension between two



lines and Figure 3-20 shows the minor angle dimension between the
same set of lines.

First

g . /
: Dimension |
object placement-
point

Figure 3-17 Angular dimensioning between two lines
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Figure 3-18 Dimension of the vertically opposite angle between two lines
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Figure 3-20 Minor angle dimension

Angular Dimensioning Using Three Points You can also apply
angular dimensions using three points. Remember that the three points
should be selected in clockwise or counterclockwise sequence. The
points that can be used to apply the angular dimensions include the
endpoints of lines or arcs, or the center points of arcs, circles, and
ellipses. Figure 3-21 shows angular dimensioning using three points.



Angular Dimensioning of an Arc

You can use angular dimensions to dimension an arc. In case of arcs, the three
points are the endpoints and the center point of the arc. Note that the points
should be selected in the clockwise or counterclockwise sequence, but the center
point should always be the second selection point. Figure 3-22 shows the angular
dimensioning of an arc. In Autodesk Inventor, you can also assign angular
dimensions to an arc by using the Marking menu. To do so, invoke the
Dimension tool. Then, select the arc and right-click; a Marking menu will be
displayed. Choose Dimension Type from the Marking menu; a cascading menu
will be displayed. Choose Arc Length from the cascading menu before placing
the dimension on the graphics window, refer to Figure 3-23. Figure 3-24 shows
the angular dimensioning of an arc using the Marking menu.
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Figure 3-21 Angular dimensioning using three points
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Figure 3-22 Angular dimensioning of an arc
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Figure 3-23 Angular dimensioning using the Marking menu
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Figure 3-24 Angular dimensioning of an arc using the Marking menu



Diameter Dimensioning

Diameter dimensions are applied to dimension a circle or an to specify its
diameter. In Autodesk Inventor, when you select a circle to dimension, the
diameter dimension is applied to it by default. If you select an arc to dimension
it, the radius dimension will be applied to it. You can also apply the diameter
dimension to an arc. To do so, invoke the Dimension tool and then select the arc.
Next, right click to display the Marking menu, as shown in Figure 3-25. From
the Marking menu, choose Dimension Type; a cascading menu is displayed.
Choose Diameter from this menu to apply the diameter dimension. Figure 3-26
shows a circle and an arc with diameter dimensions.
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Figure 3-25 Marking menu to apply a diameter dimension to an arc
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Figure 3-26 Diameter dimensioning of a circle and an arc



Radius Dimensioning

Radius dimensions are applied to dimension an arc or a circle to specify its radius.
As mentioned earlier, by default, circles are assigned diameter dimensions and arcs
are assigned radius dimensions. However, you can also apply the radius dimension to a circle. To do
so, invoke the Dimension tool and thenselect the circle. Next, right-click to display the Marking menu, as
shown in Figure 3-27. From the Marking menu, choose Dimension Type; a cascading menu is displayed.
Choose Radius from this menu to apply the radius dimension. Figure 3-28shows an arc and a circle
with radius dimensions.
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Figure 3-27 Marking menu to apply a radius dimension to an arc
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Figure 3-28 Radius dimensioning of a circle and an arc



Linear Diameter Dimensioning
Linear diameter dimensioning is used to dimension the sketches of the revolved
components. The sketch for a revolved component is drawn using simple

sketcher entities. For example, if you draw a rectangle and revolve, it will result
in a cylinder. Now, if you dimension the rectangle using the linear dimensions,
the same dimensions will be displayed when you generate the drawing views of
the cylinder. Also, the same dimensions will be used while manufacturing the
component. But these linear dimensions will result in a confusing situation in

manufacturing. This is because while manufacturing a revolved component, the
dimensions have to be specified as the diameter of the revolved component. The
linear dimensions will not be acceptable in manufacturing a revolved
component. To resolve this problem, the sketches for the revolved features are

dimensioned using the linear diameter dimensions. These dimensions display the
distance between the two selected line segments as a diameter, that is, double the

original length. For example, if the original dimension between two entities is
10 mm, the linear diameter dimension will display it as 20 mm. This is because
when you revolve a rectangle with 10 mm width, the diameter of the resultant
cylinder will be 20 mm. In this type of dimension, if you select two lines, the

line selected first will act as the axis of revolution for the sketch and the line

selected last will result in the outer surface of the revolved feature. It means the
line selected last will be the one that will be dimensioned. But, if one of these

lines is a centerline drawn by choosing the Centerline tool from the Format

panel, the centerline will be considered as the axis of revolution.

To apply linear diameter dimensions, invoke the Dimension tool; you will be
prompted to select the first geometry to dimension. Select the first line; you will
be prompted to select the second geometry to dimension. Select the second line
with reference to which you want to apply the linear diameter dimensions. If the
first line selected is a centerline, the linear diameter dimension will be displayed.
Alternatively, right-click and then choose Linear Diameter from the Marking
Menu, see Figure 3-29. You will notice that the distance between the two lines



is displayedas twice the distance. Also, the dimension value is preceded by
the @ symbol, indicating that it is a linear diameter dimension. Figures 3-30 and
3-31 show the use of linear diameter dimensioning.
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Figure 3-29 Choosing the Linear Diameter option
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Figure 3-30 Selecting elements for linear diameter dimension
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Figure 3-31 The linear diameter dimension

Tip. After invoking the Dimension tool, as you move the cursor close to the
sketched entities, a small symbol will be displayed close to the cursor. This
symbol displays the type of dimension that will be applied. For example, if you
select a line, the linear dimensioning or aligned dimensioning symbol will be



displayed. If you move the cursor close to another line dfter selecting the first,
the symbol of angular dimensioning will be displayed. These symbols help you in
determining the type of dimensions that will be applied.

In Autodesk Inventor, the ellipses are dimensioned as half of the major and
minor axes distances. To dimension an ellipse, invoke the Dimension tool and
then select the ellipse. Now, if you move the cursor in the vertical direction, the
axis of the ellipse along the X-axis will be dimensioned in terms of its half
length. Similarly, if you move the cursor in the horizontal direction, the axis of
the ellipse along the Y axis will be dimensioned equal to its half-length.

To distinguish whether the dimension applied to an arc or a circle is a radius or
a diameter, try to locate the number of arrowheads in the dimension. If there are
two arrowheads in the dimension and the dimension line is placed inside the
circle or the arc, it is a diameter dimension. The radius dimension has one
arrowhead and the dimension line is placed outside the circle or the arc.

SETTING THE SCALE OF A SKETCH

In Autodesk Inventor, if you change the current length of an entity by changing
its dimension value, all the other entities of the sketch get modified
proportionally or scaled accordingly. Note that this will be applicable only if no
other dimension is applied to the sketch. As you apply the second dimension to
the sketch, the sketch will not be scaled proportionally, on changing the
dimension value. Figure 3-32 shows the sketch without any dimension and
Figure 3-33 shows the sketch scaled automatically after applying the first
dimension to it.

Figure 3-32 Sketch on the graphics screen



Figure 3-33 Sketch resized after editing the first dimension



CREATING DRIVEN DIMENSIONS

Ribbon: Sketch > Format > Driven Dimension This toggle button is used to

switch between the driven dimension and the sketch (driving) dimension. A
dimension is called as a sketch (driving) dimension, if it forces an entity to
change its length and orientation. A driven dimension is the one whose
value depends on the value of the sketch (driving) dimension. The driven
dimensions are enclosed within parenthesis and display the current value of
the sketched geometry. This value cannot be modified. If you change the
value of the sketch (driving) dimension, the value of the driven dimension

will change automatically, as shown in Figures 3-34 and 3-35. All
dimensions applied after choosing the Driven Dimension button will be the

driven dimensions. To convert sketch (driving) dimensions into driven

dimensions, select the required sketch (driving) dimension and choose the

Driven Dimension button from the Format panel.

it | Oy
Dming
dimension

Figure 3-34 Driving dimension and driven dimension in a sketch

Figure 3-35 Modified driving dimension and dynamically updated driven
dimension



UNDERSTANDING THE CONCEPT OF FULLY-
CONSTRAINED SKETCHES A FULLY-
CONSTRAINED SKETCH IS THE ONE WHOSE ALL
THE ENTITIES ARE COMPLETELY CONSTRAINED
TO THEIR SURROUNDINGS USING CONSTRAINTS
AND DIMENSIONS. IN A FULLY-CONSTRAINED
SKETCH, ALL DEGREES OF FREEDOM OF THE
SKETCH ARE CONSTRAINED. A FULLY-
CONSTRAINED SKETCH CANNOT CHANGE ITS
SIZE, LOCATION, OR ORIENTATION
UNEXPECTEDLY. WHENEVER YOU DRAW A
SKETCHED ENTITY, IT WILL TURN BLACK IN
COLOR. HOWEVER, THE ENTITY WILL TURN
BLUE IF YOU ADD REQUIRED DIMENSIONS TO A
SKETCH TO MAKE IT FULLY CONSTRAINT.
THERE IS ONE MORE METHOD TO UNDERSTAND
WHETHER THE SKETCHED ENTITIES ARE
FULLY-CONSTRAINED OR NOT. IN THIS
METHOD, YOU NEED TO RIGHT-CLICK ON THE
SKETCHED ENTITY AND CHOOSE THE DISPLAY
DEGREES OF FREEDOM OPTION FROM THE
MARKING MENU DISPLAYED; THE ENTITIES
WILL DISPLAY THE AVAILABLE DEGREES OF
FREEDOM SUCH AS HORIZONTAL, VERTICAL,
ANGULAR, OR ROTATIONAL. ALTERNATIVELY,
CLICK ON THE SHOW ALL DEGREES OF



FREEDOM TOGGLE BUTTON AVAILABLE AT
THE BOTTOM OF THE GRAPHICS WINDOW TO
DISPLAY THE DEGREES OF FREEDOM. NOTE
THAT WHILE CREATING THE BASE SKETCH IN
AUTODESK INVENTOR, YOU NEED TO
DIMENSION IT WITH RESPECT TO A FIXED POINT
TO FULLY CONSTRAIN IT. TO DO SO, YOU CAN
FIX THE SKETCH WITH THE ORIGIN, WHICH IS
ALREADY FIXED BY DEFAULT. YOU CAN
CONTROL THE VISIBILITY OF THIS ORIGIN. TO
HIDE THIS POINT, CHOOSE THE APPLICATION
OPTIONS BUTTON FROM THE TOOLS TAB; THE
APPLICATION OPTIONS DIALOG BOX WILL BE
INVOKED. CHOOSE THE SKETCH TAB AND
THEN CLEAR THE AUTOPROJECT PART ORIGIN
ON SKETCH CREATE CHECK BOX. NEXT, CLOSE
THE DIALOG BOX.

Tip. In Autodesk Inventor, when you switch to the Part module, a fully-
constrained sketch is displayed by symbol in the Browser Bar.

MEASURING SKETCHED ENTITIES AUTODESK
INVENTOR ALLOWS YOU TO MEASURE
VARIOUS PARAMETERS OF THE SKETCHED
ENTITIES. THE PARAMETERS THAT YOU CAN
MEASURE ARE DISTANCES, ANGLES, LOOPS,
AND AREA. MEASURING THESE PARAMETERS IS



DISCUSSED NEXT.



Measuring Distances
Ribbon: Inspect > Measure > Distance Autodesk Inventor allows you to

measure the length of a line segment, radius of an arc, diameter of a circle,
minimum distance between two entities, or coordinates of a point. All these
distances can be measured by using the Distance tool from the Measure
panel. On invoking this tool, the Measure Distance dialog box will be
displayed and you will be prompted to select the first item. The name of the

Measure Distance dialog box is modified depending upon the type of entities
selected to be measured. The methods of measuring distances between

various entities are discussed next.

Tip. To restart measuring the distances, right-click in the graphics window to
display a shortcut menu and then choose Repeat Measure; you will be prompted
to select the first element to be measured. Alternatively, choose the right arrow
displayed next to the display box in the Measure Distance dialog box and then
choose the Restart option from the flyout displayed.

Measuring the Length of a Line Segment When you invoke the
Distance tool, the Measure Distance dialog box will be displayed
and you will be prompted to select the first entity. Select a line
segment; the Measure Distance dialog box will be changed to

the Length dialog box and the length of the selected line segment will
be displayed in this dialogbox, see Figure 3-36.

Length @

170,517 mm [__h]

Figure 3-36 The Length dialog box displaying the length of a line segment

Measuring the Distance between a Point and a Line Segment To
measure the distance between a point and a line segment, invoke
the Distance tool and then select the point. The Measure



Distance dialog box will be modified to the Position dialog box,
which shows the X, Y, and Z coordinates of the point, and you will be
prompted to select the next entity. Select the line;

the Position dialog box will change to the Minimum Distance dialog
box. This dialog box will display the minimum distance between the
point and the line, and the length of the line, see Figure 3-37.

Minimum Distance [ﬁ,l
11,565 mm )

Length
25 mm

Figure 3-37 The Minimum Distance dialog box displaying the distance between the lines

Measuring the Coordinates of a Point

To measure the coordinates of a point with respect to the current coordinate
system, invoke the Distance tool; you will be prompted to select the
first element. Select the point whose coordinates you want to know. The
selectable points include the endpoints of lines, arcs, or splines, center point of
arcs, circles, or ellipses, or hole centers. If you select a hole center or the center
point, the Measure Distance dialog box will change into the Position dialog
box and the X, Y, and Z coordinates of the selected point with respect to the
current coordinatesystem will be displayed, see Figure 3-38. However, if you
select an  endpoint, the coordinates will be  specified in
the Measure Distance dialog box.

Position @

Pasition
X: -263.684 mm

Y: 224,719 mm
Z: 0 mm

Figure 3-38 The Position dialog box displaying the coordinates of a point

Measuring the Distance between Two Points To measure the distance



between two points, invoke the Distance tool and then select the first
point; the coordinates of the selected point will be displayed in

the Position dialog box. You will be prompted to select the second
element. Select the second point; the Position dialog box will be
changed to the Minimum Distance dialog box. This dialog box will
display the distance between the two points. This dialog box will also
display the coordinates of the second point. You will also notice

the Delta X, Delta Y, and Delta Z values in this dialog box,

see Figure 3-39. These values are the distances between the two
selected points along the X, Y, and Z axes.
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(]

86,431 mm

Position
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Y: 200,458 mm
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Delta Z: O mm

Figure 3-39 The Minimum Distance dialog box

Tip. In Autodesk Inventor, you can also measure distance between the midpoint
of a linear segment and midpoint of a circular arc.

Measuring the Radius of an Arc or the Diameter of a Circle You can
also measure the radius of an arc or the diameter of a circle by using the
Distance tool. When you invoke this tool, the Measure Distance dialog box will
be displayed and you will be prompted to select the first item. If you select an
arc or move the cursor over the arc, this dialog box will be momentarily
changed to the Radius dialog box and will display the radius of the arc, see
Figure 3-40. If you select a circle or move the cursor over the circle, this dialog
box will momentarily change into the Diameter dialog box and will display the
diameter of the circle, see Figure 3-41. Note that if you select an arc or a circle,
you will not be prompted to select the second element because you cannot
calculate any value other than their radius or diameter.



Radius @

45.515 mm [»]

Figure 3-40 The Radius dialog box displaying the radius of the arc

Diameter @

156.922 mm [»]

Figure 3-41 The Diameter dialog box displaying the diameter of the circle

Measuring Angles Ribbon: Inspect > Measure > Angle To measure an angle,
right-click in the drawing window and choose Measure > Measure Angle from
the Marking menu; the Measure Angle dialog box will be displayed.
Alternatively, choose the Angle tool from the Measure panel. This tool is used
to measure the angle between two line segments or among three points. Both
these methods for measuring angles are discussed next.

Measuring the Angle between Two Lines To measure the angle
between two lines, invoke the Angle tool; the Measure Angle dialog
box will be displayed and you will be prompted to select the first item.
Select the first line; you will be prompted to select the second line.
Select the second line; the Measure Angle dialog box will

change momentarily into the Angle dialog box and the angle between
the selected line segments will be displayed, refer to Figure 3-42.

Angle @
50 deg ]

Figure 3-42 The Angle dialog box displaying the angle between two lines

Measuring the Angle Using Three Points You can also measure the
angle using three points. When you invoke the Angle tool, you will be
prompted to select the first item. Select the first point; you will be
prompted to select the next point. After you select the second point,
you will again be prompted to select the next point. Select the third
point. Once you have selected the three points, Autodesk Inventor
draws reference lines between the first and second points as well as



between the second and third points. The angle between these two
reference lines will be measured and displayed in the dialog box, as
shown in Figures 3-43 and 3-44.
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Figure 3-43 Selecting three points
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Figure 3-44 Angle between reference lines

Reference line

Tip. Autodesk Inventor allows you to switch from one measuring tool to another.
This is done using the options in the flyout that is displayed on choosing the
arrow on the right in the dialog box of any measuring tool. When you choose
this arrow, the flyout will be displayed with the options for invoking other
measuring tools.



Measuring Loops
Ribbon: Inspect > Measure > [.oop Autodesk Inventor allows you to measure

closed loops. To measure closed loops, right-click in the drawing window
and choose Measure > Measure Loop from the Marking menu; the Measure
Loop dialog box will be displayed. Alternatively, choose the L.oop tool from
the Measure panel; you will be prompted to select a face or a loop. Select
the loop to be measured; the Measure L.oop dialog box will be momentarily
changed to the L.oop Length dialog box and the measurement will be
displayed in it. Figure 3-45 shows the Measure L.oop dialog box with the

measurement of a loop.

Measuring the Area Ribbon: Inspect > Measure > Area
To measure the area of closed loops, right-click in the
drawing window and choose Measure > Measure Area
from the Marking Menu; the Measure Area dialog box
will be displayed and you will be prompted to select a
face or a loop. Select the closed loop to measure the area;
the Measure Area dialog box will be momentarily
changed to the Area dialog box and the area of the loop
will be displayed in it. Figure 3-46 shows the Area dialog
box with the area of a closed loop.

Measure Leop (3] ‘

54,794 mm D

Figure 3-45 The Measure Loop dialog box

Area (3]

215.195 mm~2 D
Figure 3-46 The Area dialog box

Tip. You can also measure the loop or the area defined by the face of an existing



feature. You will learn more about features in the later chapters.



Adding Linear Measurements
Ribbon: Measure > Distance / Angle You can calculate the total

measurement of several linear measurements by adding their values. To do
so, invoke the Distance or Angle tool. Next, select the geometry or the

distance to be measured; the measurement will be displayed in the Measure
Distance dialog box. Next, click the arrow on the right side of the display
box; a flyout will be displayed. Choose the Add to Accumulate option from
the flyout and choose the same arrow again; the same flyout will be
displayed. Choose the Restart option from the flyout. Next, choose another

measurement and follow the same procedure until you add all the desired
measurements. Then, click on the arrow and choose the Display Accumulate
option from the flyout; the sum of the measurements will be displayed in the
dialog box.




Clearing Accumulated Dimensions
On choosing the Clear Accumulate option, you can clear all the accumulated
measurements and reset the sum to zero. This option is located below the Add to

Accumulate option.



Evaluating Region Properties
Ribbon: Inspect > Measure > Region Properties This tool is used to evaluate

the properties of the closed loop sketch such as area, perimeter, and also
display the region properties of the sketch such as Area and Moment of

Inertia by taking measurements from the sketch coordinate system. To
invoke this tool, right-click in the drawing window and choose Measure >

Region Properties from the Marking menu; the Region Properties dialog
box will be displayed, as shown in Figure 3-47. Alternatively, invoke the

Region Properties tool by choosing the Region Properties tool from the
Measure panel. The options in this dialog box are discussed next.




Selections

When you invoke the Region Properties dialog box, this option is chosen by
default. Also, you will be prompted to select one or more closed sketch loops.
Select one or more closed sketch loops from the drawing window.



Dual Units

You can select the required unit of measurement from this drop-down list to
display the results of measurements in the selected unit. You can view the results
in two different units.



Calculate

After setting the options in the Selections and the Dual Units area, choose the
Calculate button; the results will be displayed in the display box. In case you
add or remove a closed loop in the Selections area or change the unit in the Dual
Units drop-down list, the recalculation will occur and the updated results will be
displayed in the display box.

Region Properties &J

Dual Units

Selections

Click to add | e g

culate

Select Region(s) and then select Calculate to see results.

Dane
Figure 3-47 The Region Properties dialog box




TUTORIALS

From this chapter onward, you will use the parametric feature of Autodesk
Inventor for drawing and dimensioning the sketches. The following tutorials will
explain the method of drawing sketches with some arbitrary dimensions and then
driving them to the dimension values required in the model.

Tutorial 1

In this tutorial, you will draw the sketch shown in Figure 3-48. This sketch is the
same as the one drawn in Tutorial 2 of Chapter 2. After drawing the sketch, you
will add the required constraints and then dimension it. (Expected time: 30
min)

10

10 1

80
Figure 3-48 Dimensioned sketch for Tutorial 1

The following steps are required to complete this tutorial:

a. Start a new metric standard part file and invoke the Sketching environment.

b. Draw the initial sketch by using the Line and Two point rectangle tools, refer
to Figure 3-49.

c. Add the required constraints and dimensions to complete the sketch, refer to
Figure 3-51.

d. Dimension the sketch by using the origin to fully constrain it, refer to Figure
3-52.

e. Save the sketch with the name Tutoriall and then close the file.



Starting a New File and Invoking the Sketching Environment Start
Autodesk Inventor and then invoke the Sketching environment by
selecting the sketching plane.

1. Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop
of your computer or by using the Start menu.

2. Choose the New tool from Quick Access Toolbar and start a new metric
standard part file by using the Metric tab of the Create New File dialog box.

3. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

4. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

5. Select the XZ plane as the sketching plane from the graphics window; the
Sketching environment is invoked and the XZ Plane becomes parallel to the
screen.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as > Top/Front
from the flyout.

Drawing the Initial Sketch 1. Using the Line and Two point
rectangle tools, draw the required sketch similar to the one shown
in Figure 3-48. You do not need to draw the sketch to the exact
length. Use the temporary tracking option for drawing the sketch.
For your reference, all lines in the sketch are numbered, see Figure
3-49.

Note that in this sketch, the display of the X and Y axes has been turned off.



Adding Constraints to the Sketch

It is evident from Figure 3-49 that some of the lines need to be of the same
length. For example, lines 1 and 7, lines 2 and 6, lines 8 and 12, and so on. To
make the lines of the same length, you can use two options. In the first option,
you can assign dimensions to all these lines. However, this will increase the
number of dimensions in the sketch. In the second option, you can apply
constraints that will force the lines to maintain an equal length. You can apply
the Equal constraint to all the lines having the same length. This constraint
will relate the length of one of the lines with respect to the other. Now, if you
dimension any one of the related lines, all other lines related to it will be
forced to acquire the same dimension value. The Equal constraint is applied in
pairs.

2 12

Figure 3-49 Initial sketch drawn using the sketching tools

1. Choose the Equal tool from the Constrain panel of the Sketch tab to invoke
the Equal constraint.

When you invoke this constraint, you are prompted to select the first line, circle,
or arc.

2. Select line 2; the color of this line is changed to blue and you are prompted to
select the second line, circle, or arc. Select line 6; the Equal constraint is
applied to lines 2 and 6. Again, you are prompted to select the first line, circle,
or arc. Select line 6 as the first line and then line 8 as the second line.

While applying any of these constraints, if the Autodesk Inventor Create
Constraint warning message box is displayed, choose Cancel to exit that box.



3. Similarly, select lines 8 and 12, 1 and 7, 3 and 5, 5 and 9, 9 and 11. The Equal
constraint is applied to all these pairs of lines. Next, right-click in the drawing
window, and then choose Cancel (ESC) from the Marking Menu displayed.

4. If needed, apply the Horizontal and Vertical constraints to the horizontal and
vertical lines of the sketch, respectively.



Dimensioning the Sketch

Once all the required constraints have been applied to the sketch, you can
dimension it. As mentioned earlier in this chapter, whenever you modify or
apply dimension to an entity, it is forced to change its size with respect to the
specified dimension value.



Note
On applying the first dimension to the sketch and editing it, the whole scale of
the sketch is modified accordingly.

1. Choose the Dimension tool from the Constrain panel of the Sketch tab.
Alternatively, right-click anywhere in the graphics window and then choose
General Dimension from the Marking menu displayed. Next, select line 1,
refer to Figure 3-49.

As soon as you move the cursor close to line 1, it turns red and a small symbol is
displayed, indicating that a linear dimension will be applied to this line. It is
important to modify the value of the dimension after it is placed so that
geometries are driven to the values that you require. Therefore, after selecting
line 1, right-click to display the Marking menu. In this menu, choose Edit
Dimension. If it has already been chosen, press ESC once. This ensures that
the Edit box is displayed whenever you place the dimension. This edit box
allows you to modify the dimension value.

2. Place the dimension below line 1; the Edit Dimension edit box is displayed.
Enter 80 as the length of line 1 in this edit box and then choose the check mark
on the right of this edit box.

You will notice that the length of this line is modified to 80 units. Also, the
length of line 7 is modified because of the Equal constraint.

3. As the Dimension tool is still active, you are prompted again to select the
geometry to dimension. Select line 2 and place the dimension on the left of
this line; the Edit Dimension edit box is displayed. Change the length of this
line to 10 in this edit box and press ENTER.

You will notice that the length of lines 6, 8, and 12 is also forced to 10 units.
This is because the Equal constraint has been applied to all these lines.

4. Select line 4 and place it along the previous dimension. Modify the dimension
value in the Edit Dimension edit box to 30 and press ENTER. Notice that the
length of line 10 is also modified.



5. Select line 16 and place the dimension outside the sketch on the right. Modify
the dimension value in the Edit Dimension edit box to 20 and press ENTER.

6. Select line 15 and place the dimension outside the sketch on the top. Modify
the dimension value to 30 in the Edit Dimension edit box and press ENTER.

7. Now, to dimension the distance between lines 4 and 14, select them one by
one. Place the dimension outside the sketch on the top and then change the
dimension value to 10 in the Edit Dimension edit box and press ENTER.

8. Similarly, select lines 16 and 10 to dimension the distance between these two
lines and place the dimension outside the sketch on the top. Change the
dimension value to 10 in the Edit Dimension edit box and press ENTER. You
will notice that the length of lines 5, 9, 3, and 11 is automatically adjusted
because the Equal constraint has been applied to them.

9. To locate the inner rectangle vertically from the outer loop, select lines 1 and
13, and then place the dimension on the right of the sketch. Next, modify the
dimension value in the Edit Dimension edit box to 15 and press ENTER.

With this step, you have applied all the required constraints and dimensions to
the sketch. Now the sketch is ready to be converted into a feature. If you try to
add more constraints or dimensions to this sketch, the Autodesk Inventor
Professional - Create Linear Dimension error message box will appear,
informing that adding this dimension will overconstrain the sketch, see Figure
3-50. If you still want this dimension to be displayed, choose the Accept
button from this message box; the dimension will be added as a driven
dimension. A driven dimension is placed inside parentheses and is not used
during the manufacturing process. This dimension is used only for reference.
Note that you cannot edit the value of a driven dimension. The sketch after
applying all the dimensions and constraints should look similar to the one
shown in Figure 3-51.



Autodesk Inventor Professional - Create Linear Dimension

@Adding this dimensionwill over-constrain the sketch. Choose Accept to aeate a Driven
Dimension.

[ Cancel ] | Accept |

Figure 3-50 The Autodesk Inventor Professional message box

Even after adding all the dimensions, the color of entities in the sketch is blue.
This is because the sketch is not fully constrained. In order to fully constrain
the sketch, you need to constrain it with respect to the origin which is fixed by
default.

10. Choose the Coincident Constraint tool from the Constrain panel of the
Sketch tab; you are prompted to select the first curve or point.

11. Select the intersection point of lines 1 and 2, which is the lower left vertex of
the sketch; you are prompted to select the second curve or point.

12. Select the origin; the entire sketch shifts itself such that the lower left vertex
of the sketch is now at the origin.

Note that inspite of its shift, the sketch is not completely visible in the drawing
window.

13. Choose the Zoom All tool from the Navigation Bar > Zoom flyout to fit the
sketch into the drawing window. You will notice that all the entities in the
sketch turn purple, indicating that the sketch is fully constrained. Next, press
ESC to exit the Coincident Constraint tool.

Figure 3-52 shows the fully constrained sketch for Tutorial 1.
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Figure 3-51 Sketch after adding dimensions
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Figure 3-52 Fully constrained sketch for Tutorial 1



Saving the Sketch

1. Choose the Finish Sketch button from the Exit panel of the Sketch tab to exit
the Sketching environment. Alternatively, choose Finish Sketch from the
Marking menu to exit the Sketching environment.

2. Choose the Save tool from the Quick Access Toolbar or Application Menu
and save the sketch with the name Tutoriall at the location given below:

C:\Inventor_2016/c03

3. Choose Close > Close from the Application Menu to close the file.

Tutorial 2

In this tutorial, you will draw the sketch shown in Figure 3-53. This sketch is the
same as the one drawn in Tutorial 4 of Chapter 2. After drawing it, you will
apply the required constraints and dimensions to fully constrain it. (Expected
time: 30 min)
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Figure 3-53 Sketch for Tutorial 2

The following steps are required to complete this tutorial:

a. Start a new metric standard part file.

b. Invoke the Sketching environment and draw the initial sketch by using the
Line tool, refer to Figure 3-54.

c. Add Linear Diameter dimensions to the sketch by using the Dimension tool.

d. Apply Coincident Constraint between the origin and the lower left vertex of



the sketch to make it a fully constrained sketch, refer to Figure 3-55.
e. Add fillets, save the sketch with the name Tutorial2.ipt, and then close the
file.

Starting a New File and Invoking the Sketching Environment 1.
Choose the New tool from the Quick Access Toolbar and start a new
metric standard part file by using the Metric tab of the Create New
File dialog box.

2. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab;
the default planes are displayed and you are prompted to select the sketching
plane.

3. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

4. Select the YZ plane as the sketching plane from the graphics window; the
Sketching environment is invoked and the YZ Plane becomes parallel to the
screen. Alternatively, you can select the YZ plane from the Browser Bar.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as > Top/Front
from the flyout.

Tip. Autodesk Inventor allows you to invoke the drawing display options even when a Sketching
environment tool is active. This is done using a combination of hot keys and the left mouse button. For
example, if the Dimension tool is active, you can use the Pan option by holding the F2 key and then
pressing the left mouse button and dragging the cursor. Similarly, you can dynamically zoom in and out

the sketch by holding the F3 key and then pressing the left mouse button and dragging the cursor.



Drawing the Initial Sketch
1. Draw the initial sketch, as shown in Figure 3-54, using the Line tool. The
lines in the sketch are numbered for your reference.

Dimensioning and Constraining the Sketch The dimensions shown in
Figure 3-53 are linear dimensions. As the sketch is for a revolved
feature, you need to add linear diameter dimensions to it. It is
recommended that you first apply all the dimensions and then add
fillets to the sketch. This is because the size of a sketch generally
changes after dimensioning. Before adding dimensions to a revolved
section, it is important to determine which line segment of the sketch
will act as the axis for revolving the sketch. If you refer to Figure 3-
54, you will notice that line 1 acts as the axis to revolve the sketch for
the model. Therefore, while applying linear diameter dimensions, line
1 should be selected first.
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Figure 3-54 Lines numbered in the sketch

1. Choose the Dimension tool from the Constrain panel of the Sketch tab; you
are prompted to select the geometry to be dimensioned. Right-click to display
the Marking Menu, and then choose Edit Dimension from it, if it has not
already been chosen. If it has already been chosen, press the ESC key once to
exit the Marking Menu.

2. Select line 1; you are prompted again to select the geometry to be
dimensioned. Select line 3 and then right-click; a Marking menu is displayed.



From this menu, choose the Linear Diameter option.

You will notice that the linear dimension is twice the actual length, which means
that the distance between line 1 and line 3 is 4, but it will be displayed as 8 in
the linear diameter dimension. Also, the dimension value is preceded by the &
symbol, indicating that it is a linear diameter dimension.

3. Place the dimension on the left of the sketch; the Edit Dimension edit box is
displayed.

Figure 3-53 shows the value to be specified as 4 because the linear diameter
dimensions are placed twice.

4. Enter 8 in the Edit Dimension edit box and press ENTER; the vertical
distance between lines 1 and 3 is automatically adjusted to the value entered.

5. As the Dimension tool is still active, you are prompted again to select the
geometry to be dimensioned. Select lines 1 and 5 and then right-click; a
Marking menu is displayed. Choose Linear Diameter from the Marking
menu; the linear dimension is changed to the linear diameter dimension. Place
the dimension on the left of the previous dimension. Next, modify its value in
the Edit Dimension edit box to 20 and press ENTER.

6. Select lines 1 and 7. Right-click to display the Marking menu, and then
choose Linear Diameter from it. Place the dimension on the left of the
previous dimension and change its dimension value in the Edit Dimension
edit box to 32. Next, press ENTER.

Tip. Sometimes while dimensioning a sketch, some existing dimensions move
from the location where they have been placed. In this case, you need to exit the
Dimension tool and then drag the existing dimensions back to their original
locations. To resume dimensioning, invoke the Dimension tool again.

7. Select lines 1 and 9, and then right-click; a Marking menu is displayed. In the
Marking menu, choose Linear Diameter. Place the dimension on the right of



the sketch and change its value in the Edit Dimension edit box to 50 and then
press ENTER.

8. Select lines 1 and 11, and then right-click to display the Marking menu. In this
menu, choose Linear Diameter. Place the dimension on the right of the
previous dimension and change its value in the Edit Dimension edit box to 60
and then press ENTER.

Now, you need to add linear dimensions to the sketch.

9. Select lines 12 and 8, and then place the dimension above the sketch. Modify
its value in the Edit Dimension edit box to 5 and press ENTER.

10. Select line 11 and then place the dimension above the previous dimension.
Modify its value in the Edit Dimension edit box to 20 and press ENTER.

11. Select line 1 and then place the dimension below the sketch. Modify its value
in the Edit Dimension edit box to 22 and press ENTER.

12. Select lines 12 and 4, and then place the dimension below the previous
dimension. Modify its value in the Edit Dimension edit box to 36 and press
ENTER.

13. Select lines 12 and 6, and then place the dimension below the previous
dimension. Modify its value in the Edit Dimension edit box to 44 and press
ENTER.

With this, all dimensions have been added to the sketch. However, entities in the
sketch are still displayed in green, indicating that the sketch is not fully
constrained. Therefore, you need to add more dimensions or constraints to
make the sketch fully constrained. In this sketch, add Coincident constraint to
the origin and the intersection point of lines 1 and 2.

14. Invoke the Coincident Constraint tool; you are prompted to select the first
curve or point. Select the intersection point of lines 1 and 2, which is the lower
left vertex of the sketch; you are prompted to select the second curve or point.



15. Next, select the origin; the entire sketch shifts from its original location and
is relocated such that the lower left vertex of the sketch now lies at the origin.
Also, all entities in the sketch are displayed in purple, indicating that the
sketch is fully constrained.



Note
If the entities of the sketch are not fully constrained, you need to apply the
Vertical constraint to the vertical lines on the right of the sketch.

16. Choose the Zoom All tool from the Navigation Bar > Zoom flyout to fit the
sketch into the drawing window. The fully constrained sketch after adding all
the dimensions is shown in Figure 3-55.
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Figure 3-55 Fully constrained sketch for Tutorial 2



Adding Fillets to the Sketch
After dimensioning the sketch, you need to add fillets to it.

1. Choose the Fillet tool from Sketch > Create > Fillet drop-down; the 2D
Fillet dialog box is displayed. In this dialog box, set the value of fillet to 1.5.
Now, select lines 8 and 9; the fillet is automatically added between these two
lines and the dimension of the fillet is displayed.

2. Similarly, select lines 4 and 5 as well as lines 7 and 8 to add fillets between
these lines. Exit the 2D Fillet dialog box. The final sketch after adding fillets
is shown in Figure 3-56.
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Figure 3-56 Fully dimensioned sketch after adding fillets



Note
To modify the radius of the fillet, double-click on it; the Edit Dimension edit box
is displayed. Modify the value in this edit box and press ENTER.



Saving the Sketch
1. Choose the Finish Sketch button from the Exit panel of the Sketch tab to exit
the sketching environment.

2. Save this sketch with the name Tutorial2 at the location
C:\Inventor_2016/c03.

3. Choose Close > Close from Application Menu to close the file.

Tutorial 3

In this tutorial, you will draw the sketch for the model shown in Figure 3-57.
After drawing the sketch, you will add the required constraints to it and then
dimension it. The dimensioned sketch required for this model is shown in Figure
3-58. The solid model shown in Figure 3-57 is only for reference.

The sketch shown in Figure 3-58 is the combination of multiple closed loops: the
outer loop and inner circles. As the numbers of loops increase, so does the
complexity of the sketch. This is because the numbers of constraints and
dimensions in a sketch increase in case of multiple loops. Now, to draw sketches
without using the Dynamic Input, it is recommended that you first draw the outer
loop of the sketch and then add constraints and dimensions to it. This is because
once the outer loop has been constrained and dimensioned, the inner circles can
be constrained and dimensioned easily with reference to the outer loop.
(Expected time: 30 min)

Figure 3-57 Model for Tutorial 3



Figure 3-58 Dimensioned sketch of the model

The following steps are required to complete this tutorial:

a. Start a new metric template and draw the outer loop of the sketch, refer to
Figure 3-59.

b. Invoke the Sketching environment and add the required dimensions and
constraints to the outer loop, refer to Figure 3-61.

c. Draw inner circles and add constraints and dimensions to them, refer to Figure
3-62.

d. Save the sketch with the name Tutorial3.ipt and close the file.

Starting a New File and Invoking the Sketching Environment 1.
Choose the New button from the Quick Access Toolbar and start a
new metric standard part file using the Metric tab of the Create New
File dialog box.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

3. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

4. Select the XY plane as the sketching plane from the graphics window; the
Sketching environment is invoked and the XY Plane becomes parallel to the
screen.



Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.



Drawing the Outer Loop
1. To draw the outer loop, invoke the Line tool from the Draw panel in the
Sketch tab, refer to Figure 3-59.
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Figure 3-59 Profile with geometries numbered

You can also draw the tangent arcs while using the Line tool. This can be done
by invoking the Line tool and by pressing the left mouse button and then
dragging it in the required direction. Move the cursor close to the endpoint of
the last line until the yellow circle snaps to that point. When the yellow circle
snaps to the endpoint, it turns gray. Next, press and hold the left mouse button
and drag the mouse through a small distance in the upward direction. Refer to
Tutorial 3 of Chapter 2 to learn more about drawing this type of arc.

For your reference, all the geometries in the sketch are numbered. You will draw
inner holes in the sketch after dimensioning the outer loop.



Note

The outer loop that you created in the previous step might be different from the
one shown in Figure 3-59. You can find the missing constraints by following the
next step and applying constraints accordingly.

Adding Constraints to Sketched Entities As evident from Figure 3-59,
some of the constraints such as tangent and equal are missing in the
sketch. The sketch shown in Figure 3-59 may not be symmetrical and
all the lines in the sketch may not be tangent to the arcs. Therefore,
you need to add these missing constraints manually to the sketch to
complete it. You can choose the Show Constraint option from the
Marking menu that is displayed when you right-click on an entity.

1. In Figure 3-59, the Tangent constraint is missing between line 1 and arc 10.
To add this constraint between the line and the arc, choose the Tangent tool
from the Constrain panel of the Sketch tab; you are prompted to select the
first curve. Select arc 10 as the first curve; you are prompted to select the
second curve. Select line 1 as the second curve. Similarly, add this constraint
to all the places in the sketch wherever it is missing.

The geometries 5 and 7, and 3 and 9 are the lines that must be of equal length.
Also, the geometries 2 and 10, and 4 and 8 are the arcs that must be of equal
radii. Therefore, you need to add the Equal constraint between the respective
pairs of all these geometries.

2. Choose the Equal tool from the Constrain panel of the Sketch tab.

3. Select line 5 as the first line and then line 7 as the second line to apply the
Equal constraint to them; you are prompted again to select the first entity.

4. Select line 3 and then line 9 to apply the Equal constraint to them; you are
prompted to select the first entity again.

5. Select arc 2 and then arc 10 to apply the Equal constraint to them. Applying
this constraint to arcs or circles forces their radii or diameters to be equal.



6. Similarly, apply the Equal constraint to arc 4 and arc 8.

7. Apply the Coincident Constraint between the center point of arc 4 and line
5, and the center point of arc 8 and line 7, if it is not applied automatically.

8. Choose the Symmetric tool from the Constrain panel of the Sketch tab to
apply Symmetric constraint between line 3 and line 9.

9. Choose the Coincident Constraint tool from the Constrain panel; you are
prompted to select the first curve or point.

10. Select the origin; you are prompted to select the second curve or point.
11. Select the center point of arc 6; the entire sketch moves to make the origin

coincident with the center point of the arc. The sketch after applying all the
constraints is shown in Figure 3-60.
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Figure 3-60 The sketch after applying all constraints



Note

The shape of the sketch that you have drawn may be a little different from the
final sketch at this stage because of the difference in specifying points while
drawing the sketch. However, once all the dimensions are applied, the shape of
the sketch will be the same as of the final sketch. Also, you may need to add
vertical constraint to lines 5 and 7 and horizontal constraint to line 1 to fully
constrain the sketch.



Dimensioning the Sketch

1. Choose the Dimension tool from the Constrain panel of the Sketch tab.
Next, right-click to display the Marking menu. From the Marking menu,
choose Edit Dimension if the check mark is not available on the left of the
Edit Dimension option. If it shows the check mark, press the ESC key once to
exit the Marking Menu. On doing so, you are prompted to select the geometry
to be dimensioned. Select line 1 and place the dimension below the sketch.
Modify the value of this dimension in the Edit Dimension edit box to 20.

2. Select arc 4 and place the dimension on the left of the sketch; the radius
dimension of the sketch is placed. Modify the dimension value in the Edit
Dimension edit box to 7.5. The size of arc 8 is also modified because the
Equal constraint is applied between these two entities.



Note
As discussed in the previous tutorial, you may need to use the combination of hot
keys to zoom or pan the model.

3. Select arc 2 and place the radius dimension on the left of the sketch. Modify
the dimension value in the Edit Dimension edit box to 10 and press ENTER.
The size of arc 10 is also modified because of the Equal constraint applied
between these two entities.

4. Select line 5 and then line 7, and then place the dimension above the sketch.
Modify the value of this dimension in the Edit Dimension edit box to 15 and
press ENTER.

5. Select line 7 and place the dimension on the right of the sketch. Modify the
value of this dimension in the Edit Dimension edit box to 20 and press
ENTER.

6. Select the upper endpoint of line 7 and select line 1, and then place the
dimension on the right of the previous dimension. Modify the value of this
dimension to 40 and press ENTER. Next, exit the Dimension tool.

With this step, all the dimensions have been applied to the sketch, refer to Figure
3-61, except the horizontal dimension between the center points of arcs 4 and
6 or arcs 8 and 6. The need of these dimensions depends on the constraints and
dimensions assumed while drawing the sketch. If the sketch gets
overconstrained, the Autodesk Inventor Professional message box is
displayed. Choose Cancel from the message box. In this case, the dimension
has already been assumed.



Drawing Circles

Once all the required dimensions and constraints have been applied to the
sketch, you need to draw circles. Figure 3-58 indicates that circles are
concentric with arcs 2 and 10.

1. To draw concentric circles, choose the Center Point Circle tool from the
Create panel; you are prompted to select the center of the circle. Move the
cursor close to the center of arc 2. Specify the center point when the cursor
snaps to the center point of arc 2 and turns green. Next, move the cursor away
from the center and specify a point to size the circle.

2. Similarly, draw the other circle taking the reference of the center of arc 10.



Adding Constraints to Circles

As both the circles have the same diameter, you can apply the Equal constraint
to them. On applying the dimension to one of the circles, the other circle will
automatically be forced to the specified diameter value because of the Equal
constraint.

1. Invoke the Equal constraint tool from the Constrain panel. Select the first
circle and then the second circle to apply the Equal constraint.

Dimensioning Circles 1. Choose the Dimension tool from the
Constrain panel and select the left circle.Place the dimension on the
left of the sketch. In the Edit Dimension edit box, change the value
of the diameter of the circle to 8 and press ENTER.

Notice that because of the Equal constraint, the size of the right circle is
automatically modified to match the dimension of the left circle. The final
sketch for Tutorial 3 after drawing and dimensioning circles is shown in
Figure 3-62.
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Figure 3-61 Dimensioned sketch for Tutorial 3
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Figure 3-62 The final dimensioned sketch for Tutorial 3

Saving the Sketch 1. Choose the Return tool from the Quick Access
Toolbar to exit the sketching environment. Save this sketch with

the name Tutorial3 at the location given below:
C:\Inventor_2016/c03



Note

If the Return tool is not available in Quick Access Toolbar, you need to add this
tool to the toolbar. To do so, choose the down arrow on the right of Quick
Access Toolbar; a flyout is displayed. Next, choose the Return option from the

flyout.

2. Choose Close > Close from the Application Menu to close the file.

Tutorial 4

In this tutorial, you will draw the sketch of the model shown in Figure 3-63. The
dimensions of the sketch are shown in Figure 3-64. After drawing the sketch,
add constraints and then dimension it. The solid model is given for reference
only. (Expected time: 30 min)

Figure 3-63 Model for the sketch of Tutorial 4




Figure 3-64 The final dimensioned sketch for Tutorial 4

The following steps are required to complete this tutorial:

a. Start a new metric standard part file and invoke the Sketching environment.
b. Draw the outer loop of the sketch.

c. Add the required dimensions and constraints to the sketch.

d. Add the inner circle to the sketch and dimension it.

e. Save the sketch with the name Tutorial4.ipt and close the file.

Starting a New File and Invoking the Sketching Environment 1.
Choose the New tool from the Quick Access Toolbar to display the
Create New File dialog box. Start a new metric standard part file
from the Metric tab of this dialog box.

2. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab;
the default planes are displayed and you are prompted to select the sketching
plane.

3. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

4. Select the XZ plane as the sketching plane from the graphics window; the
Sketching environment is invoked and the XZ Plane becomes parallel to the
screen. Alternatively, you can select XZ plane from the Browser Bar.

Note If If the orientation of the ViewCube is not the same as the orientation of
the selected plane (Top/Front) then click on the down arrow available next to
the ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.



Drawing the Outer Loop

1. Choose the Line tool from the Create panel of the Sketch tab to draw the
outer loop, as shown in Figure 3-65. As mentioned earlier, you should draw
the inner loop after drawing and dimensioning the outer loop. This is because
once the outer loop is dimensioned, you can draw the inner loop by taking the
reference of the outer loop.

You can draw the arc while the Line tool is active. You can also use the

temporary tracking option to draw this sketch. For your reference, the
geometries in the sketch are numbered, see Figure 3-65.
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Figure 3-65 Initial sketch with the geometries numbered
Adding Constraints to the Outer Loop
1. Add the Equal constraint to lines 1 and 9, 2 and 8, 3 and 5, 5 and 7, and 4 and
6.
2. Add the Perpendicular Constraint to lines 2 and 3, and 7 and 8.

3. Add the Horizontal Constraint to the lower endpoints of lines 4 and 6.

4. Add the Tangent Constraint to lines 1 and 9 with arc 10, if it is missing.

Dimensioning the Outer Loop 1. Choose the Dimension tool from the
Constrain panel of the Sketch tab; you are prompted to select the



geometry to dimension. Select line 9 and place the dimension on the
left of the sketch. Modify the dimension value in the Edit
Dimension edit box to 25 and press ENTER.

2. Select the center of the arc and then the lower endpoint of line 6. Place the
dimension on the left of the previous dimension. Modify the dimension value
in the Edit Dimension edit box to 60 and press ENTER.

3. Select line 3 and then right-click to display the Marking menu. Choose
Aligned from the Marking menu and then place the dimension below the
sketch. Modify the dimension value in the Edit Dimension edit box to 12.5
and press ENTER.

Notice that the length of lines 5 and 7 is also modified because of the Equal
constraint.

4. Select lines 1 and 2 and then place the angular dimension on the right of the
sketch. Modify the value of the angular dimension in the Edit Dimension edit
box to 135 and press ENTER.

5. Select arc 10 and then place the radius dimension above the sketch. Modify
the value of the radius of the arc in the Edit Dimension edit box to 15 and

press ENTER.

With this, the required dimensions have been applied to the outer loop. Even
after adding all dimensions, the color of entities in the sketch remains green.

6. Select the origin. Now, you can use the origin to fully constrain the initial
sketch.

7. Choose the Coincident Constraint tool from the Constrain panel; you are
prompted to select the first curve or point.

8. Select the center of the arc; you are prompted to select the second curve or
point.

9. Select the origin. The entire sketch shifts itself such that the center of arc of



the sketch is at the origin. After the sketch is shifted to a new place, it may not
be visible completely in the drawing window.

10. Choose the Zoom All tool from the Navigation Bar > Zoom flyout to fit the
sketch into the drawing window. You will notice that all the entities in the
sketch turn purple, indicating that the sketch is fully constrained. Press the
ESC key to exit the Coincident Constraint tool.



Drawing the Circle
1. Choose Center Point Circle from the Create panel of the Sketch tab; you are
prompted to select the center of the circle.

2. Move the cursor close to the center of the arc; the cursor snaps to the center
point and turns green. Select this point as the center of the circle and then
move the cursor away from the center to size the circle. Specify a point to give
it an approximate size.



Dimensioning the Circle

1. Choose Dimension from the Constrain panel of the Sketch tab and select the
circle. Place the diameter dimension below the arc dimension. Enter 25 in the
Edit Dimension edit box and then press ENTER. This completes the sketch
for Tutorial 4. The final dimensioned sketch is shown in Figure 3-66.
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Figure 3-66 The final dimensioned sketch for Tutorial 4



Saving the Sketch

1. Choose the Finish Sketch option from the Exit panel of the Sketch tab to exit
the sketching environment. Alternatively, choose the Finish 2D Sketch option
from the Marking menu to exit the sketching environment

2. Save the sketch with the name Tutorial4 at the location given below:

C:\Inventor_2016\c03

3. Choose Close > Close from Application Menu to close the file.

Self-Evaluation Test

Answer the following questions and then compare them to those given at the

end of this chapter:

1. The nature of Autodesk Inventor ensures that a selected entity is
driven to a specified dimension value irrespective of its original size.

2. When you select a circle to be dimensioned, the dimension is
applied to it, by default.

3. The dimension has one arrowhead and is placed outside a circle
or an arc.
4. The dimension displays the distance between two selected line

segments in terms of diameter and the distance shown is twice the original
length.

5. The tool is used to measure the radius of an arc.

6. A constrained sketch is the one whose entities are completely
constrained to their surroundings using constraints and dimensions.

7. The Perpendicular Constraint forces a selected entity to become perpendicular
to a specified entity. (T/F)

8. The Coincident Constraint can be applied to two line segments. ('T/F)

9. The Collinear Constraint can only be applied to line segments. (T/F)

10. If an unnecessary constraint is applied to a sketch, Autodesk Inventor



displays a message box informing that adding this constraint will
overconstrain the sketch. (T/F)



Answer the following questions:

1. You cannot apply the Concentric Constraint between a point and a circle.
(T/F)

2. You can use the Horizontal Constraint or the Vertical Constraint to line up
arcs, circles, or ellipses in the same horizontal or vertical direction. (T/F)

3. You can view all or some of the constraints applied to a sketch. (T/F)

4. There are twelve types of geometrical constraints that can be applied to the
sketched entities. (T/F)

5. The linear dimensions are the dimensions that define the shortest distance
between two points. (T/F)

6. A sketch in which the number of dimensions or constraints exceeds the
required numbers is called as Overconstrained sketch. (T/F)

7. To which of the following toolbars does the Measure Distance toolbar
change when you invoke the Distance tool and select two lines?

(a) Length (b) Distance (c) Minimum Distance (d) None of these
8. Which of the following dimensions is applied by default to an arc whenever it
is dimensioned?

(a) Radius (b) Diameter (c) Linear (d) Linear Diameter
9. In addition to lines, which of the following entities can be selected to apply
the Collinear constraint?

(a) Arc (b) Circle

(c) Ellipse (d) Ellipse axis

10. Which of the following combinations of entities cannot be used to apply the
Tangent constraint?

(a) Line, line (b) Line, arc (c) Circle, circle (d) Arc, circle



Exercises

Exercise 1

Draw the sketch of the model shown in Figure 3-67. The sketch to be drawn is
shown in Figure 3-68. After drawing the sketch, add the required constraints to it
and then dimension it. (Expected time: 30 min)

Figure 3-67 Model for Exercise 1
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Figure 3-68 Sketch for Exercise 1

Exercise 2

Draw the sketch of the model shown in Figure 3-69. The sketch to be drawn is
shown in Figure 3-70. After drawing the sketch, add the required constraints to it
and then dimension it.

(Expected time: 30 min)



Figure 3-69 Model for Exercise 2
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Figure 3-70 Sketch for Exercise 2

Exercise 3

Redraw the sketch given in Exercise 1 of Chapter 2. After drawing the sketch,
add the required constraints to it and then dimension it. The dimensioned sketch
is shown in Figure 3-71. (Expected time: 30 min)

Exercise 4
Redraw the sketch given in Exercise 2 of Chapter 2. After drawing the sketch,

add the required constraints to it and then dimension it. The dimensioned sketch
is shown in Figure 3-72. (Expected time: 30 min)
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Figure 3-72 Dimensioned sketch for Exercise 4

Exercise 5

Draw the sketch of the model shown in Figure 3-73. The sketch to be drawn is
shown in Figure 3-74. After drawing the sketch, add the required constraints to it
and then dimension it.

(Expected time: 30 min)



Figure 3-73 Model for Exercise 5
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Figure 3-74 Sketch for Exercise 5

Exercise 6

Draw the sketch of the model shown in Figure 3-75. The sketch to be drawn is
shown in Figure 3-76. After drawing the sketch, add the required constraints to it
and then dimension it.

(Expected time: 30 min)



Figure 3-75 Model for Exercise 6

Figure 3-76 Sketch for Exercise 6

Answers to Self-Evaluation Test 1. parametric, 2. diameter, 3. radius, 4. linear
diameter, 5. Measure Distance, 6. fully, 7. T, 8. F, 9. F, 10. T












Chapter 4

Editing, Extruding,and Revolving the
Sketches

Learning Objectives

After completing this chapter, you will be able to: * Edit sketches using various
editing tools.

* Create rectangular and circular patterns.

* Write text in the Sketching environment and convert it into a feature.

* Insert external images, Word documents, and EXxcel spreadsheets in the
sketching environment.

 Convert sketches into base features using the Extrude tool.

* Convert sketches into base features using the Revolve tool.

» Manipulate features by using the mini toolbar.

* Dynamically change the view of a model using Free Orbit, ViewCube, and
SteeringWheels.

* Create primitive freeform shapes.



EDITING SKETCHED ENTITIES

Autodesk Inventor provides you with a number of tools that can be used to edit
the sketched entities. These tools are discussed next.



Extending Sketched Entities
Ribbon: Sketch > Modify > Extend You can extend or lengthen the selected
entity up to a specified boundary by using the Extend tool. For using this
tool, you should have at least two entities such that when extended, they
meet at a point. Taking the reference of one of the entities, the other will be
extended. The entities that can be extended using this tool are lines, splines,
and arcs. On invoking this tool, you will be prompted to select the curve to
be extended. As you move the cursor close to the curve to be extended, the
original curve will be displayed in white and the portion to be extended will
be displayed in black. While extending the arcs, the point where you select
the arc will determine the side that will be extended. Figures 4-1 and 4-2
show the entities before and after their extension. In Autodesk Inventor,
ou can also dynamically extend lines and curves upto the nearest
boundary. To do so, choose the Extend tool from the Modify panel, press
and hold the left mouse button, and drag the cursor on the entities to be
extended; the entities through which cursor passes will be extended to the
nearest boundary.

Boundary

Before extending After extending

Figure 4-1 Line before and after extending it
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Figure 4-2 Arc before and dfter extending it



Trimming Sketched Entities

Ribbon: Sketch > Modify > Trim In Inventor, you can cut the length of an
entity. You can do so by using the Trim tool. This tool chops the selected
sketched entity by using an edge (also called the knife-edge). The knife-edge,
in its current form, may or may not actually intersect the entity to be
trimmed. However, when extended, the knife-edge must intersect the entity

to be trimmed. On invoking this tool, you will be prompted to select the
portion of the curve to be trimmed. As you move the cursor close to the
curve to be trimmed, the entity will be highlighted and the portion of the

entity to be trimmed will be displayed as a dashed line. Once you select the
ortion of the entity to be trimmed by clicking on it, the selected portion

will be trimmed to the nearest intersection point with the next closest entity.
Figure 4-3 shows the curves to be selected for trimming and Figure 4-4
shows the sketch after trimming the curves. If you use this tool on an
isolated entity, it will work as the Delete tool and will delete the isolated

entity.

Portions to

be trimmed

Portions to 4
be trimmed

Figure 4-3 Curves to be selected for trimming



Figure 4-4 Sketch after trimming the curves

To trim the entities within a boundary, press and hold the CTRL key after
invoking the Trim tool; you will be prompted to select the geometry used for
trimming. Select the geometry to be used as boundary for trimming. Next,
release the CTRL key; you will be prompted to select the portion of the curve to
be trimmed. Select the portion by clicking on it; the portion within the boundary
will be trimmed. In Autodesk Inventor, you can also dynamically trim lines and
curves. To do so, choose the Trim tool from the Ribbon, press and hold the left
mouse button and drag the cursor on the entity to be trimmed.

Tip. If you are using the Extend or Trim tool while editing, you can also
temporarily switch between these tools by pressing and holding the SHIFT key.
For example, if the active tool is Trim and you press and hold the SHIFT key,
then this tool will act as the Extend tool, but on releasing the SHIFT key, the
original tool will resume its function.

Splitting Sketched Entities Ribbon: Sketch > Modify >
Split The Split tool is used to break a sketched entity into
two or more entities at the intersection point(s) with
another sketched entity. On invoking this tool, you will
be prompted to select a curve to split. As you move the
cursor close to the sketched entity, it is highlighted in
white and a red cross-mark will be displayed at the
nearest intersection point or the apparent intersection
point. The intersection point will be selected depending
on the selection point on the sketched entity. It means
that the intersection point nearest to the point of selection
will be selected as the point of break for the sketched



entity. Click on the entity highlighted in red; the entity
will split into two parts. Each part of the split entity will
now act an individual sketched entity and can be
modified or deleted independent of the other part.
However, the broken parts will be joined through the
Coincident constraint. As a result, if you drag the broken
entity to a new position, the entire entity will also move.

Tip. If you are editing sketched entities using the Trim tool, you can switch to
the Extend or Split tool. To do so, right-click in the drawing area; a Marking
menu will be displayed. You will observe a check mark on the left of the active
tool. Choose the editing tool as per your requirement to switch to that tool.



Offsetting Sketched Entities

Ribbon: Sketch > Modify > Offset Offsetting is one of the easiest methods of
drawing parallel lines, concentric arcs and circles. You can select the entire
loop as a single entity or select the individual entities to be offset. When you
invoke the Offset tool, you will be prompted to select the curve to offset. If

you right-click at this point, a Marking menu will be displayed, as shown in
Figure 4-5. The Loop Select option is chosen by default in this Marking
menu, see Figure 4-5. This option allows you to select the entire loop as a

single entity. However, if this option is cleared, the entire loop will be
considered as a combination of individual segments and you will be allowed
to select individual entities. The Constrain Offset option applies the
constraints automatically when the loop or the individual entity is offset.

/ Line |
| Center Point Cirde IC";I ] I Two Point Rectangle |
| Cancel (ESC) X | |« OK |

=7

| General Dimension I'_'| | A Project Geometry |

4" Finish 2D Sketch |

+" Loop Select

" Constrain Offset

:4—: Previous View F5
fa} Home View F&

How To...

Figure 4-5 The Marking menu for offsetting the entities

If you choose the Loop Select option from the Marking menu, you will be
prompted to specify the offset position for the new loop immediately after
selecting the original loop. If you specify the location inside the original loop,
the new loop will be smaller than the original loop. If you specify the location
outside the original loop, the new loop will be bigger.

In case of individual entities, once you have selected the entity to be offset,
right-click to display the Marking menu and choose Continue, or press the
ENTER key to continue. You will be prompted to specify the location for the
new entity. If the selected entity is a line segment, its length will remain the
same and if it is an arc or a circle, the size of the new entity will depend on the
location of the new point. Figure 4-6 shows the offset of a loop and Figure 4-7



shows the offset of an individual entity of a loop.
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Figure 4-6 Creating a new loop by offsetting the original loop
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Figure 4-7 Offsetting an individual line segment to a new location



Mirroring Sketched Entities

Ribbon: Sketch > Pattern > Mirror The Mirror tool is used to create mirror

images of the selected entities. The entities are mirrored about a straight
line segment. This tool is used to draw sketches that are symmetrical about

a line or sketches. When you invoke this tool, the Mirror dialog box will be
displayed, as shown in Figure 4-8. The Select button is chosen by default. As

a result, you will be prompted to select the geometry to be mirrored. You
can select multiple entities to be mirrored. Once you

have selected the entities, choose the Mirror line button; you will be
prompted to select the line about which the entities should be mirrored.
After selecting the mirror line, choose the Apply button; the selected entities
will be mirrored about the mirror line. If the mirror line is at an angle,

the resultant entities will also be at an angle. After mirroring the entities,
choose the Done button to exit this dialog box. Figure 4-9 shows various
sketched entities selected for mirroring and the mirror line that will be used
to mirror the entities. Figure 4-10 shows the sketch after mirroring the

entities.

Mirror &J

% Select |§| Mirror line
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Figure 4-8 The Mirror dialog box

Figure 4-11 shows the entities selected to be mirrored about an inclined mirror
line and Figure 4-12 shows the sketch after mirroring the entities. In Autodesk
Inventor, the Self Symmetric check box is provided in the Mirror dialog box.
By default, this check box is not activated. It is activated only when the
geometry selected to mirror is an open spline and intersects the mirror line. On
selecting this check box, the mirror command creates a single spline that is
symmetric about the mirror line, refer to Figure 4-13. If this check box is
cleared, the mirror copy of the sketched entity will be created about the mirror
line, refer to Figure 4-14.
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Figure 4-9 Selecting the geometries to be mirrored about the mirror line

Figure 4-10 Sketch after mirroring the geometries and deleting the mirror line
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Figure 4-11 Selecting the geometries to be mirrored about an inclined mirror
line
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Figure 4-12 Sketch after mirroring the geometries and deleting the mirror line

Figure 4-13 Sketch mirrored after selecting the Self Symmetric check box

Figure 4-14 Sketch mirrored dfter clearing the Self Symmetric check box



Moving Sketched Entities

Ribbon: Sketch > Modify > Move The Move tool is used to move one or more
selected sketched entities from one point to the other. The points that can be
used to move the entities include the sketched points, hole centers, the

endpoints of lines, arcs, splines, and the center points of arcs, circles, and
ellipses. When you invoke this tool, the Move dialog box will be displayed,
as shown in Figure 4-15. You can also use this dialog box to create copies of

the selected entities.
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Figure 4-15 The Move dialog box




Note

R Remember that while moving constrained entities, the behavior of the entities
depends on the constraints applied to them. If the selected entities are
constrained with some other entities, the constrained entities will also move.
However, if the other entities have a Fix constraint applied to them, because of
which they cannot move from their location, the original entities will also not be
able to move.

Options in the Move Dialog Box
The options in the Move dialog box are discussed next.



Select
This button is used to select the entities to be moved. When you invoke the

Move tool, this button is automatically chosen. Entities can also be selected
using the Window Crossing options, or by selecting them one by one using the
left mouse button.



Base Point

This button is chosen to specify the point that will act as the base point for
moving the selected entities. Once you have selected all the entities to be
moved, choose this button to select the point from where the movement will

start.



Copy
This check box is selected to create a copy of the selected entities as they are

moved. If this check box is selected, a copy of the selected entities will be
created and placed at the destination point, keeping the original entities intact.



Precise Input
This check box, if selected, allows you to specify the coordinates for the base
point and the destination point using the Inventor Precise Input toolbar.



Optimize for Single Selection

If this check box is selected, the Base Point button will be activated
automatically, after making a single selection or the window selection of
geometry. But if you clear this check box, you can make multiple geometry
selections before choosing the Base Point button.

Autodesk Inventor allows you to control the geometric and dimensional
constraints of the entity being moved. To do so, choose the >> button at the
lower right corner of the Move dialog box; the Move dialog box will expand, as
shown in Figure 4-16.

Move
Select l% ‘ @=p Base Point
Copy Precise Input
|| optimize for Single Selection
Daone ‘
Relax Dimensional Constraints
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Break Geometric Constraints
MNever
Always
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Figure 4-16 The expanded Move dialog box

The radio buttons in the Relax Dimensional Constraints area are used to
control the behavior of the dimensional constraints that are applied to the
sketched entities. Different radio buttons in this area are discussed next.



Never

If this radio button is selected then while moving the sketched entities, the
existing dimensional constraints will not be ignored. If moving the sketched
entities conflicts with the constraints applied to them earlier, then the
Autodesk Inventor Professional message box will display warning about the
conflicts.



If No Equation
This radio button, if selected, modifies the dimensions that are not a function
of any other dimension, while the move operation is being performed.



Always
This radio button, if selected, modifies the dimensions of the entities that are
outside the selection box, after moving the selected entities to a new position.



Prompt

This radio button is selected by default, and if the move operation cannot be
performed with the existing dimensions and constraints, a dialog box offering
possible solutions will be displayed.

Similarly, the radio buttons in the Break Geometric Constraints area control
the behavior of the geometric constraints that are applied to the sketched entities.
These radio buttons are discussed next.



Never
This radio button, if selected, will not ignore the geometric constraints that are
applied to the sketched entities while moving them.



Always
This radio button, if selected, deletes only the geometric constraints that are
associated with the selected entity.



Prompt

This radio button is selected by default and will display the possible solutions

for moving the sketched entities.
Figures 4-17 through 4-20 show moving and copying of various sketched
entities from one specified point to the other specified point after selecting the
base point in the graphics window.
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Figure 4-17 Moving the entities using the sketch points

Figure 4-18 Objects after moving
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Figure 4-19 Moving and copying the entities using the center points of circles
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Figure 4-20 Objects after moving and copying



Rotating Sketched Entities
Ribbon: Sketch > Modify > Rotate The Rotate tool is used to rotate the
selected sketched entities about a specified center point. You can also use

this tool to create a copy of the selected entities while rotating them. When
you invoke this tool, the Rotate dialog box will be displayed, as shown in

Figure 4-21.

Options in the Rotate Dialog Box
The options in the Rotate dialog box are discussed next.



Select
This button is chosen to select the entities to be rotated.
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Figure 4-21 The Rotate dialog box

When you invoke the Rotate tool, the Rotate dialog box will be displayed and
the Select button will be automatically chosen. You can use any object
selection technique to select one or more objects.



Center Point Area

The Select button in the Center Point area helps you to specify a center point
for rotation. The Precise Input check box, if selected, allows you to input the
coordinates for the center point of rotation.



Angle

This edit box is used to define the value of the angle through which the
selected entities will be rotated. You can enter the value in this edit box or
choose the arrow on the right of this edit box to specify the predefined angle
values. Remember that a positive angle will rotate the selected entities in the
counterclockwise direction and a negative angle will rotate the selected
entities in the clockwise direction.



Copy
This check box is selected to create a copy of the selected entities as they are

rotated. If this check box is selected, a copy of the selected entities will be
created and placed at the angle that you have specified in the Angle edit box.
The original entities will be intact at their original location.



Optimize for Single Selection

If this check box is selected, then as soon as you select geometry, the Select
button of the Center Point area will be activated automatically. But if you
clear this check box, you can select multiple geometries before choosing the
Select button from the Center Point area.

Autodesk Inventor allows you to control the dimensional and geometrical
constraints that are applied to the sketched entities while rotating them. These
options are available when you choose the >> button at the lower right corner of
the Rotate dialog box. These options are the same as discussed in the previous
section on moving the sketched entities. Figure 4-22 shows the rotation of the
selected entities at various angles after selecting the base point.

Tip. You can also create a copy of the sketched entities using the Marking menu.
Select the sketched entities and right-click to display a Marking menu. In this
menu, choose Copy. Again, right-click to display a Marking menu and choose
Paste to paste the selected entities, thus creating a copy of the selected entities.

<> Original
)1 entities

Rotation angle=90° Rotation angle=—4%

Figure 4-22 Position of the entities at various angles

CREATING PATTERNS GENERALLY, IN THE
MECHANICAL INDUSTRY, YOU COME ACROSS
VARIOUS DESIGNS THAT CONSIST OF MULTIPLE



COPIES OF A SKETCHED FEATURE ARRANGED
IN A PARTICULAR FASHION. FOR EXAMPLE, IT
CAN BE MULTIPLE GROOVES AROUND AN
IMAGINARY CIRCLE. IT CAN ALSO BE ALONG
THE EDGES OF AN IMAGINARY RECTANGLE,
SUCH AS THE GROOVES IN THE PEDESTAL
BEARING. DRAWING THE SKETCHES FOR SUCH
FEATURES AGAIN AND AGAIN IS A VERY
TEDIOUS AND TIME-CONSUMING PROCESS. TO
AVOID THIS LENGTHY PROCESS, AUTODESK
INVENTOR PROVIDES YOU WITH AN OPTION
FOR CREATING PATTERNS OF THE SKETCHED
ENTITIES DURING THE SKETCHING STAGE
ITSELF. THE PATTERNS ARE DEFINED AS THE
SEQUENTIAL ARRANGEMENT OF THE COPIES OF
THE SELECTED ENTITIES. YOU CAN CREATE THE
PATTERNS IN A RECTANGULAR OR CIRCULAR
FASHION. BOTH THESE TYPES OF PATTERNS
ARE DISCUSSED NEXT.

Creating Rectangular Patterns Ribbon: Sketch > Pattern >
Rectangular Pattern Rectangular patterns are the patterns
that arrange the copies of the selected entities in rows and
columns. When you invoke this tool, the rectangutar

raern dial0g box will be displayed, as shown in Figure 4-
23. The options in this dialog box are discussed next.



r B
Rectangular Pattern ﬂ
Geometry

Direction 1 Direction 2
cee | 2 [3 § 2 3

<> [10mm b <> (10 mm b
L

Figure 4-23 The Rectangular Pattern dialog box




Geometry

This button is chosen by default and is used to select the entities to be patterned.
You can select one or more entities to be patterned using any object selection
technique.

Direction 1 Area

This area provides the option for defining the first direction of pattern creation,
the number of copies to be created in this direction, and the spacing between the
entities. These options are discussed next.



Direction

This button is with an arrow and is chosen to select the first direction of the
rectangular pattern. The other options in the Direction 1 area will be available
only after you define the first direction of the pattern creation. The direction
can be defined by selecting a line segment, which can be at any angle. The
resultant pattern will also be created at an angle, if the line selected to specify
the direction is at an angle. As you define the first direction, you can preview
the pattern created using the current values in the drawing window. The
pattern in the preview will be modified dynamically on changing the values in
this dialog box.



Flip

This button is available on the right of the Direction button and is chosen to
reverse the first direction of the pattern creation. When you define the first
direction using the Direction button, an arrow appears on the sketch. This
arrow displays the direction in which the items of the pattern will be created.
If you choose this button, the direction will be reversed and the arrow will
point in the opposite direction.



Count

This edit box is used to specify the number of items in the pattern along the
first direction. Remember that this value includes the original selected item.
On increasing the value in this edit box, you can dynamically preview the
increased items in the pattern in the drawing window. You can also select a
predefined number of items by clicking the arrow on the right of this edit box.
When you click on the arrow, a list with predefined values is displayed.
However, if you are using this tool for the first time in the current session of
Autodesk Inventor, this list will not provide any value.



Spacing

This edit box is used to define the distance between the individual items of the
pattern in the first direction. You can enter a value or choose the arrow on the
right of this edit box to use the Measure or Show Dimensions options to
define this value. The Measure option allows you to select a line segment, the
length of which will specify the distance between the individual items. The
Show Dimensions option allows you to use an existing dimension to specify
the distance between the individual items of the pattern. The selected
dimension will automatically appear in the edit box. You need to delete the
existing value in this edit box to use the measured value.

Direction 2 Area

This area provides the option for defining the second direction of the pattern
creation, the number of copies to be created in this direction, and the spacing
between the entities. All these options are discussed next.



Direction
This button is chosen to select the second direction for arranging the items of
the rectangular pattern.



Flip
This button is available on the right of the Direction button and is chosen to
reverse the second direction of pattern creation.



Count
This edit box is used to specify the number of items in the pattern along the
second direction.



Spacing
This edit box is used to define the distance between the individual items of the

pattern in the second direction. Similar to the Spacing edit box in the

Direction 1 area, you can directly enter a value in this edit box or use the
Measure or the Show Dimension options to define this value.

Figure 4-24 shows various parameters involved in creating a rectangular pattern
with three items along direction 1 and four items along direction 2.
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Figure 4-24 Creating a rectangular pattern



More

This button is provided on the lower right corner of the Rectangular Pattern
dialog box. On choosing this button, the Rectangular Pattern dialog box
expands, providing you with more options for creating the pattern, see Figure 4-
25. These options are discussed next.



Suppress

This button is chosen to suppress the selected item from the pattern. When you
select any item of the pattern using this button, it will change into dashed
lines. The items that are suppressed will be displayed on the screen, but will
not participate in the feature creation when you finish the sketch. You can
unsuppress these items later, if required.

Suppress /| Associative

Fitted

Figure 4-25 More options in the Rectangular Pattern dialog box



Note
T The process of editing sketches of the features will be discussed in the later
chapters.



Associative

This check box is selected by default. As a result, all items of the pattern are
associated with each other. All the items of the associative pattern are
automatically updated, if any one of the entity is modified. For example, if you
modify the dimension of any of the items of the pattern, the dimensions of all
the other items will also be modified. However, if you clear this check box
before creating the pattern, all the items will be individual entities and you can
modify them individually.



Fitted

This option works in combination with the Spacing option in the Direction 1
and Direction 2 areas. If you select this option, the specified number of items
will be created in the distances specified in the Spacing edit boxes in the
Direction 1 and Direction 2 areas. Figure 4-26 shows the pattern created by
clearing this check box (spacing is incremental) and Figure 4-27 shows the
pattern created by selecting this check box (included spacing between all the
items).
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Figure 4-26 Pattern created with the Fitted check box cleared
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Figure 4-27 Pattern created with the Fitted check box selected



Creating Circular Patterns
Ribbon: Sketch > Pattern > Circular Pattern Circular patterns are the

patterns created around the circumference of an imaginary circle.
To create the circular pattern, you will have to define the center of
that imaginary circle. When you invoke this tool, the Circular

Pattern dialog box will be displayed, as shown in Figure 4-28. The
options provided in this dialog box are discussed next.
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Figure 4-28 The Circular Pattern dialog box




Geometry
This button is chosen to select the entities to be patterned. As you select the
individual entities, they turn blue, indicating that they are selected.



Axis

This button is provided on the right of the Geometry button. This button is
chosen to select the center of the imaginary circle, around which the circular
pattern will be created. The points that can be used to define the center of the
pattern creation are the endpoints of lines, splines, and arcs, center points of arcs,
circles, and ellipses, and the points/hole centers. Most of the options in the
Circular Pattern dialog box are enabled only after you select the axis of
rotation. You can dynamically preview the pattern using the current values. If
you modify the other values in this dialog box, the preview of the pattern will
also be modified.

Tip. If you select an arc or a circle to define the axis of the circular pattern, its
center will be automatically selected as the center of the circular pattern.
However, this is not possible in case of an ellipse. You cannot select an ellipse to
define the center of the circular pattern. In such cases, you will have to select the
center of ellipse.



Flip

This button is provided on the right of the Axis button, and when chosen,
reverses the direction of pattern creation. By default, the circular pattern will be
created in the counterclockwise direction. If you choose this button, the circular
pattern will be created in the clockwise direction.

Tip. If the circular pattern is created through 360 degrees, you cannot notice the
difference in the change of the direction of the pattern creation from
counterclockwise to clockwise.



Count

This edit box is used to specify the number of items in the circular pattern. You
can enter a value in this edit box or choose the arrow provided on the right of
this edit box for using the predefined values or for using the Measure or Show
Dimension option. These options are the same as those discussed in the
rectangular pattern.



Angle

This edit box is used to define the angle for creating the circular pattern. You can
directly enter an angle in this edit box or use the predefined values by choosing
the arrow on the right of this edit box. You can also use the Measure or the
Show Dimensions options to define the angle. Figures 4-29 and 4-30 show the
circular patterns created using various angles.
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Figure 4-30 Circular pattern with 6 items and a 180-degree angle



More
This button is available on the lower right corner of the Circular Pattern dialog
box. When you choose this button, the Circular Pattern dialog box
expands, providing more options, see Figure 4-31. These options are discussed
next.
E S 7| Associative
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Figure 4-31 More options in the Circular Pattern dialog box



Suppress

This button is chosen to suppress the selected item from the pattern. Similar to
the rectangular pattern, when you select any item of the circular pattern, it will
change into dashed lines. Although the items that are suppressed will be
displayed in the drawing window, they will not participate in the feature
creation when you finish the sketch. However, you can unsuppress these items
later, if you need them.



Associative

This check box is selected so that all the items of the pattern are associated
with each other. All the items of the associative pattern are automatically
updated if any entity of the pattern is modified. If you clear this check box
before creating the pattern, all items will become individual entities and you
can modify them individually.



Fitted

This option works in combination with the Angle edit box. If you select this
check box, the specified number of items will be created such that the angle
specified in the Angle edit box defines the included angle between all the
items. This check box is selected by default in the Circular Pattern dialog
box. If you clear this check box, the angle that you specify in the Angle edit
box will be considered as the incremental angle between each item. Figure 4-
32 shows the pattern created by selecting this check box (included angle
between all the items) and Figure 4-33 shows the pattern created by clearing
this check box (angle is incremental).
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Figure 4-33 Pattern created with the Fitted check box cleared

Tip. If you create a circular pattern through an angle of 360 degrees and clear



the Fitted check box, you will see only one item in the drawing window. This is
because the incremental angle between the individual items is 360 degrees and
all the items will be arranged on top of each other, displaying only one copy.

WRITING TEXT IN THE SKETCHING
ENVIRONMENT AUTODESK INVENTOR ALLOWS
YOU TO WRITE TEXT IN THE SKETCHING
ENVIRONMENT. THE TEXT BEHAVES LIKE
OTHER SKETCHED ENTITIES AND CAN BE
CONVERTED INTO FEATURES USING THE
MODELING TOOLS OF AUTODESK INVENTOR.
THERE ARE TWO METHODS TO WRITE THE
TEXT. THESE METHODS ARE DISCUSSED NEXT.



Writing Regular Text

Ribbon: Sketch > Create > Text drop-down > Text To write text, choose the
Text tool from the Create panel, refer to Figure 4-34; you will be prompted
to select the location of the text. You can also drag a window to define the
text box. Specify a point in the drawing window to start the text or press
and hold the left mouse button and drag the mouse to define a window;

the Format Text dialog box will be displayed, as shown in Figure 4-35. The
options in this dialog box are discussed next.
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Figure 4-35 The Format Text dialog box






Style
This drop-down list is used to specify the text style to be applied to the text. To
apply a particular text style to the text, you need to select the corresponding

option from this drop-down list.



Bullets and Numbering in Text

The Bullet and Numbering buttons are available below the Style drop-down
list. You can create bulleted or numbered lists using these buttons. To create a
bulleted list, choose the Bullet button. Similarly, to create a numbered list click
on the down arrow next to Numbering button and select the required numbering
style from the drop-down list displayed.

Text Justification You can adjust the justification of the written text
by choosing the buttons on the right of the Numbering drop-down of
this dialog box. The justification of a text is defined using a
combination of two buttons. By default, the Left Justification and
Top Justification buttons are chosen. As a result, the justification for
the text is top left. You can select other justifications by choosing
their respective buttons. The Baseline Justification button is
activated only when you choose the Single Line Text button on the
left of Line Space drop-down list.



Spacing

You can select an option to define the spacing between the text lines using the
Line Space drop-down list. If you select the Multiple option from this drop-
down list, the Spacing Value edit box will be enabled and you can enter the

multiplication factor for the line spacing in this edit box.



Fit Text

This button is activated only when you choose the Single Line Text button and
is used to fit the text in a single line inside the window that you defined by
dragging the mouse.



Stretch
You can define the percentage of text stretching in the Stretch% edit box. The

default value in this edit box is 100. As a result, there is no stretching of the text.
If you enter a value more than 100, the text width will be increased. If you enter
a value less than 100, the width of the text will be reduced.



Font
The Font drop-down list is located below the Bullet and Numbering buttons.
You can select the font for the text using this drop-down list.



Size
The Size edit box is used to specify the height of the text. You can enter the
height in this edit box or select the standard values using the down arrow on the

right of this edit box.



Color
The default color of the text is black. You can change the color of the text by

choosing the Color button on the left of the Bold button. When you choose this
button, the Color dialog box is displayed. You can specify the color of the text

using this dialog box.



Text Style
You can define the text style by choosing the Bold, Italic, Underline, and
Strikethrough buttons on the right of the Size drop-down list.



Stack
Stack button is used to create diagonal or horizontal stacked fractions, and
superscript or subscript strings.



Text Case
This button is used to change the case of the selected string.



Text Box
If this button is chosen, a construction line box is placed around the text.



Rotation
The Reotation flyout is activated only if the Text Box button is not chosen. This
flyout is used to specify the orientation of the text.



Insert symbol

Autodesk Inventor provides you with some standard symbols that you can insert
in the text. To insert the symbols, choose the down arrow on the right of
the Insert symbeol button; the standard symbols in Autodesk Inventor are
displayed, as shown in Figure 4-36.
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Figure 4-36 Default symbols



Text Window
You can enter the text in the Text Window area available in the Format Text
dialog box. You can also paste the text copied from any other source. The text

written in this window will appear on the screen.



Note
T The remaining options in the Format Text dialog box are used in the Drawing
module and therefore, they are not discussed here.

Writing Text Aligned to a Geometry Ribbon: Sketch >
Create > Text drop-down > Geometry Text In Autodesk
Inventor, you can write a text aligned to a line, arc, or
circle. To do so, choose the arrow on the right of the Text
tool and invoke the Geometry Text tool from the Create
panel, refer to Figure 4-34; you will be prompted to select
a geometry. Select the required line, circle, or arc; the
Geometry-Text dialog box will be displayed, as shown
in Figure 4-37. Most of the options in this dialog box are
similar to the Format Text dialog box. The remaining
options are discussed next.



Geometry
You can choose this button to change the default geometry and select a new one.



Direction Area
In this area, there are two buttons, Clockwise and Counterclockwise. These
buttons are used to specify the orientation of the text.



Position Area

This area is used to specify the position of the text. Choose the Outside button to
place the text outside the geometry. Choose the Inside button to place the text
inside the geometry.
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Figure 4-37 The Geometry-Text dialog box



Start Angle
This edit box is used to specify the angle between the left quadrant point of the
selected geometry and the starting point of the text.



Offset Distance
This edit box is used to specify the offset distance between the text and the

selected geometry.

Figure 4-38 shows the text created by using the Outside and Clockwise options.
Figure 4-39 shows the text created using the Inside and Counterclockwise
options. Note that in Figure 4-39, the text is created at an offset from the circle.
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Figure 4-38 Geometry text created using the Outside and Clockwise options
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Figure 4-39 Geometry text created using the Inside, Offset Distance, and Counterclockwise options



Note
You cannot write a geometry text along an ellipse, spline, or polygon.

INSERTING IMAGES AND DOCUMENTS IN

SKETCHES Ribbon: Sketch > Insert > Insert Image The Insert Image tool

allows you to insert the external images such as JPG, BMP, PCX, TIFF, TGA,
and so on in the sketch. You can also insert Word documents or Excel
spreadsheets using this tool. To insert an image, invoke this tool; the Open

dialog box will be displayed, as shown in Figure 4-40.
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Figure 4-40 The Open dialog box

Select the image or document using this dialog box and then choose the Open
button; the dialog box will be closed and you will be prompted to select the
sketch point. The point you specify on the screen will be taken as the insertion
point for the image. After inserting the image, right-click and choose OK from
the Marking Menu to exit this tool.



Note
You may need to modify the drawing display area using the Zoom All tool to
view the image on the screen.

Tip. To modify the size of the image inserted in the sketch, drag it by holding one
of its four edges. Depending on the direction in which you drag it, the size will
increase or decrease. To rotate the image, hold it at one of the corners and drag.
The image will be rotated in the direction in which you drag the cursor. To move
the image, press and hold the left mouse button anywhere on the image and drag
the cursor.

EDITING SKETCHED ENTITIES BY DRAGGING
AUTODESK INVENTOR ALLOWS YOU TO EDIT
THE SKETCHED ENTITIES BY DRAGGING THEM.
DEPENDING ON THE TYPE OF ENTITY SELECTED
AND THE POINT OF SELECTION, THE OBJECT
WILL BE MOVED OR STRETCHED. FOR
EXAMPLE, IF YOU SELECT A CIRCLE AT ITS
CENTER AND DRAG, IT WILL BE MOVED.
HOWEVER, IF YOU SELECT THE SAME AT A
POINT ON ITS CIRCUMFERENCE, IT WILL BE
STRETCHED TO A NEW SIZE. SIMILARLY, IF YOU
SELECT A LINE AT ITS ENDPOINTS, IT WILL BE
STRETCHED AND IF YOU SELECT A LINE AT A
POINT OTHER THAN ITS ENDPOINTS, IT WILL BE
MOVED. THEREFORE, EDITING THE SKETCHED
ENTITIES BY DRAGGING IS ENTIRELY
DEPENDENT ON THE SELECTION OF POINTS. THE
TABLE GIVEN NEXT WILL GIVE YOU THE



DETAILS OF THE OPERATION THAT WILL BE
PERFORMED WHEN YOU DRAG VARIOUS
OBJECTS.



Object




Selection point




Operation




Circle




On circumference

Stretch/Shrink




Center point




Move




Arc




On circumference

Stretch/Shrink




Center point




Move




Polygon




Any of the edges




Move




Endpoints




Move




Center point

Stretch/Shrink/ Rotate




Single line

Any point other than the endpoints




Move




Endpoints

Stretch/Shrink




Rectangle




All lines selected together




Move

Any one line or any endpoint|

Stretch/Shrink




TOLERANCES

In simple words, tolerance is defined as a permissible variation from the actual
value. As it is an allowed variation, you can vary the dimension of the
component through the specified value while manufacturing.

Adding Tolerances to the Dimensions in the Sketching
Environment In Autodesk Inventor, tolerances are added
to the sketch after dimensioning it. To add tolerance to a
dimension, right-click on the dimension and choose
Dimension Properties from the Marking menu; the
Dimension Properties dialog box will be displayed. You
can use the options in the Dimension Settings tab of this
dialog box to add tolerances, refer to Figure 4-41.
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Figure 4-41 The Dimension Settings tab of the Dimension Properties dialog
box

By default, the Default option is selected in the Type drop-down list of the
Tolerance area. As a result, no tolerance is added to the dimension. To add
tolerance, select the required tolerance type from this drop-down list. Next,
specify the value of the upper and lower limits in the Upper and Lower edit
boxes. However, note that you can specify the upper and lower limits only if you
select the Deviation, Limits-Stacked, or Limits-Linear option from the Type
drop-down list. If you select any fit tolerance from this drop-down list, you can
select the values of the hole fit and the shaft fit from the Hole and Shaft drop-
down lists.

Note
While specifying tolerances for a geometry, you need to make sure that
the Dimension command is terminated.



Once you have defined all the tolerance values, choose the Apply button in the
Dimension Properties dialog box. You will notice that the tolerance is applied
to the selected dimension. Now, choose OK to exit this dialog box. Figure 4-42
shows a sketch with the tolerance applied to the dimensions.
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Figure 4-42 Sketch with the tolerance applied to the dimensions

In this figure, the vertical dimension is applied the deviation tolerance type. The
upper deviation value for this tolerance is 0.05 mm and the lower deviation value
is 0.02 mm. The horizontal dimension in the same figure is applied the
symmetric tolerance of 0.05 mm.

CONVERTING THE BASE SKETCH INTO A BASE
FEATURE AS MENTIONED EARLIER, ANY 3D
DESIGN IS A COMBINATION OF VARIOUS
SKETCHED, PLACED, AND WORK FEATURES.
THE FIRST FEATURE, GENERALLY, IS A
SKETCHED FEATURE. YOU HAVE ALREADY
LEARNED TO DRAW THE SKETCHES AND TO



DIMENSION THEM. AFTER YOU HAVE FINISHED
DRAWING AND DIMENSIONING THE SKETCH,
CHOOSE THE FINISH SKETCH BUTTON FROM
THE EXIT PANEL OF THE SKETCH TAB. ON
CHOOSING THIS BUTTON, YOU WILL EXIT THE
SKETCHING ENVIRONMENT AND ENTER THE
PART MODULE. YOU WILL ALSO NOTICE THAT
THE SKETCH TAB IS REPLACED BY THE 3D
MODEL TAB. AUTODESK INVENTOR PROVIDES
YOU WITH A NUMBER OF TOOLS SUCH AS
EXTRUDE, REVOLVE, LOFT, SWEEP, AND SO
ON TO CONVERT THESE SKETCHES INTO BASE
FEATURES. HOWEVER, IN THIS CHAPTER, YOU
WILL LEARN THE USE OF THE EXTRUDE AND
REVOLVE TOOLS FOR CONVERTING THE
SKETCH INTO A BASE FEATURE. THE
REMAINING TOOLS WILL BE DISCUSSED IN THE
LATER CHAPTERS.

Note

On exiting from the Sketching environment, the sketch will be displayed in the Isometric view. Now, if you
create any feature, you can dynamically preview the result while specifying the required options in the
respective dialog boxes.

Tip. From the Sketching environment, you can also proceed to the Part module
by using the Marking menu. To do so, right-click in the graphics window and
choose the Finish 2D Sketch option.



EXTRUDING THE SKETCH RIBBON: 3D MODEL >
CREATE > EXTRUDE THE EXTRUDE TOOL IS
ONE OF THE MOST EXTENSIVELY USED TOOLS
FOR CREATING A DESIGN. EXTRUSION IS A
PROCESS OF ADDING OR REMOVING MATERIAL
DEFINED BY A SKETCH, NORMAL TO THE
CURRENT SKETCHING PLANE. IF

YOU CREATE THE FIRST FEATURE, THE
OPTIONS AVAILABLE TO YOU WILL BE USED
FOR ADDING THE MATERIAL AND NOT

FOR REMOVING IT. THIS IS BECAUSE THERE IS
NO EXISTING FEATURE FROM WHICH YOU CAN
REMOVE THE MATERIAL. WHEN YOU INVOKE
THIS TOOL FROM THE creare PANEL IN THE rmson,
THE EXTRUDE DIALOG BOX WILL BE
DISPLAYED, AS SHOWN IN FIGURE 4-

43. ALTERNATIVELY, CHOOSE THE extruoe TOOL
FROM THE MARKING MENU THAT

IS DISPLAYED ON RIGHT-CLICKING IN THE
GRAPHICS WINDOW. IN ADDITION TO THIS
DIALOG BOX, A MINI TOOLBAR WILL

BE DISPLAYED IN THEDRAWING WINDOW. THE
MINI TOOLBAR IS A NEW

USER INTERFACE THAT PROVIDES YOU

WITH DIFFERENT OPTIONS TO CONTROL

THE EXTRUSION PROCESS. THE OPTIONS IN THIS
TOOLBAR WILL BE DISCUSSED LATER. THE



TABS IN THE EXTRUDE DIALOG BOX

ARE DISCUSSEDNEXT.
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Figure 4-43 The Extrude dialog box



Shape Tab

The options in this tab are discussed next.



Profile

This button is used to select the sketch to be extruded. If the sketch consists of a
single loop, it will be automatically selected. In this case, because the sketch is
already selected, the Profile button will not be chosen. However, if the sketch
consists of more than one loop, this button will be chosen and you will be
prompted to select the profile that you want to extrude. As you move the cursor
close to one of the loops, it will be highlighted. After you have selected the
sketch to be extruded, the preview of the resultant solid will be displayed in the
drawing window. Also, the Profile selection tag attached to the preview of the
solid feature will be displayed in the drawing window. The selection tag will be
discussed later in this chapter. Note that if you select any of the inner loops, only
that loop will be extruded. Also, after the extrusion of the selected inner loops,
the remaining loops will no more be displayed on the screen. But, if you select
the profile by specifying a point inside the outer loop but outside the inner loops,
the sketch will be extruded such that the resultant solid will have the inner loops
subtracted from the outer loop, refer to Figures 4-44 and 4-45.

Tip. To remove the closed loop that has been selected using the Profile button,
hold down SHIFT or CTRL key and then select the closed loop to be removed. As
you move the cursor close to the sketch, different loops in the sketch will be
highlighted and you can select the loop you want to remove by clicking inside
that loop.

Point of
selection

Original Resulting
sketch solid

Figure 4-44 Specifying the selection point inside the inner loop



Point of
selection

Original Resultant
sketch solid

Figure 4-45 Specifying the selection point between the inner and outer loops



Solids

The Solid button is used to select a body in a multi-body environment so that the
resultant extruded feature becomes a portion of the body. You can join, cut, or
intersect the resultant extruded feature to the selected body. This button will be
active only when there are multiple bodies in the graphics window. The
procedure to create multiple bodies will be discussed later in Chapter 5.



Output Area

The buttons in the Output area are used to specify the type of resulting feature.
If you select a closed sketch to extrude, the Solid button is chosen automatically.
As a result, a solid feature will be created. If you choose the Surface button, the
resultant feature will be a surface. Remember that the sketches for surface
models do not need to be closed loops. If you select an open sketch to extrude,
the Surface button is chosen automatically in the Extrude dialog box.



Operation Area

This area is provided on the left of the Extents area and has four buttons. As the
first feature created will be essentially a protrusion feature, no buttons except the
New solid button will be enabled in this area. However, if a feature already
exists in the drawing window and you want to extrude another sketch, the
buttons namely Join, Cut, and Intersect will be enabled. These buttons are
discussed in Chapter 5.



Extents Area

You can select the method of terminating the extruded feature using the options
in the drop-down list available in the Extents area or mini toolbar. These options
are discussed next.



Distance

By default, the Distance option is selected in this drop-down list. This option
is used to define the extrusion depth by specifying its numeric value. The
value of extrusion can be specified in the Depth edit box available below this
drop-down list. If this feature termination option is selected, four buttons will
be displayed below the Distance edit box. These buttons are used to specify
the direction of extrusion. The current direction will be displayed by the
Direction 1 button. You can reverse the direction of feature creation by
choosing the Direction 2 button. The third button is used to extrude the
feature equally in both directions of the current sketching plane. This button is
also called the Symmetric button. For example, if the specified extrusion
depth is 20 mm, the resultant feature will have extrusion depth of 10 mm
above the current sketch plane and 10 mm below the current sketch plane. In
Autodesk Inventor, you can extrude a sketch asymmetrically about the
sketching plane. You can do so by using the Asymmetric button. After
choosing this button, two edit boxes and two drop-down lists will be displayed
in the Extents area of the Extrude dialog box. Also, two arrows will be
displayed on the preview of the extruded model. Enter the required extrusion
depths in the edit boxes or drag the arrows on the sides of the sketching plane
to specify the depths of extrusion. You can interchange the extrusion depths of
feature on two sides by choosing the Flip button. You can also specify the
extrusion depth by using the mini toolbar.



Note

You can also select Measure or Show Dimensions option, or specify a
predefined distance value by choosing the arrow on the right of the Depth edit
box to specify the depth of extrusion.

Tip. You can dynamically modify the depth of asymmetric extrusion by using the
manipulators. These manipulators are displayed as arrows pointing in opposite
directions on the preview of the extrusion. Drag the required manipulator arrow
to change the extrusion depth dynamically in the corresponding direction.



To

This is the second option in the Distance drop-down list and is used to define
the termination of the extruded feature using an extended face, a work plane or
planar face. When you select this option, all other options in the Extents area
are removed and only the Select surface to end the feature creation button is
displayed. If you select a plane or a face that does not intersect the extruding
feature to terminate the extrusion, the Check to terminate feature on the
extended face check box is displayed. This check box is selected to terminate
the feature on the plane or the planar face as if it was extended.



Between

This is the third option in the Distance drop-down list. This option uses two
planes to define a feature. The first plane defines the plane from which the
feature will start and the second plane defines the plane for terminating the
feature. When you select this option, all the remaining options in the Extents
area are replaced by two buttons. The upper button is the Select surface to
start the feature creation button and is used to define the plane where the
feature starts. The lower button is the Select the surface to end the feature
creation button and is used to define the plane where the feature terminates.



Match shape
This button will be activated only when you extrude an open profile. The
procedure to create Match shape is discussed later in Chapter 5.



Note

The methods of creating work planes will be discussed in the later chapters. The
Distance drop-down list will display more options once you have created the
base feature. These options will be discussed in Chapter 5.



More Tab

The Taper option in the More tab is discussed in the next section, refer to
Figure 4-46. The remaining options will be discussed in later chapters.
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Figure 4-216 The More tab of the Extrude chialog box




Taper

This edit box is used to define the taper angle for the resulting solid model.
Taper angles are generally provided to solid models for their easy withdrawal
from the molds. A negative taper angle will force the solid to taper inwards, thus
creating a negative taper. A positive taper angle will force the resultant solid to
taper outwards, thus creating a positive taper. When you define a taper angle, an
arrow will be displayed in the preview of the solid model in the drawing
window. Depending on the positive or negative value of the taper angle, this
arrow will point inwards or outwards from the sketch. Figures 4-47 and 4-48
show the model created using the negative and positive taper angles. Figure 4-49
shows a model extruded with a positive taper angle using the Symmetric option.

Direction of
extrusion

Extruded model

Figure 4-47 Model extruded with a negative taper angle

Direction of

extrusion

Extruded mode

Figure 4-48 Model extruded with a positive taper angle



Current
sketch plane

Direction of extrusion

Model extruded with positive taper angle

Figure 4-49 Model extruded with a positive taper angle using the Symmetric
option



REVOLVING THE SKETCH

Ribbon: 3D Model > Create > Revolve The Revolve tool is used to create

circular features like shafts, couplings, pulleys, and so on. You can also use
this tool for creating cylindrical cut features.

A revolved feature is created by revolving the sketch about an axis. You can
use a normal line segment, a center line, or aconstruction line of a sketch as

the axis for revolving the sketch. On invoking this tool, the Revolve dialog
box, as shown in Figure 4-50, and a mini toolbar will be displayed in the
drawing window. This mini toolbar provides you

withdifferent options to control the revolution of sketches and will
be discussed later. The options in the Revolve dialog box are discussed next.

Revolve =2 |
shape |More
— Extents
|%‘ Profile IEI |Full—v
|E| Axis IEI
B Solids I'E'I
Qutput T
|@| I ' Match shape
|@| e | QK | | Cancel |
A

Figure 4-50 The Revolve dialog box



Shape Tab

The buttons in this tab are used to select the sketch to be revolved and the axis of
revolution. These buttons are discussed next.



Profile

This button is chosen to select the sketch to be revolved. If there is only one loop
in the drawing window, the sketch will be automatically selected. Also, the
Profile button will not be chosen. However, if there are more than one loops,
this button will be chosen and you will be prompted to select the profile to be
revolved. Also, two selection tags, Profile and Axis, will be displayed near the
profile in the drawing window. The selection tag will be discussed later in this
chapter.



Axis

This button is chosen to select the axis for revolving the sketch. As mentioned
earlier, you can select a line segment in the sketch as the axis for creating the
revolved feature. When you select the axis, the preview of the feature that is
created using the current values will be displayed in the drawing window.



Solids

The Solids button is used to select a body in a multi-body environment so that
the resultant revolved feature becomes a portion of the body. You can join, cut,
or intersect the resultant revolved feature to the selected body. This button will
be active only when there are multiple bodies in the graphic window.



Output Area

The buttons in the Output area are used to specify the type of output for the
revolved feature. If you choose the Solid button, the resulting feature will be a
solid. However, if you choose the Surface button, the resulting feature will be a
surface. The sketch for the surface may or may not be closed. But for a solid
feature, the sketch needs to be closed.



Operation Area

This area is provided on the left of the Extents area and has four buttons, namely
New solid, Join, Cut, and Intersect. As the first feature created will essentially
be a new revolved feature, no button except the New solid button will be active
in this area. However, if a feature already exists in the drawing window and you
want to extrude another sketch, all four buttons will be available. These buttons
are discussed in Chapter 5.



Extents Area

The drop-down list provided under this area is used to specify the method of
termination of a revolved feature. You can also specify the termination option by
using the mini toolbar. These options are discussed next.



Full
This option is selected to create a feature by revolving the sketch through 360-
degree. This is the default option.



Angle

This option is used to terminate the revolved feature at the specified angle.
You can specify the angle of revolution by first selecting the Angle option and
then entering the value in the edit box displayed below this drop-down list.
Alternatively, you can specify the angle in the mini toolbar. You can also use a
predefined value by choosing the arrow provided on the right side of this edit
box. You can also use the Measure and Show Dimensions options to define
the angle of revolution.

When you select the Angle option, four buttons will be displayed in this area.
These buttons are used to define the direction of rotation. You can also revolve
the sketch equally in both directions by choosing the Symmetric button.
Figures 4-51 and 4-52 show the features created by revolving the sketches
through different angles.
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Figure 4-51 Revolving the sketch through 360 degrees
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Figure 4-52 Revolving the sketch through 270 degrees



In Autodesk Inventor, you can revolve a sketch asymmetrically about the
sketching plane. You can do so by using the Asymmetric button. After
choosing this button, two edit boxes and two drop-down lists will be displayed
in the Extents area of the Revolve dialog box. Also, two arrows will be
displayed in the preview of the revolved feature. Enter the values for the
revolution angle in the edit boxes or drag the arrows on the sides of the
sketching plane to specify the angle on the respective sides. You can
interchange the angle values of the feature by choosing the Flip button. You
can also specify the revolution angle values by using the mini toolbar.



To

This is the third option in the Extents drop-down list and is used to define the
termination of the revolved feature using an extended face, a work plane, or a
planar face. When you select this option, the Select surface to end the
feature creation button will be displayed. If you select a plane or a face that
does not intersect the revolved feature to terminate revolution, the Check to
terminate feature on the extended face check box will be displayed. This
check box is selected to terminate the feature on the plane or the planar face as
if it was extended toward it.



Between

This is the fourth option in the Extents drop-down list and uses two planes to
create a revolved feature. The first plane defines the plane from which the
feature will start and the second plane defines the plane for terminating the
feature. When you select this option, the Select surface to start the feature
creation and Select surface to end the feature creation buttons are
displayed. The Select surface to start the feature creation button is used to
define the plane where the feature starts and the Select surface to end the
feature creation button is used to define the plane where the feature
terminates.

DIRECT MANIPULATION OF FEATURES BY
USING THE MINI TOOLBAR MINI TOOLBAR
ALLOWS YOU TO DIRECTLY MANIPULATE OR
MODIFY A FEATURE BY SPECIFYING VALUES OR
OPTIONS OF THE FEATURE CREATION TOOLS
SUCH AS EXTRUDE, REVOLVE, HOLE, FILLET,
CHAMEFER, FACE DRAFT, AND OTHER WORK
FEATURE TOOLS. THIS TOOLBAR IS ACTUALLY
A USER INTERFACE WITH COMBINATION OF
SELECTION TAGS, COMMAND OPTIONS, AND
MANIPULATORS. FIGURES 4-53 AND 4-54 SHOW
THE MINI TOOLBARS THAT ARE DISPLAYED ON
SELECTING THE SKETCHES FOR THE EXTRUDE
AND REVOLVE OPERATIONS, RESPECTIVELY.
DIFFERENT COMPONENTS OF THE MINI
TOOLBAR, SHOWN IN FIGURE 4-55, ARE
DISCUSSED NEXT.



Figure 4-53 Mini toolbar for the extrude feature
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Figure 4-54 Mini toolbar for the revolve feature

Command Options The options that define the
extent,direction, and value for the feature to be created
are called command options. For example, in case of
revolved feature, the extent options such as Angle, To next
face/body, To selected face/plane, Between two faces/planes, A1l Full and the
direction options such as pirectiont, Direction2, Symmetric,

and Asymmetric, select Profile, aNd Axis OpPtions are available. You
can also enter the angle of revolution in the edit box
provided in the mini toolbar. After setting these options,
choose ok to finish the creation of revolve feature or



choose cancel.

Extent Input edit box
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Figure 4-55 Components of the mini toolbar

Manipulators The manipulators appear in the form of
arrows. The manipulators for the Extrude, Revolve, and
Hole tools are represented by a straight arrow, a curved
arrow, and a sphere, respectively. With the help of these
manipulators, you can specify the extrusion depth of an
extruded feature, angle of revolution for a revolved
feature, and the location of the hole dynamically.

The function of the mini toolbar differs, based on the selection of the feature. If
you have not invoked any tool and you click on the face of a model, the mini
toolbar displays the options that can be used to create or edit sketches and edit
the feature, refer to Figure 4-56. If acommand is not active and you select an
edge, the mini toolbar will provide you with options to create a fillet or a
chamfer feature, refer to Figure 4-57. Similarly, if you select a sketch
without invoking any command, the mini toolbar displays the options to
create extruded feature, revolved feature, and hole as well as the option to edit a
sketch, refer to Figure 4-58.



Edit Extrude

— Face selected

Figure 4-56 Mini toolbar displayed on selecting a face



Note

In Autodesk Inventor, when a calculation error occurs in the active
command mode, an aerror glyph is displayed in the Graphics window, next
to the mini toolbar. If you click on the error glyph, the Autodesk Inventor
Professional message box describing the error will be displayed on the
screen. Error glyphs are commonly displayed while performing fillet,
chamfer, and shell operations.

Create Fillet

B3 1€

Edge
selected

Create Chamfer

Figure 4-57 Mini toolbar displayed on selecting an edge
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Figure 4-58 Mini toolbar displayed on selecting a sketch

ROTATING THE VIEW OF A MODEL IN 3D SPACE
AUTODESK INVENTOR PROVIDES THREE
DIFFERENT TOOLS TO ROTATE THE VIEW OF
THE MODEL. THESE TOOLS ARE DISCUSSED
NEXT.



Rotating the View of a Model Using the Orbit Ribbon:
View > Navigate > Orbit drop-down > Orbit Autodesk
Inventor provides you with an option to rotate the view of
a solid model freely in 3D space. This feature allows you
to visually maneuver the solid model and view it from
any direction. To maneuver the model, choose the Orbit
tool from the Navigate panel of the View tab, refer to
Figure 4-59. When you choose this tool, a circle will be
displayed with small lines at all four quadrant points and
a cross at the center of the circle. The circle is called the
rim, the small lines at four quadrants are called handles,
and the cross at the center is called the center point. Also,
when you invoke this tool, the shape of the cursor
changes and the new shape thus created will depend on
its current position. For example, if the cursor is inside
the rim, it will show two elliptical arrows, suggesting that
the model can be freely rotated in any direction. If you
move the cursor close to the horizontal handles, the
cursor will change to a horizontal elliptical arrow. The
methods to rotate the view of a model are discussed next.
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Figure 4-59 Tools in the Orbit drop-down



Rotating the View of a Model Freely in 3D Space To freely rotate the
view of a model, move the cursor inside the rim; the cursor will be
replaced by two elliptical arrows. Click inside the rim and then drag it
anywhere in the drawing window. The model will dynamically rotate
as you drag the cursor around the drawing window.

Rotating the View of a Model Around the Vertical Axis To rotate the
view of a model around the vertical axis, move the cursor close to one
of the horizontal handles; the cursor will be replaced by a horizontal
elliptical arrow. Next, click and drag the cursor to rotate the model
along the vertical axis.

Rotating the View of a Model Around the Horizontal Axis To rotate
the view of a model around the horizontal axis, move the cursor close
to one of the vertical handles; the cursor will be replaced by a vertical
elliptical arrow. Now, click and drag the cursor to rotate the model
along the horizontal axis.

Rotating the View Around the Axis Normal To the View To rotate the
view of a model around an axis normal to the current view, move the
cursor close to the rim; the cursor will be replaced by a circular arrow.
Now, press and hold the left mouse button down and drag the cursor;
the model will be rotated around the center point.

Figure 4-60 shows the view of a model being rotated freely in 3D space. To exit
this tool, right-click to display the Marking Menu and choose Done [ESC].



Figure 4-60 Rotating the view of a model freely in 3D space

Changing the View Using the ViewCube Autodesk Inventor
provides you with an option to change the view of a solid model freely in 3D
space using the ViewCube. A ViewCube is a 3D navigation tool, which allows
you to switch between the standard and isometric views in a single click. By
default, ViewCube remains in the inactive state, as shown in Figure 4-61. When
you move the cursor closer to the ViewCube, it gets activated, as shown in
Figure 4-62. You can control the visibility of the ViewCube by using the
Ribbon. To do so, click on the User Interface drop-down in the Windows
panel of the View tab and select /clear the ViewCube check box to view/hide the
ViewCube, refer to Figure 4-63.

Figure 4-61 Inactive ViewCube

FRONT

Figure 4-62 Active ViewCube

The faces, vertices, and the edges of the ViewCube are called clickable areas. If
you place the cursor on any clickable area of the ViewCube, they will be
highlighted. Click on the required area to orient the model such that the clicked
area and the model becomes parallel to the screen. If you press and drag the left
mouse button over the ViewCube, it will provide a visual feedback of the current
viewpoint of the model. When you right-click on the ViewCube, a shortcut menu



will be displayed, as shown in Figure 4-64. The options in this shortcut menu are
discussed next.

User | Clean
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Figure 4-63 Options in the User Interface drop-down

Go Home

[ Orthographic
Perspective

Perspective with Ortho Faces
Lock to Current Selection

Set Current Yiew as Home  #
Set Current View as 4
Reset Front

Options...

Help Topics...

Figure 4-64 The shortcut menu



Go Home
It is used to display the default view of the model. On choosing this option, you
can switch over to the home view of the model.



Orthographic

Choose this option to display the model in the orthographic view.



Perspective
Choose this option to display the model in the perspective view.



Perspective with Ortho Faces
Choose this option to display the model in the orthographic projection when one
of the faces of the ViewCube is active.



Lock to Current Selection

By default, this option remains inactive. To activate it, first you need to select
the sketch or the model. If you choose this option, the View Cube will use the
selected object as the center of the view and zoom to the extents of the selected
object.



Set Current View as Home

This option is used to set the current view as the default view. When you move
the cursor over the Set Current View as Home option, a small flyout will be
displayed. The options in this flyout are Fixed Distance and Fit to View.

Fixed Distance is used to set a Home view, which defines direction of the view
as well as extent of the model that fills the view. Fit to View is used to set a
Home view which defines direction of the view as well as extent of the model
always taken as Zoom All or view all mode.



Set Current View as
This option is used to set the current view of the model as Front or Top view

depending upon your requirement. When you move the cursor to the Set
Current View as tab, a small flyout will be displayed. You can select the
options displayed in the flyout and make your current view as Top view or Front

view.



Reset Front
This option is used to reset the front view to the default setting.



Options

Choose this option to invoke the ViewCube Options dialog box, as shown in
Figure 4-65. Alternatively, you can access this dialog box by choosing the
Application Options button from the Options panel of the Tools tab; the
Application Options dialog box will be displayed. Next, choose the Display tab
from the Application Options dialog box and then choose the ViewCube
button; the ViewCube Options dialog box will be displayed, refer to Figure 4-
65. The options in this dialog box are discussed next.

ViewCube Options =
Application Options
[/| Show the ViewCube on window create
@) All 3D Views
_ | Only in Current View
Display

Top Right | On-Screen Position
Automatic ¥ | ViewCube Size

50 % | Inactive Opadty

When Dragging on the ViewCube

/| Snap to dosest view

When Clicking on the ViewCube

|/ Fit-to-View on view change

|| Use animated transitions when switching views
|| Keep model upright

Default ViewCube Orientation
Front View Flane Top View Flane

XY (+2) - XZ(+Y) -
Document Settings

Compass
| Show the Compass below the ViewCube

0 = Angle of Morth (degressy

Figure 4-65 The ViewCube Options dialog box

Show the ViewCube on window create

By default, this check box is selected. As a result, the ViewCube will be
displayed in the graphics window. Also, two radio buttons, All 3D Views and
Only in Current View will be activated. By default, the All 3D Views radio
button is selected and is used to display the ViewCube in all views. If you



select the Only in Current View radio button, the ViewCube will be
displayed in the current view only.



Display Area

This area is used to display the on-screen position of the ViewCube, its size,
and its inactive opacity. Select the required option from the On-Screen
Position drop-down list in this area to set the position of ViewCube at any
corner of the window such as Top Right, Bottom Right, Top Left, or
Bottom Left. In this area, the default selection is Top Right.

Select the required option from the ViewCube Size drop-down list; the size of
the ViewCube will be set. You can also set the opacity of the ViewCube in the
inactive state using the Imactive Opacity drop-down list in this area. The
default selection in this drop-down is Automatic.

When Dragging on the ViewCube Area

If the Snap to closest view check box is selected in this area, the view point
will snap to one of the fixed views when the model is rotated using the
ViewCube.

When Clicking on the ViewCube Area
This area is used for setting the preferences while clicking on the ViewCube.



Default ViewCube Orientation Area

The options in this area are used to set the alignment of the front and top plane
of the ViewCube with the model-space plane, when you create a new part or

assembly from a template.

Document Settings Area This area is used to set the preference for the default
display of the Compass. If you select the Show the Compass below the
ViewCube check box, the Compass will be displayed below the ViewCube in
the graphics window, as shown in Figure 4-66. The Angle of North
(degrees)spinner is used to set the angle between the FRONT face of the
ViewCube and the N (North direction) of the Compass.
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Figure 4-66 The ViewCube with Compass



Navigating the Model

Autodesk Inventor Professional allows you to navigate the model using different
navigating tools such as Zoom, Pan, Track, and so on. Different navigating
tools in Autodesk Inventor are discussed next.

SteeringWheels The SteeringWheels are the tracking tools that are divided
into different wedges. Each wedge represents a single navigation tool such
as PAN, ORBIT, ZOOM, REWIND, LOOK, CENTER, WALK,
and UP/DOWN. You can activate any wedge of the SteeringWheels
by pressing and holding the cursor over it. The SteeringWheels travels along
with the cursor to provide a quick access to common navigation controls. To
display the SteeringWheels, choose the Full Navigation Wheel drop-down and then
choose therequired option corresponding to the SteeringWheels. Figure 4-67
shows a Steering Wheels. You can also change the type of a SteeringWheels. To do
so, right-click on the SteeringWheels; a shortcut menu will be displayed.
Different types of SteeringWheels are available in this shortcut menu. You can
choose any type of SteeringWheels by clicking on it

Figure 4-67 The Steering Wheels



Previous View
The Previous View tool in the Navigate panel of the View tab is used to view
the previous orientation of the model.



Next View

The Next View tool in the Navigate panel of the View tab is used to activate the
view that was current before you chose the Previous View tool. You can also
switch to the previous view by pressing the F5 key and to the next view, by
holding down the SHIFT key and then pressing the F5 key.

Note
The Pan and Zoom All options are the same as those discussed in Chapter 2.



CONTROLLING THE DISPLAY OF MODELS

Autodesk Inventor allows you to control the display of the models by setting
various display modes and the camera type for displaying them. You can also
control the display of the shadows of the model. The options for controlling the
display of the models are discussed next.



Setting the Visual Styles

Ribbon: View > Appearance > Visual Style drop-down Visual style of a model

determines the display of edges and face of a model in the graphics window.

You can set the visual style for the solid models by using the visual Style drop-

down provided in the Appearance panel of the View tab, refer to Figure 4-
68. Various visual styles available in this drop-down are discussed next.

CL)J C_E Shadows - Orthographic = O Ti

Visual Style [ Reflections - --Q,-t Ground Plane -

Grey Room -

2y Realistic
Realistically textured model with high quality shading

Shaded
Smooth shaded model

Shaded with Edges
Smooth shaded meodel with visible edges

Shaded with Hidden Edges
¥ Smooth shaded model with hidden edges

" Wireframe
Model edges only

(:_r:j Wireframe with Hidden Edges
[ Model edges with hidden edges shown

Wireframe with Visible Edges Only
1 Model edges with hidden edges removed

(T‘g Monochrome

Simplified monochromatic shaded model

Watercolor
_ ¥ Hand painted watercolor appearance

@ Sketch Dllustration

Hand drawn appearance
Technical HNustration
Technical shaded appearance

Figure 4-68 Tools in the Visual Style drop-down




Realistic

The realistic visual style is used to shade the faces of a model with realistic
materials. To apply this visual style, choose the Realistic tool from the

Appearance panel. In this style, the visibility of the visible and hidden edges is
turned off.



Shaded

This style is used to shade the faces of a model with standard materials and
colors. To apply this visual style, choose the Shaded tool from the Appearance
panel. In this style, the visibility of the visible and hidden edges is turned off.



Shaded with Edges
This visual style is selected by default. In this style, the model appears shaded

with all external edges clearly visible. To apply this visual style, choose the
Shaded with Edges tool from the Appearance panel. In this style, the standard
materials and colors are assigned to the model.



Shaded with Hidden Edges

This style is used to shade a model with standard materials and colors keeping
all the edges visible. To apply this visual style, choose the Shaded with Hidden
Edges tool from the Appearance panel. In this style, the visibility of both the
visible and hidden edges is turned on. The visible edges are displayed as solid
lines and the hidden edges are displayed as dashed lines.



Wireframe

This style is used to display a model in wireframe with the shading turned off.
To apply this visual style, choose the Wireframe tool from the Appearance
panel. In this style, the visibility of both the visible and hidden edges is turned
on and these edges are displayed as solid lines.



Wireframe with Hidden Edges

This style is used to display a model in wireframe with the shading turned off.
To apply this visual style, choose the Wireframe with Hidden Edges tool from
the Appearance panel. In this style, the visibility of the visible and hidden edges
is turned on. In this style, all visible edges are displayed as solid lines, and all the
hidden edges are displayed as dashed lines.



Wireframe with Visible Edges Only

This style is used to display a model in wireframe with the shading turned off.
To apply this visual style, choose the Wireframe Visible Edges Only tool from
the Appearance panel. In this style, the visibility of visible edges is turned on,
and the visibility of hidden edges is turned off.



Monochrome

This style is used to give the model a simple monochromatic appearance. To
apply this visual style, choose the Monochrome tool from the Appearance
panel. In this style, the visibility of both the visible and hidden edges is turned
off.



Watercolor

This style is used to give the visible components of a model a watercolor
appearance. To apply this visual style, choose the Watercolor tool from the
Appearance panel. In this style, the model appears to be hand-painted with
water color. Also, the visibility of both the visible and hidden edges is turned
off.



Sketch Illustration

This style is used to give the visible components of the model a hand drawn
appearance. To apply this visual style, choose the Sketch Illustration tool from
the Appearance panel. The visibility of the visible and hidden edges is turned

off in this style.



Technical Illustration

This style is used to give the visible components of a model a shaded technical
drawing apppearance. To apply this visual style, choose the Technical
Illustration tool from the Appearance panel. The visibility of the visible and
hidden edges is turned off in this style.



Setting the Shadow Options

Ribbon: View > Appearance > Shadows drop-down In Autodesk Inventor,

you can make your design look realistic by casting the shadows of ebjects.
By default, the shadow option is turned off. You can cast three types of
shadows. You can use the Shadows drop-down in the Appearance panel to
cast different types of shadows, refer to Figure 4-69. The three types of

shadows are discussed next.
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Figure 4-69 Options in the Shadows drop-down




Ground Shadow

A ground shadow is a flat shadow appearing below the model. To cast a flat
shadow, select the Ground Shadow check box from the Shadows drop-down in
the Appearance panel; the shadow of the model will appear below it, as shown
in Figure 4-70.



Object Shadows

The object shadows, also known as self shadows, are those that cast on the
object itself. These shadows depend on the shape of the object and the lighting
arrangement surrounding it. To cast an object shadow, select the Object
Shadows check box from the Shadows drop-down in the Appearance panel;
the object shadow of the model will be cast, as shown in Figure 4-71.

Figure 4-70 Model with the ground shadow

Figure 4-71 Model with the object shadows

Ambient Shadows The ambient shadows are those that are cast on the
transition regions of the model such as cavities, grooves, and corners.
These shadows are significant for enhancing the visual display of
these transition regions. To cast the ambient shadow, select the
Ambient Shadows check box from the Shadows drop-down in the
Appearance panel.



All Shadows

You can have an object with all above mentioned shadows cast on it. To do so,
you need to select the All Shadows check box from the Shadows drop-down in
the Appearance panel.



Note
You can cast shadows only below the model and not on any other plane. The
distance of the shadow from the model gets modified as you zoom the model.

Setting the Camera Type By default, the models are
displayed in the orthographic camera type. You can
change the camera type from the default orthographic to
the perspective camera. This is done by choosing the
Perspective tool from the Appearance panel of the View
tab. On doing so, the model will be displayed in the
perspective camera. Figure 4-72 shows the view of the
model when the perspective camera is on.

Figure 4-72 Displaying a model in the perspective camera



CREATING FREEFORM SHAPES

The Solid primitives freeform shapes form the basic building blocks of a
complex solid. In Autodesk Inventor 2016, you can directly create the primitive
freeform shapes such as Box, Plane, Cylinder, Sphere, Torus, and Quadball. The
procedure of creating various freeform shapes is discussed next.



Creating a Box

Ribbon: 3D Model > Create Freeform > Create Freeform drop-down > Box
You can create a box primitive by using the Box tool. To do so, invoke the
Box tool from the Freeform drop-down in the Create Freeform panel of the
3D Model tab, refer to Figure 4-73; the Box dialog box will be displayed and

you will be prompted to select a plane. Select a plane from the Browser
Bar or from the Graphics window; you will be prompted to specify the
center of the box. Specify the center point; the preview of the box feature
with distance manipulator arrows will be displayed, as shown in Figure 4-
74. Specify the length, width, and height parameters for creating a box

primitive in the Box dialog box. You can also specify number of face
divisions along the width, length, and height in their respective edit fields of

the Box dialog box. After specifying the required values, choose the OK
button; the box will be created. By using the buttons in the Direction area of
the dialog box, you can specify the direction in which the box will be
created. By default, Single Direction button is activated. As a result, the box

will be created on one side of the sketching plane. On activating the Both
Directions button, the box will be created symmetrically on both side of the
sketching plane.

Note that the Length Symmetry, Width Symmetry, and Height Symmetry
check boxes are used to apply the symmetry condition along the length, width,
and height of the model.

Figure 4-73 Options available in the Freeform drop-down



Figure 4-74 The Extrude Distance Manipulator displayed after the center point
is specified

Creating a Plane Ribbon: 3D Model > Create Freeform > Freeform drop-down
> Plane To create a plane primitive on an origin plane, a work plane, or a planar
face, choose the Plane tool from the Freeform drop-down in the Create
Freeform panel of the 3D Model tab; the Plane dialog box will be displayed
and you will be prompted to select a plane. Select a plane from the Browser Bar
or from the graphics window; you will be prompted to specify the center of the
plane. Specify the center of the plane; the preview of the plane with manipulator
arrows will be displayed in the graphics window. In the dialog box, specify the
length and width of the plane in the Length and Width edit boxes, respectively
and choose the OK button; the freeform plane will be created, as shown in
Figure 4-75. The remaining options are the same as discussed while creating
freeform box feature.

Figure 4-75 The plane created after specifying the centre point



Note that the Length Symmetry and Width Symmetry check boxes are used to
apply the symmetry condition along the length and width of the model,
respectively.

Creating a Cylinder Ribbon: 3D Model > Create Freeform > Freeform drop-

down > Cylinder To create a cylindrical primitive, choose the Cylinder tool from

the Freeform drop-down in the Create Freeform panel of the 3D Model tab; the Cylinder dialog box will
be displayed and you will be prompted to select a plane. Select a plane from the Browser Bar or from the
Graphics window; you will be prompted to specify the center of the cylinder by clicking the left mouse
button. Specify the center of the cylinder by clicking the left mouse button, the preview of the cylinder with
Manipulator arrows will be displayed. In the dialog box, specify the radius and height of the cylinder in the
Radius and Height edit boxes, respectively and choose the OK button; the freeform cylinder will be created,
as shown in Figure 4-76. The remaining options are the same as discussed while creating box freeform
feature.

Figure 4-76 The freeform cylindrical feature

Note that the X Symmetry, Y Symmetry, and Z Symmetry check boxes are
used to apply the symmetry condition in the X, Y, and Z axis directions,
respectively.



Creating a Sphere
Ribbon: 3D Model > Create Freeform > Freeform drop-down > Sphere To

create a spherical shaped freeform, choose the Sphere tool from
the Freeform drop-down in the Create Freeform panel of the 3D Model tab;

the Sphere dialog box will be displayed. Also, you will be prompted to select
a plane. Select a plane from the Browser Bar or from the Graphics window; you

will be prompted to specify the center of the sphere. Specify the center of
the sphere by clicking the left mouse button; the preview of the sphere will
be displayed. In the Sphere dialog box, specify the radius of the sphere.
Also, you can specify number of face divisions along the I.ongitude and
Latitude directions in their respective edit fields of the dialog box. Next,
choose the OK button; the freeform sphere will be created, as shown in

Figure 4-77.

Figure 4-77 The freeform sphere feature

Note that the X Symmetry, Y Symmetry, and Z Symmetry check boxes are
used to apply the symmetry condition in the X, Y, and Z directions, respectively.



Creating a Torus

Ribbon: 3D Model > Create Freeform > Freeform drop-down > Torus To
create a torus in Autodesk Inventor, choose the Torus tool from the
Freeform drop-down of the Create Freeform panel of the 3D Model tab; the

Torus dialog box will be displayed, refer to Figure 4-78. Also, you will be
prompted to select a plane. Select a plane from the Browser Bar or from the
Graphics window; you will be prompted to specify the center of the torus.

Specify the center of the torus; the preview of the torus will be displayed. In
the Torus dialog box, specify the radius and the ring of the torus in their

respective edit boxes. Next, choose the OK button; the freeform torus
feature will be created, refer to Figure 4-79.
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Figure 4-78 The Torus dialog box

Figure 4-79 The freeform torus feature

Note that the X Symmetry, Y Symmetry, and Z Symmetry check boxes are
used to apply the symmetry condition in the X, Y, and Z directions respectively.



Creating a Quadball
Ribbon: 3D Model > Create Freeform > Freeform drop-down > Quadball To

create a spherical shaped freeform

Figure 4-80 The freeform quadball feature

quadball, choose the Quadball tool from the Freeform drop-down in the Create
Freeform panel of the 3D Model tab; the Quadball dialog box will be
displayed; you will be prompted to select a plane. Select a plane from
the Browser Bar or from the Graphics window; you will be prompted to specify
the center of quadball. Specify the center point; the preview of the quadball will
be displayed. In the Quadball dialog box, specify the radius and the faces for the
quadball in their respective edit boxes. Next, choose the OK button; the freeform
quadball feature will be created, refer to Figure 4-80.

Note that the X Symmetry, Y Symmetry, and Z Symmetry check boxes are
used to apply the symmetry conditions in the X, Y, and Z directions,
respectively.



TUTORIALS
Tutorial 1

In this tutorial, you will open the sketch drawn in Tutorial 1 of Chapter 3. You

will then convert this sketch into a solid model by extruding it to a distance of 20

mm. After creating the solid model, you will rotate its view in 3D space by using

the SteeringWheels. (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Save the sketch from the c03 folder to the c04 folder with another name.

b. Open the sketch from the c04 folder and extrude it to a distance of 20 mm
using the Extrude tool.

c. Change the material of the model by using the Color Override drop-down list
from the Quick Access Toolbar.

d. Rotate the model in 3D space using the SteeringWheels tool.

Opening the Sketch Drawn in Chapter 3

1. Start Autodesk Inventor by double-clicking on its shortcut icon on the desktop
of your computer or by using the Start menu. Next, choose the Open tool
from the Launch panel of the Get Started tab; the Open dialog box is
displayed.

2. Open the c03 folder from the location C:\Inventor_2016 and then open the
Tutoriall.ipt file.

When you open an existing part drawing, by default, you get into the Part
module even if the drawing is just a sketch. Also, the sketch is displayed in the
isometric view, see Figure 4-81.
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Figure 4-81 Sketch displayed in the isometric view

Saving the Sketch with Another Name After opening the sketch, you
need to first save it with another name so that the original sketch
drawn in Chapter 3 is not modified. To do so, make sure you save a
copy of the file with a different name in c04 folder.

1. Choose Save As > Save As from the Application Menu; the Save As dialog
box is displayed.

2. Browse to the location C:\Inventor_2016\c04 in the Save in drop-down list.

3. Save the sketch with the name Tutoriall.ipt.

Tip. If you have not created a folder with the name c04, you can create it by
using the Save Copy As dialog box. To do so, select the Inventor_2016 folder
from the Save in drop-down list. Next, choose the Create New Folder button and
specify c04 as the name of the folder.



Extruding the Sketch

As mentioned earlier, when you open an existing part file, you are by default, in
the part modeling environment and the sketch is displayed in the isometric
view. Sometimes, when you open an existing sketch, the dimensions of the
sketch are not displayed in the current view. In such a case, use the Zoom All
tool to increase the drawing display area so that all the dimensions are
displayed in the current view. As you are in the part modeling environment, all
tools of this module are available in the 3D Model tab.

1. Choose the Extrude tool from the Create panel of the 3D Model tab to
invoke the Extrude dialog box. Alternatively, choose the Create Extrude
tool from the mini toolbar, which is displayed when you select any sketched
entity in the graphics window.

As the sketch consists of two loops, the sketch is not automatically selected.
Therefore, the Profile button in the Shape tab gets activated and you are
prompted to select the profile to be extruded. Also, the Profile selection tag is
displayed in the mini toolbar in the graphics window. The mini toolbar also
provides you with various options to browse through and make the work easier
for you. It comprises almost all commands that are displayed in the Extrude
dialog box.

2. Move the cursor outside the inner loop but inside the outer loop; the profile is
highlighted, as shown in Figure 4-82.

As shown in Figure 4-82, the area inside the inner loop is not highlighted. This
shows that the selected profile, when extruded, will have a cavity at the center.
This cavity is defined by the inner loop.

3. Click anywhere in the highlighted area, refer to Figure 4-82; the preview of
the extruded model along with the mini toolbar interface is displayed in the
drawing window.

4. Enter 20 in the Depth edit box available in the Extents area. Alternatively,
enter 20 in the input edit box of the mini toolbar. You can also drag the
extrude manipulator to specify the extrusion depth.



5. Choose OK from the dialog box to create the model and exit the Extrude
tool. Alternatively, choose OK from the mini toolbar. The extruded model is
shown in Figure 4-83.

Figure 4-82 Selecting the profile to be extruded

Figure 4-83 The model created on extruding the profile

Changing the Material of the Model
After extruding the sketch, you need to change the material of the extruded part.

1. Click on the down arrow on the right of the Material option in the Quick
Access Toolbar; a drop-down list is displayed.

2. Select the Brass, Soft Yellow option from this drop-down list; the material of

the extruded model changes to metallic brass. Also, the color of the model gets
changed in the graphics window.

Rotating the View of the Model in 3D Space 1. Choose the Full



Navigation Wheel tool from the Navigation Bar or from the
Navigate panel of the View tab; the SteeringWheel is attached to the
cursor.

2. Move the cursor over the model and then move it inside the Zoom wedge, as
shown in Figure 4-84.

Figure 4-84 Zooming the model freely in 3D space

3. Press and hold the left mouse button; the Zoom tool is activated. Next, drag
the cursor front and back to zoom the model in or out.

4. After releasing the left mouse button, move the cursor inside the ORBIT
wedge and press and hold the left mouse button; the Orbit tool is activated.
Now, as you drag the cursor, the model rotates about the PIVOT point
displayed in green color in the Graphics window.

5. Move the cursor inside the PAN wedge and press and hold the left mouse
button; the Pan tool is activated. Drag the cursor; the model moves along with
the cursor.

6. Move the cursor inside the REWIND wedge and press and hold the left
mouse button; the previous views are displayed in small boxes in a row. Drag
the cursor along the row and select a view.



7. Move the cursor over the model and then move it inside the CENTER wedge.
Next, press and hold the left mouse button on the CENTER wedge; a pivot is
attached to the model. Release the left mouse button; the pivot is moved to the
center of the drawing area.

8. Click on the cross mark at the top right corner of the SteeringWheels to exit
this tool. Alternatively, right-click to display the shortcut menu and choose
Close Wheel from the shortcut menu to exit this tool.

9. Again, right-click and choose Home View from the shortcut menu; the current
view is changed to the isometric view.



Saving the Model

1. Choose Save > Save from the Application Menu to save the changes made to
the model. As the file is already saved once, the Save As dialog box is not
displayed.

2. Choose Close > Close from the Application Menu to close this file.

Tutorial 2

In this tutorial, you will open the sketch drawn in Tutorial 2 of Chapter 3 and

then convert it into a fully revolved model. Next, you will change the projection

type to perspective and then view the model. (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Open the sketch in Tutorial? from the c03 folder and save it in the c04 folder.

b. Open the sketch from the c04 folder and revolve it through an angle of 360
degrees by using the Revolve tool.

c. Change the projection type and view the model.

Opening the Sketch Drawn in Chapter 2
1. Choose Open from the Application Menu to display the Open dialog box.

2. Using the Open dialog box, open the Tutorial.ipt file from the location
C:\Inventor_2016\c03; the sketch is displayed in the Part module in the
isometric view.

Saving the Sketch with Another Name 1. Choose Save As > Save As
from the Application Menu; the Save As dialog box is displayed.

2. Browse to the location C:\Inventor_2016\c04 and save the sketch with the
name Tutorial2.

Sometimes, the dimensions of the sketch are not be displayed completely in the
current drawing display area. In such a case, you can increase the drawing
display area using the Zoom All and Pan tools to fit the dimensions in the
current view, refer to Figure 4-85.



B50@60

%

g20 *7|
@32

[~

Figure 4-85 Sketch in the isometric view after zooming and panning




Revolving the Sketch
As mentioned earlier, you need an axis of revolution to revolve a profile. This
axis can be a sketched line segment.

1. Choose the Revolve tool from the Create panel to display the Revolve dialog
box.Alternatively, choose the Revolve tool from the mini toolbar that is
displayed on selecting any of the sketched entities in the graphics window.
Since the sketch has just one loop, therefore it is automatically selected and
highlighted. Also, the Axis button is activated and you are prompted to select
the axis.

2. Select the bottom horizontal line that measures 22 mm as the axis of
revolution.

When you move the cursor close to this line, it is highlighted. On selecting this
line, the preview of the revolved model is displayed in the drawing window.
Also, the mini toolbar with the Full option selected in the Extents drop-down
list is displayed in the drawing window.

3. Accept the default values and choose OK from the mini toolbar to complete
the process of creating the revolved model.

Changing the View of the Model
The current view, in which the model is displayed, does not show the model
properly. Therefore, you will have to change the view of the model.

1. In case, the ViewCube is hidden, select the ViewCube check box from the
User Interface drop-down in the Windows panel of the View tab.

2. To view the component from another direction, click on the top-most corner
of the ViewCube, as shown in Figure 4-86.

3. Press and hold the left mouse button on any face of the ViewCube and drag
the cursor. As the cursor moves, the model also reorients to give you a better
view of the model.

4. Choose the Zoom All tool from the Navigate panel of the View tab or from
the Navigation Bar to modify the drawing display area.






Changing the Camera Type

By default, the orthographic camera type is selected to display the model and
therefore the orthographic view of the model is displayed. However, in this
tutorial, you need to display the model in perspective camera or view.

1. Choose the Perspective tool from the Appearance panel in the View tab; the
perspective view of the model is displayed, refer to Figure 4-87.

Figure 4-86 Selecting the corner of the ViewCube

Figure 4-87 Model displayed using the perspective projection



Saving the Model
1. Choose Save > Save from the Application Menu to save the model.

2. Now, choose Close > Close from the Application Menu to close this file.

Tutorial 3

In this tutorial, you will create the model shown in Figure 4-88. Its dimensions
are shown in Figure 4-89. The extrusion height for the model is 10 mm. After
extruding it, you will set the option to cast the X-ray ground shadow. (Expected
time: 45 min)

Figure 4-88 Model for Tutorial 3
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Figure 4-89 Dimensions of the model

The following steps are required to complete this tutorial:
a. Start a new metric standard part file. Draw the sketch of the outer loop and
add constraints to it.



b. Draw the inner circles and add the required constraints. Dimension the
complete sketch.

c. Extrude the sketch to a distance of 10 mm using the Extrude tool.

d. Cast the object and ambient shadows on the final model.



Starting a New Part File

If you have installed Autodesk Inventor with millimeter as the unit of
measurement, you can directly start a new metric standard part file, thus
avoiding the use of the Create New File dialog box for opening a new part
file.

1. Choose the New tool from the Quick Access Toolbar; a flyout is displayed.

2. Choose the Part option from this flyout to start a new metric part file. If
Autodesk Inventor was not installed with millimeter as the measurement unit,
you need to choose the Metric tab of the Create New File dialog box to start
the new metric standard part file.

Note

You can change the units used in Inventor file by using the Document
Settings dialog box.To invoke this dialog box, choose the Document
Settings tool from the Options panel in the Tools tab. Next, choose the Units tab
in this dialog box to display various options related to units. Select the required
unit from the Length drop-down list in the Units area of this dialog box. Next,
choose Apply and then Close to exit the dialog box.



Y
Creating the Sketch of the Model

As shown in Figure 4-89, the sketch is a combination of an outer loop and three
circles. First, you will create the outer loop. This outer loop will be created by
drawing three circles, two at the ends and one at the center, and then
connecting the middle circle with the other two circles through tangent lines.
Finally, you will trim the unwanted portions of the circles.

1. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select a
sketching plane.

2. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

3. Now, select the XY plane from the Browser Bar as the sketching plane; the
Sketching environment is invoked and the XY plane becomes parallel to the
screen. Alternatively, you can also select XY plane from the Graphics
window.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout .

4. Draw the sketch, which is a combination of three circles and tangent lines.
Add the Tangent constraint to the lines wherever it is missing. Also, add the
Equal constraint to all four lines, and the circles on the left and right sides.
Finally, add the Horizontal constraint to the centers of the circles. The sketch,
after drawing and adding constraints, should look similar to the one shown in
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Figure 4-90 Sketch after drawing and adding constraints




Next, you need to remove the unwanted portions of the circles using the Trim
tool.

5. Choose the Trim tool from the Modify panel of the Sketch tab; you are
prompted to select the portion of the curves to be trimmed.

6. Move the cursor close to the right half of the left circle.

As you move the cursor close to the circle, the color of the circle turns white and
it appears as dashed on the right side.

7. Specify a point on the right half of the left circle; the right half of this circle is
trimmed. Similarly, select portions of the other circles to trim, as shown in
Figure 4-91.

8. Next, draw three circles concentric to the three trimmed arcs. Add the Equal
constraint between the left and right circles. The sketch after drawing the
circles and applying the Equal constraint to them should look similar to the
one shown in Figure 4-92.

Portions selected
to be trimmed

Figure 4-91 Selecting the portions to be trimmed
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Figure 4-92 Sketch after creating the outer loop and the three circles




Dimensioning the Sketch
1. Dimension the sketch as required. The sketch, after it has been dimensioned,
will look similar to the one shown in Figure 4-93.
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Figure 4-93 Sketch after adding dimensions



Extruding the Sketch

The sketch consists of four loops: the outer loop and the three circles. When you
extrude this sketch, the three circles will be automatically subtracted from the
outer loop. As a result, you will get the required model. However, this is
possible only if the point specified for selecting the profile is inside the outer
loop but outside all three circles.

1. Choose the Finish Sketch button from the Exit panel of the Sketch tab to exit
the sketching environment. Alternatively, choose the Finish 2D Sketch option
from the Marking Menu that is displayed on right-clicking anywhere in the
graphics window. You will notice that the current view is changed to the
Home view.

2. Choose the Extrude tool from the Create panel of the 3D Model tab; the
Extrude dialog box is invoked. You can also invoke the Create Extrude tool
from the mini toolbar, which is displayed when you select the sketched entity.
As the sketch consists of more than one loop, the Profile button is chosen in
the Shape tab of the Extrude dialog box and you are prompted to select the
profile to be extruded.

3. Move the cursor to a point anywhere inside the outer loop but outside all three
circles; the profile is selected and highlighted. Notice that the area inside any
of these circles is not shaded. This shows that the area inside these circles will
not be extruded. This is also one of the methods to cross check whether the
profile selected is the one you need to extrude or not.

4. Click inside the shaded profile; the preview of the model is displayed in the
drawing window. Also, the mini toolbar is displayed in the drawing window.

5. Accept the default values and then choose OK from the mini toolbar to
extrude the profile to a depth of 10 mm.

You may need to change the camera type from perspective to orthographic if the
camera type currently used is perspective. To change the camera type, choose
the Orthographic button from the Appearance panel of the View tab. The
final model is shown in Figure 4-94.



Casting the Object Shadow and the Ambient Shadow Next, you need
to apply the object shadow and ambient shadow to the model. You
can cast these shadows using the options in the Shadows drop-down
list in the Appearance panel of the View tab.

1. Click on the down arrow on right of Shadows in the Appearance panel; a
drop-down is displayed.

2. In this drop-down, the Ambient Shadows check box is selected by default.
Select the Object Shadows check box from the drop-down; the object and
ambient shadows are cast on the model, as shown in Figure 4-95.



Saving the Model
1. Choose the Save tool from the Quick Access Toolbar; the Save As dialog
box is displayed.

2. Save the model with the name Tutorial3 at the location given below:
C:\Inventor_2016\c04

3. Choose Close > Close from the Application Menu to close the file.

Figure 4-94 Final model for Tutorial 3

Figure 4-95 Object and ambient shadows applied on the model

Tutorial 4

In this tutorial, you will extrude the text and then change the visual style of the
extruded text, as shown in Figure 4-96. The font size of the text is 5 mm and the
height of extrusion of the text is 2.5 mm. (Expected time: 45 min)



Figure 4-96 Extruded text with the hand drawn appearance

The following steps are required to complete this tutorial:

a. Start a new metric standard part file and write the text in the sketching
environment.

b. Extrude the text to a distance of 2.5 mm using the Extrude tool.

c. Change the visual style of the extruded text.

Starting a New File and Writing the Text 1. Start a new metric
standard part file using the Metric tab of the Create New File dialog
box. Also, ensure that the display of the shadow is turned off.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

3. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

4. Now, select the XY plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the XY plane becomes parallel to the
screen. Alternatively, you can also select the XY plane from the Graphics
window.

Note If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the



ViewCube; a flyout is displayed. Next, choose Set Current View
as > Top/Front from the flyout.

If

5. Choose the Text tool from the Create panel of the Sketch tab; you are
prompted to click on the location of the text.

6. Specify a point anywhere in the drawing window; the Format Text dialog
box is displayed.

7. Select the Arial font from the Font drop-down list and then set the font height
to 5 mm in the Size edit box.

8. Type the text Autodesk Inventor in the Text Window in two lines. Choose
OK to exit the dialog box; the typed text is displayed in the drawing window,
as shown in Figure 4-97.

Extruding the Text Next, you need to exit the sketching environment
and extrude the text.

1. Choose the Finish Sketch button from the Exit panel of the Sketch tab and
exit the sketching environment. Alternatively, choose the Sketch option from
the Marking Menu that is displayed when you right-click anywhere in the
graphics window. Note that the current view is changed to the home or
isometric view.

Note
The Finish Sketch button will not be available if you have already exited the
sketching environment.

2. Choose the Extrude tool from the Create panel of the 3D Model tab; the
Extrude dialog box is invoked and the mini toolbar is displayed in the
drawing window. Also, you are prompted to select the profile to extrude.

3. Move the cursor over the text and select it when it is highlighted.



4. Specify 2.5 as the extrusion depth in the input edit box of the mini toolbar.
Choose OK from the mini toolbar; the text is extruded to a distance of 2.5
mm, refer to Figure 4-98.



Changing the Visual Style

After extruding the text, you need to change its visual style.

1. Click the Visual Style in the Appearance panel of the View tab; a drop-down
is displayed.

Figure 4-98 Text after extrusion

2. Choose the Sketch Illustration tool from this drop-down to give the extruded
text a hand-drawn appearance. The final extruded text with the hand-drawn
appearance is shown in Figure 4-98.



Figure 4-99 Text after changing the visual style



Saving the Sketch
1. Choose the Save tool from the Quick Access Toolbar; the Save As dialog
box is displayed. Save the model with the name Tutorial4 at the location given

below:
C:\Inventor_2016\c04

2. Choose Close > Close from the Application Menu to close the file.

Self-Evaluation Test Answer the following questions and
then compare them to those given at the end of this
chapter:

1. The tool is used to switch between the different standard views in
a single click.

2. In the shortcut menu, you need to clear the option if you want to
select only one entity from a closed loop for offsetting.

3. To create a copy of an existing sketched entity by rotating it, select the
check box in the Rotate dialog box.

4. Autodesk Inventor is used to create two types of sketch patterns, namely
and

5. The option is used to select a line segment whose length will
define the distance between the individual items.

6. The angles are generally provided to solid models so that the
models can be easily taken out from the casting.

7. If the button is chosen in the Extrude dialog box, the resulting
feature will be a surface and not a solid.

8. In Autodesk Inventor, you cannot reduce the length of a line once it is drawn.
(T/F)

9. The copies of the sketched entities can be arranged along the length and width
of an imaginary rectangle using the Circular Pattern tool. (T/F)



10. When you select a profile by using a point that is inside the outer loop but
outside the inner loops, the resultant solid will have the inner closed loops
subtracted from the outer closed loop. (T/F)

Review Questions Answer the following questions: 1.
Which of the following tools can be used to reposition the
sketched entity from one place to another place by using
two points?

(a) Move (b) Rotate (c) Mirror (d) Extend
2. Which of the following tools can be used to arrange multiple copies of
sketched entities around an imaginary circle?

(a) Move (b) Rotate (c) Rectangular Pattern (d) Circular Pattern

3. Which of the following options allows you to use an existing dimension to
define the distance between individual items of a pattern?

(a) Dimension (b) Show Dimensions (c) Measure (d) None of these
4. Which of the following check boxes should be selected to ensure that all items
in the pattern are automatically updated, if any one of the entities is modified?

(a) Associative (b) Fitted (c) Suppress (d) None of these
5. Which of the following options in the ViewCube shortcut menu is used to the
display the home view of the model?

(a) Go Home (b) Reset Front (c) Options (d) Orthographic

6. You can invoke the Trim tool from within the Extend tool by pressing the
SHIFT key. (I/F)

7. Offsetting is one of the easiest methods of drawing parallel lines or concentric
arcs and circles. (T/F)

8. If you select a circle by clicking on a point on its circumference and then drag
it, the circle will move from its location. (T/F)

9. Selecting a line at its endpoint and dragging it will stretch the line. (T/F)

10. You can move a rectangle by selecting and then dragging it. (T/F)

EXxercises



Exercise 1
In this exercise, you will extrude the sketch drawn in Exercise 5 of Chapter 3,

refer to Figure 4-100. The extrusion depth for the model is 15 mm. (Expected
time: 30 min)
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Figure 4-100 Sketch for Exercise 1
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Exercise 2

In this exercise, you will extrude the sketch drawn in Exercise 1 of Chapter 3,
refer to Figure 4-101. The extrusion depth for the model is 80 mm. (Expected
time: 30 min)
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Figure 4-101 Sketch for Exercise 2
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Exercise 3

In this exercise, you will extrude the sketch drawn in Exercise 3 of Chapter 2,
refer to Figure 4-102. The extrusion depth for the model is 40 mm.
(Expected time: 30 min)
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Figure 4-102 Sketch for Exercise 3

Exercise 4

In this exercise, you will extrude the sketch drawn in Exercise 3 of Chapter 3,
refer to Figure 4-103. The extrusion depth for the model is 35 mm. (Expected



time: 30 min)
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Figure 4-103 Sketch for Exercise 4

Exercise 5

In this exercise, you will extrude the sketch drawn in Exercise 4 of Chapter 3,
refer to Figure 4-104. The extrusion depth for the model is 65 mm. (Expected
time: 30 min)
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Figure 4-104 Sketch for Exercise 5



Exercise 6

In this exercise, you will extrude the sketch drawn in Exercise 4 of Chapter 2,
see Figure 4-105. The extrusion depth for the model is 30 mm. (Expected time:
30 min)
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Figure 4-105 Sketch for Exercise 6

Exercise 7

In this exercise, you will extrude the sketch, as shown in Figure 4-106. The
extrusion depth for the model is 30 mm. (Expected time: 30 min)



Figure 4-106 Sketch for Exercise 7

Answers to Self-Evaluation Test 1. ViewCube, 2. Loop Select, 3. Copy, 4.
Rectangular, Circular, 5. Measure, 6. taper, 7. Surface, 8. F, 9. F, 10. T









Chapter 5

Other Sketching and Modeling Options

Learning Objectives

* Create features on planes other than the default XY plane.
* Create work features such as work planes, work axes, and work points.
* Use other extrusion and revolution options for creating models.






NEED FOR OTHER SKETCHING PLANES

In the earlier chapters, you created basic models by extruding or revolving the
sketches. All those models were created on a single sketching plane, either XY,
YZ, or XZ plane. But most mechanical designs consist of multiple sketched
features, referenced geometries, and placed features. These features are
integrated together to complete a model. Most of these features lie on different
planes. When you start a new Autodesk Inventor part file and try to invoke a
sketching plane, you are prompted to select the plane on which you want to draw
the sketch. On the basis of design requirements, you can select any plane to
create the base feature. To create additional sketched features, you need to select
an existing plane or a planar surface, or you need to create a plane that will be
used as a sketching plane. For example, consider the model shown in Figure 5-1.

N

Figure 5-1 Model created by combining various features

The base feature for this model is shown in Figure 5-2. The sketch for the base
feature is drawn on the XY plane. As mentioned earlier, after creating the base
feature, you need to create other sketched features, placed features, and work
features, refer to Figure 5-3. The extrude features shown in Figure 5-3 require
additional sketching planes on which the sketch for the other features will be
created.

It is evident from Figure 5-3 that the additional features created on the base
feature do not lie on the same sketching plane. They are created by defining
additional sketching planes. Also, appropriate extrusion options are selected at
the time of creating these features.



Figure 5-2 Base feature for the model
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Figure 5-3 Model after adding other features

Note

When you define a new sketching plane to draw the sketch for the next feature,
by default the sketching environment will be invoked and the selected sketching
plane will become parallel to the screen. This is because the Look at sketch
plane on sketch creation and edit check box is selected by default under
the Sketch tab of the Application Options dialog box. This dialog box will be
displayed on choosing the Application Options button from theOptions panel of
the Tools tab in the Ribbon.

If the Look at sketch plane on sketch creation and edit check box is cleared
then on invoking the sketching environment, the orientation of the model will
remain same as it was before invoking the Sketching environment. In this case
before proceeding further, you need to orient the sketching plane parallel to



your screen. You can do so by choosing the Look At tool from
the Navigate panel. This tool is used to reorient the view using an existing plane
or sketched entity. On invoking this tool, you will be prompted to select the entity
to look at. Select the new sketching plane or an entity; the view will be changed

to the plane view of the selected plane. You can also use the ViewCube to orient
the sketching plane.



WORK FEATURES

Work features are parametric features that are associated with a model.

Autodesk Inventor has provided three types of work features to assist you in creating a design. The three
types of work features are:

* Work Planes
» Work Axes
» Work Points
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Figure 5-4 The Plane drop-down showing various tools for creating work
planes

The methods of creating these work features are discussed next.






Creating Work Planes

Ribbon: 3D Model > Work Features >Plane drop-down

Work planes are similar to sketching planes and are used to draw sketches of
sketched features or create placed features like holes. The reason for preferring
work planes over sketching planes is that the latter has some limitations. For
example, it is not possible to define a sketching plane at an offset distance from
an existing plane. Also, it is not possible to define a sketching plane that is
tangent to a cylindrical feature. In such situations, you can define a work plane
and use it as the sketching plane. In Autodesk Inventor, there are many tools that
can be used to create work planes. You can choose the desired tool from the
Plane drop-down in the Work Features panel of the 3D Model tab, see Figure
5-4. The procedures of creating work planes using these tools are discussed next.

Creating a Work Plane through Selected Objects
Ribbon: 3D Model > Work Features > Plane drop-down > Plane

You can create a work plane based on the reference objects selected and the
sequence of their selection. To do so, choose the Plane tool from the Work
Features panel (see Figure 5-4) and then select the required entity from the
model in the drawing window. Figure 5-5 shows a planar face and a point to be
selected for creating a work plane and Figure 5-6 shows the resulting work
plane.




Note
The new work plane will be displayed on the screen as a shaded plane. If

required, you can turn off the display of this work plane. The procedure to
do so will be discussed later in this chapter.

Point to be
selected

Face to be
selected

Figure 5-5 The face and a point to be selected to define a work plane

Figure 5-6 Resulting work plane

Creating a Work Plane Using Two Coplanar Edges, Axes, or Lines
Ribbon: 3D Model > Work Features > Plane drop-down > Two Coplanar Edges
You can create a work plane that passes through any two coplanar edges, axes,
or lines. To do so, choose the Two Coplanar Edges tool from the Work
Features panel (see Figure 5-4) and then select the two coplanar edges, axes, or
lines from the model. Figure 5-7 shows the edges to be selected for creating a
work plane and Figure 5-8 shows the resulting work plane.



Creating a Work Plane Using Three Vertices or Points
Ribbon: 3D Model > Work Features > Plane drop-down > Three Points

You can create a work plane that passes through three points. These points can
be the vertices of the model or the point/hole center. To create such a plane,
choose the Three Points tool from the Work Features panel (see Figure 5-4).
Next, move the cursor close to a vertex; a yellow circle with a cross is snapped
to it, suggesting that the vertex can be selected. Select any three vertices or
points; the work plane will be created. Figure 5-9 shows three vertices selected
to create a work plane and Figure 5-10 shows the resulting work plane.

First edge

Second

Figure 5-8 Resulting work plane
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Figure 5-10 Resulting work plane

Tip. You can also select work axes to define the work plane. You will learn more
about work axes later in this chapter.

Creating a Work Plane through an Edge/Axis and at an angle to a

Plane/Planar Face
Ribbon: 3D Model > Work Features > Plane drop-down > Angle to Plane
around Edge

You can create a work plane that passes through an edge or axis and lies at the
specified angle to a plane or a planar face. To do so, choose the Angle to Plane



around Edge tool from the Work Features panel (see Figure 5-4). Select the
work plane or the planar face to which the resulting work plane will be at an
angle. Next, select the edge through which the work plane will pass; a preview
of the plane along with the mini toolbar will be displayed. Enter the required
angle value in the edit box of the mini toolbar and then choose OK. You can
also drag the manipulator arrow to specify the angle value of the plane. Figure 5-
11 shows the edge and the planar face selected to create the work plane and
Figure 5-12 shows the work plane created at an angle of -30 degrees. With the
help of the mini toolbar, you can create a plane parallel or perpendicular to the
selected plane/planar face. To create a plane parallel to the selected plane/planar
face, enter 0 in the edit box of mini toolbar and then choose OK. Figure 5-13
shows a planar face and an edge selected for creating the work plane and Figure
5-14 shows the resulting work plane. To create a plane perpendicular to the
selected plane/planar face, enter 90 in the edit box of the mini toolbar and then
choose OK. FFigure 5-15 shows a planar face and an edge selected for creating
a work plane and Figure 5-16 shows the resulting work plane.
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Figure 5-11 An edge and a planar face selected to define a work plane at -30
degrees to the selected plane




Figure 5-12 Resulting work plane
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Figure 5-13 A planar face and an edge selected to define a work plane parallel
to the selected plane
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Figure 5-14 Resulting work plane
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Figure 5-15 An edge and a planar face to be selected to create a work plane
normal to the selected plane
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Figure 5-16 Resulting work plane

Creating a Work Plane Passing through a Point and Parallel to a

Plane/Planar Face
Ribbon: 3D Model > Work Features > Plane drop-down > Parallel to Plane

through Point

You can create a work plane that passes through a specified point and is parallel
to a plane or a planar face. To do so, choose the Parallel to Plane through
Point tool from the Work Features panel (see Figure 5-4). Next, select the
point and the plane or planar face. You can select the point first and then the
plane or the planar face to which the new work plane will be parallel and vice-
versa. Figure 5-17 shows a point and a planar face to be selected to define a
work plane and Figure 5-18 shows the resulting work plane.
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Figure 5-17 A point and a planar face to be selected to define the work plane
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Figure 5-18 Resulting work plane

Creating a Work Plane Tangent to a Circular Face and Parallel to a

Plane/Planar Face

Ribbon: 3D Model > Work Features > Plane drop-down > Tangent to Surface

and Parallel to Plane

You can create a work plane that is tangent to a circular face and parallel to a
plane or a planar face. To do so, choose the Tangent to Surface and Parallel to
Plane tool from the Work Features panel (see Figure 5-4). Next, select the
cylindrical face and then select the XY, YZ, or XZ plane or the planar face to
which the resulting work plane should be parallel. Figure 5-19 shows a circular
face to which the new work plane will be tangent and a planar face to which the
resulting work plane will be parallel. Figure 5-20 shows the resulting work

plane.
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Figure 5-19 Circular feature and a planar face to be selected to define a work
plane

Figure 5-20 Resulting work plane

Tip. To select the XY, YZ, and XZ planes, click on the (+) sign located on the left
of the Origin node in the Browser Bar. The three default planes along with three
axes and center point will be displayed. You can now select the required plane
from the Browser Bar.

Creating a Work Plane Normal to a Line Passing through a Point
Ribbon: 3D Model > Work Features > Plane drop-down > Normal to Axis
through Point

You can create a work plane that is normal to an axis and passes through a point.
The axis can be a line, an edge, or a work axis and the point can be any vertex in



the model, a sketched point, hole center, or a work point. To create a work plane
normal to an axis through a point, choose the Normal to Axis through Point
tool from the Work Features panel (see Figure 5-4). Next, select the point and
the edge in any sequence to create the plane. Figure 5-21 shows an edge and a
point selected to create a work plane and Figure 5-22 shows the resulting work
plane.

You can also use the Normal to Axis through Point tool to create a work plane
that is normal to a line and passes through the intersection of the line with an arc
or a circle. To do so, first you need to draw a circle or an arc and then a line or a
centerline. Note that one endpoint of the line should lie on the circumference of
the circle. After drawing the circle/arc and the line or the centerline, exit the
sketching environment. Next, choose the Normal to Axis through Point tool
from the Work Features panel (see Figure 5-4); you will be prompted to define
the work plane by highlighting and selecting the geometry. Select the line or the
centerline and then select the point of intersection of the line and the circle/arc;
the work plane will be created at the intersection of the line/centerline and the
circle/arc. Also, the new work plane will be normal to the centerline, see Figures
5-23 and 5-24.

Figure 5-21 Selecting an edge and a point to define a work plane
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Figure 5-22 Resulting work plane
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Figure 5-24 Resulting work plane



Note
1. The size of the work plane in Figure 5-24 has been modified to improve
its clarity. The work planes are the planes which are constructed with
respect to the features. The size displayed on the graphics screen is just for
reference. To resize a work plane, move the cursor over one of its corners
and then click.

2. If you want to move the work plane, then drag the mouse when the cursor
turns into a four-sided arrow.

Creating a Work Plane Tangent to a Circular Face and Passing

through an Edge/Axis
Ribbon: 3D Model > Work Features > Plane drop-down> Tangent to Surface

through Edge

You can create a work plane that is tangent to a circular face and passes through
the selected edge. To do so, choose the Tangent to Surface through Edge tool
from the Work Features panel (see Figure 5-4). Next, select an edge or an axis
and then select a circular face; a work plane passing though the selected edge
and tangent to the circular face will be created. Figure 5-25 shows a circular face
and an edge selected to create a work plane and Figure 5-26 shows the resulting
work plane.

Circular face

Figure 5-25 Selecting a circular face and an edge to define a work plane



Figure 5-26 Resulting work plane

Creating a Work Plane Parallel to a Plane/Planar Face and at an Offset
Ribbon: 3D Model > Work Features > Plane drop-down > Offset from Plane

You can create a work plane that is parallel to a plane or a planar face and is at
some offset distance from the selected plane or planar face. To do so, choose the
Offset from Plane tool from the Work Features panel (see Figure 5-4). Next,
select the plane or the planar face to which the resulting plane will be parallel; a
preview of the work plane along with a mini toolbar will be displayed. Specify
the offset distance in the edit box of the mini toolbar or drag the arrow
manipulator to specify it. After specifying the offset distance, choose OK from
the mini toolbar. If you specify a negative offset value, the work plane will be
offset in the opposite direction. Figure 5-27 shows a plane selected to define the
offset work plane and Figure 5-28 shows the new work plane created at an offset
of 30 mm.




Note
To create more than one work features in succession, you can choose to
repeat the command even dfter it has been used once. To invoke the Repeat
command, first invoke any work feature tool and then right-click in the
graphics window. From the shortcut menu, choose the Repeat command
option. Choosing this option ensures that the work feature tool invoked
earlier will repeat until you terminate it.
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Figure 5-27 Selecting a planar face to define the offset work plane

Figure 5-28 Resulting work plane

Creating a Work Plane in the Middle of Two Planes or Planar Faces
Ribbon: 3D Model > Work Features > Plane drop-down > Midplane between
Two Planes

You can create a work plane in the middle of two parallel planes or planar faces.
To do so, choose the Midplane between Two Planes tool from the Work



Features panel (see Figure 5-4). Next, select two

planes/faces; a plane will be

created in the middle of the selected planes/faces. Figure 5-29 shows two planar
faces to be selected and Figure 5-30 shows the resulting work plane.
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Figure 5-29 Selecting two planar faces to
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Figure 5-30 Resulting work plane

Creating a Work Plane Tangent to a Surface and Passing through a

Point

Ribbon: 3D Model > Work Features > Plane drop-down > Tangent to Surface

through Point

You can create a work plane that is tangent to a
specified point. To do so, choose the Tangent to

surface and passes through a
Surface through Point tool

from the Work Features panel (see Figure 5-4). Next, select a surface and then
a point or a vertex; a work plane passing though the selected point and tangent to

the surface will be created. Figure 5-31 shows

a surface and a point to be

selected to create a work plane and Figure 5-32 shows the resulting work plane.
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Figure 5-31 A surface and a point to be selected to define a work plane

Figure 5-32 Resulting work plane

Creating a Work Plane through the Center or the Midplane of a Torus
Ribbon: 3D Model > Work Features > Plane drop-down > Midplane of Torus

You can create a work plane that passes through the center or the midplane of a
torus. To do so, choose the Midplane of Torus tool from the Work Features
panel (see Figure 5-4). Move the cursor to the torus; the preview of the plane
will be displayed. Next, select the torus; the work plane will be created on its
midplane. Figure 5-33 shows the torus to be selected and Figure 5-34 shows the
resulting work plane.




Figure 5-33 Torus to be selected to define the work plane

Figure 5-34 Resulting work plane



Note
The features/models created by using the freeform tools cannot be used as
reference for creating work plane.

Creating a Work Plane Normal to a Curve
Ribbon: 3D Model > Work Features > Plane drop-down > Normal to Curve at
Point

You can create a work plane that is normal to a curve at the specified point. The
curve can be a line, a spline, or an arc. The point can be any control vertex or the
endpoint of the curve or spline. To create a work plane normal to a curve, choose
the Normal to Curve at Point tool from the Work Features panel (see Figure
5-4). Next, select the curve and then the point. Figure 5-35 shows a curve and a
point to be selected to create a work plane and Figure 5-36 shows the resulting
work plane.

Spline

Point to
be selected

Figure 5-35 Spline (curve) and point to be selected to define the work plane



Figure 5-36 Resulting work plane



Creating Work Axes
Ribbon: 3D Model > Work Features > Axis drop-down

Work axes are parametric axes that pass through a model or feature. These axes
are used as a reference to create work planes, work points, and circular patterns.
The work axis is displayed both in the model and in the Browser Bar. In
Autodesk Inventor, there are eight tools that can be used to create work axes.
You can choose the desired tool from the Axis drop-down in the Work Features
panel of the 3D Model tab, see Figure 5-37. The procedures of creating work
axes using these tools are discussed next.

Creating a Work Axis through Selected Objects
Ribbon: 3D Model > Work Features > Axis drop-down > Axis

You can create a work axis through selected objects depending upon the
reference objects and the sequence in which they are selected. To do so, choose
the Axis tool from the Work Features panel, see Figure 5-37, and then select
the required entities from the model in the drawing window.
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Figure 5-37 The Axis drop-down with various tools for creating work axes

Creating a Work Axis passing through a Revolved or Cylindrical
Feature



Ribbon: 3D Model > Work Features > Axis drop-down > Through Revolved
Face or
Feature

You can create a work axis that passes through the center of a revolved
or cylindrical feature. To do so, choose the Through Revolved Face or
Feature tool from the Work Features panel (see Figure 5-37); you will be
prompted to select a cylindrical or a revolved surface. Select a cylindrical or
revolved feature from the drawing window; a work axis passing through the

center of the selected feature will be created, see Figure 5-38.
Work axis
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Figure 5-38 Work Axis passing through the center of a circular feature

Creating a Work Axis Normal to a Plane/Planar Face and Passing

through a Point
Ribbon: 3D _Model > Work Features > Axis drop-down > Normal to Plane

through Point

You can create a work axis that is normal to a plane or a planar face and passes
through a specified point. To do so, choose the Normal to Plane through Point
tool from the Work Features panel. Next, select a plane or a planar face to
which the axis will be normal and then select the point through which the axis
will pass, see Figure 5-39.
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Figure 5-39 Creating a work axis through a planar face and a sketched point

Creating a Work Axis Passing through the Intersection of Two

Planes/Planar Faces
Ribbon: 3D Model > Work Features > Axis drop-down > Intersection of Two
Planes

You can create a work axis that passes through the intersection of two planes or
planar faces. To do so, choose the Intersection of Two Planes tool from the
Work Features panel. Next, select two intersecting planar faces; a work axis
will be created at their intersection. If you select two planar faces that do not
intersect in the model but intersect when extended, the resulting axis will pass
through the extended intersection, see Figure 5-40.

Creating a Work Axis Passing through Two Points
Ribbon: 3D Model > Work Features > Axis drop-down > Through Two Points

You can create a work axis that passes through two specified points. The points
can be the vertices, midpoints of edges, sketched points, hole centers, or work
points. To create a work axis passing through two points, choose the Through
Two Points tool from the Work Features panel (see Figure 5-37). Next, select
two points from the drawing window; an axis passing through the selected points
will be created. Figure 5-41 shows a work axis created using the midpoints of
two edges of a model.
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Figure 5-40 Work axis passing through the intersection of two planes
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Figure 5-41 Creating a work axis through the midpoints of two edges

Creating a Work Axis along a Linear Edge/Sketch Line/3D Sketch
Line

Ribbon: 3D Model > Work Features > Axis drop-down > On Line or Edge

You can create a work axis along a linear edge/sketch line/3D sketch line. To do

so, choose the On Line or Edge tool from the Work Features panel (see Figure
5-37) and select a linear edge, sketch line, or 3D sketch line of a model.

Creating a Work Axis Passing through a Point and along a Line/Edge
Ribbon: 3D Model > Work Features > Axis drop-down > Parallel to Line

through Point

You can create a work axis that is parallel to a linear edge or a line and passes
through a point. To do so, choose the Parallel to Line through Point tool from
the Work Features panel. Next, select a point and then a line or a linear edge;
an axis parallel to the selected line or edge and passing through the selected




point will be created. Figure 5-42 shows a work axis that is parallel to a line and
passes through a specified point.

Creating a Work Axis Coincident with the Axis of the Circular,

Elliptical, or Fillet Edge of a Feature
Ribbon: 3D Model > Work Features > Axis drop-down > Through Center

of Circular or Elliptical Edge

You can create a work axis that is coincident with the axis of an elliptical, a
circular, or a fillet edge of a feature. To do so, choose the Through Center of
Circular or Elliptical Edge tool from the Work Features panel (see Figure 5-
37). Next, select the circular, elliptical, or fillet edge from the feature; a work
axis coincident with the axis of the selected edge will be created. Figure 5-43
shows a work axis created. This work axis coincides with the axis of the circular
edge of the feature.
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Figure 5-42 Creating a work axis parallel to a line passing through a point
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Figure 5-43 Creating a work axis coincident with the axis of the circular edge



Creating Work Points

Ribbon: 3D Model > Work Features > Point drop-down

Work points are parametric points that can be created on an existing model.
These points help create work planes, work axes, or other features. In Autodesk
Inventor, there are nine tools that can be used to create work points. You can
choose the desired tool from the Work Point drop-down in the Work
Features panel of the 3D Model tab, see Figure 5-44. The procedure of creating
work points using these tools is discussed next.
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Figure 5-44 The Point drop-down with various tools for creating work points

Creating a Work Point through Selected Objects
Ribbon: 3D Model > Work Features > Point drop-down > Point

You can create various types of work points depending upon the reference
objects selected and the sequence in which they are selected. To do so, choose
the Point tool from the Work Features panel (see Figure 5-44) and then select
the required entities from the model in the drawing window.

Creating a Work Point at a Vertex or at the Midpoint of an Edge
Ribbon: 3D Model > Work Features > Point drop-down > On Vertex, Sketch




point, or Midpoint

You can create a work point at any vertex of a model or at the midpoint of any of
its edges. To do so, choose the On Vertex, Sketch point, or Midpoint tool from
the Work Features panel (see Figure 5-44). Next, select a vertex of the model; a
new work point will be created on the selected vertex. To create a work point at
the midpoint of an edge, move the cursor close to the midpoint of the edge; the
midpoint will be highlighted. Next, select the midpoint; the work point will be
created. You can also right-click and choose Select Other from the shortcut
menu to cycle through various entities and select the midpoint when it is
displayed. Figure 5-45 shows work points created at the vertices and at the
midpoints of the edges of the model.

Creating a Work Point at the Intersection of Two Edges/Axes
Ribbon: 3D Model > Work Features > Point drop-down > Intersection of Two
Lines

You can create a work point at the intersection or extended intersection of two
edges or axes. To do so, choose the Intersection of Two Lines tool from the
Work Features panel (see Figure 5-44). Select the two intersecting edges or
axes; the work point will be created at the intersection point. Figure 5-46 shows
two edges to be selected to create the work point and the resulting work point.

Work points
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Work point
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Figure 5-45 Work points at the vertices and at the midpoints of edges
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Figure 5-46 Work point at the intersection of two edges

Creating a Work Point at the Intersection of a Plane/Planar Face and

an Edge/Axis
Ribbon: 3D Model > Work Features > Point drop-down > Intersection of Plane/
Surface and Line

You can create a work point at the intersection of a plane or a planar face and an
edge or axis. To do so, choose the Intersection of Plane/Surface and Line tool
from the Work Features panel (see Figure 5-44). Next, select the plane or the
planar face and then the line or linear edge normal to it in any sequence; a work
point will be created at their intersection, see Figure 5-47.

Creating a Work Point at the Intersection of Three Planes/Planar
Faces

Ribbon: 3D Model > Work Features > Point drop-down > Intersection of Three
Planes

You can create a work point at the intersection of three planes or planar faces.
To do so, choose the Intersection of Three Planes tool from the Work
Features panel (see Figure 5-44). Select the three planes or planar faces; a work
point will be created at their intersection, see Figure 5-48.
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Figure 5-47 Work point created at the intersection of an edge and a work plane
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Figure 5-48 Work point created at the intersection of three planes

Note

If you delete work features such as work planes, work axes, or work points, the
features created with reference to these work features will also be deleted. To
hide the work features, right-click on the desired feature in the Browser Barand
clear the Visibility option from the shortcut menu; the display of the selected
work feature will be turned off. Select this option again to turn the visibility on.

Creating a Work Point at the Center Point of a Loop of Edges
Ribbon: 3D Model > Work Features > Point drop-down > Center Point of L.oop

of Edges

You can create a work point at the center point of a closed loop of edges of a
feature. To do so, choose the Center Point of Loop of Edges tool from the
Work Features panel (see Figure 5-44). Next, select an edge that forms a closed
loop with other edges; a work point will be created at the center point of the loop
of the selected edges, see Figure 5-49. Note that before selecting the edge for




creating a work point, you need to right-click and then choose the Loop Select
option from the shortcut menu.

Creating a Work Point through the Center or Midplane of a Torus
Ribbon: 3D Model > Work Features > Point drop-down > Center Point of Torus

You can create a work point that passes through the center or midplane of a
torus. To do so, choose the Center Point of Torus tool from the Work
Features panel (see Figure 5-44). Move the cursor to the torus; the preview of
the work point will be displayed. Next, select the torus; the work point will be

created at its center or midplane. Figure 5-50 shows a torus with a work point
created at its center.
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Figure 5-49 Creating work point at the center point of an edge of a closed loop

Figure 5-50 Work point created at the center of a torus



Note
The features/models created by using the freeform tools cannot be used as
reference for creating work point.

Creating a Work Point through the Center or Midplane of a Sphere

Ribbon: 3D Model > Work Features > Point drop-down > Center Point of
Sphere

You can create a work point that passes through the center or midplane of a
sphere. To do so, choose the Center Point of Sphere tool from the Work
Features panel, refer to Figure 5-44. Next, select the sphere; the work point will
be created at its center or midplane. To view the center point in the drawing area
if not visible, change the view style to Wireframe. Figure 5-51 shows a sphere
with a work point created at its center.

Figure 5-51 Work point created at the center of a sphere



Note
The features/models created by using the freeform tools cannot be used as
reference for creating work point.



Creating a Grounded Point
Ribbon: 3D Model > Work Features > Point drop-down > Grounded Point

You can create a grounded point by using the Grounded Point tool. To create a
grounded point, choose the Grounded Point tool from the Work Features
panel (see Figure 5-44); you will be prompted to select a vertex or work point to
specify the initial position of the point. Select a vertex or a work point; a triad
will be placed at the selected vertex or point, as shown in Figure 5-52. Also, a
mini-tool bar will be displayed, as shown in Figure 5-53. You can move the triad
in the required direction by clicking on the corresponding axis and then dragging
it. You can also rotate the triad about its axis. After specifying the position and
orientation of the grounded point, choose the OK button; the grounded point will
be placed at the specified position.

Figure 5-52 Triad placed at the selected vertex
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Figure 5-53 The mini-tool bar

Tip. 1. To understand the geometrical dependency of an axis, work plane, or
work point, select the Work Point, Work Axis, or Work Plane in the Browser
Bar or in the graphic window and right-click; a shortcut menu will be displayed.
Choose the Show Inputs option from the shortcut menu; the geometry that was



used to create the work plane, work axis, or work point will be highlighted in the
graphic window.

2. The work features can also be created in-line. The in-line features are created
while you are in the process of creating some other feature. For example, while
creating a work axis, if you right-click, a shortcut menu will be displayed. This
shortcut menu provides the options, Create plane and Create point for creating
work features. The work plane and the work point created using this shortcut
menu will be the in-line work features. Note that all in-line features are
dependent on the parent features.



OTHER EXTRUSION OPTIONS

The Extrude dialog box cannot be invoked until the base feature is created in
the sketch environment. Once you create the base feature in the Sketching
environment and choose the Finish Sketch option from the Marking menu, you
will automatically be taken to the 3D Model tab of the Ribbon. If you choose
the Extrude tool in this tab, the Extrude dialog box will be displayed.

Some of the options of the Extrude dialog box will not be available until you
have created the base feature. Once the base feature is created, all the options in
the tabs of this dialog box will be available. These options are discussed next.



Shape Tab

The options in the Shape tab of the Extrude dialog box, shown in Figure 5-54,
are discussed next.



Join

@This is the first button on the left of the Extents area and is used to create an
extruded feature by adding new material to an existing feature. This button will
be activated only after you have created the base feature. You can also choose
this button from the mini toolbar, refer to Figure 5-55. Figure 5-56 shows the
join feature created using a sketch.
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Figure 5-54 The Extrude dialog box with the Shape tab chosen

Figure 5-55 The Cut option in the mini toolbar



Cut

This is the second button on the left of the Extents area. This button will be
available only after you have created the base feature. The Cut option is used to
create an extruded feature by removing material from the existing feature. You
can also choose this option from the mini toolbar that is displayed on invoking
the Extrude tool, refer to Figure 5-55. The material to be removed will be
defined by the sketch that you have drawn. Figure 5-57 shows the cut feature
created using the same sketch.



Intersect

This button is available below the Cut button and is used to create an extruded
feature by using the material that is common to both the existing feature and the
sketch, see Figure 5-58. You can also choose this option from the mini toolbar,
refer to Figure 5-55.

Figure 5-56 Extruding the sketch using the
Join option

Figure 5-57 Extruding the sketch using the Cut option
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Figure 5-58 Extruding the sketch using the Intersect option



New solid

On choosing this button, the resultant feature will be a new body. The new body
thus created will be independent of the existing body and will be listed in the
Solid Bodies node of the Browser Bar. You can also choose this option from
the mini toolbar, refer to Figure 5-55.



Extents Area

The Extents area is used to specify the termination options for the feature to be
extruded. These options are also available in the mini toolbar, refer to Figure 5-
59. Some of the options in this area were discussed in Chapter 4 and the rest of
them are discussed next.



To Next
This option is used to terminate the extruded feature on the first plane or the

first face that it comes across in the specified direction. On selecting this
option, the Terminator button will appear in the Extents area. This button is
used to define the end of the extruded feature. You can also invoke this option
by choosing the To next face/body option from the mini toolbar, refer to
Figure 5-59.

UG"'I'I 28.750 mm ¥
,:" H Distance
b 4| To next face/body
] | To selected face/paint
=
I_l.
u

i Between two faces/planes

Through All

Figure 5-59 Choosing the To next face/body option from the mini toolbar

Note
The Symmetric option will not be available with the To Next termination option

because you cannot select planes or planar faces in both directions of the
current sketch plane in a single attempt



All

The All option is used to create a feature by extruding the sketch through all
the features that it comes across. You can also invoke this option by choosing
the Through All option from the mini toolbar, refer to Figure 5-59. You can
extrude the sketch in either direction of the current sketching plane by using
the direction buttons in the Extents area. You can also extrude the sketch in
both the directions of the current sketch plane by choosing the Symmetric
button.

Figure 5-60 shows a sketch drawn on an offset plane. Figures 5-61 and 5-62
show the profile extruded using the To Next and All options, respectively.

Figure 5-60 Sketch drawn on an offset plane

Figure 5-61 Sketch extruded using the To Next option



Match shape

This check box is available only when you are extruding an open sketch. If this
check box is selected, the open sketch is extruded in such a way that it extends
upto the last face of the model that it comes across. The sketch fills the material
in all the features up to the last face of the model. For example, refer to the open
sketch shown in Figure 5-63. This sketch is drawn at a plane offset from the
bottom face of the model.

Figure 5-62 Sketch extruded using the All option

Figure 5-63 Sketch drawn on the offset plane

When you invoke the Extrude tool and select this open profile, you are allowed
to extrude it on either of the two sides, as shown in Figures 5-64 and 5-65.



Figure 5-64 First side for extruding the profile

Figure 5-65 Second side for extruding the profile

While selecting the side to be extruded, you need to be careful because the
feature creation will be successful only when you extrude it in the direction in
which the sketch will find faces to terminate the feature. In this case, the feature
will not be created if you select the side shown in Figure 5-65 because there is
no face available in the front direction to terminate the feature.

After you select the side of the sketch to be extruded, you will be prompted to
define the extent of the feature. You can select the type of termination from the
Distance drop-down list and define the direction using the two buttons. If the
Match shape check box is selected, the sketch will fill the model with the
material and the feature will be created similar to that shown in Figure 5-66. But
if the Match shape check box is cleared, the feature will be created similar to
that shown in Figure 5-67. As evident from this figure, the shape of the sketch is
not retained while creating the feature.



Figure 5-66 Result with the Match shape check box selected

Figure 5-67 Result with the Match shape check box cleared



More Tab

While creating a feature after creating the base feature, you can also use the
remaining options of the More tab shown in Figure 5-68. These options are
discussed next.
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Figure 5-68 The Extrude dialog box with the More tab chosen




Alternate Solution Area

The options in the Alternate Solution area are used in combination with the To
and the To Next termination options. These options are used for creating those
extruded features that terminate on the curved faces, resulting in more than one
possible solution. These options are discussed next.



Flip
The Flip buttons are used to reverse the direction of the extruded features.



Minimum Solution

By default, in case of more than one solution, the extruded feature terminates
at the face that is at maximum distance from the sketch. Figure 5-69 shows the
sketch and the face at which the extruded feature will terminate. Notice that
the resultant feature shown in Figure 5-70 is stretched up to the face that is at
the maximum distance from the sketch. However, if you select the Minimum
Solution check box, the feature will terminate at the face that is at minimum
distance from the sketch, see Figures 5-71 and 5-72.



Note
In Figures 5-70 and 5-72, the visibility of work planes has been turned off.

Shetch
Figure 5-69 The sketch and the termination face

Figure 5-70 Resulting extruded feature

To
face

Shetch
Figure 5-71 The sketch and the termination face



Figure 5-72 Resulting extruded feature



Infer iMates

iMates are references that allow you to define the mating references such as
planar surfaces, axes, edges, and so on before assembling a component. The
Infer iMates check box in the More tab is selected to apply an iMate to the

edge of a solid. Note that only the edge of cylindrical feature can be selected for
this purpose.



OTHER REVOLUTION OPTIONS

Most of the options in the Revolve dialog box were discussed in Chapter 4. The
remaining options are discussed next.



Operations Area

Once you have created the base feature, the Join, Cut and Intersect buttons will
be activated in the Operations area of the Revolve dialog box, see Figure 5-73.
These options are also available in the mini toolbar. The functions of these
options are discussed next.
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Figure 5-73 The Revolve dialog box



Join
This is the first button on the left of the Extents area and is used to create
a revolved feature by adding new material to an existing feature. This button will
be available only after you have created the base feature. You can also invoke
this option from the mini toolbar, refer to Figure 5-74.
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Figure 5-74 Choosing an option from the mini toolbar



Cut

This is the second button on the left of the Extents area. This button will be
available only after you have created the base feature. You can also choose this
option from the mini toolbar, see Figure 5-74. The Cut option is used to create a
revolved feature by removing the material from the feature. The material to be
removed is defined by the sketch you have drawn and the axis of revolution.



Intersect

This button is available below the Cut button and is used to create a revolved
feature by retaining the material common to the existing feature and the sketch.
You can also choose the Intersect option from the mini toolbar, refer to Figure

5-74.



New Solid

On choosing the New solid button, the resultant revolved feature will be a new
body. The new body will be independent of the existing body and will be listed
in the Solid Bodies node of the Browser Bar. You can also choose this option
from the mini toolbar, refer to Figure 5-74.



Match shape

This check box is available only when you revolve an open sketch. Similar to the
Extrude tool, in this case also, the Match shape check box is used to revolve
the open sketch in such a way that it extends to the axis of revolution. On doing
so, the sketch floods all features up to the last face of the model with material.
Figure 5-75 shows the open sketch and Figures 5-76 and 5-77 show the revolved
feature created by selecting and clearing this check box respectively.

Figure 5-75 Sketch for the revolve feature

Figure 5-76 Revolve feature with the Match shape check box selected

Figure 5-77 Revolve feature with the Match shape check box cleared



Infer iMates
This check box is selected to apply an iMate to a full circular edge of the solid
feature.



THE CONCEPT OF SKETCH SHARING

Generally, while creating a design, you will frequently come across situations
where you have to use a consumed sketch for creating another feature in the
same plane and along the same direction of extrusion. As mentioned at the start
of this chapter, a consumed sketch is the one that has already been converted
into a feature. For example, consider a case where you have to create a join
feature by extruding the sketch to different distances in both the directions about
the current sketch plane.

In some solid modeling programs, to use the consumed sketch, you will have to
copy it to new location. After placing the sketch, you will have to add
dimensions to locate it on its exact location. However, in Autodesk Inventor, you
can directly use the same sketch by sharing it. This concept of using the
consumed sketch again is termed as sharing the sketches. This concept has
drawn a very distinct line between Autodesk Inventor and other solid modeling
programs as it reduces the design time appreciably.



Sharing Sketches

As mentioned in Introduction, all the operations that were used to create a model
are displayed in the form of a tree view in the Browser Bar. All these operations
will be arranged in the sequence in which they were performed. Also, once the
sketch is converted into a feature, the sketch will be hidden and the feature will
be displayed in the Browser Bar. For example, when you create the sketch for
the base feature, the Browser Bar will display Sketchl below Origin. When
this sketch is extruded and converted into the base feature, the Browser Bar will
display Extrusionl below Origin and it will have a plus sign (+) located on the
left. If you click on this plus sign, it will expand and will display Sketchl.
Similarly, if you click on the plus sign of any sketched feature, it will expand
and display the sketch.
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Figure 5-78 Shortcut menu displaying the Share Sketch option

To share the sketch, right-click on the sketch that you want to share; a shortcut
menu will be displayed, see Figure 5-78. In this shortcut menu, choose Share
Sketch; another sketch with the same name will be displayed in the Browser
Bar. Also, the shared sketch will be displayed in the graphics window. You can
now convert this sketch into a feature.

Note

By default, the visibility of the shared sketch is set to ON. As a result, after
converting into a feature, the sketch will also be displayed along with the new
feature. You need to manually turn off the visibility of this sketch. This is done by



using the shortcut menu that is displayed upon right-clicking on the sketch. In
this shortcut menu, the Visibility option will have a check mark on its left.
Choose this option again to turn off the visibility. You will notice that the sketch
is no more visible on the screen. Similarly, right-click on any work feature and
turn off its visibility using the Visibility option in the shortcut menu.



TUTORIALS
Tutorial 1

In this tutorial, you will create the model of the Standard Bracket shown in
Figure 5-79. The views and dimensions of the model are shown in the same
figure.

(Expected time: 30 min)




The following steps are required to complete this tutorial:

a. On the XY plane, create the base feature with two holes, refer to Figures 5-80
and 5-81.

b. Define a new sketch plane on the back face of the base feature and create the
join feature with a hole, refer to Figure 5-83.

c. Define a new sketch plane on the front face of the model and create the
rectangular join feature, refer to Figure 5-86.

Creating and Dimensioning the Sketch of the Base Feature
1. Start Autodesk Inventor and then start a new metric standard part file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the sketch

plane.

3. Choose the Home button from the ViewCube; the current orientation of the



sketch plane is changed.

4. Select the XY plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the XY Plane becomes parallel to the
screen. Alternatively, you can select the XY plane from the graphics window.

5. Draw the sketch of the base feature using various sketching tools, see Figure
5-80.

6. Add the required constraints and dimensions to the sketch to make it fully
constrained.

7. Choose the Finish Sketch button from the Exit panel of the Sketch tab; you
will exit the Sketching environment and the current view is changed to the
home view or isometric view.



Note

If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as > Top/Front

from the flyout.



Extruding the Base Sketch
After creating the sketch, you need to extrude it to create the base feature.

1. Using the Extrude tool, extrude the sketch to a distance of 32 mm.

As the sketch has multiple loops, you need to specify the profile to be extruded.
Make sure you define the profile to be extruded by specifying a point outside
the circles but inside the outer loop. The model after creating the base feature

is shown in Figure 5-81.
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Figure 5-80 Sketch of the base feature

Figure 5-81 Base feature of the model

Creating a Feature on the Back Face of the Base Feature
To create a feature on the back face of the base feature, you first need to define

the sketching plane on the back face.
1. Choose the Start 2D Sketch tool from 3D Model > Sketch > Start 2D



Sketch drop-down; you are prompted to select the sketching plane.

2. As the Start 2D Sketch tool is active, move the cursor close to the back face
of the model and hover it for sometime. On doing so, the Select Other flyout
is displayed on the model. Choose the desired face option from this flyout to
select the back face of the model, refer to Figure 5-82. Next, click on the
model to confirm your selection.

Sometimes, while reorienting the model, the X axis of the model (displayed red
in the 3D Indicator) points vertically downward.

3. In case the X axis points vertically downward, choose the arrow on the top
right corner of the ViewCube to reorient the model. However, this step can be
skipped if this axis points horizontally toward the left.

Figure 5-82 Selecting the back face of the model using the options in the Select Other flyout

Once you orient the model, you will notice that the red arrow in the 3D Indicator
has become horizontal and is pointing toward the left. This shows that the X
axis of the model is now in the horizontal direction. Note that you may not
need to reorient the model toward the X axis.

4. Draw the sketch of the feature using various sketching tools, see Figure 5-83.

5. Add the required constraints to the sketch and then dimension it to make it



fully constrained. The sketch after dimensioning should look similar to the one
shown in Figure 5-83.

6. Choose the Finish Sketch button from the Exit panel of the Sketch tab and
exit the Sketching environment.



Extruding the Sketch
1. Change the current view to isometric and then extrude the sketch upto a
distance of 32 mm by using the Extrude tool.

You can change the direction of the depth in the mini toolbar. To do so, select
the Direction 2 option from the Direction drop-down list. The model after
creating the feature on the back face will look similar to the one shown in
Figure 5-84.
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Figure 5-83 Sketch of the feature on the back face

Figure 5-84 Model after creating the feature

Creating the Sketch on the Front Face of the Base Feature
1. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab;
you are prompted to select the plane on which the sketch will be created.

2. Select the front face of the model; the Sketching environment is activated and



a rectangle defining the contour of the front face is created.

3. Delete the reference geometries, if any, and then draw a rectangle as the
sketch for the next feature, as shown in Figure 5-85. Add the Collinear
Constraint between the lower edge of the rectangle and the upper edge of the
front face of the base feature.
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Figure 5-85 Dimensioned sketch for the feature on the front face
4. Add the required dimensions to the sketch, refer to Figure 5-85.

5. Exit the Sketching environment and then change the current view to isometric
view.

Tip. Whenever you apply the Collinear Constraint between a sketched line and
an edge, another line will be created. It is recommended that you do not delete
this line. If you delete this line, the Collinear Constraint will also be deleted.



Extruding the Sketch
1. Choose the Extrude tool from the Marking menu; the Extrude dialog box is
displayed. Select the rectangle as the profile to be extruded.

2. Choose the To selected face/point option from the mini toolbar, as shown in
Figure 5-86. Alternatively, select To from the Distance drop-down list in the
Extents area of the Extrude dialog box; the Select surface to end the feature
creation button is displayed below the drop-down list. This button is chosen
by default.

3. Select the front face of the second feature as the face where the current feature
will terminate; the Check to terminate feature on the extended face check
box is displayed on the right of the Select surface to end the feature creation
button in the Extrude dialog box. This check box is selected by default.

As the current feature will terminate on the selected face, you need to clear this
check box.

4. Clear the Check to terminate feature on the extended face check box and
then choose the OK button. Alternatively, choose OK from the mini toolbar.
The final model for Tutorial 1 is shown in Figure 5-87.
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Figure 5-86 Choosing the To selected face/point option



Figure 5-87 Final model for Tutorial 1



Saving the Model
1. Save the model with the name Tutoriall at the location given below and then

close the file.

C:\Inventor_2016\c05

Tutorial 2

In this tutorial, you will create the model shown in Figure 5-88. Its views and
dimensions are shown in the same figure. (Expected time: 30 min)

The following steps are required to complete this tutorial:

a. Create the base feature on the YZ plane by defining a new sketch plane on it,
refer to Figures 5-89 and 5-90.

b. Define a new sketch plane on the front face of the model and create a cut
feature, refer to Figures 5-91 and 5-92.

c. Create the next cut feature by defining a new sketch plane on the back face of
the model, refer to Figures 5-93 and 5-94.

d. Define a new sketch plane on the new face that is exposed by creating the last
cut feature and create a circular cut feature, refer to Figure 5-95.

e. Create the final cut feature on the top face of the horizontal base of the first
feature, refer to Figure 5-95.
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Figure 5-88 Views and dimensions for Tutorial 2






Changing the Sketch Plane
The base feature for this model is an L-shaped feature. You have to create the
sketch in the YZ plane.

1. Start a new metric standard part file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

3. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

4. Select the YZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the YZ Plane becomes parallel to the
screen. Alternatively, you can select YZ plane from the graphics window.



Note

If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as
> Top/Front from the flyout.

If

Creating and Dimensioning the Sketch of the Base Feature
1. Draw the L-shaped sketch for the base feature and add the required constraints
to it.

2. Add dimensions to the sketch. The sketch after adding the dimensions is
shown in Figure 5-89.

3. Choose the Finish Sketch button from the Exit panel of the Sketch tab to exit
the Sketching environment. Change the current view to the isometric view.



Extruding the Sketch

1. Choose the Extrude tool from the Create panel of the 3D Model tab to
invoke the Extrude dialog box. Next, extrude the sketch to a distance of 72
mm using the Symmetric button. You can also choose the Symmetric option
from the mini toolbar. Choose OK to exit the Extrude dialog box. The base
feature is created, as shown in Figure 5-90.

i

Figure 5-89 Sketch for the base feature

Figure 5-90 Base feature

Creating the Sketch for the Cut Feature on the Front Face
The next feature is a rectangular cut feature and is to be created on the front face
of the base feature.

1. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab;
you are prompted to select the sketching plane. Select the front face of the
base feature as the Sketching plane; the Sketching environment is invoked.



2. If required, reorient the model by using the ViewCube. Draw the sketch for
the cut feature and delete the reference geometries, if any, created while
defining the sketch plane.

3. Next, add required constraints and dimensions to it. The dimensioned sketch
is shown in Figure 5-91.

4. Choose the Finish Sketch button from the Marking menu and then change the
current view to the isometric view.

Creating the Cut Feature on the Front Face of the Model

1. Extrude the profile defined by the rectangle to a distance of 50 mm using the
Cut operation. The isometric view of the model with the cut feature is shown
in Figure 5-92.

Figure 5-91 Sketch for the cut feature

Figure 5-92 Model dafter creating the cut feature on the front face



Creating the Sketch for the Cut Feature on the Left Face
The next feature is a cut feature and is to be created on the left face of the model.

1. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab;
you are prompted to select a plane for creating the sketch. Select the left face
of the model; the Sketching environment is activated.

2. Delete all the reference geometries and then draw the sketch for the cut
feature. Add required constraints and dimensions to the sketch, as shown in
Figure 5-93.

3. Exit the Sketching environment and then change the current view to the
isometric view.

Extruding the Sketch to Create a Cut Feature
1. Extrude the profile to a distance of 12 mm using the Cut operation. The
model after creating a cut feature on the left face is shown in Figure 5-94.



Creating a Hole
1. Define a new sketch plane on the face that is exposed after creating the cut
feature in the previous step.

2. Draw a circle on this face and then add dimensions to it; refer to Figure 5-88
for dimensions.

3. Invoke the Extrude tool and extrude the circle using the Cut operation. Note

that to create this cut feature, you need to select the All option from the
Distance drop-down list in the Extents area.
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Figure 5-93 Sketch for the cut feature

Figure 5-94 Model after creating the cut feature on the left face



Creating the Last Cut Feature
1. Define a sketch plane on the horizontal face of the base feature and then
reorient the model using the ViewCube.

2. Delete all the reference geometries, if any, and then create the sketch for the
cut feature, refer to Figure 5-88 for dimensions. Add required constraints and
dimensions to the sketch.

3. Extrude the sketch using the Cut operation. Use the All option from the
Distance drop-down list in the Extents area. The final model for Tutorial 2 is
shown in Figure 5-95.

Figure 5-95 Solid model for Tutorial 2



Saving the Model
1. Save the sketch with the name Tutorial2 at the location given next.

C:\Inventor_2016\c05

2. Choose Close from the Application menu to close this file.

Tutorial 3

In this tutorial, you will create the model shown in Figure 5-96. Its dimensions
and views are shown in the same figure. (Expected time: 45 min)

The model for this tutorial is a combination of a base feature, two join features,
and six cut features (Holes).

The following steps are required to complete this tutorial:

a. Create the base feature on the YZ plane, refer to Figures 5-97 and 5-98.

b. Create a join feature on the top face of the base feature, refer to Figure 5-100.
c. Create a work plane at an offset of 10 mm from the bottom face of the join
feature and then create a cylindrical join feature on it, refer to Figure 5-102.

d. Create a hole in the cylindrical feature by defining a new sketch plane on its
top face, refer to Figure 5-103.

e. Create two holes by defining a sketch plane on the left face of the model, refer
to Figure 5-103.

f. Define a new sketch plane on the top face of the groove which is on the top
face of the model. Then, create three holes on it, refer to Figure 5-103.
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Figure 5-96 Views and dimensions for Tutorial 3



Creating the Base Feature
1. Start Autodesk Inventor and then start a new metric standard part file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the sketch
plane.

3. Choose the Home button from the ViewCube; the current orientation of the
sketch plane is changed.

4. Now, select the YZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the YZ Plane becomes parallel to the
screen. Alternatively, you can select YZ plane from the graphics window.

5. Create the sketch for the base feature and then add the required constraints
and dimensions to it. The dimensioned sketch for the base feature is shown in
Figure 5-97.

6. Exit the Sketching environment and then change the current view to the
isometric view by choosing the Home button of the ViewCube. Next, choose
the Extrude tool from the Create panel of the 3D Model tab; the Extrude
dialog box is displayed. As the sketch has a single loop, it is automatically
selected.

7. Extrude the sketch to a distance of 60 mm using the Symmetric option. The
base feature is created, as shown in Figure 5-98.
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Figure 5-97 Dimensioned sketch for the base feature

Figure 5-98 Base feature created

Note
If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the

ViewCube; a flyout is displayed. Next, choose Set Current View as
> Top/Front from the flyout.



If

Creating the First Join Feature on the Top Face
1. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab
and select the top face of the base feature as the new Sketching plane.

2. Reorient the view using the ViewCube, see Figure 5-99. Draw the sketch for
the first join feature and add the required constraints and dimensions to it, as
shown in Figure 5-99.

3. Exit the Sketching environment and change the current view to the isometric
view.

4. Extrude the sketch in the downward direction to a distance of 10 mm, see
Figure 5-100.



Note
If the join feature is extruded in an opposite direction, reverse its direction
by choosing the Direction 2 button from the mini toolbar or from the
Extents area of the Extrude dialog box.



Creating the Cylindrical Feature

As shown in Figure 5-96, the cylindrical feature starts at a distance of 10 mm
below the bottom face of the feature you just created. Therefore, you first need
to define a work plane offset at a distance of 10 mm from the bottom face of
the first join feature. But first, you need to change the orientation of the model
such that the bottom face of the first join feature is visible.
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Figure 5-99 Sketch for the first join feature

Figure 5-100 Model after extruding

1. Reorient the model using the Free Orbit tool such that the bottom face of the
first join feature is visible.

2. Choose the Offset from Plane tool from 3D Model > Work Features >
Plane drop-down. Click on the bottom face of the first join feature; the mini

toolbar is displayed.

3. Enter 10 in the edit box available in the mini toolbar and make sure the arrow



manipulator in the mini toolbar points downward. Next, press ENTER; a work
plane is created at an offset of 10 mm from the bottom face of the first join
feature.

4. Choose the Start 2D Sketch tool from the Sketch panel of the 3D Model tab
and select the work plane as the plane for drawing the sketch of the cylindrical
feature. Next, reorient the model, if required, using the ViewCube, see Figure
5-101. Increase the drawing display area using the scroll wheel of the mouse,
if required.

5. Draw a circle and then add the required constraints and dimensions to it, see
Figure 5-101.

6. Exit the Sketching environment.

7. Extrude the sketch to a distance of 60 mm in the upward direction and then
increase the drawing display area. The extruded feature is shown in Figure 5-
102.

After extruding the sketch, you will notice that the work plane is still visible in
the drawing window. As the work plane is not required, you need to turn off
its visibility. This is done using the Browser Bar.

8. Right-click on Work Planel in the Browser Bar to display the shortcut
menu.

In the shortcut menu, you will notice that there is a check mark beside the
Visibility option. This indicates that the work plane is visible in the drawing
window.

9. Choose the Visibility option from the shortcut menu; the check mark is
cleared making the work plane invisible. Figure 5-102 shows the model after
turning off the visibility of the work plane and changing the current view to
the isometric view.



Figure 5-101 Sketch for the cylindrical feature

Figure 5-102 Model after creating the cylindrical feature



Creating the Remaining Cut Features

1. Create the remaining cut features by creating their respective sketches on the
sketching planes. For dimensioning, refer to Figure 5-96. The final model after
creating all the cut features is shown in Figure 5-103.

Figure 5-103 Final model for Tutorial 3



Saving the Model
1. Save the model with the name Tutorial3 at the location given below and then
close the file.
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Self-Evaluation Test
Answer the following questions and then compare them to those given at the
end of this chapter:

1. The work axes are the lines passing through the model or the
feature.
2. When you select a vertex after invoking the tool, a triad is

displayed on the selected vertex.

3. When you select a planar face or a plane for defining a work plane and then

drag it, the toolbar is displayed.

4. All the operations that have been used to create a model are displayed in the
form of in the Browser Bar.

5. The check box in the More tab is selected to apply an iMate to

the edge of the solid body.

6. The planes are not visible on the screen, but the
planes are visible both on the screen and in the Browser Bar.

7. In mechanical designs, all the features are created on the XY plane. (T/F)
8. As you select a sketching plane, the Sketching environment is activated. (T/F)

9. You cannot define a sketch plane on the circular face of a cylindrical feature.
(T/F)



10. The visibility of the shared sketches is turned off by default. (T/F)

Review Questions
Answer the following questions:

1. Which of the following features is not a work feature?

(a) Work line (b) Work axis
(c) Work plane (d) Work point

2. How many planes are displayed when you click on the plus sign on the left of
the Origin folder in the Browser Bar?

@) 2 (b) 3
(©4(d)1

3. Which of the following options in the shortcut menu is used to turn off the
display of the work features?

(a) Display (b) Show
(c) Visible (d) Visibility

4. Which of the following operations is used to create a feature by retaining the
material common to the existing feature and the sketch?

(a) Cut (b) Join
(c) Intersect (d) None of these

5. In Autodesk Inventor, which of the following options displays the geometrical
dependency of a selected work point, work axis, or work plane?

(a) Show Inputs (b) Visibility
(c) Adaptive (d) Show dimensions

6. Whenever you open a new file, by default you start drawing in the XY plane.
(T/F)



7. You can create a work plane tangent to a cylinder by selecting its cylindrical
face and then the XY, YZ, or XZ plane to which the resulting work plane
should be parallel. (T/F)

8. You can create a work axis on a cylindrical feature by directly selecting it.
(T/F)

9. The All option in the Distance drop-down list of the Extents area in the
Extrude dialog box cannot be used with the Join operation. (T/F)

10. A consumed sketch can be used again for creating another feature. (T/F)



Exercise 1

Create the model shown in Figure 5-104. Its dimensions are also given in the
same figure.
(Expected time: 45 min)
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Exercise 2

Create the model shown in Figure 5-105. Its dimensions are given in Figure 5-
106. (Expected time: 30 min)
Figure 5-105 Model for Exercise 2
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Figure 5-106 The dimensions of the model for Exercise 2

Exercise 3

same figure.
(Expected time: 30 min)

Create the model shown in Figure 5-107. Its dimensions are also given in the
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Figure 5-107 Model and its dimensions for Exercise 3
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Exercise 4



Create the model shown in Figure 5-108. Its dimensions are given in Figure 5-
109. (Expected time: 45 min)
Figure 5-108 Model for Exercise 4
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Figure 5-109 Dimensions of the model for Exercise 4

Answers to Self-Evaluation Test
1. parametric, 2. Grounded Point, 3. Offset, 4. tree view, 5. Infer iMates, 6.
sketch, work, 7. F, 8. T,9.T, 10. F









Chapter 6
Advanced Modeling Tools-1

Learning Objectives

After completing this chapter, you will be able to:

* Create various types of holes.

* Create fillets on a model.

» Chamfer the edges of a model.

* Mirror features.

* Create rectangular patterns of features.

* Create circular patterns of features.

* Create rib features.

» Thicken faces or surfaces, offset faces or surfaces.
» Emboss or engrave sketched entities on a feature.

* Use the Decal tool to apply an image on a feature.
» Assign different colors/styles to a model.

ADVANCED MODELING TOOLS

Autodesk Inventor has a number of advanced modeling tools to assist you in
creating a design. These advanced modeling tools appreciably reduce the time
taken in creating the features in the models, thus reducing the designing time.
For example, to create a hole in a cylindrical feature, one option is that while
sketching the cylindrical feature, you sketch the hole also. But, to edit the
dimensions of the hole, you will have to edit the complete sketch. Also, if the
hole is drawn along with the sketch of the cylindrical feature, it will be extruded
to the same distance. However, if you want the hole to terminate before the end
of the cylindrical feature, you will have to draw another sketch. But, if you



create the hole using the Hole tool, you can specify its depth and other
parameters. The advanced modeling tools used in Autodesk Inventor are listed
below.

1. Hole
2. Fillet
3. Chamfer

4. Mirror

5. Rectangular Pattern
6. Circular Pattern

7. Rib

8. Thicken/Offset
9. Emboss
10. Decal
11. Sweep

12. Loft

13. Coil

14. Thread

15. Shell

16. Face Draft
17. Split

18. Boundary Patch
19. Stitch Surface
20. Replace Face
21. Delete Face
22. Move Face
23. Sculpt

24. Extend

Note
All features created using the advanced modeling tools are parametric in nature
and can be modified at any time.



Creating Holes

Ribbon: 3D Model > Modify > Hole Holes are circular cut features that are
created on an existing feature. Holes are generally provided

to accommodate fasteners in an assembly. You can create

drilled, counterbore, spotface, and countersink holes using the Hole tool.
On invoking this tool, the Hole dialog box will be displayed, as shown

in Figure 6-1. Alternatively, select the sketch created on an existing feature;

a mini toolbar will be displayed in the Graphics window. Choose
the Create Hole tool from the mini toolbar to invoke the Holetool. You can also

invoke the Hole tool from the Marking Menu which is displayed when vou
right-click anywhere in the graphics window. You can also specify whether
a hole is a simple, tapped, taper tapped, or clearance hole usingthe options

in the Hole dialog box. The options in this dialog box are discussed next.
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Figure 6-1 The Hole dialog box

Placement Area
The options in this area are used to specify the placement of a hole. These
options are discussed next.

Linear

If there is no unconsumed sketch in the model, this option is selected by
default in the drop-down list in the Placement area. This option is used to
place a hole by defining its location from two linear edges in the model. When
you select this option, the Face button will be enabled and chosen. As a result,
you will be prompted to select a planar face or a work plane as the placement



plane. As soon as you select the placement plane, the preview of the hole
along with the hole manipulator (sphere) will be displayed on the selected
face. Also, the Reference 1 button will be chosen and you will be prompted to
select a linear edge to reference the dimension. You can change the location of
the hole dynamically by dragging the hole manipulator. If you select a linear
edge, the Dimension edit box and the lock icon will be displayed. Using this
edit box, you can specify the distance from the center of the hole to the
selected edge. After specifying the distance value, lock this value by clicking
the lock icon; the Reference 2 button will be chosen and you will be prompted
to select a linear edge to reference the dimension. When you select the second
linear edge, the Dimension edit box and the lock icon will be displayed. Using
this edit box, you can specify the distance from the center of the hole to the
selected edge. Figure 6-2 shows the preview of a hole placed using two linear
edges.

Note
The lock icon, when enabled, helps you to keep the entered values intact.
You cannot move the hole along its references.

From Sketch

This option is used to specify the center point of a hole by selecting a sketch
point or endpoint of an unconsumed sketch. This option is selected by default
if there is an unconsumed sketch in the model. When you select this option,
the Centers button is automatically chosen in the Placement area. If the
sketch has a predefined center, it will be automatically selected as the center of
the hole. But to use the endpoints of the entities you need to select them
manually. Figure 6-3 shows the preview of a hole with a center point.

Tip. In case the From Sketch option is selected, you need to press the SHIFT
key and select the hole centers once again to exclude them from being selected.
You will notice that the preview of the hole is not displayed. It suggests that the
hole center is removed from the selection set and no hole will be created on it.



Figure 6-2 Hole placed using two linear edges

Figure 6-3 Hole placed on a center point

Concentric

This option is used to place the hole concentric to a circular feature. When you
select this option, the Plane button will be chosen in the Placement area and
you will be prompted to select a planar face or work plane as the reference
plane. This is the plane where the hole will be placed. On selecting
the placement plane, the Concentric Reference button will be chosen and you
will be prompted to select a circular edge or a cylindrical face to reference the
hole center. Select the circular edge. Figure 6-4 shows the preview of a hole
placed concentric to the cylindrical face of the fillet feature.



Figure 6-4 Preview of a hole placed concentric to the fillet

On Point

This option is used to place the hole on a work point. The work point can be
created by using the Grounded Point option from the Work Features panel
in the 3D Model tab. When you invoke this option, you will be prompted to
select a work point for the hole placement. After selecting the work point, the
Direction button will be chosen in the Placement area and you will be
prompted to select a planar face, work plane, edge, or axis. Select the required
direction; the preview of the hole to be created will be displayed, as shown in
Figure 6-5. Figure 6-6 shows the preview of the hole at the same work point
but the direction is defined by the side planar face.

Drilled

This is the first radio button in the area to the right of the Placement area. This
radio button is selected by default and is used to create a drilled hole. A drilled
hole is the one that has a uniform diameter throughout its length. The hole
diameter and depth have to be specified in the preview window on the right side
of this dialog box. Figure 6-7 shows the section view of a drilled hole.
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Figure 6-5 Direction defined using the top plane

Figure 6-6 Direction defined using the side plane

Counterbore

This radio button is available below the Drilled radio button and is used to
create a counterbore hole. A counterbore hole is a stepped hole and has two
diameters: a bigger diameter and a smaller diameter. The bigger diameter is
called the counterbore diameter and the smaller diameter is called the drill
diameter. In this type of hole, you also have to specify two depths. The first
depth is the counterbore depth. The counterbore depth is the depth up to which
the bigger diameter will be defined. The second depth is the depth of the hole,
including the counterbore depth. All these values are defined in the preview
window on the right side of the Hole dialog box. Figure 6-8 shows the section
view of a counterbore hole.
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Figure 6-8 Section view of a counterbore hole
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Spotface

This radio button is available below the Counterbore radio button and is
selected to create spotfaced holes. Spotfacing provides a seat or a flat surface at
the entrance and the surrounding area of a hole. It also allows a cap screw or bolt
to seat squarely with the material, even if the clearance hole is not normal to the
surrounding material. Spotfacing is generally carried out on castings that have
irregular surfaces. It has two diameters: a bigger diameter and a smaller
diameter. The bigger diameter is called the spotface diameter and the smaller
diameter is called the drill diameter. In this type of hole, you also have to specify
two depths. The first depth is the spotface depth, which is the depth up to which
the bigger diameter will be defined. The second depth is the depth of the hole,
excluding the spotface depth. The cross-section of a spotfaced hole is similar to

that of a counterbore hole. Figure 6-9 displays the section view of a spotface
hole.
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Figure 6-9 Section view of a spotface hole

Countersink

This radio button is provided below the Spotface radio button and is used to
create a countersink hole. A countersink hole also has two diameters, but the
transition between the bigger diameter and the smaller diameter is in the form of
a cone. You need to define the countersink diameter, drill diameter, depth of the
hole, and the countersink angle. Figure 6-10 shows the section view of a
countersink hole.

Drill Point Area
The options in the Drill Point area are used to specify whether the end of the
hole will be a flat or a tapered face. These options are discussed next.

Flat
If this radio button is selected, the end of the hole will be a flat plane.

Angle

If this radio button is selected, the end of the hole will be tapered and will
converge to a point. The angle of the taper can be defined in the Drill Point
Angle edit box provided on the right of this radio button. Figure 6-11 shows a
countersink hole with a tapered end.



Figure 6-11 Countersink hole with a tapered end

Termination Area
The drop-down list under this area is used to define the termination of the holes.
The options available in this drop-down list are discussed next.

Distance
This option is used to create a hole by defining its depth up to a certain
distance. The depth of the hole is defined in the preview window. You can



reverse the direction of hole creation by choosing the Flip button available on
right of this drop-down list.

Through All

The Through All option is used to create a hole through all features that it
comes across. The direction of the hole creation can be reversed by using the
Flip button. When you select this option, the depth of the hole is no more
displayed in the preview window because the hole will be created
automatically by cutting through all features in the specified direction. Also,
the Drill Point area will be deactivated.

To

The To option is used to terminate the hole feature at a specified plane, planar
face, or an extended face. When you select this option, the Flip button is
replaced by the Select surface to end the feature creation button. Using this
button, you can select the face to terminate the hole feature.

Note
The end condition of a hole depends on the option selected from the
Termination drop-down list. If you select the Through All option from this
drop-down list, the end of the hole will be flat (refer to Figures 6-7 and 6-8).
If you select the Distance option from it, the end of the hole will have a drill
point (refer to Figures 6-9 and 6-11).

Simple Hole
This radio button is selected by default and is used to create simple holes.

Clearance Hole

The Clearance Hole radio button is selected to create clearance holes to
accommodate standard fasteners. When you select this radio button, the Hole
dialog box expands and displays the Fastener area, as shown in Figure 6-12.
This area provides the options to create a tapped hole. These options are
discussed next.
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Figure 6-12 The expanded portion of the Hole dialog box displaying the
Fastener area

Standard
The Standard drop-down list is used to select the standard of the fastener to
be accommodated in the hole.

Fastener Type
The Fastener Type drop-down list is used to select the type of fastener to be
accommodated in the hole.

Size
This drop-down list is used to select the size of the fastener.

Fit
This drop-down list is used to specify the type of hole fit. The default option
selected is Normal.

Tapped Hole

The Tapped Hole radio button is selected to create threaded holes. When you
select this radio button, the Hole dialog box expands and displays the Threads
area, as shown in Figure 6-13. This area provides the options to create a tapped
hole. These options are discussed next.
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Thread Type
The Thread Type drop-down list is used to select the type of threads. You can
select the default type of threads in this drop-down list.

Size
This drop-down list is used to select the nominal size of the threads. The
designation and the class value will be different for different nominal sizes.

Designation
This drop-down list is used to specify the designation of the thread profile.

Class
The Class drop-down list is used to select the class of threads. Also, higher the
numeric value in this drop-down list, more accurate is the fitting.

Diameter

The options in the Diameter drop-down list are used to specify whether the
diameter defined for creating threads is the major, minor, pitch, or drill
diameter. Note that you can change this option only by using the Modeling tab
of the Document Settings dialog box. This dialog box can be invoked by
choosing the Document Settings tool from the Options panel in the Tools
tab.

Full Depth
If the Full Depth check box is selected, the threads will run through the length



of the hole. If this check box is not selected, you will have to specify the depth
up to which the threads will be created. This depth is defined in the preview
window on the right side of the Hole dialog box.

Direction Area
The options in the Direction area are used to specify the direction of the
threads. These options are discussed next.

Right Hand
The Right Hand radio button is used to create right-handed threads. A
right-handed thread enters a nut when you turn it in the clockwise direction.

Left Hand

The Left Hand radio button is used to create left-handed threads. A left-
handed thread enters a nut when you turn it in the counterclockwise
direction.

Figure 6-14 shows a hole without threads and Figure 6-15 shows a hole with
threads.

Figure 6-14 A counterbore hole without threads



Figure 6-15 A counterbore hole with threads

Taper Tapped Hole

The Taper Tapped Hole radio button is selected to create taper threaded holes.
When you select this radio button, the Hole dialog box expands and displays the
Threads area, as shown in Figure 6-16. This area provides the options to create
different types of taper threaded holes. These options are discussed next.
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Figure 6-16 The expanded portion of the Hole dialog box

Thread Type
The Thread Type drop-down list is used to select the type of threads. You can
select the default type of threads in this drop-down list.



Size
This drop-down list is used to select the nominal size of the threads. The
designation and the class value will be different for different nominal sizes.

Designation
This drop-down list is used to specify the designation of the thread profile.

Class
The Class drop-down list is used to select the class of threads. Also, higher the
numeric value in this drop-down list, more accurate is the fitting.

Diameter

The Diameter drop-down list is used to specify whether the diameter defined
for creating the threads is the major, minor, pitch, or the drill diameter of the
original hole. The default option selected is Minor.

Direction Area
The options in the Direction area are used to specify the direction of the
threads. These options are discussed next.

Right Hand
The Right Hand radio button is used to create right-handed threads. A
right-handed thread enters a nut when you turn it in the clockwise direction.

Left Hand

The Left Hand radio button is used to create left-handed threads. A left-
handed thread enters a nut when you turn it in the counterclockwise
direction.

Figure 6-17 shows the section view of a straight hole with threads and Figure 6-
18 shows the section view of a tapered hole with threads.



Figure 6-17 Section view of a straight hole with threads
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Figure 6-18 Section view of tapered hole with threads

Infer iMates
This check box is available below the Termination area and is selected to create
an iMate on the hole feature.

Note
The Taper Tapped Hole radio button in the dialog box is not active in case of
creating counterbore hole.

Creating Fillets
Ribbon: 3D Model > Modify > Fillet

In Autodesk Inventor, you can add fillets or rounds using the Fillet tool. Fillets
are generally used to apply curves on the interior edges of a model and result in
concave surfaces by adding material. Rounds are generally used to apply curves
on the exterior edges and result in convex surface by removing the material.




Autodesk Inventor allows you to create different types of fillets. You will learn
about these fillets in the following topics.

Creating Edge Fillets

To create edge fillets, choose the Fillet tool; the Fillet dialog box will be
displayed, as shown in Figure 6-19. Alternatively, invoke the Fillet dialog box
by choosing the Create Fillet tool from the mini toolbar that is displayed when
you select the edge to be filleted. By default, the Edge Fillet button is chosen in
the Fillet dialog box. As a result, the options to create the edge fillet are
displayed. Also, the preview of the fillet along with the modified mini toolbar
will be displayed on the selected edge, as shown in Figure 6-20. You can enter
the radius of the fillet in the edit box of the mini toolbar and choose OK to

create the fillet. The options available under various tabs of the Fillet dialog box
are discussed next.
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Figure 6-19 The Fillet dialog box

Figure 6-20 Mini toolbar displayed on invoking the Fillet tool

Constant Tab



The options under this tab are used to fillet the selected edges such that they
have a constant radius throughout their length. However, different edges can
have a different fillet radius.

Edges: This column displays the number of edges you selected. However, note
that all the edges selected will have the same fillet radius. If you want to
specify a different fillet radius to some edges, click on the text Click to add;
another row will be added. Now, if you select an edge, it will be displayed in
the second row. The second row can be assigned a different fillet radius.

Radius: In this column, you can specify the fillet radius for the selected edges.
Different rows can have different radii. You can also specify the fillet radius
for the selected edges by entering the radius value in the edit box of the mini
toolbar or by dragging the arrow manipulator.

Continuity: This drop-down list is available on the right of the Radius
column. In this drop-down list, you can select the option to apply tangent
continuity or smooth (G2) continuity.

Select Mode Area: The options under this area are used to set the priorities of
selection for filleting.

Edge: If the Edge radio button is selected, you can select the individual
edges of a model for filleting. As you move the cursor close to any of the
edges, the edge is highlighted.

Loop: The Loop radio button is used to select all the edges of a face of the
model. To use this option, select the Loop radio button and move the cursor
close to an edge of the face; all its edges will be highlighted. Click at this
stage to select all the edges of the face. Remember that edges selected using
this option will have the same fillet radius.

Feature: If the Feature radio button is selected, all edges in the selected
feature will be selected for filleting. In this case, all the selected edges will

also be applied with the same fillet radius.

Solids: The Solids button is used to select a body in a multi-body environment



so that the resultant fillet feature becomes a portion of the body. When you
choose this button, you can create rounds or fillets on all edges of the selected
body. It will only be active in a multi-body environment.

All Fillets: The All Fillets check box is selected to create concave-shaped
fillets at all possible edges. Note that the fillet radius is same at all places.
Figure 6-21 shows a model with fillets.

All Rounds: The All Rounds check box is selected to create convex-shaped
fillets at all possible edges. All exterior corners will also be curved if you
select this check box. The radius for all rounds will be the same. Figure 6-22
shows a model with rounds.

Figure 6-21 Model with fillets

Figure 6-22 Model with rounds

Enable/Disable feature preview: This check box is used to enable or disable
the preview of a fillet feature. If this check box is selected, the preview of the
fillet will be displayed in the drawing window.



Note

In Autodesk Inventor, if any of the edges in a fillet selection set is not fit to create
a fillet of the specified radius, a message box will be displayed showing the
number of edges that can not be filleted at the specified radius.

Variable Tab

The options in the Variable tab, as shown in Figure 6-23, are used to fillet the
selected edges such that they can be applied different radii along their length.
If you select a linear or a curved edge, there will be two points on the edge,
one at the start point and the other at the end point. However, if you select a
circular edge, no point will be defined. You can add points by specifying their
desired location on the edge.

Edges: This column displays the number of edges selected to be filleted. You
can select more edges by clicking on Click to add option. Figure 6-23 shows
the Fillet dialog box with the Variable tab active.
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Figure 6-23 The options in the Variable tab

Continuity Drop-down List: This drop-down list is used to specify the type of
fillet to be created. The options in the drop-down list are discussed next.

Tangent Fillet
When the Tangent Fillet option is selected in the drop-down list, the resulting



fillet feature maintains tangent continuity (G1) with the adjacent faces.

Smooth (G2) Fillet

When the Smooth (G2) Fillet option is selected in the drop-down, the
resulting fillet feature maintains smooth continuity (G2) with the adjacent
faces. When this option is selected, the curvature is applied gradually, which
makes the resulting fillets more smooth.

Figure 6-24 shows the fillet created with the Tangent Fillet option and Figure
6-25 shows the fillet created with the Smooth (G2) Fillet option.

Point: This column displays the points selected on the edge. By default, there
will be only two points, Start and End, in this column. These two points refer
to the start and end points of a linear or curved edge. To add a point, move the
cursor on the edge; the preview of the point is displayed. Click to place the
point. As soon as you add a point by specifying its location on the edge, it will
be added in this column. Similarly, you can add as many points as required on
the edge. As mentioned earlier, if you select a circular edge for adding a
variable fillet, no point will be added by default. You need to add all the points
manually by clicking on the edge.

Radius: The Radius column displays the radius at a point selected on an edge.
When you click on a value field in this column, it changes to an edit box.
Also, the point selected on the edge is displayed under the Point column. You
can change the radius value of a point by selecting its corresponding value
field in the Radius edit box and entering a new value in it. You can access all
options explained previously using a more compact and user-friendly mini
toolbar.



Figure 6-24 Fillet created using the Tangent Fillet option

Figure 6-25 Fillet created using the Smooth (G2) Fillet option

Position: This edit box is used to define the position of the point specified on
an edge. Remember that the position is defined in terms of the percentage of
the selected edge. This edit box will not be available until you select a point
other than the default points on an edge. The length of the selected edge is
taken as 1 (100 percent) and the position of the new point will be defined
anywhere between 0 and 1. For example, a value of 0.5 will suggest that the
point is placed at the midpoint of the edge. Figures 6-26 and 6-27 show the
variable fillets on the edges of a model.



Figure 6-26 Defining the fillet radius

Figure 6-27 Model after creating the variable fillet

Smooth radius transition: This check box is selected to allow a smooth
transition between all the points defined in an edge. If this check box is
selected, there will be a smooth blending between all points, as shown in
Figure 6-28. If it is cleared, the blending will be linear, as shown in Figure 6-
29.



Figure 6-28 Edges with Smooth transition

Figure 6-29 Edges with Linear transition

Setbacks Tab

The options in the Setbacks tab are used to specify the setbacks of the
transition between the three edges that comprise a vertex. The setback
smoothly blends the transition surfaces between the selected edges and the
vertex that you define to fillet. To add a setback fillet, first you need to select
the three edges that intersect at a corner by using the Constant tab and then
choose the Setbacks tab, refer to Figure 6-30. The options in this tab are
discussed next.
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Figure 6-30 The options in the Setbacks tab

Vertex: After you have selected three edges and set the radius of the fillet
using the Constant tab, invoke the Setbacks tab; you will be prompted to
select the common vertex to add the setback. Select the vertex common to the
three selected edges. The selected vertex will be displayed in this column. You
can also add more vertices by clicking on Click to add.

Minimal: This check box is selected to define the minimum allowable setback
for a given vertex. You can solve difficult vertex fillets with smoothest
transition by using this option.

Edge: This column displays the edges common to the vertex selected on a
model. The edge that will have the arrow in front will be highlighted in the
drawing window.

Setback: This column displays the setback value for the transition along the
edge selected. You can modify this value by clicking on it. Figures 6-31 and 6-
32 show the fillets created using different setback values.



Figure 6-31 Fillet with setback value = 2

Figure 6-32 Fillet with setback value = 10

Note
You cannot set the radius of a fillet by using the Setbacks tab. It will be set in the

Constant tab where you have selected the edges.

>> (More)
This button is available at the lower right corner of the Fillet dialog box.

When you choose this button, the Fillet dialog box will expand and display
some more options, refer to Figure 6-33. All these options are discussed next.

[ |Roll along sharp edges Help Point
7| Roling ball where possible B |Faint

[ | Automatic Edge Chain —

[ |Preserve All Features

Figure 6-33 More options of the Fillet dialog box



Roll along sharp edges: This check box is selected to modify the radius of the
fillet in order to retain the shape and the sharpness of the edges of the adjacent
faces. If this check box is cleared, the adjacent faces will extend in case the
fillet radius is more than what can be adjusted in the current face. Figure 6-34
shows the fillet created with the Roll along sharp edges check box cleared
and Figure 6-35 shows the fillet created with this check box selected.

Rolling ball where possible: This check box is selected to create a rolling ball
fillet, wherever it is possible. If this check box is cleared, the transition at the
sharp corners will be continuously tangent. Figure 6-36 shows the rolling ball
fillet created by selecting this check box and Figure 6-37 shows the tangent
fillet created by clearing the check box. Note that you need to select all the
edges in a single fillet sequence to use this option.

Figure 6-34 Fillet created with the Roll along sharp edges check box cleared

Figure 6-35 Fillet created with the Roll along sharp edges check box selected



Figure 6-36 Rolling ball fillet

Figure 6-37 Tangent fillet

Automatic Edge Chain: If this check box is selected, all tangent edges will
also be selected on selecting an edge to fillet.

Preserve All Features: This check box is selected to calculate the intersection
of all the features that intersect with the fillet. If this check box is cleared, the
intersection of only the edges that are a part of the fillet will be calculated.

Creating Face Fillets

You can create the face fillets using the Face Fillet tool. When you create the
fillet using this tool, the material is added or removed completely or partially
based on the geometric conditions, to accommodate the fillet. To create a fillet
between two faces, invoke the Fillet dialog box. Next, choose the Face Fillet
button located below the Edge Fillet button in the Fillet dialog box; the dialog
box will be modified, as shown in Figure 6-38 and you will be prompted to
select faces to blend. The options used to create a face fillet are discussed next.
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Figure 6-38 The Fillet dialog box for creating the face fillet

Face Set 1: This button is chosen by default and is used to select the first face
to create the face fillet. You can choose the Flip button on the right of this
button to reverse the direction in which the fillet will be created. The Flip
button will be activated only if you are creating the face fillet between two
surfaces. As soon as you select the first face, it will be highlighted in blue and
the Face Set 2 button will be chosen. If you have to select multiple faces to
create the fillet, you need to clear the Optimize for Single Selection check
box available in this dialog box.

Face Set 2: This button is used to select the second face to create the face
fillet. You can choose the Flip button on the right of this button to reverse the
direction in which the fillet will be created. The face that you select as the
second face to blend will be highlighted.

Radius Area: The edit box available in this area is used to specify the face
fillet radius. If the default value specified in this edit box is valid to create the
fillet, the preview of the fillet will also be displayed as soon as you select the
face set 2.

Include Tangent Faces: If this check box is selected, all faces tangent to the
selected face sets will also be selected to create the fillet.

Optimize for Single Selection: If this check box is selected, then on selecting
the first face the Face Set 2 button will be automatically chosen. If this check
box is cleared, you can select multiple faces.



>> (More): This button is available at the lower right corner of the Fillet
dialog box. When you choose this button, the Fillet dialog box will expand
and display some more options, refer to Figure 6-39. The Help Point area in
the More option is discussed next.

Rall along sharp edges [ "] Help Point
Raolling ball where possible % Paint
Automatic Edge Chain

[ |Preserve All Features

Figure 6-39 More options for creating the face fillet

Help Point Area: This area is available when you choose the More button
from the Fillet dialog box. When you select this check box, the Point button
will be enabled this button allows you to place help point on one of the faces
selected to be filleted if there are multiple fillet solutions. Figure 6-40 shows
the faces selected to create the face fillet and Figure 6-41 shows the resulting

face fillet.
E[acesetZ
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Figure 6-40 Faces selected to create a face fillet



Figure 6-41 Resulting face fillet

Tip. You can also apply different types of fillet by using the mini toolbar
displayed in the graphics window, refer to Figure 6-42.
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Figure 6-42 The mini toolbar displayed on choosing the Fillet tool

Creating Full Round Fillets
A full round fillet is a semicircular fillet created between two side faces that are

separated by a centre face. In this case, the system determines the required
radius value, based on the side faces and center face. To create this type of fillet,

choose the Full Round button available below the Face Fillet button of the

Fillet dialog box; the options for creating the full round fillet will be displayed
in the dialog box, as shown in Figure 6-43. Also, you will be prompted to select

the faces to blend. The options used for creating a full round fillet are discussed
next.
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Figure 6-43 The options in the Fillet dialog box to create the full round fillet

Side Face Set 1
This button is chosen by default and isused to select the first side face. As

soon as you select the first side face, the Center Face Set button is chosen.
The side face 1 is highlighted.

Center Face Set

This button is chosen to specify the center face for the full round fillet. Note
that this face will be removed from the fillet. As soon as you select the center
side face, the Side Face Set 2 button is chosen. The center face is highlighted.

Side Face Set 2
This button is chosen to specify the second side face. As soon as you select the

second side face, the preview of the fillet will be displayed. The side face 2 is
highlighted.

Figure 6-44 shows the faces to be selected to create the full round fillet and
Figure 6-45 shows the resulting fillet.

Note
The remaining options to create the full round fillet are the same as those

discussed while creating the face fillet.
T
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Figure 6-44 Faces to be selected to create the fillet

Figure 6-45 Resulting face fillet

Creating Chamfers

Ribbon: 3D Model > Modify > Chamfer Chamfering is a process of
beveling the sharp edges of a model to reduce stress
concentration. In Autodesk Inventor, chamfers are
created using the Chamfer tool. To create a chamfer,
choose the Chamfer tool from the Modify panel of the 3D
Model tab; the Chamfer dialog box will be displayed, as
shown in Figure 6-46. Alternatively, choose the Create
Chamfer tool from the mini toolbar that is displayed on
selecting the edge to be chamfered. In the Chamfer dialog
box, the Edges button will be active by default. As a
result, you will be prompted to select an edge. Select the




required edge(s); the preview of the chamfer along with
the modified mini toolbar will be displayed on the
selected edge(s), refer to Figure 6-47. You can enter the
chamfer value(s) either in the edit box(es) of the mini
toolbar or in the Distance edit box(es) of the Chamfer
dialog box. Next, specify the chamfer option and then
choose OK to create the chamfer with the specified
options.
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Figure 6-46 The Chamfer dialog box

Figure 6-47 Mini toolbar displayed on the selected edge by invoking the Chamfer tool

The options in the Chamfer dialog box are discussed next.

Distance



This is the first button in the dialog box and is provided on the upper left corner
of the Chamfer dialog box. This button is chosen to create a chamfer such that
the selected edge is equidistant from both the faces. The chamfer thus created
will be at 45-degree angle. Since both the distance values are the same,
therefore, there will be only one edit box in the Distance area. You can specify
the chamfer distance in it. You can also invoke the Distance option from the
mini toolbar and specify the chamfer distance by dragging the arrow head
manipulator.

Distance and Angle

This is the second method of creating chamfers. This option is used to create a
chamfer by defining the chamfer distance and angle. On choosing this button,
you will be prompted to select the face to be chamfered. This is the face from
which the angle will be calculated. After selecting the face, you will be
prompted to select an edge. Select the edge to be chamfered. The distance value
and the angle value can be specified in their respective edit boxes in the dialog
box. You can also invoke the Distance and Angle option from the mini toolbar
and then specify the chamfer distance and the angle by dragging the
corresponding manipulators in it.

Two Distances

This button is chosen to create a chamfer by using two different distances. You
can also invoke this option from the mini toolbar. The distance values can be
specified in the Distancel and Distance2 edit boxes. These edit boxes are
displayed when you choose this button. You can also specify the chamfer
distances by dragging the corresponding manipulators in the mini toolbar. The
distance values can be interchanged by choosing the Flip button available below
the Edge button.

Figure 6-48 shows the Chamfer dialog box with the Distance and Angle option
chosen and Figure 6-49 shows the Chamfer dialog box with the Two Distances
option chosen.
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Figure 6-48 The Chamfer dialog bo?c with the Distance and Angle option
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Figure 6-49 The Chamfer dialog box with the Two Distances option chosen

Figure 6-50 shows the model before chamfering and Figure 6-51 shows the model after chamfering.

Figure 6-50 Edges selected for chamfering



Figure 6-51 Model after chamfering

>> (More)

Edge Chain Setback
DD (35
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Figure 6-52 More options in the Chamfer dialog box

This button is available at the lower right corner of the dialog box. When you
choose this button, the Chamfer dialog box will expand and display some
more options, refer to Figure 6-52. These options are discussed next.

Edge Chain Area

The buttons in this area are used to set the priorities for selecting the edges to
be chamfered. If you choose the All tangentially connected edges button, all
the edges that are tangent to the selected edge will also be selected for
chamfering. If you choose the Single edge button, the tangent edges will be
ignored.

Setback Area

The buttons in this area are used to specify whether or not a setback will be
applied to the model. If you choose the Setback button, the setback will be
applied and the vertex will be flattened. However, if you choose the No
setback button, the setback will not be applied and the vertex will be pointed.
Figure 6-53 shows the chamfer created with a setback and Figure 6-54 shows
the chamfer without a setback.



Figure 6-53 Chamfer with a setback

Figure 6-54 Chamfer without a setback

Note
1. The Preserve All Features check box is the same as that discussed in the
Fillet dialog box.

2. The Setback area will be activated only when you select the Distance button
in the Chamfer dialog box.

Mirroring Features and Models
Ribbon: 3D Model > Pattern > Mirror The Mirror tool is used to create the

mirrored copies of selected features or to mirror the entire model by using a

mirror plane. The plane that can be used to mirror the features can be a planar
face or a work plane. On using this tool, an exact replica of the selected entities

will be created on the other side of the mirror plane. On choosing



the Mirror tool, the Mirror dialog box will be displayed, as shown in Figure 6-
55, and you will be prompted to select the feature to be mirrored. The options in

the Mirror dialog box are discussed next.

Mirroring Features

In Autodesk Inventor Professional, you can create symmetric models using the
Mirror tool, you can mirror filleted features in symmetrical models. To mirror a
fillet feature, choose the Mirror individual features button from the Mirror dialog
box; the Features button will be activated and you be will prompted to select the
feature that you want to mirror. Select the filleted feature, as shown in Figure 6-
58. Next, select the Mirror Plane button in the Mirror dialog box and then
specify the midplane across which you want to create the mirror feature. Choose
OK to apply the mirror and exit the Mirror dialog box. Figure 6-59 shows the
mirrored feature with the midplane. You can turn off the visibility of the
midplane from the Browser Bar. To do so, select the work plane and then right-
click; a shortcut menu will be displayed. Choose the Visibility option from the
shortcut menu; the plane will become invisible. You can turn on the visibility of
the plane by choosing the Visibility option again.

Mirror @
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Figure 6-55 The Mirror dialog box




~Features

Figure 6-57 Model after mirroring the features and hiding the work plane

Mirroring Fillets

In Autodesk Inventor Professional, you can create symmetric models using the
Mirror tool, you can mirror filleted features in symmetrical models. To mirror
a fillet feature, choose the Mirror individual features button from the
Mirror dialog box; the Features button will be activated and you be will
prompted to select the feature that you want to mirror. Select the filleted
feature, as shown in Figure 6-58. Next, select the Mirror Plane button in the
Mirror dialog box and then specify the midplane across which you want to
create the mirror feature. Choose OK to apply the mirror and exit the Mirror
dialog box. Figure 6-59 shows the mirrored feature with the midplane. You
can turn off the visibility of the midplane from the Browser Bar. To do so,
select the work plane and then right-click; a shortcut menu will be displayed.
Choose the Visibility option from the shortcut menu; the plane will become
invisible. You can turn on the visibility of the plane by choosing the Visibility



option again.

Figure 6-58 Fillet to be mirrored

Figure 6-59 Mirrored fillet feature

Mirroring Models

To mirror the entire model, choose the Mirror solids button from
the Mirror dialog box; the entire model will be selected and highlighted. Also,
the Mirror Plane button will be chosen and you will be prompted to select a
plane to mirror about. You can choose the Include Work/Surface Features
button to select the work features that you want to mirror. Selecting the Remove
Original check box allows you to remove the original model after it has been
mirrored. You can select one body from a set of multiple bodies to pattern by
choosing the Selid button from the Mirror dialog box. Choose the Join button
to merge the selected solid body to the pattern. Figure 6-60 shows the model
selected to be mirrored, the highlighted mirror plane, and the preview of the



mirrored model. Figure 6-61 shows the mirrored model.

Figure 6-60 Selecting a model to be mirrored
and the mirror plane

Figure 6-61 The model after mirroring the entire model

>> (More)

This button is available at the lower right corner of the Mirror dialog box. If
you choose this button, the Mirror dialog box will expand and display some
other options, refer to Figure 6-62. These options are discussed next.
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Figure 6-62 Other options in the Mirror dialog box

Optimized
This radio button is selected to mirror the model as the direct copy of the



original model without any overlapping.

Identical

This radio button is selected to create a mirrored feature that is exactly similar
to the original feature, even if it intersects other features. This radio button is
active by default.

Adjust

This radio button is available only when you mirror features and is selected if
the feature to be mirrored terminates on a face of the model. In this case, the
mirror feature will modify its termination such that it adjusts in the model.

Creating Rectangular Patterns
Ribbon: 3D Model > Pattern > Rectangular

You can use the Rectangular tool to create a rectangular pattern of
the selected features or surfaces, or the entire model. When you invoke this tool,
the Rectangular Pattern dialog box will be displayed, as shown in Figure 6-63. The
options in this dialog box are discussed next.
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Figure 6-63 The Rectangular Pattern dialog box

Pattern individual features
This button is chosen to create a pattern of the selected features. You can select
the features using the Features button that is available on the right of this



button.

Pattern a solid

This button is chosen to select the entire model to create a pattern. You can
choose the Include Work/ Surface Features button on the right of this button
to select the work features that you want to include in the pattern of the model.

Direction 1/Direction 2 Area

Most of the options in the Direction 1 and Direction 2 areas are similar to those
discussed in the Rectangular Pattern dialog box in the Sketching environment.
However, there are some additional options and they are discussed next.

Midplane

This button is selected to place the items symmetrically on both sides of the
original feature. If there are even number of items in the pattern, the additional
item is placed on the side in which the direction arrow points.

Spacing
The Spacing option, which is the default selected option, is used to specify the
distance between the items in terms of the spacing between individual items.

Distance
The Distance option is used to specify the total distance between the first and
the last instances of the feature to be patterned in a particular direction.

Curve Length

The Curve Length option is used to select the length of the edge selected to
define direction 1 or 2 as the distance between all the items in the pattern.
When you select this option, the Spacing edit box is not enabled.

Figure 6-64 shows the hole to be selected for creating a rectangular pattern and
Figure 6-65 shows the model after creating a rectangular pattern.



Figure 6-64 Hole to be patterned

Figure 6-65 Model dfter creating the pattern

If you choose the >> (More) button at the lower right corner of the dialog box,
the dialog box will expand and display more options, as shown in Figure 6-66.
These options are discussed next.

Figure 6-66 More options in the Rectangular Pattern dialog box

Direction 1/Direction 2 Area



The Start buttons in these areas are used to specify the start point of the path
along the first or second direction. You can use this option in association with
the Curve Length option. For example, when you define the first and second
directions using the edges, two green points are displayed at their corners. These
points specify the start points of the path along both the directions. Now, select
the Curve Length option from the drop-down list available in the Direction 1
and Direction 2 areas and then select the start points in direction 1 and direction
2. You will notice that the selected feature starts patterning from the start points
specified.

Compute Area
The options under this area are discussed next.

Optimized

The Optimized radio button is used to create optimized pattern instances for a
lesser calculation time. This option is not useful while working on complex
patterns such as when the pattern instances are intersected by some other
features.

Identical
The Identical radio button is selected, if you want the patterned features to be
exactly similar to the original feature, even if they intersect other features.

Adjust

The Adjust radio button is selected if any of the patterned features terminate
at a face of the model. In this case, the patterned features will be modified
such that they adjust in the model. But the pattern calculation time in such
cases is longer.

Orientation Area
The options under this area are discussed next.

Identical
The Identical radio button is selected to specify the orientation of the

patterned items to be the same as that of the original item.

Direction 1



The Direction 1 radio button is selected to orient the items with reference to
the first direction.

Direction 2
The Direction 2 radio button is selected to orient the items with reference to
the second direction.

Note

All instances of the rectangular pattern are arranged in the Browser Bar with
the name Rectangular Pattern and a number suffixed to it. The number indicates
the order in which a particular pattern was created. To suppress a feature
pattern, right-click on it in the Browser Bar and choose Suppress Features. The
remaining options in the Rectangular Pattern dialog box are similar to those
discussed under the Rectangular Pattern dialog box in Chapter 4.

For a better understanding of the Orientation options, create a pattern only in
the first direction and use a circular edge to define the first direction. Now, one
by one, set the orientation to Identical and Direction 1 and notice the difference
in the orientation of the items. For example, Figure 6-67 shows the preview of
the rectangular pattern oriented using the Identical option and Figure 6-68
shows the preview of the rectangular pattern oriented using the Directionl
option. Note that in both these options, the first direction of the pattern is defined
using the circular edge.

Figure 6-67 Preview of the pattern oriented using the Identical option



Figure 6-68 Preview of the pattern oriented using the Directionl option

Note
In Figures 6-67 and 6-68, the pattern is created only along one direction
that is defined by the circular edge of the cylindrical feature.

Creating Circular Patterns
Ribbon: 3D Model > Pattern > Circular

In the Part module, you can use the Circular tool to arrange
the selected features around an imaginary cylinder, thereby creating a
circular pattern. When you invoke this tool, the Circular Pattern dialog box
will be displayed. If you choose the >> button from this dialog box, this dialog
box will expand, as shown in Figure 6-69.




Circular Pattern @

-
¥ | Rotation Axis

Solid

Placement

ot [B v| [Ge0deg Pl
[2) C Caneel <<
Creation Method Positioning Method
Optimized Incremental
@) Identical @ Fitted

Adjust

Figure 6-69 The expanded Circular Pattern dialog box

Most options in the Placement and Positioning Method areas are similar to
those discussed in the sketching environment. The remaining options of this
dialog box are discussed next.

Pattern individual features
This button is chosen by default and is used to select the individual features to
create the circular pattern.

Pattern a solid
This button is chosen to pattern the entire solid. You can also select work
features to be patterned along with solid by choosing the Include Work/Surface
Features button.

Rotation Axis

The Rotation Axis button is chosen to select the axis about which the features
will be arranged. The entities that can be selected as the rotation axis include a
work axis or a linear edge of any face of the model. You can also select a
cylindrical feature, whose central axis will be selected as the axis of rotation.

Midplane

This button is selected to place the items symmetrically on both sides of the



original feature. If there are even number of items in the pattern, the additional
item is placed on the side in which the direction arrow points.

Creation Method Area

The options under this area will be displayed when you choose the button with
two arrows provided at the lower right corner of this dialog box. These options
are discussed next.

Optimized

The Optimized radio button is used to create optimized pattern instances for a
lesser calculation time. This option is not useful while working on complex
patterns such as when the pattern instances are intersected by some other
features.

Identical
This radio button is selected if you want the patterned features to be exactly
similar to the original feature, even if they intersect other features.

Adjust

This radio button is selected if any patterned feature terminates at a face of the
model. In this case, the patterned features will be modified such that they
adjust in the model.

Figure 6-70 shows a model before creating the circular pattern and Figure 6-71
shows the model after creating the circular pattern. In this case, the cylindrical
feature is selected for defining the axis of rotation. By doing so, you will select
its central axis as the axis of rotation.

Feature to be selected

Cylindrical
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Figure 6-70 Model before creating the pattern



Figure 6-71 Model after creating the pattern

Positioning Method Area

This area is used to define the spacing between instances of the features. The
options in this area works in combination with the Angle edit box and they are
discussed next.

Incremental

This option is used to determine the orientation of each pattern with respect to
the previous pattern. If you select this radio button, the angle that you specify
in the Angle edit box will be considered as the incremental angle between
patterns. Therefore, the circular pattern will be created such that the angle
between the two items is equal to the angle specified in the Angle edit box.
Figure 6-72 shows the pattern created by selecting this radio button and at an
incremental angle of 20 degrees.

Fitted

If you select this radio button, the circular pattern will be created such that all
items are fitted within the angle specified in the Angle edit box. This radio
button is selected by default in the Circular Pattern dialog box. Figure 6-73
shows the pattern created by selecting this radio button and within an angle of
20 degrees.



Figure 6-73 Pattern created using the Fitted radio button

Creating Rib Features

Ribbon: 3D Model > Create > Rib

Ribs are defined as thin wall-like structures used to bind joints together so that
they do not fail under an increased load. They are used to increase the stiffness
of the whole structure. In Autodesk Inventor, ribs are created using an open
profile, refer to Figures 6-74 and 6-75.




Figure 6-74 Sketch for the rib feature

Figure 6-75 The rib feature

Remember that before invoking the Rib tool, you must have an unconsumed
sketch. When you invoke the Rib tool, the Rib dialog box will be displayed,
refer to Figure 6-76. The options in this dialog box are discussed next.

Figure 6-76 The Rib dialog box

Type Specification Area



This area is located on extreme left of the Rib dialog box. It has two options:
Normal to Sketch Plane and Parallel to Sketch Plane. These options are
discussed next.

Normal to Sketch Plane

This button is chosen by default. When this option is selected, the rib sketch is
extruded normal to the sketch plane and the thickness of the rib feature is
added parallel to the sketch plane. Additionally, on choosing this button, three
tabs, Shape, Draft, and Boss become available in the Rib dialog box.

Parallel to Sketch Plane

This is the second button available in the Type Specification area of the Rib
dialog box. If this button is chosen, then the rib sketch will be extruded
parallel to sketch plane but the thickness of the rib will be added normal to the
sketch plane. On choosing this button, only the Shape tab is available in the
Rib dialog box.

Shape Tab
The options under this area are used to select the profile of the rib or the web
feature as well as the direction of the feature creation. These options are
discussed next.

Profile

The Profile button is chosen to select the sketch of the rib or the web feature.
If there is a single unconsumed sketch, it will be automatically chosen when
you invoke the Rib tool.

Solid

This button will be active only when there are multiple solid bodies in the
graphics window. Choose this button to select the required body from the
graphics window for creating the rib feature.

Direction1/Direction2

The Directionl/Direction2 button is chosen to define the direction in which
the rib or the web feature will be created. The feature can be created in a
direction normal to the selected sketch or parallel to it. After selecting the
sketch for the rib feature, choose the Direction 1 or Direction 2 button and



the direction of rib extrusion will change accordingly. A dynamic preview of
the resulting feature can also be seen along with the direction. Note that the rib
feature will be successful only if it is created in the direction in which it
intersects the existing model faces.

Thickness Area

The options under this area are used to define the thickness of the rib or the
web feature. The thickness is specified in the Thickness edit box. This area
also has three buttons that are used to define the direction, in which the
thickness will be applied. You can apply the thickness on either side of the
sketch or equally on both sides.

Extents Area

The buttons in this area are used to specify whether the feature will be
extended to the next face or to a specified distance. The two buttons in this
area are discussed next.

To Next
If this button is chosen, the rib or web feature will be created such that it
merges with the next face, refer to Figure 6-77.

Finite

Choose the Finite button to create the rib or web feature to a specified
distance, refer to Figure 6-78. The distance is specified in the Extent edit box
that will be displayed in this area when you choose the Finite button. The
direction is controlled using the Direction button in the Shape area.

Figure 6-77 Rib created by extending the sketch to the next face



Figure 6-78 Rib created by extending the sketch to a specified distance

Extend Profile

The Extend Profile check box will be activated when you select the direction to
apply the thickness parallel to the sketch or choose the Finite button from the
Extents area. If the sketch of the rib feature does not intersect with a face of
the model, and this check box is selected, the rib feature will be extended such
that it intersects the face of the model.

Draft Tab

This tab will be only available when the Normal to Sketch Plane button is
chosen from the Rib dialog box, as shown in Figure 6-79. The options available
in the Draft tab are used to provide a draft angle to the web feature. When a
draft angle is applied to parts, it becomes easier to take them out of the mould
without any damage.

Different options available in the Draft tab of the Rib dialog box are discussed
next.

Hold Thickness Area

This area has two radio buttons: At Top and At Root. These radio buttons are
used to control the origin of draft angles. If the At Top radio button is
selected, the draft will be applied to the top of the rib feature, but if the At
Root radio button is selected, the draft will be applied to the bottom of the
feature. The bottom of the sketch is the point where the rib feature ends. The
preview of the draft when the At Top radio button is selected is shown in
Figure 6-79. The Draft Angle edit box is used to specify the draft angle to be



applied to the rib feature.
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Figure 6-79 The Draft tab of the Rib dialog box

Note
While applying draft, all angles are applied with respect to the vertical axis,
as the direction of the draft is always vertical.

Boss Tab

The Boss tab of the Rib dialog box is only available when the Normal to
Sketch Plane button is chosen in the Type Specification area of the Rib dialog
box.

In most of the injection moulding components, the mounting bosses are used to
hold internal and external parts together. Figure 6-80 shows the Boss tab of the
Rib dialog box.
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Figure 6-80 The Boss tab of the Rib dialog box




The options available in the Boss tab of the Rib dialog box are discussed next.

Centers
The Centers button is chosen by default. This button is used to select the
center of the draft.

Diameter
This edit box is used to specify the diameter of the boss feature to be created,
refer to Figure 6-80.

Offset
This edit box is used to specify the offset distance of the boss feature, refer to
Figure 6-80.

Draft Angle
This edit box is used to specify the draft angle to be applied to the boss
feature, refer to Figure 6-80.

Thickening or Offsetting the Faces of Features
Ribbon: 3D Model > Maodify > Thicken/Offset

You can thicken a specified face or offset it using the Thicken/Offset tool. You
can achieve the resulting output as a solid face or a surface. You can also use
this tool to offset or thicken a surface. The resulting feature can be a surface or a
solid face of the specified thickness. On invoking this tool, the Thicken/Offset
dialog box will be displayed. The options provided in various tabs of this dialog
box are discussed next.

Thicken/Offset Tab

The options in the Thicken/Offset tab, shown in Figure 6-81, are discussed
next.

Select

The Select button is chosen to select the face or the surface to thicken or
offset. When you invoke the Thicken/Offset dialog box, this button is chosen
by default and you are prompted to select faces.
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Figure 6-81 The Thicken/Offset tab of the Thicken/Offset dialog box

Solids
Choose this button to select the required multi-body from the Graphics
window for offsetting the selected face or surface.

Filter Area

This area is available on upper right side of the Thicken/Offset dialog box
and it provides two radio buttons. The Face radio button is selected to restrict
the selection to the faces of the solid models. The Quilt radio button is
selected to restrict the selection to the surfaces only. Note that if you select the
Face radio button, you can also select a surface. This is because a surface is
also considered as a face.

Distance

The Distance edit box is used to specify the offset distance or the thickness
value of the resulting feature. Note that you are also allowed to offset a
selected face or a surface with a zero distance, making a copy at the same
location. However, in this case, the output can only be a surface.

Output Area

The two buttons in the Output area are used to specify the output of using the
Thicken/Offset tool. If you choose the Solid button, the resulting feature will
be a solid face. If you choose the Surface button, the resulting feature will be
a surface. Figure 6-82 shows a surface and Figure 6-83 shows a solid face



created by offsetting the surface by a distance of 4 mm.

Figure 6-84 shows the output of this tool in the form of an offset surface. In
this case, the offset distance is also 4 mm.

Figure 6-82 Original surface

Figure 6-83 Solid face created by offsetting the surface by a distance of 4 mm

Figure 6-84 Output in the form of an offset surface



Operation Area
The Operation area is on the right of the Output area and has four buttons.
These four buttons Join, Cut, Intersect and New solid are used to specify the
resulting operation to be performed using the Thicken/Offset tool. Note that
these buttons will not be available if the output of this tool is a surface. The
functions of these buttons are the same as those discussed in the Extrude
dialog box. The Join button is chosen for creating a join feature, the Cut
button for a cut feature; and the Intersect button for an intersect feature. The
New solid button is used to create a new solid that is independent of other
solid bodies in the Graphics window. Figure 6-85 shows a feature created by
offsetting the top face of the base feature by using the Join operation. Figure
6-86 shows the feature created by offsetting the same face by using the Cut
operation.

Note
It is evident from Figures 6-85 and 6-86 that the resultant feature is always
normal to the selected face or surface.

Figure 6-85 Offsetting the top face by using the Join operation



Figure 6-86 Offsetting the top face by using the Cut operation

Direction Area

This area with three buttons is located below the Distance edit box. The
buttons in this area are used to specify the direction in which the resulting
feature will be created.

More Tab
The options in the More tab, as shown in Figure 6-87, are discussed next.
Thicken/Offset 23]
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Create Vertical Surfaces
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Figure 6-87 The More tab of the Thicken/Offset dialog box

Automatic Face Chain

This check box is used to automatically select all tangent faces that form a
chain with a selected face. To use this option, invoke the Thicken/Offset
dialog box and then choose the More tab. Select this check box and then
select the face by using the Select button in the Thicken/Offset tab. You will



notice that all tangent faces that form a chain with the selected face are
automatically selected.

Create Vertical Surfaces

This check box is used to create the vertical sides of internal surfaces.
Remember that this option is available only if the output of this tool is a
surface. Also, it works only if the original face selected to be offset is a
surface. Figure 6-88 shows a surface selected to be offset and Figure 6-89
shows the resulting offset surface with the side faces created by selecting the
Create Vertical Surfaces check box. Note that the original surface selected to
be offset in this case is removed.

Surface selected
to be offset

Figure 6-88 Surface selected to be offset

Figure 6-89 Resulting offset surface with side faces

Allow Approximation
This check box is selected to allow Autodesk Inventor to make some



assumptions if the exact thicken or offset solution of the model cannot be
determined. When you select this check box, the options in this area will be
enabled. The drop-down list in this area is used to specify the type of
approximation to be made. You can select the Mean, Never too thin, or
Never too thick option from this drop-down list. The Optimized radio button
is selected to make an optimized approximation such that minimum time is
required. Selecting the Specify Tolerance radio button allows you to specify
the tolerance that will be used to make the approximation. If the tolerance is
more, the time required to compute the feature will be increased.

Creating the Embossed and Engraved Features
Ribbon: 3D Model > Create > Emboss

The Emboss tool allows you to «create an embossed or
engraved feature. Generally, this tool is used to emboss or engrave text on an
existing feature. This tool remains inactive until a sketch or a text is available in
the graphics window. When you invoke this tool, the Embossdialog box will be
displayed, as shown in Figure 6-90. The options in this dialog box
are discussed next.
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Figure 6-90 The Emboss dialog box

Profile

The Profile button is chosen to select the profile or the text to be engraved or
embossed. When you invoke this dialog box, this button is chosen automatically
and you are prompted to select the profile.

Solid



This button is used to select the required body from the graphics window for
offsetting the selected face or surface.

Depth
The Depth edit box is used to enter the depth of the embossed or engraved
feature.

Top Face Appearance
The Top Face Appearance button, present below the Depth edit box, is chosen
to assign a different color to the top face of the embossed or engraved feature.

When you choose this button, the Appearance dialog box will be displayed.
This dialog box has a drop-down list that can be used to select a color to assign
to the top face of the new feature.

Emboss from Face

The Emboss from Face button is used to create an embossed feature. The
selected profile or text is projected on a face and then a join feature is created.
The shape of the join feature is defined using the profile or text selected to be
embossed. Note that the depth you define is calculated from the plane on which
the feature is created and not from the sketching plane. Figure 6-91 shows a
model with an embossed text.

Engrave from Face

The Engrave from Face button is used to create an engraved feature. The
selected profile or text is projected on a face and then a cut feature is created. A
material equivalent to the shape of the profile or text is removed from the feature
on which it is projected. Figure 6-92 shows a model with text engraved in it.
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Figure 6-91 Model with the embossed text

Figure 6-92 Model with the engraved text

Emboss/Engrave from Plane

The Emboss/Engrave from Plane button is used to create a feature that is
embossed and engraved feature. The profile or the text is extruded in both the
directions of the sketch plane. When you select this option, the Taper edit box
appears in the Emboss dialog box. You can enter the taper value for the
emboss/engrave feature in it. Note that when you choose this button, the Depth
edit box is not displayed. Figure 6-93 shows a model with the embossed text.

Direction
The direction buttons are used to reverse the direction of the embossed or
engraved features.

Wrap to Face

The Wrap to Face check box is selected to wrap the embossed or engraved
feature such as the face of a revolved feature around a curved face. When you
select this check box, the Face button will becomes available. This button allows



you to select the face on which the feature will be embossed or engraved. Figure
6-94 shows a bottle with an embossed text wrapped on the outer face.

Figure 6-94 Bottle with an embossed text wrapped on the outer face

Applying Images on a Feature
Ribbon: 3D Model > Create > Decal

While designing a product, you may need to apply an image to the product. The
image can be the label of a company, a bar code, an instruction
for handling the component, and so on. These images can be applied on the
feature using the Decal tool. When you invoke this tool, the Decal dialog box
will be displayed, as shown in Figure 6-95. The options in this dialog box are
discussed next.

Decal @1

|:| Wrap to Face

Chain Faces

F iéure 6-95 The Decal dialog box




Image

The Image button is chosen by default and is used to select the image to be
applied to the feature. Note that before invoking the Decal tool, you need to
insert an image in the sketch by using the Insert Image tool from the Insert
panel of the Sketch tab.

Face
The Face button is chosen to select the face on which the image will be applied.

Wrap to Face

The Wrap to Face check box is selected to wrap an image about a circular face.
This check box will not be active if you select a non-circular face. Figure 6-96
shows a bottle after wrapping an image on it. In this figure, the circular face of
the bottle was selected as the face to transfer the image.

Figure 6-96 Image wrapped on a bottle

Chain Faces

The Chain Faces button is chosen to select all tangentially connected chain
faces to transfer an image. Figure 6-97 shows a model with the side edges
filleted and an image. The top face of this model is selected to transfer the
image. Notice that the image appears on the filleted chain faces automatically, as
shown in Figure 6-98.



Figure 6-98 Model after applying the image

ASSIGNING DIFFERENT COLORS/STYLES TO A
MODEL

Autodesk Inventor allows you to change the color/style of a model to improve its
appearance. You can apply a different color/style to a model by selecting an
appropriate option from the Appearance drop-down list available on the
extreme right of the Quick Access Toolbar. Note that this drop-down list will
be activated only when a model is available in the graphics window. By default,
the Default style will be applied to the model. To change the color/style of the
model, click on the Appearance drop-down list; the list of all available styles
and colors will be displayed, as shown in Figure 6-99. Select the required
style/color from the list displayed; the selected style or color will automatically
be applied to the model.

If you want to change the style/color of a particular feature in a model, select the
required feature from the Browser Bar or from the drawing window and then
choose the required style or color from the Appearance drop-down list.



You can also assign a different color/style to feature by right-clicking on it in the
Browser Bar. On doing so, a shortcut menu will be displayed. Choose the
Properties option from the shortcut menu; the Feature Properties dialog box
will be displayed. Select the required color/style from the Feature Appearance
drop-down list of this dialog box.

To change the style/color of a particular face, select the required face and right-
click; a shortcut menu will be displayed. Choose Properties from the shortcut
menu; the Face Properties dialog box will be displayed, refer to Figure 6-100.
Select the required style/color from the Face Appearance drop-down list and
choose the OK button.
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Figure 6-99 The Appearance Override drop-down list
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Figure 6-100 The Face Properties dialog box

ASSIGNING DIFFERENT MATERIAL TO A MODEL

Autodesk Inventor allows you to change the material of a model. You can apply
a different material to a model by selecting the appropriate option from the
Material drop-down list available in the Quick Access Toolbar. By default,



generic material will be applied to the model. To change the material of the
model, click on the Material drop-down list; a list of available materials will be
displayed, as shown in Figure 6-101. Select the required material from the list
displayed; the selected material will be applied to the model.

If you want to override the material of the model, select the required component
from the Browser Bar or from the drawing window and then choose the required
material from the Material drop-down list; the existing material will be
overridden with the selected material.

Modifying the Properties of an Existing Material

In Autodesk Inventor, you can also edit the material properties of an existing
material with the help of the Material Browser dialog box. To invoke the
Material Browser dialog box, choose the Material tool from the Quick Access
Toolbar; the Material Browser dialog box will be displayed, as shown in
Figure 6-102. To edit the material properties, move the cursor over the material
that you want to edit; two buttons, Add material to documents and Add
material to document and displays in editor are highlighted. Choose the Adds
materials to documents and displays in editor button; the Material Editor
dialog box will be displayed, as shown in Figure 6-103. Now, you can edit the
identity, appearance, and physical properties of the material by specifying
appropriate values in their respective edit boxes in the Identity, Appearance,
and Physical tabs of this dialog box. After changing the properties of the
material, the material is added in the Document Material area of the Material
Browser dialog box. Now choose Apply, and then the OK button from the
Material Editor dialog box.
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Identity | Appearance 2 | Physical 2

Mame | CFRP

Descriptive Information
Description | Carbon fiber reinforced cpoxy
Type | Plastic

TUTORIALS
Tutorial 1

In this tutorial, you will create the model of a Fixture Base shown in Figure 6-
104. Its dimensions are given in the same figure. After creating the solid model,
you will change its color to yellow. (Expected time: 45 min)

The following steps are required to complete this tutorial:

a. Start a new part file and invoke the Sketching environment. Create the sketch
for the base feature on the XZ plane and extrude it to a distance of 102 mm,
refer to Figure 6-105.

b. Define a new sketch plane on the back face of the base feature and create the
join feature, refer to Figure 6-108.

c. Create two cylindrical features with holes on the front face of the second
feature, refer to Figure 6-110.

d. Create the fillet on the base feature, refer to Figure 6-111.

e. Create two counterbore holes taking the reference of the cylindrical faces of
fillets by using the Hole tool, refer to Figure 6-112.

f. Finally, draw an open sketch and convert it into a rib using the Rib tool to
complete the model, refer to Figure 6-114.

g. Change the appearance of the model by using the Appearance drop-down list
in the Quick Access Toolbar.



Creating the Base Feature
You need to create the base feature on the XZ plane.

1. Start a new metric standard part file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

3. Select the XZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the XZ plane becomes parallel to the
screen. Alternatively, select the XZ plane from the Graphics window.

Note
1. Before selecting the sketching plane, you need to choose the Home button
from the ViewCube in order to maintain the right orientation of the model.

2. If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as
> Top/Frontfrom the flyout.

4. Create the sketch for the base feature. Add the required constraints and
dimensions to it. The sketch after adding constraints and dimensions is shown
in Figure 6-105.

5. Exit the Sketching environment and extrude the sketch to a distance of 102
mm using the Extrude tool to create the base feature. The base feature is
shown in Figure 6-106.
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Figure 6-104 Views and dimensions of the model for Tutorial 1
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Figure 6-105 Sketch for the base feature



Figure 6-106 Base feature

Creating a Join Feature on the Back Face of the Base Feature

1. Define a new sketch plane on the back face of the base feature. Draw the
sketch for the join feature and then add the required constraints and
dimensions to it. The sketch after adding constraints and dimensions is shown
in Figure 6-107.

2. Exit the Sketching environment and then extrude the sketch to a distance of 20
mm toward the front of the base feature, as shown in Figure 6-108.
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Figure 6-107 Sketch for the join feature
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Figure 6-108 Model dafter creating the join feature

Creating Cylindrical Features on the Front Face of the Second Feature

To create two cylindrical features, you need to draw a sketch consisting of
two concentric circles. The reason for drawing the sketch for both the features
together is that both the cylindrical features are to be extruded to the same
distance.

Figure 6-109 Sketches for the cylindrical features

1. Define a new sketch plane on the front face of the second feature and draw the
sketches for both the cylindrical features, as shown in Figure 6-109.

2. Invoke the Extrude tool and extrude the sketches to a distance of 10 mm.

While selecting profiles for extrusion, in both sketches make sure that you click
between the inner and outer circles. As a result, the inner circles are subtracted
from the outer circles when you extrude the sketch, thus creating holes. The
model after creating the cylindrical features is shown in Figure 6-110.



Figure 6-110 Model after creating cylindrical features

Creating Fillets

The vertical edges of the front face of the base feature need to be filleted so that
you can use the cylindrical faces of fillets to define the center of the
counterbore holes.

1. Choose the Fillet tool from the Modify panel of the 3D Model tab; the Fillet
dialog box is displayed and you are prompted to select the edges to be filleted.
By default, the Constant tab is chosen in this dialog box.

2. Select the outer left and outer right vertical edges on the front face of the base
feature.

On selecting the edges, the Edges column displays 2 selected edge and the
preview of the fillet is displayed on the model with 2 mm as the default radius
value.

Figure 6-111 Model dfter creating fillets



3. Click on the default radius value in the Radius column and enter 30 in the edit
box displayed. Alternatively, enter 30 in the edit box of the mini toolbar. You
will notice that the fillet in the preview of the model has also increased
accordingly. Choose the OK button to exit the Fillet dialog box; the fillets are
created, as shown in Figure 6-111.

Creating Counterbore Holes

As mentioned earlier, in Autodesk Inventor, you can create holes concentric to
cylindrical faces. To create two counterbore holes, you need to use the
cylindrical faces of the fillet.

1. Choose the Hole tool from the Modify panel of the 3D Model tab to invoke
the Hole dialog box.

2. Select the Counterbore radio button from the area located on the right of the
Placement area.

3. Select the Concentric option from the drop-down list in the Placement area;
the Plane button is chosen in the Placement area and you are prompted to
select a planar face or a work plane for the placement plane.

4. Select the top planar face of the base feature as the face to place the hole; the
preview of the counterbore hole with the current values is displayed. Also, the
Concentric Reference button is chosen automatically and you are prompted
to select a circular edge or a cylindrical face to reference the hole center.

5. Select the cylindrical face of the fillet on the right; the preview of the hole is
relocated.

6. Select the Through All option from the drop-down list in the Termination
area. Modify the value of the counterbore diameter in the preview window to
38. Similarly, modify the value of the bore diameter to 20 and the counterbore
depth to 6.



7. Without closing the Hole dialog box, choose the Apply button to create the
hole.

8. Similarly, using the options already set in the Hole dialog box, create another
hole concentric to the fillet on the left.

9. Choose Cancel to close the Hole dialog box. The model after creating the
counterbore holes is shown in Figure 6-112.

Figure 6-112 Model after creating counterbore holes

Creating the Rib Feature

The rib feature is created at the center of the model. Therefore, you need to
define an offset work plane at the center on which the rib feature will be
created.

1. Choose the Offset Plane tool from 3D Model > Work Features > Plane
drop-down and select the right face of the base feature; the preview of the
work plane along with the mini toolbar is displayed in the Graphics window.

2. Enter -108 in the edit box available in the mini toolbar and then choose OK
from it. The negative value ensures that the work plane gets created inside the
model. Select this work plane as the sketching plane.

3. Draw an open sketch for the rib feature and then add the required constraints
and dimensions to it, as shown in Figure 6-113.



When you apply the Coincident constraint between the lines in the sketch and
the edges of the model, the lines defining the edges are drawn. Make sure
these lines are not selected when you select the sketch for creating the rib
feature.

4. Exit the Sketching environment. Next, invoke the Rib dialog box and choose
the Parallel to Sketch Plane button from the Rib dialog box. Select the open
profile. You need not select the direction button and move the cursor.

5. Set the value in the edit box in the Thickness area to 30. Choose to exit the
Rib dialog box. The final model after creating all features is shown in Figure
6-114.

j
Figure 6-114 Final model for Tutorial 1



Changing the Appearance of the Model
When a model is created, the default color is applied to it. However, in Autodesk
Inventor, you can change the default color/style of the model.

1. Select the Yellow option from the Appearance drop-down list on the right of
the Quick Access Toolbar; the color of the model changes to yellow. Note
that you do not need to select the model to apply color to it.

2. Save the model with the name Tutoriall at the location C:\Inventor_2016\c06
and then close the file.

Tutorial 2

In this tutorial, you will create a model of the Pivot Base shown in Figure 6-115.
Its dimensions are given in the same figure. Change the color/style of the model
to Zinc Chromate. (Expected time: 45 min)

The following steps are required to complete this tutorial:

a. Create the base feature on the XZ plane, refer to Figure 6-116.

b. Create the join feature on the back face of the base feature, refer to Figure 6-
119.

c. Create another join feature on the front face of the second feature, refer to
Figure 6-121.

d. Create the cut feature on the third feature, refer to Figure 6-123.

e. Create the rib and the join feature on the right of the model, refer to Figure 6-
127.

f. Mirror the rib and the join feature on the left of the model, refer to Figure 6-
128.

g. Create a hole on the top face of the base feature, refer to Figure 6-130.

h. Change the style of the model by using the Appearance drop-down list in the
Quick Access Toolbar.
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Figure 6-115 Views and dimensions of the model for Tutorial 2

Creating the Base Feature
1. Start a new metric part file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the



sketching plane.

3. Select the XZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the XZ plane becomes parallel to the
screen. Alternatively, select the XZ plane from the Graphics window.

Note
1. Before selecting the sketching plane, you need to choose the Home button
from the ViewCube in order to maintain the right orientation of the model.

2. If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to
the ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.

4. Draw the sketch of the base feature, as shown in Figure 6-116.

5. Exit the Sketching environment.

6. Click on the sketch in the Graphics window; the mini toolbar with the Create
Extrude, Create Revolve, and Edit Sketch tools is displayed.

7. Choose the Create Extrude tool; the Extrude dialog box is displayed. Also,
the preview of the extrude feature along with the mini toolbar is displayed.

8. Enter 96 in the edit box of the mini toolbar and choose OK to create the base
feature of the model, as shown in Figure 6-117.

Fa—51—F=i—

120 o]

Figure 6-116 Sketch of the base feature



Figure 6-117 Base feature

Creating a Join Feature on the Back Face of the Base Feature
1. Rotate the model by using the ViewCube such that its back face is visible.

2. Select the back face of the base feature; the mini toolbar along with the Edit
Extrude, Edit Sketch, and Create Sketch tools is displayed in the Graphics
window.

3. Choose the Create Sketch tool and draw the sketch for the next feature on it,
as shown in Figure 6-118.

4. Extrude the sketch to a distance of 14 mm toward the front of the base feature
by using the Extrude tool, see Figure 6-119.

Figure 6-118 Sketch of the join feature
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Figure 6-119 Model dfter creating the join feature

Creating the Join Feature on the Front Face of the Second Feature
1. Define a new sketch plane on the front face of the second feature.

2. Draw two disjoint sketches of the join feature, as shown in Figure 6-120.
3. Extrude both sketches to a distance of 14 mm using the Extrude tool. The
model after creating the join feature is shown in Figure 6-121. Note that the

two sketches are displayed as a single feature in the Browser Bar because
both the sketches are extruded together.
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Figure 6-120 Sketches of the join feature on the front face
Figure 6-121 Join feature on the front face of the second feature




Creating the Cut Feature

Next, you need to create a cut feature that will remove material from the
previous feature. You need to draw two disjoint sketches for the cut feature at
the same time and then extrude them using the Cut operation. As the sketches
are to be extruded through the model, you need to select both of them together
while selecting the profile for creating the cut feature.

. Define a new sketch plane on the front face of the semicircular feature. When
you define the sketch plane on the semicircular feature, a sketch defining the
semicircular feature is drawn. Offset this sketch inside, refer to Figure 6-122.
Note that after invoking the Offset tool, you need to right-click, and then
choose the Loop Select option from the shortcut menu. This ensures that the
entire loop is offset. Since you have used a reference entity to draw the inner
sketch, you need to specify just one dimension value, that is, the radius of any
of the arcs.

. Draw the sketch for the cut feature and the circle for the hole, refer to Figure
6-122.

. Extrude the sketch and the circle by using the Through All option of the Cut
operation in the mini toolbar to create the cut feature, see Figure 6-123.



Figure 6-123 Model after creating the cut feature

Creating the Rib Feature

The sketch for the rib will be created on the sketch plane defined on the right
face of the second feature. The sketch will be extruded toward the left to
create the feature.

1. Define a new sketch plane on the right face of the second feature and then
draw the sketch of the rib feature. Add the required dimensions and constraints
to the sketch, as shown in Figure 6-124.

2. Exit the Sketching environment and choose the Rib tool from the Create
panel of the 3D Model tab; the Rib dialog box is displayed. By default, the
Normal to Sketch Plane button is chosen in the Type Specification area.
Choose the Parallel to Sketch Plane button in this area.

3. Select the open sketch. Choose the second direction button in the Thickness
area to extrude the feature toward left. Next, choose the Direction2 button
from the dialog box; the preview of the rib feature is displayed, showing the
sketch extruded toward the left of the sketch.



4. Enter 10 in the Thickness edit box in the Thickness area.

5. Choose OK to exit the Rib dialog box; the rib is created, as shown in Figure
6-125.
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Figure 6-125 Model after creating the rib

Creating the Join Feature on the Right Face of the Base Feature
1. Define a new sketch plane on the right face of the base feature.

2. Draw the sketch of the join feature. Draw a circle inside the sketch such that
when extruded, a hole is created automatically. Add the required constraints
and dimensions to it, as shown in Figure 6-126, and then exit the Sketching
environment.

3. Extrude the sketch to a distance of 12 mm to create the feature. Make sure that
you select the profile by using a point inside the outer loop but outside the
circle. The model after creating the join feature is shown in Figure 6-127.
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Figure 6-127 Model dafter creating the join feature

Mirroring Features on the other Side of the Model

The second set of rib and join features will be created by mirroring the first set
of these features on the other side of the model. The features will be mirrored
about the offset work plane created at the center of the model.

1. Choose the Offset From Plane tool from 3D Model > Work Features >
Plane drop-down; you are prompted to select a planar surface.

2. Select the right face of the base feature; the preview of the plane along with
the mini toolbar is displayed.

3. Enter -111 in the edit box of the mini toolbar and then choose OK; the plane
is created.



4. Choose the Mirror tool from the Pattern panel of the 3D Model tab; the
Mirror dialog box is displayed and you are prompted to select the features to
be patterned. Select the rib feature and the feature created on the right face of
the base feature.

5. Choose the Mirror Plane button and select the offset work plane as the
mirror plane; the preview of the mirrored features is displayed. Choose OK to
exit this dialog box.

6. Right-click on the work plane in the Browser Bar to display the shortcut
menu. Choose the Visibility option from the shortcut menu to turn off the
visibility of the work plane. The model after mirroring the features is shown in
Figure 6-128.

Figure 6-128 Model after mirroring the features

Creating the Hole on the Top Face of the Base Feature
1. Choose the Hole tool from the Modify panel of the 3D Model tab to invoke
the Hole dialog box.

2. Select the Linear option from the drop-down list in the Placement area; the
Face button is chosen and you are prompted to select a planar face or a work
plane.

3. Select the top planar face of the base feature. Next, select the edge labeled 1
on the top face of the base feature, refer to Figure 6-129; the mini toolbar is
displayed.



4. Modify the value in the edit box of the mini toolbar to 88.

5. Similarly, select the edge labeled 2 on the top face of the base feature and
modify the value to 41, refer to Figure 6-129.

6. Select the Through All option from the drop-down list in the Termination
area.

7. Set the value of the diameter of the hole in the preview window to 22; the
diameter of the hole in the preview also increases automatically. Choose the
OK button. The final model for Tutorial 2 is shown in Figure 6-130.

Changing the Style and Saving the Model
As mentioned earlier, the style of the feature is changed using the Appearance
drop-down list in the Quick Access Toolbar.

1. Select the Zinc Chromate 2 option from the Appearance drop-down list
available on the extreme right of the Quick Access Toolbar; the material of
the model is changed to Zinc Chromate.

2. Save the model with the name Tutorial? at the location C:\Inventor_2016\c06
and then close the file.

Figure 6-129 The preview of the hole feature



Figure 6-130 Final model for Tutorial 2

Tutorial 3

In this tutorial, you will create the model shown in Figure 6-131. Its views and

dimensions are also given in the same figure. After creating a solid model, you

will change the color of the front face of base feature to green color. (Expected

time: 30 min)

The following steps are required to complete this tutorial:

a. Create the sketch of the base feature on the YZ plane and extrude it using the
Symmetric option, refer to Figures 6-132 and 6-133.

b. Create the second feature on the YZ plane and extrude it using the Symmetric
option, refer to Figures 6-134 and 6-135.

c. Create one of the holes on the front face of the second feature and then create
a circular pattern of this hole, refer to Figures 6-136 and 6-137.

d. Create the cylindrical join feature and then create a hole in it, refer to Figure
6-140.

e. Create the circular patterns of the last join feature and the hole, refer to Figure
6-141.

f. Finally, create the central hole, refer to Figure 6-142.

g. Change the color of the front face of the base feature.

The base feature of this model will be created on the YZ plane. Also, all features
in this model will be extruded using the Symmetric option because they extend
equally from the front face and the back face of the base feature.
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Figure 6-131 Views and dimensions of the model for Tutorial 3

Creating the Base Feature

The base feature of this model will be created on the YZ plane. Therefore, you

need to invoke the Sketching environment and then define a new sketch plane
on the YZ plane.



1. Start a new metric standard part file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the

sketching plane.

Note
1. Before selecting the sketching plane, you need to choose the Home button

from the ViewCube in order to maintain the right orientation of the model.

2. If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as

> Top/Frontfrom the flyout.

3. Select the YZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the YZ plane becomes parallel to the

screen. Alternatively, select the YZ plane from the Graphics window.

Draw the sketch of the base feature, as shown in Figure 6-132.

4. Add the required constraints and dimensions to the sketch, refer to Figure 6-
132. Exit the Sketching environment and then extrude the sketch to a distance
of 22 mm using the Symmetric option. The base feature of the model is

B4l

shown in Figure 6-133.
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Figure 6-132 Sketch of the base feature



Figure 6-133 Base feature of the model

Creating the Next Join Feature

As the last feature was created on the YZ plane and extruded using the
Symmetric option, you can also create other features on the same plane and
extrude them using the Symmetric option.

1. Choose the Start 2D Sketch tool from 3D Model > Sketch > Sketch drop-
down; you are prompted to select a plane or a planar face to create the sketch.

2. SelectYZ plane from the Browser Bar; the Sketching environment is
invoked. As the sketch is drawn inside the model, it is hidden by the faces that
lie between the sketch and the user. Therefore, you need to slice the model.

3. Right-click in the drawing window to display a shortcut menu and choose
Slice Graphics from it.

4. Draw the sketch of the join feature, as shown in Figure 6-134. For dimensions,
refer to Figure 6-131.

5. Exit the Sketching environment and then extrude the sketch to a distance of 32
mm using the Symmetric option. The model after creating the join feature is
shown in Figure 6-135.



Figure 6-134 Sketch of the join feature

Figure 6-135 Model dfter creating the join feature

Note
It is recommended that you create a big circle and a small circle on the
periphery of the base feature. Trim the unwanted portion of the small circle
and then pattern the small circle, refer to Figure 6-134.

Creating the Hole and its Pattern

Next, you need to create six holes on the previous feature. Instead of creating all
holes, create one hole and then create a circular pattern of this hole. To create
the pattern, you need to create one hole by defining the sketch plane on the
front face of the previously created feature.

1. Choose the Hole tool from the Modify panel of the 3D Model tab; the Hole
dialog box is displayed. Select the Concentric option from the drop-down list
in the Placement area.

2. Select the front planar face of the second feature as the plane to place the hole
and then select one of the six semicircular features.

3. Select the Through All option from the drop-down list in the Termination
area.



4. Modify the value of the diameter of the hole in the preview window to 6.
Choose OK to exit the dialog box. The model after creating one of the holes is
shown in Figure 6-136.

5. Choose the Circular tool from the Pattern panel of the 3D Model tab; the
Circular Pattern dialog box is displayed and you are prompted to select the
feature to be patterned.

6. Select the hole from the Graphics window. Next, choose the Rotation Axis
button from the dialog box and then select the outer cylindrical face of the
second join feature.

As you select the cylindrical face to specify the rotation axis, an axis passing
through its center is displayed and the preview of the hole pattern is displayed
on the model. Also, a copy of the hole is displayed on each of the semicircular
features.

7. In the Circular Pattern dialog box, accept the default values and choose OK
to exit this dialog box. The model after creating the hole pattern is shown in
Figure 6-137.

Figure 6-136 Model after creating the hole



Figure 6-137 Model after creating the hole pattern

Creating the Cylindrical Join Feature
The cylindrical join feature will also be created on the YZ plane and will be
extruded using the Symmetric option.

1. Define a new sketch plane on the YZ plane and then slice the graphics. Draw
a circle as the sketch of the cylindrical join feature, as shown in Figure 6-138.
Add the required constraints and dimensions to the sketch.

2. Exit the sketching environment and then extrude the circle to a distance of 32
mm using the Symmetric option, refer to Figure 6-139.

Figure 6-138 Sketch of the cylindrical join feature



Figure 6-139 The cylindrical join feature

Creating the Hole in the Join Feature
1. Choose the Hole tool from the Modify panel of the 3D Model tab; the Hole
dialog box is displayed.

2. Select the Concentric option from the drop-down list in the Placement area,
if it has not already been selected.

3. Select the front face of the previous feature and then the cylindrical face of the
same feature to place the hole.

4. Select the Through All option from the drop-down list in the Termination
area, if it has not already been selected.

5. Modify the value of the diameter of the hole in the preview window to 20.
Choose OK; the dialog box is closed and a hole is created. The model after
creating the hole on the join feature is shown in Figure 6-140.

Creating Circular Patterns

1. Choose the Circular tool from the Pattern panel of the 3D Model tab; the
Circular Pattern dialog box is displayed and you are prompted to select the
feature to be patterned.

2. Select the cylindrical join feature and the hole from the Graphics window or
the Browser Bar to pattern; both the features are displayed with a blue
outline.

3. Choose the Rotation Axis button and select the bottom cylindrical face of the
base feature to define the axis of rotation for the pattern.



The preview of the pattern with six items arranged through an angle of 360
degrees is displayed on the model. As the pattern shown in the preview is not
the required pattern, you need to modify values in the Circular Pattern dialog
box.

4. Enter 3 and 81 in the Occurrence Count and Occurrence Angle edit boxes,
respectively in the Placement area.

Note
Sometimes the orientation of the pattern features in the preview does not
match with the required orientation. In such a case, you need to choose the
Flip button that is located on the right of the Rotation Axis button in the
Circular Pattern dialog box.

5. Accept the other default values and choose OK to create the circular pattern.
The model after creating the pattern is shown in Figure 6-141.

Figure 6-140 Model after creating the hole on the join feature



Figure 6-141 Model after creating the circular pattern of the join feature and
the hole

Creating the Hole on the Second Feature (Join Feature)

1. Choose the Hole tool from the Modify panel of the 3D Model tab; the Hole
dialog ox is displayed. Select the Concentric option from the drop-down list
in the Placement area.

2. Select the front face of the second feature and then the cylindrical face of the
same feature to place the hole.

3. Select the Through All option from the drop-down list in the Termination
area, if it has not already been selected.

4. Modify the value of the diameter of the hole in the preview window to 40.

5. Choose OK to create the hole and exit the dialog box. The isometric view of
the final model for Tutorial 3 is shown in Figure 6-142.



Figure 6-142 Final model

Changing the Color of the Front Face of the Base Feature
As mentioned earlier, you need to change the color of the face by using the
Properties option.

1. Select the front face of the base feature and right-click; a Marking menu is
displayed.

2. Choose the Properties option from the Marking menu; the Face Properties
dialog box is displayed.

3. Click on the Face Appearance drop-down list and select the Green Polished
option from it. Next, choose the OK button; the color of the front face of the
base feature turns green.

4. Save the model with the name Tutorial3 at the location C:\Inventor_2016\c06
and then close the file.

Tutorial 4

In this tutorial, you will create a bottle and then write text on the upper circular
face of the bottle, as shown in Figure 6-143. The wall thickness of the bottle is 1
mm. Also, apply an external image from your computer, to the bottle. The
dimensions of the bottle are shown in Figure 6-144. (Expected time: 30 min)



Figure 6-143 Bottle with an image and text wrapped on it

Figure 6-144 Dimensions of the bottle
The following steps are required to complete this tutorial:

a. Create the bottle by revolving a sketch drawn on the XZ plane, refer to Figure
6-145.

b. Write the text such that it can be wrapped on the upper circular face of the
bottle, refer to Figure 6-147.

c. Emboss the text on the bottle such that it is wrapped on it, refer to Figure 6-

150.
d. Insert an image into the Sketching environment and then apply it to the bottle
such that it is wrapped around it, refer to Figure 6-150.

Creating the Bottle
First, you need to create the sketch of the bottle on the XZ plane.



1. Start a new metric template file.

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

3. Now, select the XZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the XZ plane becomes parallel to the
screen. Alternatively, select the XZ plane from the Graphics window.

Note
1. Before selecting the sketching plane, you need to choose the Home button
from the View Cube in order to maintain the right orientation of the model.

2. If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to the
ViewCube; a flyout is displayed. Next, choose Set Current View as
> Top/Frontfrom the flyout.

4. Draw the sketch of the bottle and then offset it outward to a distance of 1 mm
to create a hollow bottle. Join the endpoints of the sketch using the Line tool
to create a closed sketch, as shown in Figure 6-145.
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Figure 6-145 Sketch for the bottle



5. Add the required constraints and specify the dimensions, refer to Figure 6-
145.

Note
In Figure 6-145, the display of grids has been turned off for the clarity of
the sketch.

6. Exit the Sketching environment and then invoke the Revolve tool.

7. Select the sketch from the Graphics window and then select Z Axis as the axis
of revolution from the Browser Bar; the preview of the revolved feature is
displayed in the Graphics window. Choose OK to create the revolved feature
and exit the dialog box.

8. Next, select the Glass option from the Materials and Appearance drop-
down list. On doing so, the material of the bottle is changed to the selected
material, as shown in Figure 6-146.

Embossing the Text on the Bottle

Next, you need to write the text and emboss it on the bottle. The text is written
on a work plane created tangent to the outer face of the bottle and parallel to
the YZ plane.

1. Choose the Tangent to Surface and Parallel to Plane tool from 3D Model >
Work Features > Plane drop-down; you are prompted to select a curved face
or a planar face.

2. Select the YZ plane from the Browser Bar and then select the lower
cylindrical part of the bottle; a work plane tangent to the bottle and parallel to
the YZ plane is created. Note that the plane needs to be created in the front of
the bottle.

3. Select the new work plane as the sketching plane and then invoke the Start
2D Sketch tool.



4. Choose the Text tool from Sketch > Create > Text drop-down and then drag
the cursor or click in the drawing window; the Format Text dialog box is
displayed.

Tip. If the text is written in the reverse direction, you need to flip the normal of
the work plane. To do so, exit all tools and then select the work plane. Next,
right-click on the selected work plane, and then choose Flip Normal from the
shortcut menu.

5. Select 3.50 mm from the Size drop-down list and enter CADCIM
Technologies in the Text Window of the Format Text dialog box. Choose to
exit the dialog box; the text is displayed in the drawing window, as shown in
Figure 6-147. If the text created is not at the position shown in Figure 6-147,
you can select it and drag it to the required position.

Figure 6-146 Bottle with the selected material



Figure 6-147 Partial view of the bottle displaying the position of the text

6. Exit the Sketching environment and then choose the Embeoss tool from the
Create panel of the 3D Model tab in the Ribbon; the Embeoss dialog box is
displayed and you are prompted to select the profile.

7. Select the text and then choose the Top Face Appearance button below the
Depth edit box; the Appearance dialog box is displayed. Select the Gold -
Metal option from the drop-down list in the Appearance dialog box. Choose
OK to exit this dialog box.

8. Select the Wrap to Face check box. Next, choose the Face button, if it is not
already been chosen and select the neck of the bottle on which you need to
wrap the text. Choose OK to exit the dialog box. The partial view of the bottle
after wrapping the text on it is shown in Figure 6-148.



Figure 6-148 Partial view of the bottle after wrapping the text
Note
If the embossed feature is created on the backside of the neck, you need to
reverse its direction by choosing the corresponding direction button from

the Emboss dialog box. The direction buttons are available above the Wrap
to Face check box.

Wrapping the Image on the Bottle

Next, you need to insert an image into the Sketching environment and then wrap
it on the bottle. It is recommended that you copy the image to the current
folder and then insert in the Sketching environment.

1. Copy any external image to the current folder and then choose the Start 2D
Sketch tool from the Sketch panel of the 3D Model tab; you are prompted to
select the plane.

2. Select the tangent work plane created earlier as the sketching plane to invoke
the Sketching environment.

3. Choose the Image tool from the Insert panel of the Sketch tab; the Open
dialog box is displayed.

4. In the Open dialog box, select the image that you have copied and then
choose the Open button; the preview of the image attached to cursor is



displayed in the Graphics window and you are prompted to select the sketch
point.

5. Click in the Graphics window to place the image. Right-click, and then choose
OK from the shortcut menu. You may need to resize and relocate the image
such that its size and location is close to that shown in Figure 6-149.

6. Exit the Sketching environment and then choose the Decal tool from the
Create panel of the 3D Model tab; the Decal dialog box is displayed and you
are prompted to select the image.

7. Select the image inserted in the Sketching environment. Next, select the face
of the bottle to transfer the image.

8. Select the Wrap to Face check box and then choose OK to exit the dialog
box; the image is wrapped on the bottle. The final model of the bottle after
wrapping the text and the image on it is shown in Figure 6-150.

Figure 6-149 Image inserted in the Sketching environment
Figure 6-150 Final model of the bottle



9. Save the model with the name Tutorial4 at the location C:\Inventor 2016\c06
and then close the file.

Tutorial 5

In this tutorial, you will create the model shown in Figure 6-151. Its dimensions
are given in the same figure. (Expected time: 45 min)
The following steps are required to complete this tutorial:

a. Start a new metric template file Standard (mm).ipt.

b. Use the Line tool to draw the sketch of the base feature in the YZ plane.

c. Extrude the base feature.

d. Create the second feature on the top of the base feature.

e. Create the cut feature on the bottom of the model.

f. Create the hole features on the model.

g. Create the fillet on the base feature, refer to Figure 6-154.

h. Mirror the fillets and features using the Mirror tool, refer to Figure 6-155.
i. Save the model.
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Figure 6-151 Views and dimensions of the model for Tutorial 5

Creating the Base Feature



You need to create the base feature on the YZ plane.

1. Start a new metric file

2. Choose the Start 2D Sketch button from the Sketch panel of the 3D Model
tab; the default planes are displayed and you are prompted to select the
sketching plane.

3. Now, select the YZ plane as the sketching plane from the Browser Bar; the
Sketching environment is invoked and the YZ plane becomes parallel to the
screen. Alternatively, select the YZ plane from the Graphics window.

Note
1. Before selecting the sketching plane, you need to choose the Home button
from the ViewCube in order to maintain the right orientation of the model.

2. If the orientation of the ViewCube is not the same as the orientation of the
selected plane (Top/Front) then click on the down arrow available next to
the ViewCube; a flyout is displayed. Next, choose Set Current View as >
Top/Front from the flyout.

4. Next, create the sketch for the base feature on the YZ plane. Add the required
constraints and dimensions to it. The sketch after adding constraints and
dimensions is shown in Figure 6-152.

5. Exit the Sketching environment. To do so, right-click and then choose the
Finish 2D Sketch option from the Marking menu displayed.

6. Invoke the Extrude tool and extrude the base feature symmetrically about the
YZ plane to a distance of 110 mm, as shown in Figure 6-153.
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Figure 6-152 Sketch for the base feature

Figure 6-153 Base feature

Note
If the orientation of the model is not similar to the Figure 6-153, change the
current orientation by using the ViewCube.

Creating the Fillet Feature and Mirroring it
1. Create the fillet feature of radius 22, as shown in Figure 6-154.

Figure 6-154 Model dfter creating the fillet feature



2. Invoke the Mirror tool from the Pattern tab of the Ribbon; the Mirror
dialog box is displayed with the Features button chosen by default.

3. Select the fillet feature. After selecting the fillet feature, choose the Mirror
Plane button from the Mirror dialog box and then choose the YZ plane from
the Origin tab of the Browser Bar; the preview of the mirror feature is
displayed in the Graphics window, as shown in Figure 6-155.

4. Choose OK from the Mirror dialog box to create the mirror feature, as shown
in Figure 6-156.

@ Note
You may have to adjust the orientation of the model according to your
convenience. Use the Orbit tool to adjust the screen appearance.

Figure 6-155 Preview of the mirror

Figure 6-156 Mirrored fillet feature

Creating a Join Feature on the Back Face of the Base Feature



1. Define a new sketch plane on the back face of the base feature. Draw the
sketch for the join feature and then add the required constraints and
dimensions to it. The sketch after adding constraints and dimensions is shown
in Figure 6-157.

2. Exit the Sketching environment and adjust the view of the model using the
ViewCube. Next, extrude the sketch to a distance of 10 mm toward the front
of the base feature, as shown in Figure 6-158.

While selecting profiles for extrusion, make sure that you select a point inside
the loop sketch but outside the circle. As a result, the new sketch is extruded
along the circle, thus creating a hole. The model after creating the second
feature is shown in Figure 6-158.
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Figure 6-157 Sketch for the join feature

Figure 6-158 Model dfter creating the join feature

Creating Fillets



As evident from the Figure 6-158, the fillets need to be created on the side
surfaces of the second feature with respect to the first feature. In this tutorial,
you will create only one fillet feature and then mirror it to the other side of the
feature by using the Mirror tool.

1. Choose the Fillet tool from the Modify panel of the 3D Model tab; the Fillet
dialog box is displayed and you are prompted to select the edges to be filleted.
By default, the Constant tab is chosen in this dialog box.

2. Select the right edge that is common to both the first and the second feature.
As soon as you select the edge, 1 selected is displayed on the Edges column
and the preview of the fillet is displayed on the model with the default radius
value 2 mm.

3. Enter 10 in the R: edit box of the mini toolbar and choose OK. Alternatively,
enter 10 in the Radius column of the Fillet dialog box and then choose OK.
The fillet feature is created, as shown in Figure 6-159.

Mirroring the Fillets
To mirror the fillet created earlier, you need to use the Mirror tool.

1. Invoke the Mirror tool from the Pattern panel of the 3D Model tab; the
Mirror dialog box is displayed. By default, the Mirror individual features
button is chosen.

2. Select the filleted feature which is to be mirrored. Figure 6-16