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Where are the Lesson Files?

Purchase of this Classroom in a Book in any format gives you access to the lesson files you’ll
need to complete the exercises in the book.

You’ll find the files you need on your Account page at peachpit.com on the Registered
Products tab.

1. Go to www.peachpit.com/register.
2. Sign in or create a new account.
3. Enter the ISBN: 9780134863542

4. Answer the questions as proof of purchase.
5. The lesson files can be accessed through the Registered Products tab on your Account page.
6. Click the Access Bonus Content link below the title of your product to proceed to the

download page. Click the lesson file links to download them to your computer.
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Getting Started

Adobe Dimension CC gives designers the ability to quickly composite 3D and 2D elements in a
scene, customize models, specify materials, and create realistic lighting. Once the final staged
scene is assembled, the advanced rendering engine in Dimension will output the scene to a two-
dimensional Photoshop file complete with realistic textures, materials, shadows, and reflections.
Dimension is perfect for advertising, product design, scene visualization, abstract art, package
design, or creative exploration.

About Classroom in a Book
Adobe Dimension CC Classroom in a Book (2019 release) is part of the official training
series for Adobe graphics and publishing software, developed with the support of Adobe
product experts. The lessons are designed to let you learn at your own pace. If you’re new
to Adobe Dimension, you’ll learn the fundamental concepts and features that you’ll need to
master the program. And if you’ve been using Adobe Dimension for a while, you’ll find
that Classroom in a Book teaches many advanced features, including tips and techniques
for using the latest version of the application and creating realistic scenes with 3D models.

Although each lesson provides step-by-step instructions for creating a specific project, there’s
room for exploration and experimentation. You can follow the book from start to finish or do
only the lessons that match your interests and needs. Each lesson concludes with a review section
summarizing what you’ve covered.

Prerequisites
Before you begin to use Adobe Dimension CC Classroom in a Book (2019 release), you
should have a working knowledge of your computer and its operating system. Make sure
that you know how to use the mouse and standard menus and commands, and also how to
open, save, and close files. If you need to review these techniques, see the documentation
for your Microsoft Windows PC or Apple Mac computer.

To complete the lessons in this book, you’ll need to have Adobe Dimension CC installed. It will
also be helpful to have Adobe Photoshop CC and Adobe Illustrator CC installed for exploration
in a couple of the lessons.

Installing Adobe Dimension
Before you begin using Adobe Dimension CC Classroom in a Book (2019 release), make
sure that your system is set up correctly and that you’ve installed the required software.



You must license the Adobe Dimension CC software separately. For system requirements
and complete instructions on installing the software, visit
helpx.adobe.com/dimension/system-requirements.html.

A couple of the lessons in this book use Adobe Photoshop CC and Adobe Illustrator CC. You
can install Photoshop and Illustrator on your computer using the Adobe Creative Cloud desktop
application, available at adobe.com/creativecloud/desktop-app.html. Follow the on-screen
instructions.

Starting Adobe Dimension
You start Dimension just as you do most software applications.

To start Adobe Dimension in Windows: Click the Start button in the taskbar, and in the
alphabetical list under A, click Adobe Dimension CC.

To start Adobe Dimension in Mac: Click the Adobe Dimension CC icon in the Launchpad or
Dock.

If you don’t see Adobe Dimension CC, type Dimension into the search box in the taskbar
(Windows) or in Spotlight (Mac), and when the Adobe Dimension CC application icon appears,
select it and press Return/Enter.

Online content
Your purchase of this Classroom in a Book includes online materials provided by way of
your Account page on peachpit.com.

Lesson files
To work through the projects in this book, you will need to download the lesson files from
peachpit.com. You can download the files for individual lessons or download them all in a
single file.

Web Edition
The Web Edition is an online interactive version of the book, providing an enhanced
learning experience. Your Web Edition can be accessed from any device with a connection
to the Internet, and it contains the following:

The complete text of the book

Hours of instructional video keyed to the text

Interactive quizzes

In addition, the Web Edition may be updated when Adobe adds significant feature updates
between major Creative Cloud releases. To accommodate the changes, sections of the online
book may be updated or new sections may be added.

http://helpx.adobe.com/dimension/system-requirements.html


Accessing the lesson files and Web Edition
If you purchased an eBook from peachpit.com or adobepress.com, your Web Edition will
automatically appear under the Digital Purchases tab on your Account page. Click the Launch
link to access the product. Continue reading to learn how to register your product to get access to
the lesson files.

If you purchased an eBook from a different vendor or you bought a print book, you must register
your purchase on peachpit.com in order to access the online content:

1. Go to www.peachpit.com/register.
2. Sign in or create a new account.
3. Enter the ISBN 9780134863542
4. Answer the questions as proof of purchase.
5. The Web Edition will appear under the Digital Purchases tab on your Account page. Click

the Launch link to access the product.

The lesson files can be accessed through the Registered Products tab on your Account page.
Click the Access Bonus Content link below the title of your product to proceed to the download
page. Click the lesson file links to download them to your computer.

 Note

As you complete each lesson, you may want to keep your start files. In case you
overwrite them, you can restore the original files by downloading the corresponding
lesson files from your Account page at peachpit.com.

Restoring default preferences
The preferences file stores information about various command settings in Dimension. Each time
you quit Dimension, the selections you make in the Preferences dialog are saved in the
preferences file.

To ensure that what you see on-screen matches the images and instructions in this book, you
should restore the default preferences as you begin each lesson. If you prefer to preserve your
preferences, be aware that the settings in Dimension CC may not match those described in this
book.

To restore your preferences to the factory default, do the following:

1. Start Adobe Dimension.
2. Choose File > New to create a new, blank file.
3. Choose Adobe Dimension CC > Preferences (Mac) or Edit > Preferences (Windows).
4. Click Reset Preferences.
5. Click OK.

http://adobepress.com
http://www.peachpit.com/register


Additional resources
Adobe Dimension CC Classroom in a Book (2019 release) is not meant to replace documentation
that comes with the program or to be a comprehensive reference for every feature. Only the
commands and options used in the lessons are explained in this book. For comprehensive
information about program features and tutorials, refer to these resources:

Adobe Dimension Learn and Support: helpx.adobe.com/support/dimension.html is where you
can find and browse Learn and Support content on Adobe.com. You can go there directly from
Dimension by choosing Help > Dimension Help.

Start screen: In Dimension, the Start screen contains various links to tutorials and other learning
content.

Dimension tutorials: helpx.adobe.com/dimension/tutorials.html lists online tutorials for
beginner and experienced users. You can go there directly from Dimension by choosing Help >
Learn.

Dimension blog: theblog.adobe.com/creative-cloud/dimension/ brings you tutorials, product
news, and inspirational articles about Dimension.

Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions, questions, and
answers on Adobe products.

Adobe Dimension CC product home page: adobe.com/products/dimension.html provides
information about product features and system requirements.

Resources for educators: adobe.com/education and edex.adobe.com offer a trea- sure trove of
information for instructors who teach classes on Adobe software. Find solutions for education at
all levels, including free curricula that use an integrated approach to teaching Adobe software
and can be used to prepare for the Adobe Certified Associate exams.

Adobe Authorized Training Centers
Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products.

A directory of AATCs is available at training.adobe.com/trainingpartners.

http://helpx.adobe.com/support/dimension.html
http://Adobe.com
http://helpx.adobe.com/dimension/tutorials.html
http://theblog.adobe.com/creative-cloud/dimension/
http://forums.adobe.com
http://adobe.com/products/dimension.html
http://adobe.com/education
http://edex.adobe.com
http://training.adobe.com/trainingpartners


1 Introducing Adobe Dimension

Lesson overview
In this lesson, you’ll explore the workspace and learn the following:

What Adobe Dimension is

How to open a Dimension file

How to work with the tools and panels

How to change your view of a scene

How to make simple edits to a scene

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



The modern, uncluttered interface of Adobe Dimension makes it easy to find the tools and options you need.

Introducing Adobe Dimension
Adobe Dimension is a desktop program for Macintosh and Windows for creating
photorealistic images from 3D assets for branding, product shots, scene visualization, and
abstract art.

Dimension makes 3D design, compositing, and rendering accessible to people with little or no
3D software experience. Wherever possible, special terminology that is unique to the 3D
modeling world is avoided in both the Dimension program and this book. The Dimension
interface should be familiar to users of other Adobe design tools, such as Adobe XD, Illustrator,
Photoshop, and InDesign.

Dimension is a subscription product, available as part of the Adobe Creative Cloud product
offering. Depending on your subscription plan, you might be paying only for Dimension, or you
might have access to all the Creative Cloud applications, including Adobe Photoshop and
Illustrator, which are particularly useful as companions to Adobe Dimension.

Where do 3D models come from?
Dimension isn’t intended for creating 3D models. 3D models are usually created with
modeling software such as 3ds Max, Blender, Inventor, Maya, Rhino, Sketchup,
SolidWorks, Strata 3D, and so on. Most of these products have a fairly steep learning
curve, are quite technical, and, due to their complexity, aren’t well-suited for part-time or
occasional use.



Dimension’s sweet spot is in importing models from these programs; it can then apply new
materials to their surfaces, position them with other models, composite them into 2D scenes, and
apply realistic lighting, reflections, and shadows. The result is then “rendered,” or converted into
a flat 2D image, as a PSD or PNG file that can be used in print publications or on websites or for
other digital uses. Dimension also includes a “beta” feature (at the time of this writing) that lets
you export an interactive 3D version of the scene to a website to share with others.

1. Create a scene.

2. Adjust lighting, materials, size, position, rotation, etc.

3. Add background.



4. Output. Publish to Web (Beta). Render to PSD or PNG.

Starting Dimension and opening a file
In this lesson, you will open a finished Dimension scene and poke around a bit to learn
how Dimension’s interface is designed.

1. Launch Adobe Dimension.

A start screen is displayed. Your screen may look different than the screenshot shown here,
and that’s OK. The start screen contains links to various tutorials and other Dimension
resources.

If you’ve worked on Dimension files previously, those files will be displayed in a list at the
bottom of the start screen.

In the lower-left corner of this screen there are links to more helpful learning content, as
well as links through which to provide feedback to Adobe about Dimension.



2. Click Open.
3. Select the file named Lesson_01_begin.dn, which is in the Lessons > Lesson01 folder that

you copied onto your hard disk, and then click Open.

You’ll use this simple 3D scene to explore the Dimension interface.

Dimension limitation: One file open at a time
3D files can be complex and demand a lot of computer memory and processing power.
Because of this, Dimension allows you to open only a single file at a time. In other words, if
you have a project open in Dimension and then create a new file or open another file, the
file you originally had open will close.

Exploring the tools
The Tools panel on the far left side of the screen contains a handful of tools that you’ll use
to create and edit your 3D scenes. Let’s take a tour of the Tools panel.

1. Hover over each of the tools in the Tools panel, and note that a blue tooltip is displayed.
This tooltip tells you the name of the tool, the keyboard or mouse shortcut that can be used
to access the tool, and what the tool is used for.



2. Note that the Tools panel is divided into four sections by subtle horizontal lines.

The top three tools—the Select and Move tool, the Select and Scale tool, and the Select and
Rotate tool—are used for selecting and transforming 3D models. Note that there isn’t a
separate Selection tool like in other Adobe design programs. Instead, each of these tools
will allow you to both select 3D objects and transform them.

The next two tools—the Magic Wand and the Sampler—are grouped together because they
are both used for selecting and changing the color or surface materials of just part of a
larger 3D object, such as the cap on a bottle or the handle on a mug.

The next four tools—Orbit, Pan, Dolly, and Horizon—are used for adjusting the position of
the “camera” in the 3D scene. These tools are often referred to as the camera tools.

The bottom two tools—the Zoom tool and the Hand tool—are used to adjust your view of
the “canvas,” or work area, on the screen. These tools work similarly to the Zoom and Hand
tools in Photoshop, Illustrator, and InDesign.

3. Right-click the Select and Move tool, and note that some additional options for this tool
appear on the screen.



The small black arrow in the lower-right corner of a tool in the Tools panel indicates that
additional tools or tool options will appear if you either right-click the tool or press and
hold the mouse button on the tool.

Exploring the panels
As in many other Adobe design programs, panels on the right side of the screen display the
properties of objects that you have selected in the work area; the panels allow you to edit
those properties as well. Let’s see how this works in Dimension.

1. Select the Select and Move tool (keyboard shortcut: V) in the Tools panel.
2. Click the red chair in the scene. Note that the chair displays with a blue highlight to

indicate that it is selected.

Explore the Scene panel
The Scene panel displays a list of all the components that make up the scene.

1. Look at the Scene panel on the right side of the screen. In this case, there are five objects in
the scene: Environment, Camera, retro_green_chair, retro_table, and retro_red_chair.



2. Right-click the Select and Move tool in the Tools panel. In the tool options that appear, turn
on the Group Select option. This causes the tool to select the entire group when you click a
grouped object, similar to the Selection tool in Photoshop, Illustrator, and InDesign.

3. Click the green chair on the canvas (the “page” or the work area) to select it. This will
highlight the retro_green_chair model in the Scene panel.

4. Hover over the retro_green_chair entry in the Scene panel, and you’ll see an eyeball icon 

 to the right of the entry. Click this eyeball icon to hide the green chair on the canvas.
5. Click the eyeball icon again to show the model on the canvas.
6. Click the words “retro_ table” in the Scene panel, and the table will be selected on the

canvas. Sometimes clicking an entry in the Properties panel is an easier and more precise
way to select models than clicking the models on the canvas.

Explore the Actions panel
Depending on what you have selected in your scene, the Actions panel will display quick
shortcuts to various “actions,” or things that you can do to your selection.

1. With the retro_table model selected, the Actions panel displays the Delete, Duplicate,
Move to Ground, and Group actions.

2. Hover over each action icon to see the name of the action as well as a keyboard shortcut
that can be used for each.

Explore the Properties panel
Depending on what you have selected in your scene, the Properties panel displays various
properties of the selection.



1. With the retro_table object selected, the Properties panel displays the “pivot” point, as well
as X, Y, and Z values for Position, Rotation, and Scale, respectively. Each of these values
can be edited.

2. Enter a value of 4 in the X field for Position. This will move the table to the right in the
scene.

3. In the Scene panel, click Environment to select the environment, which is the area around
the 3D models that controls the lighting and ground properties.

In the Properties panel, you’ll see settings for Background, Environment Light, Sunlight,
and Ground Plane displayed.

4. Under Environment Light, drag the Intensity slider to the left to about 75% to reduce the
amount of overall light in the scene.



 Note

Unlike in some other Adobe products, these three panels (Scene, Actions, and Properties)
cannot be closed or rearranged—they will always be displayed on the screen at the same
location. You can collapse and expand each of these panels by clicking the disclosure
arrow to the left of the panel name.

Understanding the Camera
Every Dimension project contains a single camera. You can manipulate the camera with
the Orbit, Pan, Dolly, and Horizon tools to view the 3D scene from various angles,
distances, and perspectives.

1. Choose the Select and Rotate tool in the Tools panel (keyboard shortcut: R).
2. Either click the red chair on the canvas or click the retro_red_chair object in the Scene

panel to select the red chair.
3. In the Properties panel, enter ° for the Y value for Rotation, and press Return/Enter. Note

that the chair rotates around the vertical (y) axis.



4. Choose Edit > Undo Edit Scene to undo the rotation.
5. Choose Edit > Redo Edit Scene to redo the rotation.

Note that as the chair rotates, the shadows change in length and appearance but are still cast
in the same direction.

6. Choose the Dolly tool in the Tools panel (keyboard shortcut: 3). Drag down on the screen
with your mouse to move the camera farther away from the object.

7. Choose Camera > Camera Undo to return to the original view of the object.
8. Choose the Orbit tool in the Tools panel (keyboard shortcut: 1).
9. Drag around on the scene with the Orbit tool. This changes your view of the scene. It is as

if you are flying around the scene, viewing the models from different angles through a
camera lens.

Note that as you rotate your view of the scene with the Orbit tool, the shadows change
direction but stay the same length and appearance; this is because the models and light
source remain the same relative to each other, and you are just moving around the scene.

10. Choose Camera > Camera Undo as many times as necessary to return to the initial view of
the scene.

 Note

Dimension has two undo commands. Edit > Undo reverses the last actual edit that you
made to the objects in your scene. Camera > Camera Undo reverses the last movement of
the camera.

Understanding the Canvas
So far, all our manipulation of our 3D scene has occurred inside a large rectangle that
occupies most of your work area on the screen. This rectangle is called the “canvas.” Think
of the canvas as your “page.” It’s the actual dimensions of the final 2D image that is being
created from your 3D objects. Most of the time, you’ll probably just leave this canvas as it
is on your screen, using the camera tools to change your view of the scene within the



bounds of the canvas. Depending on what other software programs you may have used, it
might be helpful to think of the canvas as the “viewport” into your 3D scene.

If you’ve used Adobe design tools such as Photoshop, Illustrator, or InDesign, you may want to
manipulate your view of the canvas independent of the camera tools.

 Tip

It might be helpful to think of the canvas this way. The camera tools (Orbit, Pan, Dolly,
and Horizon) manipulate your view of the scene within the canvas. The Zoom and Hand
tools manipulate your view of the canvas itself.

 Tip

As with many other Adobe design tools, you can use the Command+plus and
Command+minus (Mac) or Ctrl+plus and Ctrl+minus (Windows) keyboard shortcuts to
zoom in and out. Use Command+1 (Mac) or Ctrl+1 (Windows) to see your design at
100%, and use Command+zero (Mac) or Ctrl+zero (Windows) to return to the “fit in
window” view.



1. Select the Zoom tool in the Tools panel (keyboard shortcut: Z), and click the canvas or drag
across the canvas to zoom in.

2. Select the Hand tool in the Tools panel (keyboard shortcut: H), and drag the scene to move
the canvas around on the screen.

3. Select the Zoom tool in the Tools panel (keyboard shortcut: Z).
4. Hold down the Option key (Mac) or Alt key (Windows), and click the canvas a couple of

times to zoom out.
5. Choose View > Zoom to Fit Canvas to fit the canvas on the screen.

Understanding the Ground Plane
The vanishing lines (the grid of squares that you see on the screen) represent the Ground
Plane of the 3D scene. The Ground Plane is the “floor” that objects in the scene typically
sit on, although objects can float above this floor or be buried below the floor.

1. Choose Camera > Switch to Home View to ensure that your camera view is back to the
way it was at the beginning of this lesson.

2. Choose the Select and Rotate tool in the Tools panel (keyboard shortcut: R).
3. Select the retro_green_chair object in the Scene panel.
4. In the Properties panel, change the Z value for Rotation to 90°, and press Return/Enter. The

chair rotates around the z-axis so that half of the chair disappears into the Ground Plane.

5. Choose the Orbit tool in the Tools panel (keyboard shortcut: 1).
6. Drag down on the screen with the Orbit tool. This changes your view of the scene so that

you are viewing it from above.



Note that the grid lines on the Ground Plane are dark gray and that the Ground Plane is
opaque. In other words, you can’t see through the floor to what is underneath.

7. Drag up on the screen with the Orbit tool until you can see the entire green chair. Now you
are viewing the scene from below the Ground Plane, looking up at the bottom of the table.

Note that you can see both the part of the green chair that is sticking “up” from the ground
and the part that is “buried” below the ground. When you are viewing the scene from below
the Ground Plane, the Ground Plane appears transparent so that you can see through it to
the objects above.

Note also that the grid lines on the underside of the Ground Plane are red. This can help
reduce confusion in those instances when you aren’t sure if you are viewing a scene upside
down or right-side up.



8. Choose the Dolly tool in the Tools panel (keyboard shortcut: 3). Drag down on the screen
repeatedly with your mouse to move the camera farther away from the object. Note that the
Ground Plane is “infinite.” The camera can be moved a long way away from the object.

9. Choose Camera > Switch to Home View to return the camera view back to the way it was
at the beginning of this lesson.

 Tip

The grid lines on the Ground Plane can be toggled on and off with View > Toggle Grid.
And, the Ground Plane itself can be turned on and off in the Properties panel when
Environment is chosen in the Scene panel.

Using Render Preview
Getting an accurate view of the surfaces, colors, lighting, shadows, and reflections in a
scene requires that a scene be rendered. Rendering is a processor-intensive, time-
consuming task in which the computer analyzes how the objects in a scene interact with
each other, the background, and the lighting in the scene, and then calculates accurate
shadows, highlights, surface details, and reflections.

But even the fastest computers today are unable to render a complex scene in real time as you
make edits to the scene. This is why rendering isn’t usually done until the final stages of a
project. However, the Render Preview window gives you a quick, fairly accurate idea of what the
final rendering will look like, almost in real time, as you work on a scene.

1. Click the Render Preview icon  in the upper-right corner of the screen.



After a 15- to 20-second delay (depending on the speed of your computer), you’ll see a
small thumbnail image of what the final render will look like.

2. Choose the Select and Rotate tool in the Tools panel (keyboard shortcut: R).
3. If it isn’t already selected, click the retro_green_chair in the Scene panel to select the chair.
4. In the Properties panel, change the Z value for Rotation to 0°, and press Return/Enter. After

a brief delay, you’ll see the Render Preview window update to show the new, edited scene.

The two modes of Dimension
The Dimension interface consists of two modes: Design and Render. Design mode is where
you’ll spend the lion’s share of your time creating and editing 3D scenes. Render mode is
where you’ll create the final, high-quality pixel-perfect output of your scene. You’ll learn



all about both of these modes throughout this book.

 Note

At the time of this writing, Dimension includes a “Beta” feature called Publish to Web.
To try this out, click the share button in the upper-right corner and choose Publish 3D
Scene. Dimension will publish your scene to a Web server (hosted by Adobe), and return
a URL that you can share. Anyone who follows the URL will be able to interactively
change their view of the 3D scene.

1. In the upper-left corner of the screen, you’ll see a line underneath Design to indicate that
we are currently in Design mode. Whenever you open a Dimension file or create a new file,
Dimension will initially display the file in Design mode.

2. Click Render to switch to Render mode. Note that the 3D content disappears from view and
that all the tools and panels are replaced with new panels for controlling the render settings.

We’ll cover the details of rendering in a later lesson. For now, I’ve rendered the exercise
file used in this lesson for you.

3. Open the Lesson_01_final_render.psd file in Adobe Photoshop to examine the final render
and compare it to what you saw in the small Render Preview window earlier.



4. Click Design to switch back to Design mode, making the 3D content visible again.

 Note

You can switch between Design and Render modes at any time and as often as you wish.
Although rendering is usually done at the end of a project, you may wish to occasionally
render your work as it progresses so you can get an accurate view of how your project
looks at the moment.

Getting help

The Learn icon  in the far upper-right corner of the screen gives you access to online
help content for Dimension, including tutorials, videos, keyboard shortcuts, and galleries of
finished work.

Review questions
1 How many files can be open at one time in Dimension?

2 What is the purpose of Render mode?
3 Why isn’t there a selection tool in Dimension?



4 What is the “floor” that 3D objects rest on called?

Review answers
1 Only one file can be open at a time in Dimension. If you have one file open and then

open a second file, the first file will close.
2 Render mode is used to create the final scene with accurate lighting, shadows, reflections,

materials, and surface properties. Computers are unable to keep up with rendering in real time
as you make edits to a scene, so rendering is a separate process that takes place in Render
mode.

3 Dimension instead has the Select and Move, Select and Scale, and Select and Rotate tools, all
of which will allow you to select an object in addition to moving, scaling, or rotating the
object.

4 The imaginary “floor” in a 3D scene is called the Ground Plane.



2 Exploring Design Mode

Lesson overview
In this lesson, you’ll create a simple 3D scene from scratch and learn the following:

How to create a new project and specify the canvas size

How to change the properties of the background

How to import starter assets

How to transform 3D objects

How to apply materials to objects

How to adjust the lighting

How to render a scene and produce output that can be used in other programs

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



Design mode is where you will spend most of your time in Dimension. This is where you’ll position, scale, and rotate models,
apply materials to surfaces, and adjust lighting and reflections.

Creating a new project
Starting a new project from scratch in Dimension is as easy as choosing File > New.

1. Choose File > New to create a new document. If you currently have another document
open, it will close. If that document isn’t saved, you’ll be prompted to save it before
closing.

Dimension doesn’t ask you anything about page size or file size as you create a new file.
But you do have control over this.

2. Select the Select and Move tool in the Tools panel (keyboard shortcut: V).
3. Click the 1024 x 768 dimensions that are displayed in the upper-left corner of the canvas.

This will select the canvas, and you’ll see some options for changing the canvas size appear
in the Properties panel on the right.



4. In the Properties panel, change Size to a width of 3000px and a height of 2000px.

5. Choose View > Zoom to Fit Canvas to position the new canvas size on the screen.

 Note

The appropriate values to enter for the canvas width and height depend on the intended
use of the final rendered image. If you just need a low-resolution image to use in a small
section of a web page, 600px x 600px might be sufficient. But an image that will be
reproduced on the cover of a print magazine may need to be 4000px x 4000px or more.
Talk to your web developer or print partner if you need more guidance on this issue.
They should be able to tell you the exact pixel dimensions required.

 Tip

Canvas size significantly influences render time. Use a canvas size that is no larger than
necessary.

Change the background color
By default, the background of the scene is white. But you can easily change the
background color to any value you want.

1. In the Scene panel, select Environment.



2. In the Properties panel, click the property swatch to the right of the word “Background,”
and enter 220, 205, 185 for the RGB values to change the background to a light tan color.

3. Click away from the color picker when you are finished to close it.
4. Choose File > Save, name the file, and save it somewhere you can find it again

if necessary.

 Note

Dimension files are automatically assigned the .dn filename extension. Depending on
how your operating system is configured, you may or may not see this extension
displayed at the end of the filename.

Working with starter assets
Dimension ships with dozens of “starter assets,” including 3D models, materials, lights,
and background images you can use to get started creating 3D scenes. You can also use
content from Adobe Stock, Creative Cloud Libraries, or your own imported 3D models and
2D images to compose your scenes. In this lesson, we’ll work with the starter assets.



1. Click the Content button  in the lower-left corner of the screen. This button displays and
hides the Content panel on the left side of the screen. Click the button until the Content
panel is displayed.

The Content panel displays content that you can use in your scene, such as 3D models,
materials, lights, and images.

2. If Starter Assets isn’t displayed at the top of the Content panel, choose Starter Assets from
the dropdown menu.

3. Click the model icon  at the top of the panel to display only models in the panel.
4. Type pipe into the search assets field.

The Pipe starter asset is located.

5. Click once on the pipe starter asset to place it into your scene.
6. Type prism into the search field.

The Prism starter asset is located.



7. Click once on the Prism starter asset to place it into your scene.

Note that the pipe and the prism were both placed at the same location in the scene, so they
are intersecting. You’ll fix this in the next steps.

 Note

When you click a starter asset model, it will always be positioned at the “zero” point in
the center of the scene to start. From there, you can move the model to any position in the



scene that you wish.

Selecting and transforming objects
The Scene panel makes it easy to determine the various pieces that compose a scene, and it
can help you select those pieces. Let’s rearrange the pipe and the prism in the scene.

Move objects
1. Select the Select and Move tool in the Tools panel (keyboard shortcut: V).
2. Select the Prism model in the Scene panel by clicking the word “Prism.” You’ll see the

prism outlined in blue on the canvas to indicate that it is selected.
3. Enter values of X=0, Y=0, and Z=10 for Position in the Properties panel. This will move

the prism closer to the “front” of the scene.

4. Click the Pipe model in the Scene panel.

Note the colored widget that appears on the Pipe model. Rather than typing values into the
Properties panel, you can use this widget to move the model along the x-, y-, or z-axis.

5. Drag the red arrow to the right until 5 is displayed for the X position in the Properties
panel.

6. Drag the blue arrow to the right until –5 is displayed for the Z position in the Properties
panel.

7. Drag the green arrow down until –5 is displayed for the Y position in the Properties panel.
This moves the pipe down so that it is partially “buried.”



Understanding the 3D axis
Perhaps you’re familiar with the x-axis and y-axis that are used in many 2D design
programs. Moving an object along the x-axis moves it from left to right or from right to left.
Moving an object along the y-axis moves the object up and down. However, when working
in the world of 3D, we need a third axis, the z-axis. Moving an object along the z-axis
moves it closer to you or farther away from you.

This is pretty easy to understand and visualize, except that in Dimension the default viewing
angle has the x- and z-axes off-center, so you’re viewing the objects at an angle. As you
move an object closer to you on the z-axis, it also moves right to left across your screen.
This can be confusing until you get accustomed to it.



The 3D axes as they are used in the default view of Dimension. The view is off-center, which makes movement along the
z-axis easier to see but can be a bit confusing at first.

Rotate and scale objects
Just as you dragged the arrows with the Select and Move tool to interactively move an
object along the x-, y-, and z-axes, you can also drag on-screen widgets to rotate and scale
objects.

 Tip

Hold down the Shift key while dragging the rotation widget to constrain the rotation to
increments of 15 degrees.

1. Select the Select and Rotate tool in the Tools panel (keyboard shortcut: R).
2. Click the Pipe model on the canvas to select it.
3. Drag the blue arrow clockwise on the rotation widget until –30 is displayed in the on-screen

widget or in the Z field of the Rotation settings in the Properties panel.
4. Select the Select and Scale tool in the Tools panel (keyboard shortcut: S).
5. Drag the green handle on the scale widget down until a value of .8 is displayed in the Y

field of the Scale settings in the Properties panel. This causes the pipe to be scaled only in
the Y direction, shortening the pipe. Holding down the Shift key while dragging the handle
would have caused the pipe to be scaled proportionally in all directions.



6. Select the Prism object with the Select and Rotate tool (keyboard shortcut: R).
7. Drag the green arrow on the rotation widget to the left until –30 is displayed in the Y field

of the Rotation settings in the Properties panel.
8. Drag the blue arrow on the rotation widget up until 10 is displayed in the Z field of the

Rotation settings in the Properties panel.
9. Switch to the Select and Scale tool (keyboard shortcut: S).

10. Drag the green handle on the scale widget down until a value of .9 is displayed in the Y
field of the Scale settings in the Properties panel.



Applying materials to models
When you import a 3D model into a scene, it will arrive with whatever materials were
applied to the model when it was created. But Dimension allows you to adjust the
properties of materials or to apply entirely new materials to a model. We’ll look briefly at
this in this lesson and then dive more deeply into materials in a later lesson.

1. Select the Prism object with the Select and Move tool (keyboard shortcut: V).

2. In the Content panel on the left side of the screen, click the X icon  next to the search
field to clear the previous search term.

3. Click the Materials icon  to view only materials in the panel.
4. Click the More icon  in the upper-right corner of the panel, and choose Toggle List/Grid

View to switch to List view.



5. Experiment by clicking different materials in the list to apply them to the Prism model.
6. Type concrete into the search field, and click the Clean Concrete material to apply it to the

surface of the Prism model.
7. Click the pipe with the Select and Move tool.
8. Type Marble into the search field, and click the Grey Marble material to apply it to the

surface of the Pipe model.

Adjusting the lighting



Dimension scenes can contain two different types of lighting: environment light and
sunlight. Environment light is the ambient light that surrounds the scene. Sunlight can be
added to, or used in place of, environment light to create strong directional shadows and
reflections. Both of these lights can be customized in many ways.

Adjust and preview the environment light
Let’s see what happens when we adjust the rotation and color of the environment light.

1. Click the Render Preview icon  in the upper-right corner of the screen to display the
Render Preview window. You may wish to keep this window open as you work through the
following steps.

2. Choose Edit > Deselect All to deselect the Pipe model.
3. Click Environment in the Scene panel to select the environment instead of one of the 3D

models.
4. In the Properties panel, adjust the Rotation slider under Environment Light to about 135°.

Note that as you do this, the locations of the light and dark areas on the surface of the prism
and pipe change.

5. In the Properties panel, under Environment Light select the Colorize option.
6. By default the Colorize option is set to white. Click the color swatch next to Colorize and

choose a color with RGB values of 250, 250, 150. This will apply a slight yellow warmth to
the environment light. When you are finished, click away from the color picker to dismiss
it.



Adjust and preview the sunlight
Let’s experiment briefly with the sunlight properties. We’ll examine these in more detail in
another lesson.

1. In the Properties panel, click the button next to the word “Sunlight” to toggle sunlight on.
This causes the scene to immediately brighten, and stronger shadows and highlights appear.

2. Experiment with the Intensity, Cloudiness, Height, and Rotation sliders. I used values of
110% for Intensity, 10% for Cloudiness, 60° for Height, and 0° for Rotation.

Adjust the ground plane properties
By default, the ground plane is a solid surface with a matte finish, meaning that it will
display shadows but won’t show any reflections of objects sitting on it. We can change
these properties as we wish.



1. In the Properties panel under Ground Plane, adjust the Reflection Opacity slider to 10%.
2. Adjust the Reflection Roughness slider to 10%. This will add a subtle, natural-looking

reflection to the surface on which the prism and pipe are sitting. But this will not be visible
in the on-canvas preview. This is visible only in the Render Preview panel or in the final
render of the scene.

3. Click the Render Preview icon  in the upper-right corner of the screen to view the
objects reflected on the ground plane.

Adjusting the camera
So far, we’ve been working on this scene without changing our camera view. But now we
want to examine the scene from different angles to see if there is an angle that is more
interesting or perhaps to examine more closely how the prism and the pipe intersect.

1. Click the Camera Bookmarks icon  in the upper-right corner of the screen.

2. Click the plus button  to save a camera bookmark named View 1. This will enable us to
easily return to the current camera view later.



3. Select the Orbit tool in the Tools panel (keyboard shortcut: 1).
4. Drag around the scene with the Orbit tool to examine it from different angles.
5. Select the Pan tool in the Tools panel (keyboard shortcut: 2).
6. Drag around the scene with the Pan tool to pan the camera view.

7. Click the Camera Bookmarks icon .
8. Click View 1 to return to the previously saved camera view.
9. Select the Dolly tool in the Tools panel (keyboard shortcut: 3).

10. Drag down on the scene a bit to zoom out, leaving a little more space around the objects in
the scene.

11. Choose File > Save.

Introduction to scene rendering
The file you’ve been working on is saved as a Dimension file. The Dimension file format
can’t be opened with Photoshop, placed in InDesign or Illustrator, or printed to a color
printer. Getting output in a form that is useful requires that you render the scene. You’ll
render this scene in the following steps, and you’ll learn much more about rendering in a
later lesson.

1. Click the Render tab at the upper-left corner of the screen.

2. Under Render Settings on the right side of the screen, select Current View.
3. Make a note of the filename.
4. Choose Low (Fast) for Quality.
5. Choose an export location.
6. Choose PSD (16 Bits/Channel) for the export format.
7. Click Render.



8. Wait for the render to complete. Depending on the speed of your computer, this can take 15
minutes or more.

You can’t do anything else in Dimension while the render is taking place, but you can use
other programs on your computer while the render is finishing.

9. When the render is complete, open and view the completed PSD file in Photoshop.
10. In Photoshop, choose Image > Image Size, and you’ll see that the rendered PSD file is

3000px x 2000px, as we specified for the canvas size when we began the project.
11. Zoom in on the image in Photoshop. You’ll see that the image contains a lot of “noise,”

particularly noticeable in the cast shadows. This is because we chose a low quality and fast
speed for the render settings. A high-quality, slow-speed render would give much nicer
results but take considerably longer to render.



Review questions
1 What filename extension is added to Dimension files?

2 When, and where, do you specify the canvas size in Dimension?
3 When you add a starter asset to a scene, where is the asset positioned in the scene?
4 Moving an object along the z-axis moves the object in what direction?
5 What are two ways to rotate a 3D object?
6 What are the two kinds of lights built into Dimension?

Review answers
1 The filename extension for Dimension files is .dn.

2 The canvas size can be specified after a file is created, in the Properties panel.
3 When you add a starter asset to a scene, it is added to the “middle” of the scene, at X=0, Y=0,

and Z=0 in the dimension coordinate system.
4 Moving an object on the z-axis moves it closer to, or farther away from, the viewer.
5 Select the object with the Select and Rotate tool and then either enter values in the Properties

panel or drag the rotation widget on the object.
6 There are two types of lights that can be used in Dimension: Environment and Sunlight.



3 Changing Your View of the Scene: Working
with the Camera

Lesson overview
In this lesson, you’ll manipulate your view of an existing 3D scene and learn the following:

How the Orbit, Pan, Dolly, and Horizon tools work

When and why to use the camera tools

How to use bookmarks to save camera angles

How to simulate camera depth of field in a scene

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



The Camera tools in Dimension allow you to fly around the scene and view it from different angles and perspectives.

What is the camera?
While you’re composing a 3D scene, you’ll often need to examine the scene from a variety
of angles. For example, if you are trying to position a vase precisely on a tabletop, you may
need to view the table with your eye level even with the top of the table so you can see
when the vase is resting on the tabletop. When looking down on the table from above, it is
difficult to determine whether the vase is “floating” above the table or resting upon it.

Dimension uses the concept of a virtual “camera” through which you view the scene. There are
four camera-related tools:

The Orbit tool

The Pan tool

The Dolly tool

The Horizon tool

In this lesson, we’ll look closely at how these tools work.

Saving a camera bookmark



Camera bookmarks provide a way to save a specific view of your scene so that you can
quickly and easily return to the view later after you’ve changed your view with the camera
tools. In this exercise, you’ll open a file and save a camera bookmark of your initial view
of the scene.

1. Launch Adobe Dimension.
2. Click Open, or choose File > Open.
3. Select the file named Lesson_03_begin.dn, which is in the Lessons > Lesson03 folder that

you copied onto your hard disk, and then click Open.

4. Click the Camera Bookmarks icon  at the top of the screen.

5. Click the plus icon  to create a new bookmark.
6. To rename the bookmark, type Starting view and press Return/Enter.

Using the Orbit tool
The Orbit tool does what its name suggests: it lets you “orbit” around the scene, examining
it from different angles. You can move up, down, clockwise, and counterclockwise around
your scene. And, unlike in real life, you can even move the camera “underground” and
view the scene looking up from beneath the ground plane. In other words, imagine that the
ground plane is ice on a lake. With the Orbit tool, you can dive into the lake, point the
camera up at the scene that is sitting on the frozen surface of the ice, and view the scene
through the transparent ice.

1. Select the Orbit tool in the Tools panel (keyboard shortcut: 1).
2. Drag from right to left across the screen to “fly” around the scene in a counterclockwise

direction.
3. Choose Camera > Camera Undo to reset to the initial view.
4. Drag from left to right across the screen to orbit in a clockwise direction.
5. Drag from the bottom of the screen to the top of the screen to view the scene from below

the ground plane.

As we saw in a previous lesson, the grid lines on the ground plane are black on top and red
underneath. This is your visual cue as to where you “are.” If you see red lines, you’re
looking up through the ground plane (the floor). If you see black lines, you’re looking down
on the ground plane.

6. Click the Camera Bookmarks icon .



7. Click “Starting view” to return to the initial view of the scene.

 Tip

If you have a two-button mouse, you can also drag with the right mouse button while any
other tool is selected to use the Orbit tool.

 Note

Even though you can “see” up through the floor when viewing the scene from below as
you work on the canvas, if you try to render a view from below the floor, you won’t see
any models that are above the floor, as the floor is opaque when rendered.

Examine the scene with the Orbit tool
Changing your view of the scene with the Orbit tool is often helpful when you are
attempting to precisely align objects.

1. Drag with the Orbit tool until you are viewing the models straight on from the right side,
similar to this:

2. Choose Camera > Frame All. This command automatically manipulates the camera so that
all the models in the scene are centered on the screen and fill the screen.

3. Click the Camera Bookmarks icon .

4. Click the plus icon  to create a new bookmark.
5. To rename the bookmark, type Right side view and press Return/Enter.



From this angle, you can see that the space between the red and blue bottles is larger than
the space between the rest of the bottles. Let’s fix this.

6. Select the Select and Move tool (keyboard shortcut: V).
7. Click the “Whole milk – red” model in the Scene panel to select the bottle with the red cap.

Selecting the model in the Scene panel ensures that you get the entire bottle selected, not
just the body or the bottle cap.

8. Drag the blue arrow to the right until the bottles are equally spaced.

9. Select the Orbit tool (keyboard shortcut: 1).
10. Drag with the Orbit tool until you’re viewing the models from the end, similar to this:



11. Click the Camera Bookmarks icon .

12. Click the plus icon  to create a new bookmark.
13. To rename the bookmark, type Column view and press Return/Enter.

From this angle, you can see that one of the upright bottles isn’t lined up with the rest of the
bottles. Let’s fix this.

14. Select the Select and Move tool (keyboard shortcut: V).
15. Click the “1 percent – yellow” model in the Scene panel to select it.
16. Drag the red arrow to the right until the bottles are lined up.



17. Click the Camera Bookmarks icon .
18. Click “Starting view” to return to the initial view of the scene.

Using the Pan tool
The Pan tool is used to move the camera left, right, up, or down. Panning is different from
orbiting. When you pan the camera from right to left, it is as if you are simply walking by
the scene in a straight line, not curving around the scene. When you pan from the top of the
screen to the bottom of the screen, the horizon stays fixed in place, and it appears as if you
are climbing a ladder.

1. Select the Pan tool (keyboard shortcut: 2).
2. Drag from right to left across the screen to pan the scene from right to left.
3. Choose Camera > Camera Undo to reset to the initial view.
4. Drag from the bottom of the screen to the top of the screen to view the scene from below

the ground plane. Note that the imaginary horizon remains fixed on the screen when you
pan vertically.



5. Click the Camera Bookmarks icon .
6. Click “Right side view” to go to the side view of the scene.
7. Select the Select and Move tool (keyboard shortcut: V).
8. Click the “Whole milk – red” model in the Scene panel to select it.
9. Choose Camera > Frame Selection.

10. This will reposition the camera to center the single bottle on the screen.
11. Select the Pan tool (keyboard shortcut: 2).
12. Drag from right to left across the screen to pan the scene from right to left until the green

and purple bottles are visible on the screen.

From this view, you can see that the two bottles are intersecting. Let’s fix this.

 Tip

If you have a three-button mouse, you can drag with the middle mouse button to pan
the camera. (On some mice, pressing the scroll wheel acts as a third button.)



13. Select the Select and Move tool (keyboard shortcut: V).
14. Select the purple bottle model in the Scene panel.
15. Drag the blue arrow to the right until the bottles no longer intersect.

Using the Dolly tool
The Dolly tool moves the camera toward the scene or away from the scene. The name of
this tool comes from the wheeled camera “dollies” used in film and television production.

 Note

Depending on how your mouse preferences are configured on your computer, the
direction you drag the Dolly tool may be inverted from what is described here.



 Tip

You can also use the scroll wheel to engage the Dolly tool when any other tool is
selected.

1. Select the Dolly tool (keyboard shortcut: 3).
2. Drag from the bottom to the top of the screen, or from left to right, to move the camera

toward the scene, enlarging your view of the models.
3. Drag from the top of the screen to the bottom, or from right to left, to move the camera

away from the scene, which makes the models appear smaller.

4. Click the Camera Bookmarks icon .
5. Click “Starting view” to return to the initial view of the scene.

Using the Horizon tool
The Horizon tool allows you to move the horizon in your scene up or down or adjust the
tilt of the horizon. This tool is particularly useful when you are trying to place a 3D model
in a 2D image.

1. Choose File > Import > Image as Background.

2. Select the Simple_background.psd file in the Lessons > Lesson03 folder that you copied
onto your hard disk and then click Open.

3. In the Actions panel, click Match Image.

4. Select the option to resize the canvas, and deselect the options to create environment light
and match sunlight.

In this case, note that the Match Camera Perspective option isn’t available. This is because
this background image doesn’t have any perspective lines to help it determine a vanishing
point.



5. Click OK.
6. Select the Horizon tool (keyboard shortcut: N).

Because this background image doesn’t contain any perspective lines to help it determine a
vanishing point and horizon, you’ll have to set the horizon manually.

7. Drag the middle handle on the blue horizon line on the image until it is lined up with the
“horizon” between the tan and gray areas of the background image.

8. Grab the round selection handle on the right end of the horizon line and drag up. This is
what you would need to do if the horizon in your scene were tilted.



9. Choose Camera > Camera Undo to return the view to a horizontal horizon.

The bottles are too small in the scene. You can fix this with the Dolly tool.

10. Select the Dolly tool (keyboard shortcut: 3).
11. Drag up on the image to enlarge your view of the bottles.

Now you can’t see the tops of the bottles, and you’re now looking up on the bottom of the
bottles from beneath the ground plane! But the horizon is still intact, so you can easily fix
this.

12. Select the Horizon tool again (keyboard shortcut: N).
13. Drag down on the scene to raise the camera so that you are looking down on the bottles.

Note that the horizon line remains in place.



14. If necessary, select the Dolly tool again, and drag up on the image to enlarge the bottles
further. Then switch to the Horizon tool and drag up, down, left, or right on the image to
reposition the camera so that the scene looks something like this:

15. Click the Camera Bookmarks icon .



16. Click the plus icon  to create a new bookmark.
17. To rename the bookmark, type Final view and press Return/Enter.

18. Select the Orbit tool (keyboard shortcut: 1).
19. Orbit around the image a bit to change your angle of view.
20. Select the Horizon tool (keyboard shortcut: N). Your horizon line is probably now out of

position and no longer lined up with the horizon in the background. This is because the
Orbit tool adjusts only your view of the 3D models in the scene, not the background image.

21. Use the Horizon tool to reposition the horizon line on the background image. You may also
need to drag up on the image with the Horizon tool to lower the camera for a better view
after you’ve moved the horizon line.



Using camera bookmarks
As you’ve seen, camera bookmarks are a handy way to save camera angles so that you can
quickly return to the same angle at any time. There are a few more details about camera
bookmarks that you should know.

1. Earlier, we saved a camera bookmark named “Final view.” But we made a few changes to
the camera angle and perspective after saving the bookmark. To update the bookmark, click

the Camera Bookmarks icon .

2. Hover over the “Final view” bookmark and then click the Update to Current View icon 
to update the bookmark to match the current camera angle and perspective.

3. The bookmark named “Starting view” has a Home icon  next to it. This means that this
is the view that the Camera > Switch to Home View command (keyboard shortcut:
Command+B/Ctrl+B) will switch to. Hover over the space to the left of the “Final view”
bookmark and click the light gray home icon to make this view the Home view.

 Note

There is no limit to the number of camera bookmarks that you can save in a Dimension
file.

 Tip

Use the Page Up and Page Down keys to cycle through each view in the Camera
Bookmarks panel.

 Tip



Another reason to save a camera bookmark is that when you go to Render view, you can
tell Dimension to render a specific camera view. So, you could save several different
camera views of a scene and then render all the views at once.

Simulating depth of field
Depth of field is a photographic term that refers to how much of the scene being
photographed will be in focus when the shutter is clicked. Depending on the lens and the
lighting, the depth of field may be virtually infinite (so that everything is in focus), or it
may be shallow (so that only objects at a specific distance from the lens are in focus and
everything else is blurry). We can simulate this photographic principle with the Focus
controls in Dimension.

1. In the Scene panel, select Camera.

2. In the Properties panel, toggle the Focus option on by clicking the switch to the right of the
word “Focus.” This will open the Focus controls.

3. Click the Set Focus Point button and then click the yellow bottle cap. You’ll see an icon 

 that indicates the focus point placed on the scene.
4. Enter a value of 10 for Blur Amount.



5. A rough preview of the result displays on the canvas. To view a more accurate result of the

focus controls, click the Render Preview icon .

 Note

If you need to reposition the focus point, you’ll need to click the Set Focus Point button
again and click a new location for the focus point. In other words, the focus point
indicator on the Canvas cannot be dragged and moved.

Review questions
1 Which tool moves the camera closer to, or farther away from, the scene?

2 What does the Pan tool do?
3 What is the purpose of saving a camera bookmark?
4 Is there a limit to the number of camera bookmarks you can save?
5 What are the Dimension options called that let you simulate camera depth of field?

Review answers
1 The Dolly tool allows you to move the camera closer to or farther from the scene.



2 The Pan tool is used to move the camera left, right, up, or down. As you do this, the horizon
stays in place.

3 You save a camera bookmark so that you can quickly return to a particular view of a scene at
any time. Camera bookmarks are also useful for saving specific views to be rendered later.

4 No, there is no limit to the number of camera bookmarks that can be saved with a file.
5 The Focus options in the Properties panel will simulate camera depth of field in your scene.



4 Exploring Render Mode

Lesson overview
In this lesson, you’ll explore how to render a 3D scene and learn the following:

The three different places that rendering takes place in Dimension, and how they differ
from one another

The limitations of on-canvas rendering

The trade-offs between render speed and quality

How to achieve the highest-quality rendered image

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



Dimension’s Render Mode produces a 2D scene from 3D models, complete with realistic light, shadow, materials, and
reflections.

What is rendering?
Renderingrefers to the process of producing a realistic-looking 2D scene from a 3D model
or models.

Dimension uses a form of rendering called ray tracing. A high-level explanation of ray tracing is
that the computer has to calculate a path from each pixel in the scene back to the camera and
calculate the color of that pixel based on the environment lighting, the sunlight, the material
applied to the surface, and reflections from other objects. This requires a lot of computing
horsepower, and is far too complex for today’s computers to accomplish in real time as a scene is
edited.

Because of this, Dimension offers three levels of rendering: a rough “on-canvas” rendering that
Dimension performs as you edit a 3D scene, a render preview, and Render mode.



 Note

Dimension uses a proprietary ray tracing renderer owned by Adobe. Earlier versions of
Dimension used a ray tracing renderer developed by Chaos Group. If you wish to use this
earlier rendering engine, you can switch the renderer in Dimension’s Preferences (Adobe
Dimension CC > Preferences on the Mac, or Edit > Preferences on Windows).

On-canvas rendering
As you position 3D models in Design mode, Dimension attempts to display a realistic
preview of the resulting scene on the canvas. Because an accurate rendering of the scene is
so time-consuming, this on-canvas preview is only a rough approximation of what the final
scene will look like. Effects that will appear especially rough in the on-canvas preview
include

Shadows cast by 3D models on the ground plane

Glass and other semi-transparent materials applied to 3D model surfaces

The camera depth of field

Things that don’t display at all in the on-canvas preview include

Reflections cast on one model by another model

Reflections cast by models on the ground plane

1. Launch Adobe Dimension.
2. Click Open, or choose File > Open.
3. Select the file named Lesson_04_begin.dn, which is in the Lessons > Lesson04 folder that

you copied onto your hard disk, and then click Open.
4. Note some of the limitations of the on-canvas rendering of this scene. The shadows being

cast by the two 3D models are hard-edged.



You’d expect to see some part of the wood model being reflected in the shiny silver surface
of the Pipe model, but the reflection isn’t visible.

5. Select Environment in the Scene panel.



6. Click the disclosure triangle to the right of Ground Plane in the Properties panel to
reveal the ground plane options.

Because there is a Reflection Opacity value of 10%, you’d expect to see a slight reflection
of the 3D models in the ground plane, but no reflection appears in the on-canvas preview.

The bottom line is that the on-canvas preview is useful primarily as a way to judge the position,
size, and placement of 3D models within a scene. To see materials, surfaces, and lighting
accurately, you must render the scene.

Render preview
The Render Preview window provides a pretty good idea of what the final render will look
like, but the quality of the preview is limited so that the preview can update quickly as you
edit the scene.

1. Click the Render Preview icon  at the upper-right corner of the work area.
2. Wait for the render preview to update.

3. Click the Toggle Fullscreen icon  at the top of the Render Preview window to view a
larger preview.

4. Note the rough, speckled “noise” in the shadows in the render preview. This is a limitation
of the render preview.

You can adjust settings in the Properties panel, even while the full-screen Render Preview
window is displayed on the screen.

5. In the Scene panel, click Environment.
6. In the Properties panel, turn on Sunlight.
7. Change the Rotation value to 130°.



You should see new cast shadows, caused by the sunlight, appearing to the left of the
objects.

8. Click the Close icon  in the upper-right corner of the Render Preview window to close
it.

9. In the Properties panel, turn off Sunlight.

 Tip

Use the \ key to show and hide the Render Preview window.

Render mode
To really see an accurate view of the scene, the scene must be rendered in Render mode.

1. Before you go to Render mode, click the Camera Bookmarks icon  at the top of the
screen.

You’ll see that there are five bookmarks saved with this file.



2. Click each bookmark in turn to see what each view looks like.
3. When you’re finished, click the “Front view” bookmark to return to that view.
4. To enter Render mode, click the Render tab at the top of the screen.

In Render mode, you’ll see all five of the camera bookmarks displayed at the top of the
Render Settings panel. This handy feature lets you render multiple camera views of a scene
all at once. Since rendering can be very time consuming, this provides a way to queue up
multiple renders of a scene and let them run overnight or while you’re at lunch.

For now, just leave “Current View” selected.

5. Type My_Lesson_04_end LOW in the Export Filename field. Dimension appends the
name of the view to the end of the filename, so this file will be exported as
My_Lesson_04_end LOW-Current View.

6. If you want to change the export location, click the blue export path and choose a new
export location.



7. In the Quality setting, choose Low (Fast).

8. Deselect PSD under Export Format, and select PNG.

9. Click Render.

 Note

Although you can’t continue to work in Dimension while a file is being rendered,
you can continue to work in other applications on your computer. If you have
notifications turned on in your operating system, you’ll receive a notification when
the render is complete.

10. Wait for the render to finish.

The render took about 1 minute and 23 seconds on my 3-year-old MacBook Pro. If you
don’t want to wait for the render to finish, I’ve saved a copy of the rendered file for you in
the lesson files (Lesson_04_end LOW-Current View.png).

11. Now change the Quality setting to High (Slow).
12. Change the filename to My_Lesson_04_end HIGH.
13. Click Render.



Wait for the render to finish. This render took almost 6 minutes on my computer. If you
don’t want for it to finish, I’ve saved a copy of the file for you in the lesson files
(Lesson_04_end HIGH-Current View.png).

While a file is rendering, the Render Status panel displays a progress bar that provides a
rough approximation of how much of the render has completed.

 Tip

While a file is rendering, you can click the Snapshot icon  at any time to save a PNG
or PSD file of the render in progress. Since the render engine performs multiple “passes”
through the scene, a partially completed render may be far enough along to give you a
good idea of what the final render will look like.

Render speed and quality
As you’ve seen, there are three Quality settings available in Render mode: Low (Fast),



Medium, and High (Slow). How do these settings compare?

1. Use Adobe Photoshop to open the two files you just rendered or, if you wish, the
Lesson_04_end HIGH-Current View.png and Lesson_04_end LOW-Current view.png files
included in the lesson files.

2. Examine the files closely. You’ll see that the low-quality render (on the left in the
accompanying image) contains a lot of noise, which is particularly visible in the shadows.
The high-quality render (on the right) contains much smoother shadows and less noise.

You’ll need to determine which render quality you need when you render. Rendering can be
very slow. This is a simple file, and it’s only 1200 x 800 pixels in size. Larger, more
complex files can take much, much longer to render.

Render export formats
So far, you’ve been rendering into the PNG format. But you may have noted that you can
also choose PSD as an output format. What are the advantages to rendering as a PSD file?

There is no difference in the quality of the rendered image between the two formats. The
difference is that the PSD file will contain extra layers and masks that would make it easier to
edit the 2D scene later if necessary. You’ll learn about this in more detail in a later lesson. But
for now, open the lesson file named Lesson_04_end HIGH-Current View.psd and examine the
Layers panel in Photoshop to view the extra data included in a PSD render.

Factors that influence render speed
The time it takes for Dimension to render a scene can vary significantly from file to file and
is influenced by a number of factors. I’ve ranked these factors from most significant



(hardware) to least significant (memory).

Hardware
The speed of the CPU (central processing unit) on your computer has a big effect on render
speed. Generally speaking, the faster your processor, the quicker rendering will complete.
Modern CPUs with more cores and higher speeds will render fastest.

Materials
More than any other factor, the combination of materials used in a scene has a huge impact
on the length of time it takes to render the scene. In general, translucent materials like glass,
liquids, or gels render more slowly than other materials.

Reflections
Reflections on shiny surfaces slow rendering. This includes objects that are reflected on the
shiny surfaces of other objects around them, as well as a ground plane with a Reflection
Opacity greater than zero so that models reflect on it.

Focus

The Focus feature, which simulates depth of field—causing some objects to be blurred and
others to be crisp—slows rendering times.

Canvas size
The total pixel dimensions of the canvas affects render speed. The more pixels, the slower
the render time.

Number and complexity of models
Surprisingly, the complexity and number of models in the scene don’t have a very large
effect on render speeds.

Memory
The amount of memory you have installed on your computer has little effect on rendering
speeds.

Review questions
1 What is ray tracing?

2 What are the three places that the 3D scene is rendered into 2D in Dimension?
3 Do reflections appear in the on-canvas preview?
4 What is the most visible limitation of the render preview?

Review answers
1 Ray tracing refers to the rendering method used by the rendering engine built into

Dimension. Ray tracing performs complex mathematical calculations to determine the
precise color of each pixel in the scene.



2 Dimension performs rendering in three places: the on-canvas preview, the Render Preview
window, and Render mode.

3 No. Reflections cast by objects on the ground plane, and cast by objects on other objects, will
not appear in the on-canvas preview.

4 Because it renders as quickly as possible, the render preview displays a lot of noise, especially
in shadows.



5 Finding 3D Models and Using CC Libraries

Lesson overview
In this lesson, you’ll import models from various sources and learn the following:

Why the starter assets included with Dimension are a good place to start when learning
Dimension

How to use Adobe Stock to find 3D objects

How to download a model from Adobe Stock and use it in a scene

How to use CC Libraries in Dimension

How to import 3D models in other industry-standard file formats into Dimension

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



When you obtain a 3D model from Adobe Stock, you can download it to a Creative Cloud Library, and then place it in your
scene from the Library.

Using starter assets
As you saw in an earlier lesson, Dimension includes dozens of 3D models, materials,
lights, and background images you can use to get started creating 3D scenes. The 3D
models included with Dimension as starter assets are excellent for getting started with 3D
scene building. They are carefully optimized for use with Dimension—they will import
into a scene at a reliable size, arrive at consistent coordinates in the scene, and feature
clearly named surfaces and materials.

Once you begin looking elsewhere for 3D models, you’ll soon discover that model quality varies
widely. You’ll find that some models consist of a low number of polygons, so curved surfaces
appear as a sequence of straight lines. You might find that a model of a bottle is made up of only
a single unit, without the bottle cap consisting of a separate object. A model creator can do any
number of things that make it difficult to work with a model in Dimension or any other program.

Even well-designed, high-quality models are sometimes saved in such a way that when placed in
Dimension they appear upside down, rotated, huge, or tiny, or behave in some other
unpredictable fashion.

For these reasons, until you become comfortable working in Dimension, working with the starter



assets is easiest.

Examine a starter asset
Some of the starter assets are simple objects that consist of just a single model. But other
assets are carefully constructed of multiple models grouped together and clearly labeled to
make working with them easy. Let’s examine one such starter asset and see how it is
assembled.

1. Choose File > New to create a new document. If you currently have another document
open, it will close. If that document isn’t saved, you’ll be prompted to save it before
closing.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose Starter
Assets. This displays the Content panel on the left side of the screen and displays the starter
content in the panel.

3. Make sure that none of the “Filter By” icons are selected.
4. Type laptop into the Search field at the top of the Content panel.

5. Click the 16:10 Laptop model to place the model in the scene. Note that the laptop neatly
lands in the center of the scene.

6. Select the Dolly tool (keyboard shortcut: 3).
7. Drag down on the screen to move farther away from the model so you can see the entire

laptop on the screen.
8. In the Scene panel, note that the laptop model is a group of eight models, each clearly

labeled.



In the Scene panel, the  icon indicates a group that is open, and the  icon indicates a
group that is closed. You can click either of these icons to open or close the group.

 Note

Make sure you have the Filter by Models icon selected

9. Hover over the Laptop Body model in the Scene panel, and click the right-pointing arrow

icon  displayed to the right of the words “Laptop Body.” This displays a new view in
the Properties panel that shows you the material that is applied to the Laptop Body model.

10. With Frame Material selected, examine the Properties panel, and note that the surface
properties are set up for a realistic-looking gray metallic finish on the laptop body. (You
could of course change this surface to any material you wish.)



11. Click the back arrow  in the Scene panel to return to viewing the models in the panel.

12. Hover over the Glass model in the Scene panel, and click the right-pointing arrow icon 
displayed to the right of the words “Glass.” This displays a new view in the Properties
panel that shows you the material that is applied to the Glass model.

13. Examine the Properties panel, and note that the Translucence properties are set up for a
glass appearance on the screen.

14. Click the back arrow  in the Scene panel to return to viewing the models in the panel.



The starter assets have easily identifiable and clearly named groups, models, and pre-applied
materials, making the assets easy to work with.

 Tip

Use the ` keyboard shortcut to show and hide the Content panel.

Modify a starter asset
One big advantage of a model that is made up of a group of clearly labeled submodels is
that the submodels can be transformed just like you would transform the group. In the case
of this laptop model, this makes it easy to rotate the screen, “opening” or “closing” it.

1. In the Scene panel, click the Keyboard model.
2. Hold down the Shift key and then click the Laptop Body model to select the Keyboard,

Trackpad Frame, and Laptop Body models.

 Tip

Just as with most other Adobe design applications, Command+G (Mac) or Ctrl+G
(Windows) is the keyboard shortcut for Group, and Command+Shift+G (Mac) or
Ctrl+Shift+G (Windows) is the keyboard shortcut for Ungroup.

3. Choose Object > Group to group the three models into a single group.
4. Double-click the name of the group to edit it, and name it Body.



5. In the Scene panel, click the Screen Frame model.
6. Hold down the Shift key and then click the Glass model to select the Screen Frame, Screen

Frame Back, Screen, Camera, and Glass models in the Scene panel.

7. Choose Object > Group to group the five models into a single group.
8. Double-click the name of the group to edit it, and name it Screen.

9. Choose the Select and Rotate tool (keyboard shortcut: R).
10. Click the Screen group in the Properties panel to select the models that make up the laptop

screen.
11. In the Properties panel, choose Bottom Center for the Pivot.



 Note

Some 3D modeling programs allow the user to create “rigged” models. These
models contain “knowledge” of how the model parts fit together. A rigged model of
a laptop, for example, would allow the user to hinge the laptop screen open and
closed, but not detach it from the laptop base or slide it forward or back. Dimension
ignores any rigging instructions that may be present in a 3D model.

12. Drag the red rotation arrow on the rotation widget on the canvas until about 70° is
displayed for the X rotation value in the Properties panel.

 Note



Just like the models that come with Dimension as starter assets, all the 3D assets
available on Adobe Stock are carefully optimized for use with Dimension—they will
import into a scene at a reliable size, arrive at consistent coordinates in the scene, and
feature clearly named models, groups, and materials.

Finding assets on Adobe Stock
Adobe Stock is a huge collection of royalty-free images, video, artwork, templates, and 3D
assets, including models, materials, and lights. These assets can be accessed through a web
browser at stock.adobe.com or from within most Creative Cloud applications. The assets
can be purchased in a variety of ways, including via a subscription option. See
https://stock.adobe.com/plans for pricing information.

Locate free Adobe Stock models
Adobe Stock contains a growing library of thousands of 3D models. Several hundred of
these models are free, so you can use these models even without a subscription.

1. Click the Add and Import Content icon  at the top of the Tools panel.
2. Choose Browse Adobe Stock.

Your default browser launches, and you are brought to a curated page on
https://stock.adobe.com that displays many of the free 3D models offered on Adobe Stock.

Find a model and add it to the scene

http://stock.adobe.com
https://stock.adobe.com/plans
https://stock.adobe.com


When you purchase a model from Adobe Stock, or choose a free model, the model is first
downloaded to a Creative Cloud Library. Then, you import the model from the Creative
Cloud Library into Dimension.

1. In your browser on the Adobe Stock page, type 182469767 into the search field at the top
of the screen and then press Return/Enter.

This is the ID number of a specific desk model used in this lesson. This model is free.

2. In the dropdown list next to the download icon , choose the library you want to save the
model into. If you’re unfamiliar with CC Libraries, just choose My Library. Note that you
need to be signed in to Adobe Stock to see the list of libraries.

3. In Dimension, click the Add and Import Content icon  and choose CC Libraries.
4. Choose My Library (or whatever library you chose in step 2) from the dropdown list at the

top of the CC Libraries panel.



5. Locate the Wood Desk with Single Drawer model in the library, and click it. The model
will be placed in the center of the scene.

 Note

CC Libraries are available in all Creative Cloud products and are a great way to
store assets from various programs and share them between Creative Cloud
programs. CC Libraries are used in Dimension as a way to retrieve models, lights,
and materials placed in the Library by Adobe Stock or the Adobe Capture mobile
app.

6. Choose Camera > Frame All to position the camera so that you can see the entire desk on
the canvas.



Modify the scene
All the 3D models in the Adobe Stock library are optimized for use with Dimension, much
like the starter assets. Note that the desk arrived accurately in the scene, just as the laptop
did. It is centered on the scene and sitting on the ground plane.

1. Select the Select and Move tool (keyboard shortcut: V).
2. Click 16:10 Laptop in the Scene panel to select the laptop model.
3. Drag the green arrow up until the laptop model appears to sit on the top surface of the desk.

You may need to use the Camera tools to alter your view of the scene so that you can
determine when the laptop is positioned on the desk surface accurately.

4. Drag the red arrow to the left a bit to move the laptop toward the left side of the desk.

5. Choose the Select and Rotate tool (keyboard shortcut: R).



6. Drag the green arrow on the rotation widget to the right so that the laptop is turned a bit on
the surface of the desk. Again, you may need to use the Orbit tool or other Camera tools to
alter your view of the scene so that you can determine when the laptop is positioned to your
liking.

Add more objects to the scene
In addition to searching https://stock.adobe.com through a web browser, you can also
search Adobe Stock in the Creative Cloud Libraries panel right in Dimension.

1. In the Creative Cloud Libraries panel in Dimension, in the dropdown list to the right of the
search field, choose Adobe Stock.

2. Type MUG into the search field. Several different coffee mugs are displayed. To help you
quickly locate the one we want, type 172516470 into the search field. A white coffee mug
should be displayed.

3. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

https://stock.adobe.com


4. It may take a few moments for the model to download. When it has finished downloading
to your Library, click the model to add it to the scene. It will be added to the center of the
scene, and positioned on the ground plane, which in this scene is the floor beneath the desk.

 Tip

Two camera commands that you might find useful while positioning this small
object in the larger scene are Camera > Frame Selection, which will fill the screen
with the selected object, and Camera > Frame All, which will fill the screen with all
the objects in the scene.

5. Choose the Select and Move tool (keyboard shortcut: V) and use the arrows to position the
mug on the desktop surface wherever you wish.

6. In the Creative Cloud Libraries panel, type notebook into the search field. Several
notebook models will be displayed. To help you quickly locate the one you want, type
213242110 into the search field. A composition notebook model will be displayed.

7. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

8. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene. It will be added to the center of the
scene, positioned on the ground plane below the desk.

9. Choose the Select and Move tool (keyboard shortcut: V), and use the arrows to position the
composition notebook on the desktop surface wherever you wish.

10. Choose the Select and Rotate tool (keyboard shortcut: R).
11. Drag the green arrow to the left a bit to rotate the notebook.



Importing 3D models from other sources
In addition to working with starter assets and content from Adobe Stock, Dimension will
import 3D models in the following industry-standard formats:

FBX (Filmbox)

OBJ (Wavefront)

SKP (SketchUp)

STL (Stereolithography)

Depending on the skill of the person who created the model and the software used, 3D models
can be large and complex. In addition, different 3D modeling programs save their 3D objects
into these standard file formats in various ways.

How successful you’ll be importing a model in one of these formats, and how useable the
resulting model will be, depends on four variables:

How well Adobe has written the translation routine being used to translate the file format
into Dimension’s file format.

How well the modeler has created the model. For example, if the model is of a wine bottle,
did the modeler create the cork in the bottle as a separate object, so that you can apply a
different surface to the cork than to the rest of the bottle, or is the entire bottle a single
object? Is the model constructed of enough polygons so that the curve of the bottle appears
smooth, but not so many polygons that the model is overly complex?

How accurately, consistently, and reliably the modeling software being used writes its data
into the given file format.

How complex the model is relative to the processing power and memory available on your
computer. Some models may import perfectly but slowly and subsequently are slow and
unresponsive in Dimension because they are so complex.



Unfortunately, it is nearly impossible to predict how successful a particular model will import
into Dimension. You pretty much just need to try importing it to find out! If you have a model in
one of Dimension’s supported formats that doesn’t import properly, you are encouraged to report
the issue via the Adobe Dimension feedback website, at https://feedback.adobedimension.com;
be sure to attach the problem file and a description of the problem.

Import an OBJ model
Most people have some personal effects, tchotchkes, or toys on their desks. You’ll add a
toy model of an astronaut to the surface of the desktop.

1. Click the Add and Import Content icon  at the top of the Tools panel, and choose Import
Your Content.

2. Click 3D model.

 Tip

You can also drag and drop models directly from the Finder (Mac) or File Explorer
(Windows) into your scene.

3. 3 Select the file named MKIII.OBJ in the MKIII folder.

The model is placed in the center of the 3D scene, positioned on the floor beneath the desk.
The model will be small relative to the size of the desk.

4. Choose Camera > Frame Selection so that the small model fills the screen.
5. Choose the Select and Scale tool (keyboard shortcut: S).

6. In the Properties panel, click the Lock icon  to the right of Scale to lock the aspect ratio
of the model.

7. Enter 5 into one of the Scale fields to scale the astronaut five times larger.

https://feedback.adobedimension.com


8. Choose Camera > Frame All so you can see all the models.

 Note

The astronaut model is from the repository of free 3D models available from NASA
at https://nasa3d.arc.nasa.gov/models.

9. Use the Select and Move tool and the Select and Rotate tool to position the astronaut model
on the surface of the desk.

10. Click the Render tab, and render the scene if you wish. If you’d rather examine the render

https://nasa3d.arc.nasa.gov/models


of my completed scene, open the Lesson_05_end_render.psd file in Photoshop.

Other sources for 3D content
There are dozens of web sites that sell stock 3D content. Because of the complexity of 3D
models and file formats, it’s important that you purchase models from reputable vendors
that will stand behind their product if the models won’t import into Dimension.

Here is a sampling of some stock 3D sources:

CGTrader: www.cgtrader.com

Sketchfab: sketchfab.com/store

Turbosquid: www.turbosquid.com

There are also various repositories of free 3D content on the web:

3D Warehouse: https://3dwarehouse.sketchup.com/

GrabCAD: https://grabcad.com

National Institutes of Health: https://3dprint.nih.gov

Smithsonian: https://3d.si.edu

Traceparts: www.traceparts.com

http://www.cgtrader.com
http://sketchfab.com/store
http://www.turbosquid.com
https://3dwarehouse.sketchup.com/
https://grabcad.com
https://3dprint.nih.gov
https://3d.si.edu
http://www.traceparts.com


Creating 3D models in Photoshop for use in Dimension
You can use Photoshop to create 3D models for use in Dimension. Here‗s a simple exercise
to get you started.

1. In Photoshop, create a new document that is 1000 px x 1000 px.
2. With the Type tool, create a single word or line of type.
3. Make the text large.
4. Choose 3D > New 3D Extrusion from Selected Layer.
5. If you are asked if you want to switch to the 3D workspace, click Yes.
6. Use the Properties panel to experiment with Shape Preset, Extrusion Depth, and other

settings.
7. Once the model looks the way you want, choose 3D > Export 3D Layer.
8. Choose Wavefront|OBJ for the 3D File Format and then click OK.
9. Name the file, and save it somewhere you’ll remember.

10. In Dimension, create a new file.
11. Choose File > Import > 3D Model.

Identifying potential problems when importing 3D models
Models that you place in your scene from the starter assets or from Adobe Stock should
import into Dimension in a reliable, consistent manner. But models you obtain from other
sources may sometimes behave unpredictably when importing them into Dimension. Here
are some of the potential problems, as well as a few solutions.

Model appears out of scale
The creator of a model doesn’t have any idea what size you want to use the model at, so it
may come into Dimension enormous or really tiny. If the problem isn’t too extreme, you
can scale the object with the Select and Scale tool (keyboard shortcut: S). Or use the Dolly
tool (keyboard shortcut: 3) to enlarge or reduce your view of the object.

Sometimes, an object will arrive so large that just a single small surface on the object fills the
entire screen, so it is difficult to scale the object or zoom in or out. In this case, the Camera >
Frame Selection command (keyboard shortcut: F) will scale your view so that the entire object
fits on the screen.

Object positioned outside the viewable area
Sometimes an object won’t appear anywhere within the Dimension window. This is caused
by the XYZ positioning of the object being out of scale with Dimension’s coordinate

system. Thankfully, when this happens, a blue dot icon  will appear at the edge of the



screen. Clicking this icon will position the screen so that you can see the imported object.

Object positioned below the ground plane
Sometimes an object won’t appear on the screen because it is entirely below the ground
plane. Choosing Object > Move to Ground will quickly move the object above the ground
plane so that it is within view.

Review questions
1 Which of these file formats can be imported as a 3D model into a Dimension scene?
PSD
OBJ
MTL
CAN

2 Are 3D models in the Adobe Stock library free or paid?
3 What does the Object > Move to Ground command do, and when might you need to use it?

Review answers
1 OBJ is an industry-standard 3D file format that can be exported from many different 3D

modeling programs and placed into a Dimension scene.
2 The 3D models available in the Adobe Stock library can be purchased via a monthly

subscription. However, several hundred of the 3D models on Adobe Stock are free.
3 The Object > Move to Ground command will move the selected object so that it is positioned

above the ground plane. This command is sometimes necessary when an imported model
doesn’t appear within view because it is positioned “underground,” beneath the ground plane.



6 Working with Materials

Lesson overview
In this lesson, you’ll explore and apply surface materials in a 3D scene and learn the
following:

An overview of the variety of materials included with Dimension

How to import materials from Adobe Stock

How to import materials from other sources

How to select model surfaces with the Magic Wand tool and then apply materials to those
surfaces

How to adjust the properties common to all materials, such as glow, opacity, and
translucence

How different types of materials affect render speeds

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lessons or to the lesson files.
Look on the Lesson & Update Files tab to access the most current content.



You can apply infinite variations of surface materials to models in Dimension, including metals, glass, wood, and more.

What are materials?
One of the core capabilities of Dimension is the ability to apply a “material” to a 3D object.
Dimension uses materials defined in a subset of the NVidia Material Definition Language
(MDL). Adobe calls this subset Adobe Standard Material. This format defines how light
behaves when it hits the surface of the material. For example, is light emitted from the
surface? If so, how much? Is the surface opaque, transparent, or semi-transparent? Is the
surface rough or smooth? Does the surface exhibit “luster” like shiny metal? If you can see
through the object to the interior, is the interior translucent, and does the object refract the
light?

 Tip

You can learn much more about Adobe Standard Material at
https://helpx.adobe.com/dimension/using/standard-materials.html.

A material can optionally include images that can control properties of the material. For
example, a brick material may include a color image for the variations of brick color, a
roughness image to give areas shiny or matte effects, and a normal image that adds details like
pores to the surface.

https://helpx.adobe.com/dimension/using/standard-materials.html


This lesson is a deep dive into materials. But another way to change the appearance of the
surface of a model is to apply one or more graphics to the surface. Any JPEG, PNG, AI, PSD, or
SVG file can be applied as an image. Applying graphics to model surfaces is covered in depth in
a later lesson.

Where to find materials
Several dozen starter asset materials can be found in Dimension’s Assets panel, including
several types of glass, metals, plastics, woods, papers, fabrics, and marbles, as well as
zebra skin and beer. You can also download hundreds of additional materials from Adobe
Stock or obtain MDL files from other sources and import them into Dimension.

1. Choose File > Open.
2. Select the file named Lesson_06_01_begin.dn, which is in the Lessons > Lesson06 folder

that you copied onto your hard disk, and then click Open.

3. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

4. Click the Materials icon  to view only materials in the panel.
5. Scroll through the panel and note the many different types of starter materials available. As

you’ll see, you can change the properties of each of these materials, so these are a good
starting point for generating a wide variety of surface materials.



6. Scroll to the bottom of the list of starter materials, and click the words “Browse Adobe
Stock.”

 Tip



If you have a material from another source that has been saved as a Dimension-
compatible MDL file, you can place the material on a model by choosing File > Import >
Place Material on Selection.

Your default web browser launches, and you’re taken to stock.adobe.com, where you’ll see
hundreds of additional materials available for purchase.

Applying a material to an object
In this lesson, you’re going to apply various materials from the Starter Assets to models in
this scene.

 Tip

Click the More icon  at the top of the Content panel to toggle between List view and
Grid view. This offers two ways to view materials, depending on your preference.

1. Select the Select and Scale tool (keyboard shortcut: S).

http://stock.adobe.com


2. Click the middle cup to select it.

3. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

4. Click the Materials icon  if it isn’t already selected to view only materials in the panel.
5. In the Search Assets field at the top of the Assets panel, type plastic.
6. Click the Plastic material to apply it to the cup.

7. Click the right-most cup to select it.
8. In the Search Assets field at the top of the Assets panel, type glass.

9. Click the Glass material to apply it to the cup.



 Tip

To speed up the render preview, you can hide all the objects in your scene except the
object(s) you need to preview at the moment. To hide a group or model, click the

eyeball icon  to the right of the relevant group or model in the Scene panel.
Hidden models aren’t rendered, so the preview will generate much faster.

 Note

The three cups in this scene were created by placing the starter asset named “Coffee
Cup” and then deleting the Lid model from the model group.

10. Note that the cup that has the Plastic material applied looks fairly realistic in the work area,
but the cup with the Glass material is speckled. Some types of materials (including glass)
require more processing power to render, so to keep things working at an acceptable speed
on the canvas, these materials display as only a rough approximation. To see a more

accurate preview, click the Render Preview icon .

Apply materials via drag and drop
Sometimes, it’s more convenient to apply a material to a model by dragging the material
from the Starter Assets, from a Library, or from your file system onto the surface of a
model.

1. Choose Edit > Deselect All so that none of the objects in the scene are selected.
2. In the Search Assets field at the top of the Assets panel, type metal.
3. Drag the Metal material onto the leftmost cup in the scene. Release the mouse button when

you see a blue highlight around the cup.



4. Examine the Scene panel. The Scene panel confirms that the Metal material has been
applied to the Cup 1 model.

 Tip

As an alternative to clicking the back arrow at the top of the Scene panel, you can
press the Esc key to “back up” out of the materials view in the Scene panel and
return to the model list.

5. Click the back arrow  at the top of the Scene panel to return to the model list.

The Small Jar object is a group, as indicated by the Group icon .

6. Click the Group icon to open the group. You’ll see that the group consists of two models:
Lid and Jar. Because this object was modeled as two separate models, you can easily apply
separate materials to the lid and the jar. Note that you can open a group without selecting
the group. If you accidentally select the Small Jar group, choose Edit > Deselect All.



7. In the Search Assets field at the top of the Assets panel, type wood.
8. Drag the American Elm Wood material onto the Jar model in the scene. Release the mouse

button when you see a blue highlight around the jar body (not the lid).

9. In the Search Assets field at the top of the Assets panel, type paper.
10. Drag the Glossy Paper material onto the Bag model in the scene. Release the mouse button

when you see a blue highlight around the bag.

Sample a material from another model
Once you’ve applied a material to a model, you can easily apply the same material to other
models with the Sampler tool.

1. In the Scene panel, select the Lid model under Small Jar.

2. In the Tools panel, select the Sampler tool (keyboard shortcut: I).
3. Right-click the Sampler tool, and verify that Sample Type is set to Material since we want

to sample all the material attributes, not just the material color.



4. Click anywhere on the middle cup on the canvas (the plastic cup lying on its side). This
will sample the Plastic material from the cup model and apply it to what you have selected
(the lid of the small jar).

Previewing the materials
Some materials preview better on the canvas than others. To see what the materials really
look like under the lighting conditions of your scene, you’ll need to refer to the Render
Preview window frequently as you work. For some materials, particularly those with
transparency such as glass, you’ll need to render the scene to see the material accurately.

1. If the Render Preview panel isn’t displayed on your screen, click the Render Preview icon 

 to display it.

2. Click the  button at the top of the Render Preview window to display a full-screen
render preview. Depending on the speed of your computer, it may take quite a while for the
preview to display accurately. Notice that the computer takes several passes through the
scene, gradually rendering the scene more and more accurately.



Keep in mind that this is still just a render preview—it isn’t terribly accurate when
rendering certain types of materials. To see the material properties accurately, you’ll need
to do an actual render.

3. Click the  button at the top of the Render Preview window to return to the small render
preview window.

4. Click the Render button at the top of the screen to enter Render mode.

5. Select Current View, Low (Fast) quality, and PNG for the output format, and then click the
Render button.

Changing material properties
So far, we’ve applied starter asset materials without setting any of their properties. But
every material can be customized in several ways using the Properties panel.

1. In the Scene panel, hover over the Cup 2 model, and click the right arrow icon  to reveal
the model materials.

Let’s make the surface a bright orange.

2. In the Properties panel, click the color swatch next to the base color, and change the color
to 255 red, 123 green, 0 blue.



 Note

Because the material for the Jar Lid model was sampled from the Cup 2 model, both
models use the Plastic material. Changing the properties of the material on one
object also changes the properties of the material on the other object. You can sever
the relationship between the two instances of the material by clicking the Unlink
icon in the Actions panel when editing the material.

 Tip

If you hover over a property name in the Properties panel, a question mark will
appear. If you click the property name, you’ll see an animated visual explanation of
what that property does.

3. To make the surface a bit shinier, increase the Metallic value to 10%.

4. Click the back arrow  at the top of the Scene panel to return to the model list.



5. Hover over the Cup 1 model, and click the right arrow icon  to reveal the model
materials.

6. To make the surface a bright orange, in the Properties panel, click the color swatch next to
the base color, and change the color to 255 red, 123 green, 0 blue.

7. To make the surface less reflective, increase the Roughness value to 30%.

8. Click the plus icon  to the right of the Roughness slider.
9. Click Select a File.

10. Select the Dots-white.png file and click Open.



With this PNG mask applied, areas that are black in the PNG will be smooth metallic in the
image, and the white areas will be rough.



11. Press the Esc key to close the image picker and return to the model list in the Scene panel.

12. If the Small Jar group isn’t open, click its Group icon  to open it.

13. Hover over the Jar model (not the lid), and click the right arrow icon  to reveal the
model materials.

14. To make the wood grain finer and more realistic looking, in the Properties panel under
Base Color, change the Rotation value to 3° and change X and Y Repeat to 4.2.

How bitmap images affect material properties
If you examine the Properties panel when a material that is applied to a model is selected,
you’ll see that you can add a bitmap image to the Opacity, Roughness, Metallic, Glow, and
Translucence properties to alter the ways these properties behave.



When a bitmap image is added to Opacity, black areas are transparent, and white areas
are opaque.

When a bitmap image is added to Roughness, black areas are polished, and white areas
are matte.

When a bitmap image is added to Metallic, black areas are non-metallic, and white
areas are metallic.

When a bitmap image is added to Glow, black areas reflect light, and white areas emit
light.

When a bitmap image is added to Translucence, black areas are non-translucent, and
white areas are translucent.

Change glass properties
Adjusting the Translucence properties of a material makes it appear like glass or liquid—
you can see through the material. You can alter the Translucence, Index of Refraction,
Density, and Interior Color properties in the Properties panel to make models appear to be
made of glass, liquid, or gel.

1. Click the back arrow  at the top of the Scene panel to return to the model list.

2. Hover over the Cup 3 model, and click the right arrow icon  to reveal the model
materials.

3. In the Properties panel, click the left arrow icon  next to Translucence to reveal the
Translucence properties if they aren’t already open.

4. To cause the glass to “bend,” or refract the light more, increase Index of Refraction to 2.76.
5. To make the glass more “foggy” or “cloudy,” increase Density to .5.

Remember that you won’t see much of a result from these settings in the on-canvas
preview. The Render Preview panel will give you a much clearer picture of the changes you
make.



6. Click the back arrow  at the top of the Scene panel to return to the model list.

 Tip

To quickly increase or decrease a numeric value in the Properties panel, use the “scrubby
sliders.” Hover over the text to the left of a numeric field, and the cursor will change to a
horizontal double-ended arrow. Press the mouse button and drag to the right or left to
increase or decrease the numeric value in the field. Add the Shift key to change the value
in larger increments.

Sub-selecting model faces
You’ve seen that models can consist of a group of other models. When an object is
modeled this way, it is easy to select the various components of the model if each
component is a sub-model in a group. Sometimes you may find that you want to apply
different materials to different “parts” of a model, but although they look like separate parts
to you, they weren’t created as separate sub-models.

Assuming that the parts in question look different from the surrounding surfaces on the model,
there is a way to apply different materials to different surfaces on a single model. The key is to
use the Magic Wand tool. The Magic Wand tool works similarly to the Magic Wand tool in
Photoshop. When you click a surface with it, Dimension attempts to select the surface up to its
“edges.” Let’s try it out.

1. Select the Magic Wand tool (keyboard shortcut: W).
2. Click inside the cup that is on its side on the table. Note that a blue selection boundary

appears around the inside area of the cup.

3. In the Content panel, type plastic into the search field.
4. Click the Plastic material to apply the original white plastic material to the inside surface of



the cup.

5. In the Scene panel, hover over Cup 2 and click the right arrow icon  to reveal the model
materials.

Note that now Cup 2 has two materials applied: Plastic and Plastic 2.

6. Click the back arrow  at the top of the Scene panel to return to the model list.

Apply materials to the star
Although the Star model in our scene consists of a single model, you can use the Magic
Wand tool to select just some of the surfaces of the star and apply different materials to
these surfaces than the rest of the star.

1. Select the Star model in the Scene panel.
2. Choose Camera > Frame Selection to position the camera to give a large view of the Star

model.
3. In the Content panel, type Paper into the search field.
4. Click the Cardboard Paper material to apply it to the star.
5. Click one of the triangular “sides” of the star with the Magic Wand tool. You’ll see the

triangle highlighted in blue to indicate it is selected.



6. Hold down the Shift key, and click every other facet of the star face. Holding down the
Shift key lets you add to the selection each time you click with the Magic Wand tool.

7. In the Content panel, click the Glossy Paper material to apply it to the star facets.



8. In the Scene panel, hover over “Star” and click the right arrow icon  to reveal the model
materials.

Note that now the Star model has two materials applied: Cardboard Paper and Glossy
Paper.

9. Click the Camera Bookmarks icon  and click Final View to return to the previous
camera view.

10. If you have time, render the scene. Or open and examine the
Lesson_06_01_end_render_high.psd file, which has been rendered for you.



Linking and unlinking materials
In the preceding example, you sampled the material for the Jar Lid model from the Cup 2
model. This created a single material instance that was linked between both models. When
you changed the material color, it was updated on both models. In cases such as this, you
can unlink the material if you want to control the attributes of the material on each object
independently.

Dimension follows a fairly subtle set of rules as to when it links materials and when it doesn’t.
Let’s examine material linking more closely and see how Dimension decides when to link
materials.

Apply materials en masse
You can apply materials to several models at the same time, resulting in a common linked
material, which makes quick work of making changes to those models.

1. Choose File > Open.
2. Select the file named Lesson_06_02_begin.dn, which is in the Lessons > Lesson06 folder

that you copied onto your hard disk, and then click Open.
3. Select the Select and Move tool (keyboard shortcut: V).
4. Click one of the sphere models and then hold down the Shift key and click each of the other

sphere models to select all three models. Notice that the spheres aren’t grouped together.
5. In the Content panel, locate the Plastic material and click it to apply the material to the

three selected spheres all at once. When you apply a material to multiple objects with a
single click, the material is linked between the objects by default.



6. Choose Edit > Deselect All to deselect the sphere models.

7. In the Scene panel, hover over the Sphere 1 model, and click the right arrow icon  to
reveal the material applied to the sphere.

You will see a Break Link to Material icon  appear in the Actions panel. The presence
of this icon tells you that the material you have selected is linked to at least one other
model.

8. In the Properties panel, click the color swatch next to base color, and change the color to a
bright red. The material color of all three spheres changes because all three models share a
common linked material.

Break a link
When you no longer want the material that is applied to several models to be linked, you
can break the link, allowing you to individually modify the material applied to the model.

1. Click the back arrow  at the top of the Scene panel to return to the model list.

2. Hover over the Sphere 2 model, and click the right arrow icon  to reveal the material
applied to the sphere.

3. Click the Break Link to Material icon  in the Actions panel. The icon will disappear
from the Actions panel, indicating that the material is no longer linked to another model.

4. In the Properties panel, click the color swatch next to base color, and change the color to a
bright green.

The material color of only Sphere 2 changes since it contains an independent material that
is no longer linked to the other spheres.



Apply materials one at a time
If you apply the same material to several objects one at a time, the result is that the material
is not linked between the models. The material applied to each model is a separate
“instance” of the material. The properties of the material instance can be changed without
affecting the other models.

1. Click the back arrow  at the top of the Scene panel to return to the model list.
2. Locate the Matte material in the Content panel, and drag it onto the leftmost sphere model.
3. Drag the Matte material onto the middle sphere model.
4. Drag the Matte material on the rightmost sphere model.
5. Double-click the leftmost sphere to reveal the material applied to the sphere in the Scene

panel.

No Break Link to Material icon is displayed in the Actions panel. This means that the
material you have selected is not linked to any other models.

6. In the Properties panel, click the color swatch next to base color, and change the color to a
bright red.

The material color of only Sphere 1 changes, since it contains an independent material that
is not linked to the other spheres. When you apply materials independently to objects one at
a time, even if you apply the same material to each model, the materials are unlinked by
default.



Apply materials with the Sampler tool
If you want to apply a material that is applied to one model to another model, you can do
so with the Sampler tool. The result will be a material that is linked between the two
models.

1. Click the back arrow  at the top of the Scene panel to return to the model list.
2. In the Scene panel, click Cube 1 to select it.
3. Click the Metal material in the Content panel to apply it to the surface of Cube 1.

4. Click the back arrow  at the top of the Scene panel to return to the model list.
5. Click Cube 2 in the Scene panel to select it.
6. Select the Sampler tool (keyboard shortcut: I), and click the Cube 1 model (the cube with

the metal material applied) on the canvas.
7. The Scene panel shows that the Metal material is applied to the Cube 2 model. Note that

the Break Link to Material icon  appears in the Actions panel. This is your cue that the
metal material used for Cube 1 is linked to Cube 2 also.

8. In the Properties panel, click the color swatch next to base color, and change the color to a
bright red.

The material on both Cube 1 and Cube 2 changes since they are linked. When you use the
Sampler tool to sample a material from one model to another, the materials in both models
will be linked by default.



Paste vs. Paste as Instance
Dimension has two Paste commands in the Edit menu: Paste, and Paste as Instance. After
you’ve copied a model to the clipboard, both of these commands will paste a duplicate of
the model. But the two commands differ in how the materials on the duplicates are linked
to the original model.

1. Select the Select and Move tool (keyboard shortcut: V).
2. Select the single cylinder model at the top of the scene.
3. Choose Edit > Copy.
4. Choose Edit > Paste.
5. Drag the blue arrow to the right so you can see both cylinders.
6. On the canvas, double-click the duplicate cylinder that you just created to reveal the

cylinder material in the Scene panel.
7. In the Properties panel, click the color swatch next to base color, and change the color to a

bright green.

The material on only one of the cylinders changes since they aren’t linked. When you copy
and paste a model, use the Edit > Duplicate command, or Option/Alt-drag to duplicate a
model, the materials of the models aren’t linked by default.

8. Select the green cylinder model.
9. Choose Edit > Copy.

10. Choose Edit > Paste as Instance.
11. Drag the blue arrow to the right so you can see both green cylinders.
12. On the canvas, double-click the duplicate green cylinder that you just created to reveal the

cylinder material in the Scene panel.
13. In the Properties panel, click the color swatch next to base color, and change the color to

blue.

The material on both cylinders changes since they are linked. When you use the Paste as
Instance command, the materials in both models are linked by default.



Linking summary
The subtleties of how Dimension links materials between objects can be boiled down to the
following statements:

When you apply a material to multiple objects with a single click, the material is linked
between the objects by default.

When you apply materials independently to objects one at a time, even if you apply the
same material, the materials are unlinked by default.

When you use the Sampler tool to sample a material from one model to another, the
materials in both models are linked by default.

When you copy and paste, use the Edit > Duplicate command, or Option/Alt-drag to
duplicate a model, the materials of the models aren’t linked. But when you copy a model
and use the Paste as Instance command, the materials in both models are linked by default.

Review questions
1 Why do some materials appear “speckled” on the canvas?

2 What is one way to speed up the render preview?
3 What tool do you use to apply multiple materials to a single model?
4 When using the Magic Wand tool, how do you add to a selection?
5 What tool would you use to sample a material from one model and apply it to another?
6 If you drag the same material onto five objects, one object at a time, will the same material be

linked to all five objects?

Review answers
1 Some materials, especially glass, take a long time to render, so the preview on the canvas

is a rough approximation of the final result and will appear speckled.
2 You can greatly speed up the render preview by hiding models you don’t need to preview. To



hide a model, click the eyeball icon  next to a model in the Scene panel.
3 The Magic Wand tool allows you to “subselect” individual surfaces of a model and apply a

different material to each surface.
4 After you’ve clicked with the Magic Wand tool to select a surface on a model, hold down the

Shift key and click another surface to extend the selection.
5 You can use the Sampler tool (keyboard shortcut: I) to sample a material from one model and

quickly apply it to another model.
6 No, if you drag the same material onto five objects, one object at a time, each object will have

an independent instance of the material and not be linked to any other models. If you select all
five models and apply a material to all five models at once, then the same material is linked to
all five models.



7 Creating Materials with Adobe Capture CC

Lesson overview
In this lesson, you’ll use the Adobe Capture CC mobile app and learn the following:

How to use Capture to create unique materials to use in Adobe Dimension

How to edit materials in Adobe Capture to fit your needs

How to use materials you’ve created with Capture in Adobe Dimension

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



The Adobe Capture mobile app is a fun and powerful way to create interesting materials that you can apply to your models in
Adobe Dimension.

About Adobe Capture CC
Adobe Capture CC is a mobile app for iOS and Android devices. The purpose of Capture is
to enable you to capture inspiration from the world around you and turn that inspiration
into type, brushes, patterns, shapes, colors, and—specifically for our purposes in
Dimension—materials.

When you are out and about and see a material or texture that you think would work well for a
model in Dimension, you can shoot a photo of the texture with your mobile device’s camera and,
in a few taps of the screen, turn it into a material ready to apply to a model in Dimension.

You can learn more about Adobe Capture at www.adobe.com/products/capture.html.

Download and install Adobe Capture on your mobile device
To download and install Adobe Capture CC on your iPhone or iPad, go to
www.adobe.com/go/getcapture_ios.

To download and install Adobe Capture CC on your Android mobile device, visit
www.adobe.com/go/getcapture_android.

http://www.adobe.com/products/capture.html
http://www.adobe.com/go/getcapture_ios
http://www.adobe.com/go/getcapture_android


Capturing a material
You can capture a material from a photo that you take with your device, from a stock
photo, or from any asset you’ve saved in Creative Cloud. Here’s how.

1. Launch Adobe Capture on your mobile device. If prompted, sign in with your Adobe ID.

2. (If the Capture preferences on your device are set so that Capture opens directly into
camera mode, tap the X in the lower-left corner of the screen to close the camera.) At the
top of the screen, choose a CC Library from the dropdown list. If you’re unfamiliar with
CC Libraries, just choose My Library.

3. Tap Materials at the top of the screen.



4. Tap the Camera icon .

5. Point the camera at an interesting texture or pattern, and then tap the  icon to take a
photo.



6. Make adjustments to the material attributes, if desired.



Roughness controls how shiny the surface is. A higher value makes the surface
rougher, allowing less shine on the surface.

Detail controls the details in the surface. Increasing the Detail value adds detail to the
surface with a sharpening effect.

Metallic controls the degree of metallic luster on the surface. A higher value makes the
surface appear more metallic.

Increasing the Intensity setting makes the surface texture higher, and decreasing the
Intensity setting makes it lower. This value affects the “normal map” bitmap image
that appears in the Properties panel in Dimension when the material is applied to a
model.

Frequency determines the light and shadow. Adjusting the Frequency value adjusts the
sharpening effect to the normal map, changing the appearance of light and shadow on
the surface.

Repeat changes the “tile” size of the material. A larger value results in a smaller image



that will repeat more frequently when used on a large model. A smaller value will
repeat less frequently.

If you increase the Blend Edges value, Capture will attempt to blend the edges between
each tile when a material repeats across a model’s surface.



7. Tap Save to save the material. The material is added to the CC Library you chose in step 2
and is ready to use in Dimension.

 Tip

If you want to change the name of your material, tap the More icon  on the material
thumbnails screen and tap Rename.

Capture a material from a photo
In addition to capturing materials from your mobile device’s camera, you can also capture
materials from a photo that is in your device’s camera roll, that you previously saved in
your Creative Cloud storage, that you’ve brought into Lightroom, that is from Adobe



Stock, or that is from any other source you have access to on your device, such as Dropbox
or Google Drive.

1. Launch Adobe Capture on your mobile device.

2. If the Capture preferences on your device are set so that Capture opens directly into camera
mode, tap the X in the lower-left corner of the screen to close the camera.

3. At the top of the screen, choose a CC Library from the dropdown list. If you’re unfamiliar
with CC Libraries, just choose My Library.

4. Tap Materials at the top of the screen.



5. Tap the image icon .
6. Tap Stock from the pop-up list to access Adobe Stock.
7. In the search field, type texture and then tap Search. This will reveal hundreds of texture

images.

8. Tap a texture that you like.
9. Tap either Save Preview (to download a watermarked comp image) or License Asset (to

purchase the image).



10. Choose a CC Library to save the stock image to.



11. Tap the  icon to bring the image into Adobe Capture.
12. Make adjustments to the material attributes, if desired.
13. Tap Save to save the material to your CC Library.

Using a material from Capture in Dimension
Using a material that was created in Adobe Capture is just like using a material from any
other source.

1. Launch Adobe Dimension.
2. Choose File > Open.
3. Select the file named Lesson_07_begin.dn, which is in the Lessons > Lesson07 folder that

you copied onto your hard disk, and then click Open.

You’ll see that a brick material has been applied to the prism on the left, and a wood



material has been applied to the pipe on the right. Both of these materials were generated by
Adobe Capture. You can either work through the rest of this lesson using these materials or
follow steps 4–7 to apply the materials that you created with Capture.

4. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

5. In the dropdown menu at the top of the Content panel, choose the library that you saved the
captured materials into.

6. Drag one of the materials you created with Adobe Capture onto the Prism model on the
canvas. Or, if you prefer, choose File > Import > Place Material on Selection and choose
the Material_14.mdl file in the Bricks folder to use the Brick material I created with
Capture.

7. Drag another one of the materials you created with Adobe Capture onto the Pipe model on
the canvas. Or, if you prefer, choose File > Import > Place Material on Selection and
choose the Material_6.mdl file in the Maple folder to use the Maple wood material I
created with Capture.



Modifying material properties
You may need to adjust several things after applying a material generated by Capture to a
model in Dimension. The materials created with Capture are photographic bitmaps of a
specific width and height, along with another bitmap (stored in the Normals property) that
controls the simulated texture of the bitmap. Since the material is a bitmap of a certain
height and width, it might not be the correct size or orientation relative to your model when
you first apply it. Here are some ways to rectify these problems.

Material not aligned with model
I’ve applied a brick material to the Prism model. But I don’t want the bricks running
vertically.

 Tip

Since you probably don’t know the exact rotation value that you will need, you may find
it helpful to hover over the Rotation icon  in the Properties panel and drag to the right
or left to adjust the numeric rotation value.

1. Hover over the Prism model, and click the right arrow icon  to reveal the material
applied to the prism.

2. In the Properties panel, change the Offset, Rotation, or Repeat values as desired. In my
case, I entered 90° to rotate the bricks to align with the prism.



Material too small or too large compared to the model
When you create a material with Capture, you won’t have a sense of how large or small the
pattern or texture will be relative to the model you will apply it to. You can scale the
material up or down in Dimension.

To scale the material relative to the model, in the Properties panel, change the Repeat X and Y
values as desired. Entering a larger value for Repeat causes the bitmap to shrink in size and to
repeat multiple times, if necessary, to cover the entire model surface. Entering a smaller value
enlarges the bitmap so that any visible texture in the material becomes larger relative to the
model. In my example, I entered a repeat of 1.5 to make the bricks a bit smaller.



Seam visible in material when applied to the model
If a material is not large enough in width or height to cover the entire surface of the model,
it will repeat, or “tile,” across the surface of the model. When this happens, a seam will
usually be visible where the material repeats. In my example, this is quite visible on the
Maple material that I applied to the pipe.

One way to fix this would be to make the material larger by entering a smaller value for the
Repeat, as described earlier. But in this case, I don’t like the way the resulting material looks
when enlarged. Another way to fix this is to select the pipe with the Select and Rotate tool and
rotate the model so that the seam is hidden.

To achieve a pleasing result, you may also need to change the X and Y Offset values in the
Properties panel to change where the tiles begin and end relative to the model.



Too much (or too little) surface detail in the material
Materials generated by Adobe Capture contain a “normal map.” This is a special bitmap
file that controls how the surface affects light and shadows. Light areas in the bitmap will
appear slightly raised on the surface, and darker areas will appear slightly depressed. This
effect is most noticeable when sunlight hits the surface at certain angles.

In my example, when sunlight hits the brick material, the white mortar appears to ooze out
between the bricks.



1. Hover over the Prism model, and click the right arrow icon  to reveal the material
applied to the prism.

2. In the Properties panel, click the image swatch next to Normals. This reveals the bitmap
that is the normal map.

3. Double-click the image to edit it in Photoshop. Adding contrast will make the surface
texture more pronounced, and removing contrast will make it less pronounced. Inverting
the lights and darks will reverse the texture effect. Deleting the image altogether will
remove the texture effect entirely.





Material too flat or too shiny
When you create a material with Adobe Capture, you have some control over how metallic
the material is. But at first glance, it might appear that you can’t edit how metallic a
material from Capture is after you’ve applied it to a model. But if you know a little trick,
you can.

1. Hover over the Pipe model, and click the right arrow icon  to reveal the material applied
to the prism.

In the Properties panel, you’ll see that the sliders for Roughness and Metallic are grayed
out, which indicates that you can’t change them. But here’s the trick.

2. Click the properties swatch next to Roughness.

3. Click the trash icon to remove the bitmap that came from Capture. Now you can adjust the
Roughness slider.

4. Click the properties swatch next to Metallic.



5. Click the trash icon to remove the bitmap that came from Capture. Now you can adjust the
Metallic slider.

Now you have full control over how smooth and shiny the surface of the model is.

Review questions
1 When editing a material in Adobe Capture, what does the Metallic slider do?

2 In addition to creating materials from your mobile device camera, what other sources can you
use to create materials with Capture?

3 What should you do if a material created with Capture isn’t the right size when applied to a
model?

4 Why might you see a “seam” displayed on a model after a material has been applied?

Review answers
1 Adjusting the Metallic value controls the degree of metallic luster (shininess) on the

surface of the material.
2 You can create a material with Capture from any image that has been saved to your device’s

camera roll, Creative Cloud storage, Dropbox, or Google Drive. Capture can also access
images in Adobe Lightroom and images in Adobe Stock.

3 To change the size and position of a material that is applied to a model, adjust the Offset,
Rotation, or Repeat values as desired in the Properties panel.

4 A seam in the material may be visible if the bitmap image used to create the material isn’t large
enough to cover the entire model surface. To fix this, you can use the Offset, Rotation, or
Repeat values in the Properties panel, or reposition the object to hide the seam.



8 Selecting Objects and Surfaces

Lesson overview
In this lesson, you’ll explore how to select objects and surfaces on the canvas and learn the
following:

Two different ways to use the Select and Move, Select and Scale, and Select and Rotate
tools to select objects on the canvas

How to use tool options to modify the behavior of the Selection tools

How to restrict your selection to only certain models within a model group

How to precisely select specific surfaces of a model

This lesson will take about 30 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



In order to make quick and accurate selections of the models in your scene, it is important to understand the options provided by
the Select and Move, Select and Scale, and Select and Rotate tools.

Using the Selection tools to select objects
When you needed to select a model in previous lessons, most of the time you did so by
clicking the name of the model or the model group in the Scene panel. I am in the habit of
making most of my selections this way, as this method has three distinct advantages. First,
it is very precise. When you use this selection method, you will end up selecting the model
or models you want, and nothing extra. Second, this method makes you focus on the Scene
panel as you work, which has the added benefit of making you aware of how your models
are grouped, which models are locked, and which models are hidden. It is a best practice to
frequently refer to the Scene panel as you work on a complex project. Third, you are able
to select models and groups via the Scene panel regardless of which tool you have selected
at the moment. You can select an object while the Orbit tool is selected, for example.

But sometimes it’s quicker or more convenient to select models and groups directly on the
canvas. You can do this with the three selection tools: the Select and Move tool, the Select and
Scale tool, and the Select and Rotate tool.

Select multiple objects by clicking
Let’s look closely at the various options for selecting objects on the canvas with the Select
and Move tool.

1. Choose File > Open.
2. Select the file named Lesson_08_begin.dn, which is in the Lessons > Lesson08 folder that



you copied onto your hard disk, and then click Open.

If you look in the Scene panel, you’ll see that this scene consists of five model groups (four
cans and a table) as well as a model of a banana.

3. To zoom in on the cans, click the Camera Bookmarks icon  and click the “Four cans”
bookmark.

4. Select the Select and Move tool (keyboard shortcut: V).
5. Click the red can to select it. You can tell that it is selected because the move widget

appears on the can, and the “Red can” model group is highlighted in the Scene panel.

6. Right-click the Select and Move tool in the Tools panel, and click the Add to Selection icon



 under Selection Mode.
7. Click a second can, and you’ll see that it is added to the selection. You’ll see the move

widget move to a common center between the two models, and you’ll see both models
highlighted in the Scene panel.

8. Click a third can and then a fourth can so that all the cans are selected.
9. Right-click the Select and Move tool in the Tools panel, and click the Subtract from

Selection icon .

 Tip

Instead of right-clicking a selection tool and choosing the Add to Selection or
Subtract from Selection icons, it is much more convenient to add to a selection by
holding down the Shift key and clicking a model that isn’t yet selected; subtract
from a selection by holding down the Shift key and clicking a model that is selected.

 Note

Any change you make to the options for one of the selection tools will also apply
immediately to the other selection tools. In other words, changing the options for the
Select and Move tool will also change the options for the Select and Rotate and
Select and Scale tools.

10. Click the green can to deselect it. You should now have three cans selected, and you can
verify this in the Scene panel.



11. Drag the blue arrow to the left a bit to move all three selected cans. Note that there is no
need to group the cans just to move, rotate, or scale them. As long as all three are selected,
they can all be transformed at once.

Select multiple objects with marquee select
The Add to Selection option is good if you need to surgically select several objects in a
crowded scene and need to “skip over” some of the objects while selecting others. But if all
your objects are positioned close to each other without other objects in the way, another
selection method is very useful.

1. Choose Edit > Deselect All to deselect the cans.
2. Right-click the Select and Move tool in the Tools panel, and click the New Selection icon 

 under Selection Mode.

This returns the Select and Move tool behavior to “normal” so that it will not add to or
subtract from the selection. After using the Add to Selection or Subtract from Selection
buttons, it is easy to forget that they are chosen, causing the selection tools not to function
as you are expecting!

3. Position the mouse somewhere above and to the left of the four cans, and drag a rectangle
down and to the right so that the rectangle touches the tops of the cans but nothing else.

Anything that is touched by this selection rectangle, or “band select,” is selected. You
should see in the Scene panel that all four cans are selected. Note that a can didn’t have to
be entirely inside the band to be selected. The band needs to touch only part of a model or
model group to select the entire model or model group.



4. Choose Edit > Deselect All to deselect the cans.

5. To change your view of the scene, click the Camera Bookmarks icon  and click Banana.
6. Right-click the Select and Move tool in the Tools panel, and click Partial Marquee Select to

turn this option off.

With the Partial Marquee Select option turned off, a model must be entirely surrounded by
the selection rectangle to get selected.

7. So that we don’t accidentally bump the table while we are working with the banana, hover

over the Table group in the Scene panel, and click the light gray lock icon  to lock the
Table group.

8. Drag a selection rectangle that touches only part of the banana.

The banana is not selected, because the entire model isn’t contained within the selection
rectangle.



 Note

When the Partial Marquee Select option is on, the selection rectangle displays light
blue shading. When Partial Marquee Select is off, the selection rectangle is not
shaded. This can help you remember whether the option is on or off.

9. Drag a selection rectangle that entirely encloses the banana. It makes no difference if the
rectangle touches a part of one of the cans, but the entire banana must be contained in the
band.

Now the banana is selected.



You may notice that the arrows on the move widget aren’t aligned with the x-, y-, and z-
axes in your scene. This is because the banana was rotated after it was brought into the
scene.

10. To make it easier to move the banana around on the tabletop, right-click the Select and
Move tool and turn the Align to Scene option on.



Now you should see the arrows on the move widget aligned with the x-, y-, and z-axes.

11. Grab the banana (not one of the move widget arrows) and drag it to move it on the tabletop.

Grabbing the banana directly is the same as grabbing the magenta selection handle on the
move widget, restricting movement to the x- and z-axes.

You can choose to set the Partial Marquee Select option on or off. I prefer to leave it on, as
this more closely mimics the behavior of the Selection tool in Illustrator and InDesign.
However, if you choose to work with the option turned off, you should be aware of how it
interacts with a feature called Group Select.

12. With the Partial Marquee Select option still turned off, drag a band select that touches just
the middle of one of the cans. When you release the mouse, the can will not be selected.
This makes sense, because the entire model wasn’t inside your selection rectangle and
Partial Marquee Select is turned off.



13. Drag another selection rectangle, but this time enclose the top of one of the cans. When you
release the mouse button, you might be surprised to see that the can is selected. But why?
The entire can wasn’t enclosed in the selection marquee, so why was it selected?

If you look closely at the Scene panel, you’ll see that each can is a model group made of
three models: a Pull Ring model, a Liquid model, and a Can model. When you dragged
your selection marquee around the top of the can, the Pull Ring model was entirely
enclosed in the selection rectangle, so that model was selected. And then, by extension, the
entire model group was selected since the Group Select option was also turned on in the
Select and Move tool options. When the Group Select option is on, selecting a model in a
group selects the entire group. You will learn more about the Group Select option in the
following section.



Select part of a group
Normally, when you click a model on the canvas, if that model is part of a model group,
the entire model group is selected. This is because by default the Group Select option for
the selection tools is turned on. Let’s see what happens when you turn this option off.

1. To change your view of the scene, choose Camera > Switch to Home View.
2. With the Select and Move tool, click the blue tablecloth on the canvas. Look in the Scene

panel, and you’ll see that the entire Table group is selected.
3. To unlock the table group that you had locked earlier, choose Object > Lock/Unlock.
4. Choose Edit > Deselect All to deselect the model group.
5. Right-click the Select and Move tool in the Tools panel, and turn off the Group Select

option.

6. Click the blue tablecloth on the canvas.

Now only the Tablecloth model is selected, as you can see in the Scene panel.

7. Choose Edit > Deselect All to deselect the model group.
8. Right-click the Select and Move tool in the Tools panel, and turn the Group Select option

back on.



9. Hold down the Command key (Mac) or Ctrl key (Windows) and click the blue tablecloth
on the canvas. Only the Tablecloth model is selected, not the Table group. Holding down
the Command/Ctrl key and clicking a model restricts the selection to a single model within
a group, the same as turning on the Group Select option.

10. In the Scene panel, hover over the Tablecloth model (in the Table group), and click the

eyeball icon  to hide the tablecloth.



 Tip

When you have a model in a group selected, pressing the Esc key selects the parent group
that the model is in.

Using the Magic Wand tool to select surfaces
While the Select and Move, Select and Scale, and Select and Rotate tools are used to select
models and model groups, the Magic Wand tool is used to select individual surfaces on a
model. As you’ll see, it works a lot like the Magic Wand tool in Adobe Photoshop.

1. Select the Magic Wand tool (keyboard shortcut: W).
2. Click somewhere on the table leg closest to the camera.

You’ll see that part of the surface of the leg is selected. Depending on where you clicked, a
different amount may be selected than pictured here, and that’s okay. The Magic Wand tool
tries to determine different parts of a model surface based on edges and similarity of tone.
We want the entire leg selected, but the Magic Wand didn’t select enough.



3. Right-click the Magic Wand tool in the Tools panel.
4. Drag the Selection Size slider all the way to the right, to Large.



5. Click again on the leg, and this time the entire leg should be selected.



The attributes of a particular model and what you are trying to select will determine what
works best for the Selection Size slider. I tend to leave this slider all the way to the left, on
the Tiny setting, and then use the following technique to increase the size of the selection.

6. Double-click the Magic Wand tool in the Tools panel again.
7. Drag the Selection Size slider all the way back to the left, to the Tiny setting.

8. Click the top surface of the tabletop with the Magic Wand tool. With the Selection Size
slider set to Tiny, only the top part of the tabletop is selected, not the edges.

9. Hold down the Shift key, and click one of the edge surfaces of the tabletop. This adds that
area to the selection. If any other portions of the tabletop need to be added to the selection,
Shift-click them.

An alternative to holding down the Shift key to add to or take away from a selection is to
right-click the Magic Wand tool, click either the Add to Selection or Subtract from
Selection button, and then click the model. But it is much easier to Shift-click an unselected
surface to add it to the selection or to Shift-click a selected surface to remove it from the
selection.

Change the material applied to a surface
Now that the tabletop surface is selected separately from the rest of the model, you can
change the material applied to its surface.

1. In the Content panel, locate and click the Galvanized Metal material (in the starter assets)
to add a stylish metal top to the table.

I don’t like the way the wood grain runs vertically on the horizontal “skirt” pieces under the
tabletop. Let’s fix this.

2. With the Magic Wand tool, click the skirt piece under the left side of the tabletop.



3. Hold down the Shift key and click the second skirt piece.

4. In the Scene panel, hover over the Table model, and click the right arrow icon  to reveal
the materials applied to the table.

5. Select the American Cherry Wood material in the Scene panel.
6. In the Properties panel, under Offset, change the rotation angle to –90° and press

Enter/Return.

Unfortunately, this rotates the wood grain on the entire Table model, not just on the pieces
we selected with the Magic Wand tool.



7. Choose Edit > Undo Selection to undo the rotation. So that we can rotate the wood grain on
the skirt pieces independently, we need to apply a separate “instance” of the wood material
to the selected skirt pieces.

8. In the Content panel, locate and click the American Cherry Wood material (in the starter
assets) to apply it to the skirt pieces. No change will be visible on the canvas.

9. If you no longer see the table materials in the Scene panel, hover over the Table model and

click the right arrow icon  to reveal them.

Now you should see three materials: American Cherry Wood, Galvanized Metal, and
American Cherry Wood 2.



10. Click American Cherry Wood 2 in the Scene panel.
11. In the Properties panel, under Offset, change the rotation angle to –90° and press

Enter/Return.

Now the grain on the table skirt pieces should run in the right direction.

12. In the Properties panel, under Repeat, change the X and Y values to 2.2 and press
Enter/Return. This will make the grain look more realistic.



Review questions
1 Aside from using the Add to Selection and Remove from Selection buttons in the

selection tool options, how can you select multiple models on the canvas?
2 If you want a marquee selection to select only models that are entirely enclosed in the marquee,

should the Partial Marquee Select option be turned on or off?
3 To select only a single model (not the entire group) when the Group Select option is on, what

key would you hold down while clicking a model within a group?
4 What should you do if the move, scale, or rotation widget displayed on a model on the canvas

isn’t aligned with the x-, y-, and z-axes of your scene, making it difficult to transform your
model?



Review answers
1 Hold down the Shift key while clicking an additional model to add that model to an

existing selection. Or hold down the Shift key while clicking a selected model to remove
that model from the selection.

2 Turning the Partial Marquee Select option off in the selection tools options will cause a
marquee select to select only models that are entirely enclosed in the marquee selection
rectangle.

3 Hold down the Command key (Mac) or Ctrl key (Windows) while clicking a model in a model
group to select only the model, not the entire group.

4 When the move, scale, or rotation widget doesn’t display as expected on a model on the
canvas, right-click one of the selection tools and turn on the Align to Scene option.



9 Applying Graphics to Models

Lesson overview
In this lesson, you’ll explore and apply graphics to model surfaces and learn the following:

What types of graphics can be applied to the surface of a model

When to use a vector format versus a bitmap format for a graphic

How to edit a graphic after it has been applied

How to apply multiple graphics to a model surface

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



The ability to apply graphics to model surfaces opens all kinds of possibilities for adding labels and other artwork to your models.

Beginning a new project and importing a model
A common task in package design is mocking up a specific type of package with the
artwork that is going to be printed on, or affixed to, the package. Since you can import and
apply graphics to the surfaces of models, Dimension is useful for this workflow. In this
lesson, you will apply some background artwork and a couple of labels to the sides of a
metal spray can model.

1. In Adobe Dimension, choose File > New to start a new project.
2. In the Properties panel, change the width to 3000px and the height to 2000px. Increasing

the pixel dimensions will make your artwork look much better.

3. Choose View > Zoom to Fit Canvas to fit the new canvas size on the screen.



4. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

5. In the Creative Cloud Libraries panel, in the dropdown list to the right of the search field,
choose Adobe Stock.

6. Type 208142479 into the search field.

A spray can model should be displayed.

7. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

8. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene. It will be added to the center of the
scene, positioned on the ground plane.

In the Scene panel, you’ll see that the model is a group named tall_spray_can_1530.

9. Double-click the name of the group and change the name to Spray can. Change the name
of the top model in the group to Nozzle, and change the name of the other model to Body.

10. Choose Camera > Frame All to position the camera on the model.



11. Click the Camera Bookmarks icon  at the top of the screen.

12. Click the plus icon  to create a new bookmark.
13. To rename the bookmark, type Starting view and press Return/Enter. Creating a bookmark

will allow you to easily return to this view at any time.
14. Choose File > Save to save the file with a name and location that will allow you to find it

later.

Applying a background graphic
In previous lessons you learned how to apply materials to the surface of a model to change
its look. In addition to color and pattern, materials can contain all kinds of other properties,
such as glow, roughness, metallic, and translucence. A graphic is another way to apply
color and pattern to a model surface, and this color and pattern works in concert with the
model’s surface material.

Files in the AI (Adobe Illustrator), PSD (Adobe Photoshop), JPEG, PNG, or TIFF format can be
placed as graphics on the surface of a model.

1. In the Scene panel, click the Body model to select it.

2. In the Actions panel, click the Place Graphic on Model icon .

3. Select the file named Background_label.psd and then click Open.

The label is placed on the body of the spray can, visible to your current view at the size of
your model. The label is surrounded by a round selection widget that makes it easy to
resize, rotate, or move the label on the model. (If you don”t see the selection widget as
pictured here, select the Select and Move tool in the Tools panel (keyboard shortcut: V).



4. Hold down the Shift key, and drag one of the four selection handles on the widget outward
to make the label larger. Holding down the Shift key constrains the scaling to be
proportional.

5. Choose Edit > Undo Edit Graphic as many times as necessary until the graphic is back to
its original size.

You can also scale the graphic in the Properties panel.

6. Enter 25% for the X Scale value to make the graphic larger.

7. Drag the label downward on the surface of the model until it is covering only the sides of
the can, not the top.



Applying additional graphics
A single model surface can contain as many graphics as you wish. Let’s add a second label
to the body of the spray can.

1. In the Actions panel, click the Place Graphic on Model icon .
2. Select the file named Lessence_du_jour_label.ai and then click Open.
3. Scale and position the label on the spray can body as desired.



Note that in the Scene panel, there are now two graphics listed, as well as the original
material applied to the spray can body.

4. Double-click Graphic 2 and change the name to Lessence label graphic.



 Tip

Always take a moment to name models, groups, and labels in the Scene panel. This
added clarity will pay off later on when you need to perform further editing in the
file.

5. Double-click Graphic and change the name to Background graphic.

6. Select the Orbit tool in the Tools panel (keyboard shortcut: 1).
7. Drag from right to left across the screen until you can see the back side of the spray can.

8. In the Actions panel, click the Place Graphic on Model icon .
9. Select the file named Lessence_du_jour_label.ai and then click Open.

Since this is the same file you placed on the front of the can, you get another copy of the
L’essence du Jour label on the back of the can. But this is an Illustrator file that contains
multiple artboards, and you can choose a different artboard after the graphic is placed.

10. In the Properties panel, click the image swatch next to the word “Image.”

11. Choose Artboard 2 from the dropdown list of artboards.



12. Select the Select and Move tool in the Tools panel (keyboard shortcut: V).
13. Scale and position the label as desired.



Note that there are now three graphics listed in the Scene panel. You can change the
stacking of these graphics.

14. Drag Graphic 3 below Background graphic in the list, and you’ll see that Background
graphic covers up Graphic 3.

 Tip

You can also drag and drop graphic files from the Macintosh Finder or Windows
File Explorer onto a model to place the graphic on the model surface. Or you can
copy and paste a graphic from Photoshop or Illustrator onto a selected model in
Dimension.

15. Drag Graphic 3 back up to the top of the list so that it is visible again.

Modifying graphic properties
Each label can have its own properties for opacity, roughness, and metallic.

1. Click the Camera Bookmarks icon  at the top of the screen.
2. Click Starting View to return to viewing the front of the spray can.
3. Choose Background graphic in the Scene panel.
4. In the Properties panel, change the Roughness slider to 30% and the Metallic slider to

70%. This affects only the background graphic.



5. In the Scene panel, select Lessence label graphic. Note that in the Properties panel, the
Metallic value is set to 0%, so this label will have a flatter finish, which is what we want.

Editing a label in Illustrator
After you’ve placed a label, you can do “round-trip” editing of the file in Illustrator or
Photoshop. If you’ve placed an AI graphic on a model, when you edit the graphic, it will
open in Illustrator. If you’ve placed a JPEG, PNG, or TIFF image, it will open for editing
in Photoshop.

1. In the Scene panel, select Lessence label graphic.
2. In the Properties panel, click the image swatch next to the word “Image.”

3. In the box that appears, either double-click the image or click the pencil icon  to edit the
graphic in Illustrator.

4. In Illustrator, change the color of the pink background shape to a light green, or make any
other edit to the image that you wish.

 Note



When you place a graphic on a model, there isn’t a “link” created from the model to
the original image. Instead, the placed image is saved internally in the DN file. So
when you edit a placed graphic in Illustrator or Photoshop, it is this internally stored
image that you are editing and saving back inside the DN file.

5. In Illustrator, choose File > Close, and when prompted, save the file.

In Dimension, you should see the label update to reflect the changes you made in Illustrator.

Adding a background color
As a final touch to our project, let’s change the color of the scene background.

1. Select the Select and Move tool in the Tools panel (keyboard shortcut: V).
2. Click somewhere on the background area around the model to select the environment.
3. In the Properties panel, click the color swatch next to the word “Background.”



4. Click the Color tab.

5. Click the Color Sampler icon  in the lower-right corner of the color picker.
6. Click a colored area of the model with the color sampler. Repeat until you’ve sampled a

color that works well for the background.



Using advanced techniques
Let’s do one more example to learn some advanced techniques for working with placed
graphic images. You’ll learn how to stack semitransparent graphics, how to control where
on a model a graphic is initially applied, and how to restrict the application of a graphic
image to only certain surfaces on a model.

Begin a new project and import a model
Let’s begin by creating a new file and placing a model of a serving plate from Adobe Stock



in the scene.

1. Choose File > New to start a new project.
2. In the Properties panel, change the width to 3000px and the height to 2000px.

3. Choose View > Zoom to Fit Canvas to fit the new canvas size on the screen.

4. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

5. In the Creative Cloud Libraries panel, in the dropdown list to the right of the search field,
choose Adobe Stock.

6. Enter 178262437 into the search field.

A round serving plate model displays.

7. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

8. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene. It will be added to the center of the
scene, positioned on the ground plane.

9. Choose Camera > Frame Selection to fit the plate model on the screen.



Place overlapping semitransparent graphics on the model
Any surface of a model can have multiple overlapping graphics applied to the surface.
Transparency in the graphics is supported, so if graphics are semi-transparent, the graphics
on the bottom will partially show through those on top.

1. Select the Orbit tool (keyboard shortcut: 1) and use it to position your view of the scene so
that you are looking directly down on the top of the plate. You may need to choose Camera
> Frame Selection again after doing this so you can see the entire plate on the canvas.

When you place a graphic on a model, Dimension will attempt to center the graphic on the
surface of the model that is facing the camera. So it usually works best if you point the
camera squarely at the location on the model where you want to place the graphic. That
way, less adjustment of the graphic will be required after it is placed.



2. Select the Select and Move tool (keyboard shortcut: V) and double-click the plate model on
the canvas. This will select the material applied to the surface of the serving plate model.

3. Click the Place Graphic on Model icon  in the Actions panel.
4. Select the Blue_watercolors.png file and then click Open.

This PNG file was created in Photoshop and consists of a transparent background with
several semitransparent brush strokes created with a watercolor brush.

5. Grab one of the selection handles on the placed graphic, hold down the Shift key, and drag
the handle out to make the graphic large enough to cover the top surface of the plate.

Holding down the Shift key causes the graphic image to scale proportionally.



6. Click the Place Graphic on Model icon  in the Actions panel.
7. Again, select the Blue_watercolors.png file and then click Open.
8. Grab one of the selection handles on the placed graphic, hold down the Shift key, and drag

the handle out to make the graphic large enough to cover the top surface of the plate.

Now we have two copies of the watercolor graphic placed on top of each other. You can see
both copies in the Scene panel.

Now let’s rotate one of the copies so that the overlapping semitransparent strokes create an
interesting texture.

9. Grab the rotation handle at the top of the placed graphic, and pull to rotate the graphic so



that the two graphics aren’t lined up exactly on top of each other.

10. Click the Place Graphic on Model icon  in the Actions panel.
11. Select the Floral_border.png file, and then click Open.
12. Size and position the floral border on the plate as desired. In the Scene panel, you should

see all three graphics stacked up above the e_serving_plate_075_Mat material.

13. Select the e_serving_plate_075_Mat material in the Scene panel.
14. In the Properties panel, click the color swatch next to the words “Base Color,” and change

the color to 230 red, 255 green, 230 blue.



Fix graphic overlap
When applying graphics to models, it is common for the graphic to “overlap” or wrap
around to an area or surface of the model where you don’t want the graphic to appear.
Here’s a technique that can help fix the problem.

1. Select the Orbit tool (keyboard shortcut: 1), and drag up on the canvas to position your
view of the scene so that you are looking directly up through the ground plane to the
bottom and sides of the plate.

You can see that the graphics we added to the top of the plate wrap around onto the sides of
the plate. This is because the entire plate surface is a single model with a single applied
material. Luckily, there is a technique we can use to restrict the application of the graphic to
only the top surface of the plate.

2. Select the Magic Wand tool (keyboard shortcut: W).
3. Click the side area of the plate to select it.



4. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

5. Click the Plastic material in the Content panel to apply it to the selected area of the plate.
You’ll see that now the graphics don’t wrap onto the sides of the plate since a graphic
applies only to a single material on a model.

6. Click the bottom center of the plate to select it.
7. Click the Cardboard Paper material in the Content panel to apply it to the bottom area of

the plate.
8. Choose Edit > Deselect All.



9. Select the Select and Move tool (keyboard shortcut: V).
10. Double-click the plate model on the canvas to reveal the materials applied to the plate in

the Scene panel. You’ll see the three materials applied to the individual surfaces of the
plate, each separated by a horizontal line. One or more graphics can be applied to each
material on a model independently.

11. Select the Cardboard Paper material in the Scene panel.



12. Click the Place Graphic on Model icon  in the Actions panel.
13. Select the Penguin_pottery_logo.png file and then click Open.
14. Size and position the logo on the plate as desired.

You’ll now see in the Scene panel that the e_serving_plate_075_Mat material has three
graphics applied to it, and the Cardboard Paper material has one graphic applied.



15. Select the Orbit tool (keyboard shortcut: 1), and drag down on the canvas so that you can
see the side of the plate as well as some of the top.

16. Select the Plastic material in the Scene panel.
17. In the Properties panel, click the color swatch next to base color.

18. In the color picker, click the Sample Color icon  and click a blue area on the top surface
of the plate to sample a blue color and apply it to the sides of the plate.

19. In the Properties panel, increase Roughness to 20% to make the sides of the plate less
shiny.

20. Select the Orbit tool (keyboard shortcut: 1) and examine your finished plate from different
angles.

Review questions
1 What is the difference between a material and a graphic?

2 What file formats can be used for graphics?
3 When an image is placed as a graphic on the surface of a model, is the image linked to the



original graphics file, or does the image become part of the Dimension file?
4 Besides scaling, rotating, or moving a graphic on the model surface, what other properties of a

graphic can be changed?
5 If a graphic overlaps an area of the model where you don’t want the graphic to appear, what is

one technique you may be able to use to prevent this?

Review answers
1 Both materials and graphics can be used to apply color and pattern to the surface of a

model. But a material can contain properties such as glow, roughness, metallic, and
translucence. A graphic is a simple image that can be wrapped around the surface of the
model.

Materials cannot be stacked on the surface of a model, but multiple graphics can
be stacked on top of each other on the surface.

The surface of a model can contain a material as well as one or more graphics.

2 Graphic files in the AI (Adobe Illustrator), PSD (Adobe Photoshop), JPEG, PNG, or TIFF file
formats can be place on a model surface.

3 Graphics become part of the Dimension file. They are not linked to the original graphics file.
4 The opacity, roughness, and metallic properties can be adjusted for each graphic applied to a

model.
5 If a graphic “bleeds” over a surface of a model where you don’t want it to appear, you may be

able to prevent this by selecting the surface where you don’t want the graphic to appear with
the Magic Wand tool and then applying a new material (or another instance of the existing
material) to the surface.



10 Working with Backgrounds

Lesson overview
In this lesson, you’ll explore how to add a 2D background image to your scene and learn the
following:

What file formats can be imported

What types of images work best as background images

How to automatically match your models to a background image so that they look like
they belong in the image

What to do when the automatic image matching feature can’t match the perspective in an
image

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



If you have a background photo with strong, clear perspective lines, Dimension’s image-matching features enable you to quickly
pose your 3D models in the background.

What you can do with background images
The main purpose of Dimension is to create scenes from one or more 3D models. Every
file you create from scratch initially features a plain white background. You can change
this background color to whatever you wish, and the color will be applied to the floor (the
ground plane) as well as to the rest of the scene background.

However, you can also import a graphic image to be used as a 2D background in your scene.
You can use a graphic saved in most of the common image file formats, including AI, JPEG,
PNG, PSD, and TIFF, in the CMYK, RGB, grayscale, or indexed color space.

These background images are static. They remain stationary in the background when you adjust
your view of the models in your scene with the camera tools. So a common workflow is that
you’ll compose a 3D scene consisting of some 3D models and then use the camera tools to adjust
your perspective and angle of view so that the models appear as if they are part of the
background image. As you’ll see, Dimension has some powerful features that can help you with
this process.

Background image workflows
Sometimes, you’ll have a particular background image in mind from the start, so you’ll
import the image into your scene before adding and positioning your models.



Other times, you’ll create a scene with one or more models in Dimension and then decide to add
a background image near the end of the project.

On other occasions you won’t be able to locate a suitable background image at all, and you will
need to construct your own image.

In this lesson, you’ll examine each of these workflows.

Starting a project with a background image
Let’s begin by creating a project where you import the background image, specify the
camera perspective, and then place the models in the scene.

1. In Dimension, choose File > New to create a new file.
2. Choose File > Import > Image as Background.
3. Select the Evening_party_tabletop.jpg file, and click Open.

By default, the image arrives centered on the canvas and cropped to fill the canvas. We’ll
leave the image as it is for this lesson.

4. In the Properties panel, click the Match Image button.

5. Deselect the “Resize Canvas to” option, select the other three options in the Match Image
dialog, and click OK.

Because of the strong, clear perspective lines created by the boards in the photo, Dimension
is able to perfectly match the camera perspective to the image.



To make it easier to see the grid lines on the ground plane, let’s change them to a bright
green.

6. Select the Select and Move tool (keyboard shortcut: V).
7. Click somewhere in the gray area outside the canvas.
8. Click the color swatch next to Grid in the Properties panel.

9. Change the color to 0 red, 255 green, 0 blue; then press the Esc key to close the color
picker.

Once you get the camera perspective just right, it is a good practice to save a camera
bookmark in case you accidentally change the perspective later with one of the camera
tools.

10. Click the Camera Bookmarks icon  at the top of the screen.

11. Click the plus icon  to create a new bookmark.
12. To rename the bookmark, type Ending view and press Enter/Return.

Examine the auto-generated lights
Dimension uses the background image to automatically extract and build lighting and
reflection information for the scene.

1. Click the background image to select it.
2. In the Properties panel, click the image swatch to the right of Image.



This lets you view the spherical bitmap that Dimension generated automatically from the
background image. Dimension uses this bitmap image to create the environment light and
reflections.

3. Click away from the image picker to close it.

4. In the Properties panel, click the disclosure triangle icon  next to Sunlight to open the
Sunlight options.

Dimension has calculated values for the sunlight attributes based on the background image.
For a complex image like this one, without a strong directional sunlight, these may or may
not be the values you want for your scene.

You’ll explore the options for environment light and sunlight in a later lesson.

Add models to the scene
Once the background image and perspective are aligned properly, positioning models in the
scene is easy.



1. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

2. In the search field at the top of the Libraries panel, click the down arrow and choose Adobe
Stock.

3. Enter 199461253 into the search field. A glass of red wine should display. This is a free
asset.

4. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

5. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene. It will be added to the center of the
scene and positioned on the ground plane, which is positioned on the wood boards.

6. Use the Select and Move tool (keyboard shortcut: V) and the Select and Scale tool
(keyboard shortcut: S) to size and position the glass on the wood as desired.



7. Select the Select and Move tool (keyboard shortcut: V).
8. Hold down the Option key (Mac) or Alt key (Windows), and drag out a duplicate of the

wine glass. As long as you drag only the red or blue arrows, the glass will remain on the
ground plane (aligned with the wood in our scene) as you move it.

9. Repeat step 8 two more times, positioning the resulting four glasses how you want them to
appear.

10. You may want to select the Orbit tool (keyboard shortcut: 1) and rotate your view of the
glasses temporarily so that you can see how they are positioned relative to each other.
When you are finished, choose Camera > Switch to Home View to return to the camera
bookmark we saved.

Remember that your view of the background image doesn’t transform with the camera
tools. It’s static. The camera tools transform only your view of the 3D models in the scene.

Adding a background image to an existing scene
Sometimes, you’ll assemble a scene in Dimension with one or more models and then
decide later to composite the scene with a background image. Let’s try this.

1. In Dimension, choose File > Open.
2. Select the file Lesson_10_02_begin.dn and click Open.

This is a scene consisting of chairs, a table, and four soda cans. The scene was created
without a background image in mind. The camera view was changed many times during the
composition to aid in placing objects accurately in the scene. Now, we’ve decided to add a



background image and realistically incorporate the table and chairs into the image.

 Tip

You can also drag a graphic file from the Finder (Mac), File Explorer (Windows), or
Adobe Bridge and drop it onto the canvas to import a background image.

3. Choose File > Import > Image as Background.
4. Select the file Village_square.jpg and click Open.

The background image arrives centered on the Dimension file. But the aspect ratio of the
background is different from that of the Dimension file. You want the Dimension canvas to
match the aspect ratio of the background image, and you want to increase the pixel
dimensions of the Dimension file.



5. With the Select and Move tool (keyboard shortcut: V), click the gray area surrounding the
canvas.

6. In the Actions panel, click the Match Background Aspect Ratio icon . This changes the
dimensions of the Dimension file to match the aspect ratio of the image.

7. In the Properties panel, click the lock icon  next to the Width and Height fields to
constrain the proportions.

8. In the Width field, type *3 after the 508px text to multiply the width by 3 and then press
Enter/Return.

Because you constrained the proportions by clicking the lock icon, the height is
automatically calculated to keep the canvas proportional.

9. Choose View > Zoom to Fit Canvas.

Match the scene to the image
If your background image contains strong perspective lines, as the image of the village
square does, Dimension can attempt to match the camera perspective to the background
image. This can save a lot of work fussing with the camera tools to get the perspective just
right.

1. Choose Image > Match Image.
2. Deselect the “Resize Canvas to” option, select the other three options in the Match Image

dialog, and click OK.



Note that the objects are aligned with the new perspective and camera angle, and their
relationship to each other stays the same.

3. Select the Select and Move tool (keyboard shortcut: V).
4. To select all the models, choose Edit > Select All.
5. Drag the red and blue arrows to position the models as desired.



What to do when Match Image doesn’t set the perspective
correctly
In the first two exercises in this lesson, the Match Image command worked flawlessly, so
creating the scene was easy. But sometimes Dimension isn’t able to work out the
perspective in the image and will need some help from you. This can happen for a variety
of reasons. For example, the image might have distortion that was introduced by a wide-
angle lens or by editing. Or sometimes an image won’t have any visible vanishing lines
with which Dimension can determine the perspective.



1. In Dimension, choose File > Open.
2. Select the file Lesson_10_03_begin.dn and click Open.

To save you time, I’ve placed the background image into this file and changed the color of
the grid lines to red.

3. Click Environment in the Scene panel if it isn’t already selected.
4. Choose Image > Match Image.
5. In the Match Image dialog, deselect the “Resize Canvas to” option and select the Create

Environment Light and Match Sunlight options. Note that in this case, the Match Camera
Perspective option may be grayed out, indicating that Dimension can’t extract enough
information from the file to determine the perspective. If the Match Camera Perspective
option is not grayed out, deselect the option so that you can learn what to do when
Dimension is unable to help you with the perspective. Click the OK button.

6. To begin to set the camera perspective manually, select the Horizon tool (keyboard
shortcut: N).

7. Grab the horizon line at the top of the screen, and drag it down a bit. Aim for a location
approximately where the two parking stripes would meet if they extended away from the
camera.

8. Right-click the Horizon tool, and click the Turn Camera tool to select it.

 Note

Because of the distortion introduced by some camera lenses, sometimes it is
impossible to map the vanishing lines with exact precision. The key is to get close
enough so that when you position your models in the scene, they look as if they
belong there.

9. Click the image and then drag to the right repeatedly until the grid lines are vanishing
toward the horizon in the middle of the screen.



10. Once you have the perspective the way you want it, save the camera location as a

bookmark. Click the Camera Bookmarks icon  at the top of the screen.

11. Click the plus icon  to create a new bookmark.
12. To rename the bookmark, type Ending view and press Enter/Return.

Add a model to the scene
Once you’ve established perspective in your scene that matches the background image, you
can use this information to realistically position a model into the scene.

1. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

2. In the search field at the top of the Libraries panel, click the down arrow and choose Adobe
Stock.

3. Type 201384101 into the search field. A red pickup truck model should display. This is a
free asset.

4. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

5. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene.

Since we have radically modified the perspective, the model is placed in the scene



somewhere off the canvas, so it isn’t visible from our current perspective.

6. To make the truck better fit the scene, choose Camera > Frame Selection (keyboard
shortcut: F).

7. With the Select and Rotate tool (keyboard shortcut: R), drag the green arrow to rotate the
truck around the y-axis.

8. In the Properties panel, click the lock icon  next to the Scale values.
9. To make the truck larger, type 1.4 in the X field and press Enter/Return.

10. Use the Select and Move tool (keyboard shortcut: V) to position the truck as desired.

Building your own background



If you can’t locate a suitable background image for your scene, you can either create a 2D
background in a graphics program like Adobe Photoshop or Illustrator or construct a
background using geometric models in Dimension.

Use a 2D background built in Photoshop
Sometimes all you need to make your scene look realistic is a very simple background that
can be easily constructed with a couple of colors or gradients in Photoshop.

1. In Dimension, choose File > Open.
2. Select the file Lesson_10_04_begin.dn and click Open.
3. Choose File > Import > Image as Background.
4. Select the file named Simple_background.psd and click Open.

This is just a simple image created in Photoshop with two different gradients that represent
a “floor” and a “wall,” or a “ground” and a “sky.” You could of course create something
much more complex using various colors, textures, and patterns.

5. Choose Image > Match Image.
6. In the Match Image dialog, deselect the “Resize Canvas to” option, and select the Create

Environment Light and Match Sunlight options. Note that in this case, the Match Camera
Perspective option is grayed out, indicating that Dimension can’t extract enough
information from the file to determine the perspective. Click the OK button.



Dimension couldn’t match the perspective for you because there are no perspective lines in
this simple image. You’ll need to position the horizon manually.

7. Select the Horizon tool (keyboard shortcut: N).

Note that no horizon line shows up. That’s because, due to the camera angle in this case, the

horizon is way off the top of the canvas, indicated by the two off-screen icons  at the top
left and top right of the document window.

8. Select the Orbit tool (keyboard shortcut: 1).
9. Drag up on the image until you are viewing the scene from the side.

10. Select the Horizon tool (keyboard shortcut: N).
11. Position the horizon line on the horizon line of the background image.



12. Click the Camera Bookmarks icon  at the top of the screen.

13. Click the plus icon  to create a new bookmark.
14. To rename the bookmark, type Starting view and press Enter/Return.
15. Use the Select and Move, Select and Scale, Select and Rotate, Pan, and Dolly tools to

position the models in the scene as you see fit.



Build a 3D background in Dimension
Dimension includes some simple models—such as Curved Plane, Cloth Backdrop, Beach
Towel, Hollow Sphere, Hollow Cube, Half Pipe, and Plane—that we can use to construct a
virtual “set” or “room” in which to pose our models.

1. In Dimension, choose File > New.
2. Select the Select and Move tool (keyboard shortcut: V).

3. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

4. Locate the Plane model, and click it to place it in the scene.
5. To make the plane larger, in the Properties panel enter a value of 4 for the X scale and 2 for

Z.

6. Choose Edit > Copy.
7. Choose Edit > Paste. You can see in the Scene panel that there are now two Plane models.



8. Select the Select and Rotate tool (keyboard shortcut: R).

 Note

The Plane object has only one “good” side that will display materials properly. So it
is important that the good side face the desired direction. The good side is up
initially, so if you rotate the plane, you need to be sure that you rotate it in such a
way that the “up” side faces in the direction you want.

9. Drag the red arrow counterclockwise to rotate the plane until it is vertical (holding down
the Shift key as you rotate will constrain your movement to 15° increments, making this
easier).

10. Choose Object > Move to Ground to slide the plane up so its bottom edge rests on the
ground plane.

11. Choose Camera > Frame All so that you can see both planes in their entirety.



12. Select the Select and Move tool (keyboard shortcut: V).
13. Drag the green arrow to the right until the vertical plane is aligned with the back of the

horizontal plane.



14. In the Starter Assets list, locate the Aluminum material and drag it onto the vertical plane.
15. In the Starter Assets list, locate the American Cherry Wood material and drag it onto the

horizontal plane.
16. Click somewhere on the canvas but not on either of the planes to deselect everything.
17. Select both of the Plane models, and choose Object > Lock/Unlock. You’ll see a padlock

icon appear next to the models in the Scene panel. Now you don’t have to worry about
bumping this “backdrop” as you position models on it.

18. Position a model or models on the bottom plane, adjust your camera angle as desired, and
render your scene.



Review questions
1 What are two ways to import a background image into a scene?

2 What are the four things that the Match Image feature attempts to do?
3 If the Match Image feature doesn’t get the perspective correct, what tool would you use to

begin correcting the perspective?
4 What are two ways to access the Match Image command?

Review answers
1 You can import a background image into a scene by choosing File > Import > Image as

Background or by dragging and dropping an image onto the canvas from the Mac
Finder, Windows File Explorer, or Adobe Bridge.

2 The Match Image feature allows you to resize the canvas to match the image size or aspect
ratio, create a custom environment light based on the background image, extract the direction
and angle of the sunlight from the image, and match the perspective of the camera.

3 The Horizon tool is the primary tool you would use to correct or tweak perspective.
4 Match Image can be found in Image > Match Image, as well as in the Actions panel when a

background image is selected.



11 Working with Lights

Lesson overview
In this lesson, you’ll explore and apply lights in a 3D scene and learn the following:

The difference between environment light and sunlight

How to automatically create environment light from a background image

How to change the properties of the sunlight

How to load a new environment light and change its properties

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



The Environment Light and Sunlight properties in Dimension allow you to create realistic looking highlights, shadows, and
reflections.

Exploring two types of lights
Dimension files can contain two types of lighting: environment light and sunlight.
Environment light provides general ambient lighting, shadows, and reflections. Sunlight
refers to a strong directional light that can be manipulated separately from the environment
light. A scene may contain only environment light, only sunlight, or both types of light.

The attributes of both types of lighting are controlled by settings in the Properties panel.

Experimenting with environment light
In this exercise, you’ll experiment with the environment light in a partially completed
scene and observe the results.

1. In Dimension, choose File > Open.
2. Select the file named Lesson_11_begin.dn, which is in the Lessons > Lesson11 folder that

you copied onto your hard disk, and then click Open.

To simulate what the plaza background image would look like with a modern sculpture
added to it, I’ve placed the Mobius Strip model from the starter assets into the scene and
applied the Metal material to the model surface. I’ve also already matched the camera
perspective to the model and saved it as a camera bookmark. But I haven’t yet done
anything with the lighting.



3. Since the on-canvas render shows only a very rough approximation of lighting, you’ll want
to display the Render Preview window while you work on this lesson. To do this, click the

Render Preview icon .

4. If your render preview defaults to full-screen view, click the Toggle Fullscreen icon  at
the top of the Render Preview window to view a smaller preview so you can see both the
render preview and the canvas.

5. In the Scene panel, click Environment.
6. In the Properties panel, click the switch next to Environment Light to turn off the

environment light.

You see that the model goes completely dark because there is no environment light or
sunlight hitting the model surface. In the render preview, the ground plane also becomes
completely black.



7. Click the switch next to Environment Light again to turn the environment light back on.

You can see that the model has highlights and reflections on the metallic surface, but they
don’t seem to relate to the background image in any way.

8. In the Properties panel under Environment Light, click the image swatch next to Image.

This displays the graphic that is being used for the environment light. This is the default
environment light that is used for new files if no other environment light is specified. This
default light simulates a typical studio lighting setup.

Create a custom environment light
This scene would look much more realistic if the light hitting the model matched the light
hitting the walls of the building and if the plaza and building were reflected on the shiny



surface of the model. Dimension can automatically extract this information from the
background image for you.

1. In the Actions panel, click the Match Image button.

2. Deselect all the options except Create Environment Light, and click OK.

You’ll see that the metallic surface reflects the pattern on the concrete and the arches on the
building.

3. In the Properties panel under Environment Light, click the image swatch next to Image.

This displays a flat representation of the spherical image that Dimension automatically
created from the background image.



4. Click the image swatch again to close the image picker.
5. In the Properties panel under Environment Light, increase Intensity to 130%. This makes

the model, but not the background image, brighter.
6. In the Properties panel, pull the Environment Light Rotation slider all the way to the left.

As you pull the slider, you’ll see the spherical projection of the environment light rotate
horizontally, providing different reflections, highlights, and shadows on the model’s
surface.

7. In the Properties panel under Environment Light, click the white color swatch next to

Colorize. Click the color sampler icon  in the color picker, and click somewhere in the
light blue area of the sky. You’ll see the environment light take on a blue cast.

8. Select the model with the Select and Rotate tool (keyboard shortcut: R).
9. Drag the green rotation arrow to rotate the model around the x-axis. As you do so, you’ll

see the reflections, highlights, and shadows on the model surface change.
10. Select Edit > Undo Transform to rotate the model back to its original position.

Experimenting with sunlight
In addition to the environment light, a scene can contain a second light source, called



sunlight. Even though this light source is called sunlight and by default it has many of the
properties of actual sunlight, think of it as just another light source. By manipulating its
height, angle, intensity, and color, this light source can simulate a wide variety of
directional light sources.

1. Click Environment in the Scene panel to select the environment.
2. In the Actions panel, click Match Image.
3. Deselect all the options except Match Sunlight, and click OK.

In the Properties panel, you’ll see that the Sunlight option has been turned on, and the
model is casting shadows on the ground as if the sun were somewhere over the viewer’s left
shoulder.

4. Click the disclosure arrow  next to Sunlight to reveal the Sunlight options if they aren’t
already open.

 Note

The Intensity property controls the brightness of the light generated by the sun.
Dimension automatically makes the sun brighter when it’s high and dimmer when
it’s near the horizon. You can manipulate the height of the sun with the Height slider
in the Sunlight properties.

5. Increase the Intensity setting of the sunlight to 190%. You should see the shadows being
cast by the model get darker.



6. Drag the Cloudiness slider all the way to the left. You’ll see the cast shadows get darker
with a cloudiness of 0%.

7. Drag the Cloudiness slider all the way to the right. You’ll see the cast shadows get lighter
with a cloudiness of 100%.

The Cloudiness property affects the “softness” of the cast shadows as well as the darkness.
A cloudiness value of 0% creates shadows with hard edges, while a cloudiness value of
100% creates shadows with soft edges. This difference in the edges of the shadows doesn’t
display in the on-canvas preview; it displays only in the render preview or when the scene
is rendered.

 Note

In addition to changing the length of the shadows, the Height slider also changes the
color of the light produced by the sun. A low sun angle produces reddish lighting, as
you might find at dawn or dusk, while a value near 90° produces a bright white light,
as you’d typically find near noon. This automatic coloring is overridden if the
Colorize option is selected, which lets you choose your own color value for the
sunlight.

8. Experiment with the Height slider in the Sunlight properties.

The Height property controls the vertical rotation of the sun. The sun remains shining from
the same “direction,” but the height in the sky changes. A value near 0° provides a very low
light angle, producing long shadows. A value of 90° provides top-down lighting, as you
would observe at noon, producing very short shadows.

9. Experiment with the Rotation slider in the Sunlight properties. This slider controls the
horizontal rotation of the light around the scene, which changes the direction of the
shadows.

Using a custom environment light



Instead of creating a custom environment light from a background image, you may wish to
use a different image for the environment light. This is particularly useful for scenes where
there is no background image or where the background image is very simple.

1. In the Properties panel, deselect the Background option.

This will make the background image disappear from the scene. Note that even though the
background image is no longer visible, the reflections on the model still show the
background image, since the light created from the background image is still being applied
to the scene.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

3. Click the Lights icon  to view only lights in the panel.
4. Click Studio Panels Light in the Content panel. Studio-style lighting will be applied to the

scene, and the Sunlight will be turned off. The Render Preview window shows a much
better preview of the reflections on the shiny metallic surface of the model.

5. Click the image swatch next to Image in the Properties panel to view the spherical
representation of Studio Panels Light.



 Tip

Hundreds of additional image-based environment lights, optimized specifically for
use in Dimension, are available for purchase on Adobe Stock at stock.adobe.com.

6. Click some of the other lights in the Content panel to see the variety of lights that are
available in the starter assets.

Use a bitmap image for the environment light
In addition to lights from the starter assets or Adobe Stock, you can also use any JPEG or
PNG image as an environment light. When you do so, Dimension converts the image into a
360° panorama image, using Content Aware Fill technology from Photoshop to fill in the
missing areas.

1. Choose File > Import > Image as Light.
2. Select the file named Sunrise.jpg, and click Open.

http://stock.adobe.com


3. In the Properties panel, click the image thumbnail next to Image to see the spherical image
that Dimension produced from the JPEG image.

4. Select the Orbit tool (keyboard shortcut: 1), and rotate your view of the scene to view how
the light appears on the model surface when the model is viewed from different angles.

5. Choose Camera > Switch to Home View to return to the original camera view.

Lights and file formats
When you use a JPEG or PNG image as an environment light, dramatic lighting and
shadows are not produced, since the images are low dynamic range. The images provide
only ambient lighting and reflections. You can add dramatic lighting and shadows with
sunlight.

You can import an HDR or EXR image as an environment light. These high dynamic range
images produce ambient lighting, reflections, and dramatic lighting and shadows.

You can import files in the IBL (Image Based Light) format as environment lights. IBL files
are packaged containers that hold multiple images for lighting, reflections, and backgrounds
in a single package. This format produces very realistic-looking lighting, but due to
inconsistencies in the file format, some IBL files that you find on the web will import and
some will not.

Experimenting with glow
There is one other source of light that a scene may contain: materials that glow.
The material called Glowing (in the starter assets) is an example of such a material. This
material creates its own light, unlike all the other starter asset materials, which only reflect
light by default.

1. In the Properties panel, click the image swatch next to Background.



2. Click the Color tab.
3. Enter a value of 140 red, 130 green, 130 blue and then press the Esc key to close the color

picker.
4. Click Environment in the Scene panel.

5. In the Properties panel, turn off Environment Light and Sunlight. You’ll see the model turn
completely black on the canvas since there is no light being produced by the environment
or the sunlight to reflect off the model.



6. In the Content panel, click the Materials icon  to view only materials in the panel.
7. Drag the Glowing material onto the model surface.

Now the model is “glowing,” emitting light onto the dark ground plane. In the Render
Preview window you should see faint shadows being created because of the light emitted by
the model.

8. In the Content panel, locate the Brass material and drag it on to the Mobius Strip model.

The model turns black again because there is no lighting in the scene and the Brass material
doesn’t glow. But in the Properties panel, you’ll see that the Brass material has a Glow
property.



9. Drag the Glow slider to 40%, and you’ll see the model emit light again.

10. In the Content panel, click the Model icon  to view only models in the panel.

 Tip

You can make any of the materials found in the starter assets “glow,” or emit light,
by dragging the Glow slider to the right.

11. Locate the Sphere model, and click it to add it to the scene. It will be added behind the
Mobius Strip model.

In the Render Preview panel, you should see a faint yellow glow on the surface of the
sphere. Light emitted from a material with a Glow property will light up other models in the
scene.

Review questions
1 What are the three sources of light that can exist in a Dimension file?

2 What happens if a scene has no environment light and no sunlight?
3 What effect does the Cloudiness property have on a scene?



4 What effect does increasing the height of the sun have on a scene?
5 What file formats can be used for creating custom environment light?

Review answers
1 The three possible sources of light in a Dimension file are Environment Light,

Sunlight, and a material with the Glow property.
2 Models in the scene become completely black, and the ground plane also becomes solid black.
3 Increasing the Cloudiness property makes cast shadows lighter and softens the edges of the

shadows.
4 As you increase the angle of the sun, shadows grow shorter, and the color of the sunlight

becomes more white.
5 Files in the following formats can be used to create custom environment light: IBL, JPEG,

PNG, HDR, and EXR.



12 Pushing the Limits: Model- and Scene-
Building Techniques

Lesson overview
In this lesson, you’ll explore how to push the limits of what Dimension is intended to do by
using it to assemble new models and scenes from parts of other models and simple geometric
objects. You’ll learn the following:

How to locate and use the simple geometric shapes that come with Dimension to build
more complex models and designs

How to step and repeat objects to create geometric models

The limitations of working with plane objects

How to creatively extract and reuse parts and materials from other models in your scenes

This lesson will take about 60 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.



Dimension isn’t really intended for building models from scratch. But with some ingenuity, you can assemble more complex
models by combining and intersecting simpler models. Each of these bricks is a combination of eight cylinder models and a
cube model.

Understanding Dimension’s intended use
Dimension isn’t intended to be a three-dimensional modeling program. It isn’t intended to
be used to create models. It’s assumed that you’ll get your models from sources such as the
Starter Assets, Adobe Stock, or elsewhere, and use Dimension to arrange these models,
apply materials to their surfaces, customize the lighting, and pose them with a background
image.

3D modeling software is typically quite complex to master, with a steep learning curve. But with
some ingenuity and creativity, you can sometimes create a model right in Dimension by
grouping geometric shapes and scavenging bits and pieces from other models.

This lesson consists of a series of explorations to get you thinking about some of the possibilities
for pushing the limits of modeling and scene building with Dimension.

Using geometric shapes from starter assets
The starter assets include the following geometric models:



Sphere, Hollow Sphere

Cube, Hollow Cube, Rounded Cube, Rounded Cube Flat

Cylinder, Rounded Cylinder

Cone, Hollow Cone, Rounded Cone

Prism

Capsule

Disc, Plane

Tetrahedron (4 sides), Pyramid (5 sides), Octahedron (8 sides), Dodecahedron (12 sides),
Truncated Icosahedron (32 sides, the shape used for soccer balls)

Crystal

Drop

Pipe, Half Pipe

Torus

Star

Mobius Strip

Abstract Curves

These models can be scaled, stretched, and combined in various ways and are much more useful
for scene-building than they might first appear.



Build a Lego brick
In this exploration, you’ll use the Cube and Cylinder models to create a Lego-style brick.

1. Choose File > New to create a new document.



2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

3. Type cube into the Search field at the top of the Content panel.

4. Click the Cube model to place the model in the scene.
5. Use the Select and Scale tool (keyboard shortcut: S) to stretch the cube into a rectangle the

approximate proportions of a Lego brick.



6. Type cylinder into the Search field at the top of the Content panel.
7. Click the Cylinder model to place the model in the scene.
8. Choose Camera > Frame All so you can see all the models (the cylinder may be much

larger than the Lego brick model that you scaled, depending on how you scaled the cube).
9. Use the Select and Scale tool (keyboard shortcut: S) and the Select and Move tool

(keyboard shortcut: V) to size the cylinder to create one of the bumps at the top of the brick
and move it into place.

Because the brick is going to be totally opaque, it doesn’t matter how far the cylinder sticks
into the rectangle. In other words, there’s no reason to fuss with trying to make the cylinder
sit on top of the brick surface. The cylinder can instead be taller than you need it to be, with
the extra cylinder height hidden in the brick interior.

You may need to use the camera tools (Orbit, Pan, and Dolly) to frequently change your
view of the model as you size and position the cylinder.



10. Choose Edit > Duplicate seven times to create seven duplicate cylinders. Use the Select and
Move tool (keyboard shortcut: V) to drag the duplicate cylinders into place on the brick.

There is no Alignment function or Snap to Grid functionality to help you align the cylinders
on the top of the brick. You must eyeball the position.

Careful use of the Select and Move tool arrows can help with this somewhat—for instance,
you could have dragged four of the cylinders in the Z direction so that they all line up in a
row before duplicating all four in the X direction to create a second row.

11. Select all the pieces of the brick by dragging around all the models with the Select and
Move tool.

12. Choose Object > Group to group all the objects together.
13. Type plastic into the Search field at the top of the Content panel.
14. Click the Plastic material to apply it to the group.



15. Double-click anywhere on the Lego brick on the canvas to reveal the material applied to the
model in the Scene panel.

16. Click the color swatch next to Base Color in the Properties panel, and select a bright red
color.

Even though you are changing the material color on only one of the models in the group,
the color of all the models changes because the material is linked to all the models.

You may wish to experiment further by duplicating the brick group, changing the color of
the duplicate brick, and working to stack the bricks.

Build a submarine
In this exploration, you’ll use the Capsule, Sphere, Cylinder, and Cube models to build a
submarine model.

1. Choose File > New to create a new document.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

3. Type cylinder into the Search field at the top of the Content panel.
4. Click the Cylinder model to place the model in the scene. This cylinder will be the main

body of the submarine.



5. To rotate the cylinder so it is lying on its side, enter 90° in the X Rotation field in the
Properties panel.

6. To make the cylinder longer, enter 2.6 in the Y Scale field in the Properties panel.

7. Select the Dolly tool (keyboard shortcut: 3) and pull down on the screen a bit so that you
can see the entire cylinder.

8. Choose Object > Move to Ground so that the cylinder sits on the ground plane.



9. Type sphere into the Search field at the top of the Content panel.
10. Click the Sphere model to place the model in the scene. Since we haven’t moved the

cylinder from the zero point in the scene, the sphere aligns nicely with the cylinder.

To make it easier to align all the pieces that will compose the body of the submarine, it is
easiest to leave each object in place at the “zero” location on the canvas as long as possible.
That way, objects will often align with each other by default. So instead of moving the
models, move the camera if you need to see the objects at a different angle.

11. Select the Orbit tool (keyboard shortcut: 1) and move the camera so that you are looking at
the cylinder from the side.

12. Select the Sphere model with the Select and Move tool (keyboard shortcut: V), hold down
the Option key (Mac) or Alt key (Windows), and drag the blue arrow to the left to duplicate
the sphere and add it to the left end of the cylinder.



The sphere on the left will be the front of the submarine, and the cylinder the body. Now
let’s taper the front and back end of the submarine a bit.

13. To taper the front (left) sphere, enter 1.4 for the Z Scale in the Properties panel.
14. Select the sphere on the back (right) of the submarine, and enter 4.6 for the Z Scale in the

Properties panel.

15. Click the Cylinder model in the Content panel to place another cylinder in the scene.
16. Use the Select and Scale tool (keyboard shortcut: S) and Select and Move tool (keyboard

shortcut: V) to size and move the cylinder into place to create the conning tower on the top
of the submarine.

17. Select the Orbit tool (keyboard shortcut: 1) and move the camera to examine the submarine
from different angles.

If you’ve done everything correctly and constrained your scaling and movement of objects
along the proper axes, the submarine should appear symmetric.

I’ll leave it to you to add additional detail to the submarine. Refer to Lesson_12_02_end.dn
for hints.



Create a 3D design
Next, you’ll use multiple overlapping copies of a simple geometric shape to create an
interesting 3D design.

1. Choose File > New to create a new document.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

3. Type hollow into the Search field at the top of the Content panel.
4. Click the Hollow Sphere model to place the model in the scene.
5. Enter .3 for the Y Scale in the Properties panel to flatten the sphere.



6. Select the Orbit tool (keyboard shortcut: 1) and move the camera so you are viewing the
sphere from above.

7. Select the Select and Move tool (keyboard shortcut: V).
8. Hold down the Option key (Mac) or Alt key (Windows), and drag the blue arrow to the

right to create a duplicate sphere to the right of the original sphere. Leave the spheres so
that they are partially overlapping.

9. Select the second sphere, hold down the Option/Alt key again, and drag the blue arrow to
the right to create a third overlapping instance of the sphere.



10. Drag around the three spheres to select all three.
11. Hold down the Option/Alt key and drag the red arrow down to create three more

overlapping spheres.

Experiment with creating duplicates and overlapping spheres in interesting ways, creating
new patterns as desired.



Using step and repeat creatively
Unfortunately, there is no “step and repeat” command in Dimension. Nor is there any way
to repeat the last transformation, as there is in Adobe Illustrator. But with some effort, you
can still do precise step and repeat in Dimension.

1. Choose File > Open.
2. Select the file named Lesson_12_04_begin.dn, which is in the Lessons > Lesson12 folder

that you copied onto your hard disk, and then click Open.

The scene I’ve started for you consists of two “walls” and a “floor,” created with the Plane
model, as well as the beginnings of a wood garden arbor. I created the garden arbor by
stretching two cubes non-proportionally. You’ll use step and repeat to create a finished
arbor design.

3. Select the Select and Move tool (keyboard shortcut: V).
4. Click Arbor Unit in the Scene panel to select the vertical and horizontal pieces of wood that

make up the arbor.

In the Properties panel, note that the Arbor unit is positioned at an X position of 0.

5. Hold down the Option/Alt key, and drag the red arrow to the right to create a duplicate of
the arbor unit.



6. Make a note of the X position of the duplicated arbor unit in the Properties panel.
7. Choose Edit > Duplicate to create a duplicate of the second arbor unit. The duplicate won’t

be visible in the scene because it is directly on top of the second arbor unit.
8. In the Properties panel, click after the X Position value, press + (the plus sign), and then

enter the X position you made note of in step 6. Press Enter/Return when you are finished.

9. With the third arbor unit selected, choose Edit > Duplicate again.
10. In the Properties panel, click after the X Position value, type + (the plus sign), and then

enter the X position you made note of in step 6. Press Enter/Return when you are finished.

Repeat this process as many times as necessary.

Using this method, you are able to step and repeat the object precisely, ensuring that the
objects are equally spaced.

Rotational step and repeat



The ability to choose a pivot point of Top Center, Center, or Bottom Center in the
Properties panel is useful for stepping and repeating the rotation of objects.

1. Choose File > New to create a new document.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

3. Type drop into the Search field at the top of the Content panel.
4. Click the Drop model to place the model in the scene.
5. Select the Dolly tool (keyboard shortcut: 3) and drag down on the canvas so there is more

room above the Drop model.
6. Select the Select and Rotate tool (keyboard shortcut: R).

7. In the Properties panel, choose Top Center for the Pivot property.

8. Hold down Option+Shift (Mac) or Alt+Shift (Windows).



9. Drag the blue arrow clockwise until the Z Rotation value in the Properties panel displays –
45°. (Holding down the Option/Alt key duplicates the object as you rotate it, and holding
down the Shift key constrains the rotation to 15° increments.)

10. Repeat steps 8 and 9 six more times, rotating the new duplicate –45° each time.



Extra credit: Rotate the collection of drops 90°, and then stack and scale duplicates of the
drops to create artwork like that shown here.

Rotational step and repeat workaround
Dimension doesn’t offer any way to rotate a model around a point that isn’t on the model
itself. Sure, you can choose a pivot point of Top Center, Center, or Bottom Center in the
Properties panel, but those three options refer to points on the model itself. What can you
do if you need to rotate an object around another point in space? Here’s a sneaky trick that
will get the job done.

1. Choose File > Open.
2. Select the file named Lesson_12_06_begin.dn, which is in the Lessons > Lesson12 folder

that you copied onto your hard disk, and then click Open.

The scene I’ve started for you consists of a sphere to be rotated, as well as a cone that I’ve



placed at the point around which we will rotate the sphere.

3. Select the Select and Rotate tool (keyboard shortcut: R).
4. Click the Sphere model on the canvas, and then hold down the Shift key and click the Cone

model to select both models.
5. Choose Object > Group to group the two objects together.
6. Choose Bottom Center for the Pivot property in the Properties panel.

7. Hold down Option+Shift (Mac) or Alt+Shift (Windows), and drag the blue arrow clockwise
until the Z Rotation value in the Properties panel displays –15°. (Holding down the
Option/Alt key duplicates the object as you rotate it, and holding down the Shift key
constrains the rotation to 15° increments.)



8. Repeat step 7 four more times.



9. To rotate the other way, select the original sphere and cone group again.
10. Hold down Option+Shift (Mac) or Alt+Shift (Windows), and drag the blue arrow

counterclockwise until the Z Rotation value in the Properties panel displays 15°.
11. Repeat step 10 four more times.

12. Choose Edit > Select All to select all the groups.



13. Choose Object > Ungroup to ungroup all the groups at once.
14. Drag around the cones that are overlapping each other at the pivot point to select them, and

then click the Trash icon in the Actions panel.

This technique lends itself to creating all kinds of objects encountered in real life, such as
gears, wheels, spokes, clock faces, and more.

Working with planes
Dimension’s starter assets contain two special models: Plane and Disc. These two models
behave differently than all the other models in two ways. First, the models have no
“thickness,” so scaling the models to increase the thickness has no effect. Second, the
models have a “good” side and a “bad” side. The bad side is dark, and it reflects light
completely differently than the good side does, depending on the material applied.

You should use the Plane and Disc models only when you will need to view the model from only
one side. And even then, you’ll need to pay attention to which side of the model is facing the
camera.

1. Choose File > New to create a new document.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
Starter Assets.

3. Locate the Plane model in the Content panel, and click it to place it on the canvas.
4. Select the Select and Move tool (keyboard shortcut: V).
5. Drag the green arrow up a bit to move the Plane model above the ground plane.
6. Select the Select and Scale tool (keyboard shortcut: S).
7. Drag the green cube up to scale the plane in the Y direction. You’ll see that no matter how

much you scale the plane in the Y direction, it doesn’t get any thicker. There is no way to



make the Plane or Disc models thicker in Dimension.

8. Locate the Metal material in the starter assets, and click it to apply the material to the Plane
model.

9. In the Properties panel, click the color swatch next to Base Color, and choose a bright red
color, then press the Esc key to close the color picker.

10. Select the Select and Rotate tool (keyboard shortcut: R).
11. Drag the blue arrow on the rotation widget clockwise to rotate the plane around the z-axis.

Note that one side of the plane is red metallic, and the other side remains dark.



12. Locate the Plastic material in the starter assets, and click it to apply the material to the
Plane model.

13. In the Properties panel, click the color swatch next to Base Color, and choose a bright red
color, then press the Esc key to close the color picker.

14. Select the Select and Rotate tool (keyboard shortcut: R).
15. Drag the blue arrow on the rotation widget clockwise to rotate the plane around the z-axis.

With the Plastic material, you’ll see red on both sides, but one side remains considerably
darker than the other.

An alternative to planes
A great alternative to the Plane and Disc models is to use the Cylinder and Cube models
scaled down in height to create a very thin cylinder or very thin cube. They will look just
like the Plane and Disc models but behave in more predictable ways.

1. Click the Trash icon  in the Actions panel to delete the Plane model from the scene.
2. In the Contents panel, click the Cube model to add it to the scene.
3. In the Properties panel, change the Y value for Scale to 0.



4. Select the Select and Move tool (keyboard shortcut: V).
5. Drag the green arrow up so that the model is above the ground plane.
6. Locate the Metal material in the starter assets, and click it to apply the material to the Cube

model.
7. In the Properties panel, click the color swatch next to Base Color, and choose a bright red

color, then press the Esc key to close the color picker.
8. Select the Select and Rotate tool (keyboard shortcut: R).
9. Drag the blue arrow on the rotation widget clockwise to rotate the cube around the z-axis.

Note that both sides of this model reflect light the same way.
10. Choose File > Open.
11. Select the file named Lesson_12_07_begin.dn, which is in the Lessons > Lesson12 folder

that you copied onto your hard disk, and then click Open.

(When you are warned that opening another document will close your current document,
click Don’t Save, unless you want to save the file with the Cube model in it.)

12. Click the Render Preview icon  to display the Render Preview window.

This scene consists of two model groups. In the Scene panel, you’ll see a Cylinder group
and a Disc group.

13. Click the folder icon next to “Cylinder group,” and you’ll see that this is a group of six
cylinders; this is the object on the left side of the scene.

The object on the right side of the scene is a group consisting of six discs.

14. Click the folder icon next to “Disc group” to see the six disc models.



Both of these model groups were constructed in a similar manner: by stepping and
repeating the rotation of a model. The Damaged Silver material was applied to all the
models. But as you can see both on the canvas and in the render preview, the Cylinder
model reflects light very differently than the Disc model does.

15. Select the Select and Rotate tool (keyboard shortcut: R).
16. Click the Disc model (the model on the right) to select it.
17. Drag the green arrow on the rotation widget to rotate the Disc model. As you do so, you’ll

see that the light is reflected in odd, seemingly unpredictable ways. This is because
sometimes you are seeing the dark side of a disc, and sometimes you are seeing the light
side, depending on how the model is rotated. Shown here is a final high-quality render of
the scene so you can see the difference.



Using parts from models
What if you really need a certain model or a particular 3D shape to construct your scene,
but you can’t locate a model to fit your needs? You may be able to locate the shape you
need by extracting a model from a larger model group.

Breaking apart multiple objects
Sometimes you’ll find the perfect model, but it consists of multiple objects and you need
only one of the objects in your scene. What can you do in this case? It depends on how the
model is constructed.

1. Choose File > New to create a new document.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

3. In the Creative Cloud Libraries panel, in the dropdown list to the right of the search field,
choose Adobe Stock.



4. Type 218401592 into the search field. A model of two buttons will be displayed.

5. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

It may take a few moments for the model to download.

6. When it has finished downloading to your library, click the model to add it to the scene. It
will be added to the center of the scene, positioned on the ground plane.

7. Choose Camera > Frame Selection for a larger view of the buttons.

In the Scene panel, you’ll see a model group named shirt_buttons_1309, which contains
two models: button_01 and button_02.



8. Drag the button_01 model above the shirt_buttons_1309 group to remove it from the group.

9. Click the shirt_buttons_1309 group in the Scene panel, and then click the Trash icon  in
the Actions panel to delete the group. Now you have a single button to use in your scene.

You were able to delete the extra button in this case because the model consisted of a group
of two separate models. But depending on how the model was put together, this won’t
always be the case.

10. In the Content panel, type 218401720 into the search field. A model of five thumbtacks will
be displayed.

11. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

It may take a few moments for the model to download.

12. When it has finished downloading to your library, click the model to add it to the scene.
13. Choose Camera > Frame Selection so that you can see the thumbtacks on the canvas.
14. Examine the Scene panel. Click the folder icon next to the flat_thumbtacks_1298 model

group. You’ll see that in this case, the group consists of two models:
flat_thumbtacks_1298_plastic and flat_thumbtacks_1298_metal. Unfortunately, the
modeler modeled all the plastic parts together and all the metal parts together. So in this
case, there is no way to break apart the group and extract a single thumbtack in Dimension.



Extract a part from a larger model
Sometimes you may be able to find the part you need for your scene by scavenging a part
from another model.

Here’s the scenario: You need a couple of objects to add to a scene you’re creating. You browse
through the models available on Adobe Stock, see the Saturn model, and realize that the shape
that makes up Saturn’s rings is exactly what you need.

1. Choose File > New to create a new document.

2. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

3. In the Creative Cloud Libraries panel, in the dropdown list to the right of the search field,
choose Adobe Stock.

4. Type 222488976 into the search field. A model of Saturn will be displayed.

5. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

6. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene.

7. In the Scene panel, you’ll see that, thankfully, the rings are a separate model from the
sphere.



8. Drag the saturn_rings_GEO model above the Saturn model group to remove it from the
group.

9. Select the Saturn model group, and click the Trash icon  in the Actions panel to delete
the model group, leaving just the rings.

You could, of course, change the material applied to the rings and transform them as
desired to fit your scene. Let’s look at another example.

10. In the Content panel, type 134634095 into the search field. A model of a paper coffee cup
will be displayed.

11. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

12. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene.

13. In the Scene panel, you’ll see that in this model, the cup, lid, and sleeve have been modeled
separately. The sleeve is a simple tapered cylinder shape that could be useful to reuse in
your scene. Drag the coffee_withHolder_sleeve model above the coffee_withHolder model
group to remove it from the group.



14. Select the coffee_withHolder model group in the Scene panel, and click the Trash icon 
in the Actions panel to delete the model group.

Now you are left with two simple shapes that could be grouped with other shapes to build a
model.

Borrowing a material from another model
What if you can’t find the right material for your model? While you’re browsing models on
Adobe Stock or from other sources, keep your eyes open for unusual or useful materials
applied to the model surfaces. In many cases, depending on how the model is assembled,



the material may be useful for use on other models.

1. Choose File > Open.
2. Select the file named Lesson_12_08_begin.dn, which is in the Lessons > Lesson12 folder

that you copied onto your hard disk, and then click Open.

For these packages, I want a wrinkled gold foil material, like you might find freeze-dried
food packaged in. It occurred to me that I’ve seen foil like that used on spacecraft. A search
on Adobe Stock led me to a satellite model that contains some gold foil. Let’s see how to
apply the gold foil material to the package models in this file.

3. Click the Add and Import Content icon  at the top of the Tools panel, and choose
CC Libraries.

4. In the Creative Cloud Libraries panel, in the dropdown list to the right of the search field,
choose Adobe Stock.

5. Type 222486354 into the search field. A model of a satellite will be displayed.

6. Click the shopping cart icon  to save the model to your library. You may be asked if you
want to license the free asset. If so, click OK.

7. It may take a few moments for the model to download. When it has finished downloading
to your library, click the model to add it to the scene.

The Satellite model is huge compared to the Bag models, and that’s OK.

8. Choose Camera > Frame Selection so that you can see the entire Satellite model.
9. Select the Select and Move tool (keyboard shortcut: V).

10. Drag the blue arrow to the right to move the Satellite model out of the way so you can see
both it and the Bag models.



11. Drag a selection boundary around the Bag models to select all five of them.
12. Select the Sampler tool (keyboard shortcut: I).
13. Click somewhere on the gold foil on the Satellite model. This applies the gold foil material

to the Bag models.



14. In the Scene panel, click the near_satellite model group to select it.

15. Click the Trash icon  in the Actions panel to delete the model group.
16. Choose Camera > Frame Selection for a larger view of the Bag models.

Customize the material on each model
The scene doesn’t look very realistic because the material was applied in exactly the same
way to each model. Let’s fix this.

1. Select the Select and Move tool (keyboard shortcut: V).
2. Double-click the second bag from the left to reveal its material.

You’ll see the Break Link to Material icon  displayed in the Actions panel, alerting you
that the material is linked to one or more other models.

3. Click the icon to break the link.
4. In the Properties panel, adjust the X, Y, and Rotation values for Offset so that the material

is positioned differently than it is on the bag to the left.



5. Repeat steps 2–4 for each of the remaining bags. You can also experiment with adjusting
the background color of the material on each bag if you like.

Review questions
1 When you use the Edit > Duplicate command, where does the duplicated model appear

on the canvas?
2 What is one way to simulate a precise step and repeat effect in Dimension?
3 What are the two unique properties of the Plane and Disc models in the starter assets?
4 After you place a model in a scene, how can you determine whether you can extract individual

parts from the model for reuse?

Review answers



1 The Edit > Duplicate command duplicates the selected model and places them at the
same X, Y, and Z coordinates as the original model.

2 You can precisely step and repeat a model by duplicating the model, dragging the duplicate to
a new location, and then memorizing the XYZ position of the duplicate. Then, by duplicating
the object again and performing simple math such as addition or multiplication on the XYZ
position values, you can move the second duplicate the same distance as the first duplicate.

3 The Plane and Disc models have no thickness, and the thickness cannot be scaled.
Additionally, these models have a “dark” side that reflects light in unpredictable ways.

4 The ability to extract and reuse individual parts of a model is determined by how the modeler
assembled the model. If the model is a model group that consists of individual models and
sub-models, they can be removed from the group for use individually. If the entire model is a
single entity, there is no way to break it apart in Dimension.



13 Post-Processing with Adobe Photoshop CC

Lesson overview
In this lesson, you’ll discover why and how you would open in Adobe Photoshop CC a scene
that was rendered by Dimension and learn the following:

What Photoshop layers are created automatically by Dimension’s renderer and what you
can use them for

How to easily change the background image in Photoshop

How to use the masks that are automatically saved into the rendered image to make
selections easier

How to apply simple color correction to a rendered scene in Photoshop

This lesson will take about 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the lesson
files and Web Edition.” Store the files on your computer in a convenient location.

Your Account page is also where you’ll find any updates to the lesson files. Look on the
Lesson & Update Files tab to access the most current content.

This lesson assumes that you have some basic knowledge of how to use Adobe Photoshop and
are familiar with the Photoshop interface, in particular the Layers panel.



When you render a scene to the PSD format, Dimension adds several useful layers to the file that make certain post-processing
tasks easier.

Opening a scene rendered as a PSD file in Photoshop
Dimension is the easiest place to make changes to the lighting, color, background, and
composition of your Dimension scenes. But occasionally you might need to edit a scene in
Photoshop after it has been rendered. For example, you might want to make a quick tweak
to the overall color of the scene without re-rendering the entire scene. Or you might need to
work on the image after you’ve converted it to CMYK for print output in Photoshop. Or
you might want to manipulate the image in some way that can be done only in Photoshop.

As you saw in an earlier lesson, Dimension can save the rendered output as a PNG file or as a
PSD file. The main difference is that a PNG file is “flat.” There are no layers, masks, or other
helpful extras saved with a PNG file. However, if you save the rendered scene as a PSD file,
Dimension adds extras to the file that make it easier to edit, or “post-process,” the scene.

1. Launch Adobe Photoshop.
2. Choose File > Open.
3. Select the file named Lesson_13_begin_high_quality_render.psd, which is in the Lessons >

Lesson13 folder that you copied onto your hard disk, and then click the Open button.
4. If your Layers panel isn’t visible on the screen, choose Window > Layers.

Your Layers panel should contain six layers. Let’s look at what some of the things these
layers could be used for.



Editing the background
Because the models are all rendered onto a transparent layer separate from the background,
it is easy to make changes to the background behind the models.

Change the background color
Changing the background color of the background is straightforward. Here’s one way to do
this in Photoshop.

1. Click the eyeball icon next to the layer named Background Image to hide the background
image.

2. Double-click the thumbnail icon on the Background Color layer to access the color picker.

3. Select a new color for the background, and click OK.



The shadows cast by the models on the background are semi-transparent, so they blend
realistically with the new colored background. If this image had reflections that were
reflecting on the ground plane, those reflections would also be retained and blend
realistically with the new background color.

The image in the water glass still shows the background image through the glass. Semi-
transparent materials are rendered with the background image in the material, which can
make it difficult to edit such scenes in Photoshop.

Change the background image
Since the background image is rendered on its own Photoshop layer, it can easily be
swapped out with a different image. However, your scene will not look very realistic unless
the new background image has similar perspective and lighting as the original background
image.

1. Click the eyeball icon to the left of the Background Color layer to hide that layer.

Note that the 3D models are all rendered on a single layer called “Layer 2” and that the area
around the models on this layer is a light gray checkerboard, indicating that it is transparent.
Since the area around the models is transparent, you can just put a new layer with a new
background image beneath Layer 2 to replace the background.

2. Choose File > Place Embedded.
3. Select the file named Checkerboard.jpg, which is in the Lessons > Lesson13 folder that you



copied onto your hard disk, and then click Place.
4. Double-click the image to place it.

The image is placed on a new layer, named Checkerboard.

5. Drag the new layer beneath the layer named Background Image in the Layers panel.

The scene looks pretty good because the new background has a perspective similar to the
old background. But the original image still appears when viewed through the glass, and the
reflections that appear on the models are created from the original background. This would
be very difficult to fix in Photoshop.

Modify the background image
You’ve seen that replacing the background image can be problematic because of
translucent objects and reflections on the surface of objects. But simple edits to the
background image such as color correction, sharpening, and blurring can often be done
without destroying the realism of the scene.

1. Click in the eyeball column next to Background Image in the Layers panel to reveal the
original background.

2. Click Background Image in the Layers panel to select that layer.
3. Choose Layer > New Adjustment Layer > Brightness/Contrast.
4. Click OK in the New Layer dialog. This creates a new Brightness/Contrast adjustment

layer above the Background Image layer.



5. In the Properties panel, drag the Contrast slider all the way to the right to increase the
contrast. This increases the contrast only in the Background Image layer, not in the layers
above it.



Using masks to make selections
When you render an image in the PSD format, Dimension always creates a layer called
Object Selection Masks, in which every 3D model in the scene is filled with a separate
solid color on a black background. This layer makes it easy to select the outlines of each
model in the rendering.

You’ll use this layer to change the color of the spotted glass on the left side of the scene.

1. In the Layers panel, click the eyeball column next to Additional Layers to show the layer
group.

2. Click the eyeball icon next to Material Selection Masks to hide that layer.
3. Select the Object Selection Masks layer.

4. Select the Magic Wand tool (underneath the Quick Selection tool in the Tools panel).

5. In the options bar, make sure that Tolerance is set to 0, that Anti-alias and Contiguous are
selected, and that Sample All Layers is deselected.

6. On the Object Selection Masks layer, click the green color, which represents the left-most
glass.

7. In the Layers panel, click the eyeball icon next to Additional Layers to hide that layer
group.

8. Click Layer 2 in the Layers panel. Now the cup on that layer is precisely selected, based on
the selection we made in the Object Selection Masks layer.

9. Select Layer > New > Layer Via Copy.
10. Double-click the layer name and change it to Dotted cup.



11. Choose Layer > Layer Style > Color Overlay.
12. Choose Color from the Blend Mode menu.
13. Click the color swatch, choose a blue color for the cup, and click OK.

14. Click OK again to close the Layer Style dialog.



Adjusting materials
Dimension automatically creates a layer named Material Selection Masks in each rendered
PSD file. This layer contains individual solid-color shapes that represent each material
applied to the surface of a model. You’ll use this layer to change the look of one of the
materials used for the Star model.

1. Click the eyeball column next to the Additional Layers layer group to show the group.
2. Compare the filled area that represents the star on the Object Selection Masks layer to the

filled area that represents the star on the Material Selection Masks layer by using the
eyeball column to show and hide the layers.

You should see that the Object Selection Masks layer displays a single color for the entire
Star model. But since two different materials are applied to the different facets of the Star
model, the Material Selection Masks layer represents these two materials with two separate
colors.

3. In the Layers panel, make sure the Material Selection Masks layer is visible, and click the
layer to select it.

4. With the Magic Wand tool, click one of the light-colored facets of the Star model.



5. Hold down the Shift key, and click each of the other light-colored facets of the Star model
to add all of them to the selection.

6. Click the eyeball icon next to the Additional Layers layer group to hide the group.
7. Click Layer 2 in the Layers panel to select it.



8. Choose Filter > Pixelate > Pointillize.

 Tip

You can use the Depth Information layer as a mask to add depth of field effects or
dramatic lighting to the scene. In the Depth Information layer, light-colored areas
are farther away from the camera, and darker areas are closer to the camera.

9. Set Cell Size to 3, and click OK.



Correcting color in the image
I want the overall color of the entire scene, including the background, to be a bit warmer.
There are many ways to do this in Photoshop. Here’s one way to do it without needing to
flatten the layers containing the models and the background.

1. Click Layer 2 in the Layers panel, and then Shift-click the Background Image layer.
2. Choose Layer > New > Group from Layers.
3. Click OK.
4. Choose Filter > Convert for Smart Filters.
5. Choose Filter > Camera Raw Filter.
6. Drag the Temperature slider to the right to warm the image up.



7. Click OK.

You can do a lot to a 2D scene in Photoshop, of course. You are limited only by your
imagination, your skill, and your knowledge of Photoshop.

Review questions
1 What is the advantage of saving a render from Dimension in the PSD format instead of in

the PNG format?
2 What type of material could make it more difficult to realistically edit a background image in

Photoshop?
3 Which layer contains a colored mask for each material applied to the surface of a model?

Review answers
1 The PSD format contains extra layers that make the image easier to edit. A scene

rendered as a PNG will be a single-layer flat image.
2 Images that are semi-transparent, such as glass, once rendered, can make it difficult to swap in

a new background in Photoshop.
3 The Material Selection Masks layer contains a separate colored mask for each part of a model

that has a material applied to it.
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Adobe Illustrator. See Illustrator
Adobe Photoshop. See Photoshop
Adobe Standard Material, 94
Adobe Stock models, 79–85

adding to scenes, 80–82
browsing for free, 80
modifying in scenes, 82–83
saving to your library, 84, 85, 162, 173, 190



searching via CC Libraries, 84–85, 162, 173
AI files, 163, 183, 186
Align to Scene option, 147, 159
artboards, 167, 168
assets

Adobe Stock, 80–85
Dimension starter, 27–29, 74–78

attributes, material, 123–125

B
Background Color layer, 261, 262
Background Image layer, 262, 263
background images, 186–197

adding to existing scenes, 191–194
auto-generated lights from, 188–189
custom environment light and, 210, 214
editing in Photoshop, 263–264
matching scenes to, 193–194, 195–196
methods for importing, 204
models added to scenes with, 189–191, 196–197
replacing in Photoshop, 262–263
starting projects with, 186–191

backgrounds, 184–204
2D built in Photoshop, 198–200
3D built in Dimension, 201–203
color of, 26–27, 171–172, 261–262
creating your own, 198–203
editing in Photoshop, 261–264
graphics used as, 163–165
importing images as, 51, 186–194, 204
matching perspective to, 187, 193, 195–196
review questions/answers on, 204
workflows for adding, 186

bitmap images
environment light and, 216
material properties and, 105

Blend Edge value, 125
blog, Dimension, 4
blue dot icon, 90



Blur Amount slider, 57
bookmarks

Home view, 56
naming/renaming, 44, 46, 163
rendering views from, 66
saving, 44, 46, 58
updating, 55

Break Link to Material icon, 111, 112, 114, 255
Bridge, Adobe, 192
Brightness/Contrast adjustment layer, 263
building new models, 222–257

3D design creation, 233–234
borrowing materials for, 253–255
breaking apart objects for, 247–250
extracting parts of models for, 250–252
Lego brick model, 225–228
planes used in, 242–247
review questions/answers on, 257
step and repeat for, 235–242
submarine model, 229–232

C
camera, 16, 42–58

adjusting, 37–38
bookmarks, 44, 55–56
Dolly tool, 50
explained, 44
Focus controls, 56–57
Horizon tool, 51–55
Orbit tool, 45–48
Pan tool, 48–50
review questions/answers, 58

camera bookmarks. See bookmarks
Camera Bookmarks icon, 38, 44, 55
Camera Bookmarks panel, 56
Camera icon, 121
Camera Raw Filter, 269
Camera Undo command, 16
camera views, 66



canvas, 17
render speed and size of, 70
sizing/resizing, 26, 41

Capture mobile app, 118–139
capturing materials with, 120–129
description and purpose of, 120
downloading and installing, 120
modifying materials from, 131–138
use of materials from, 130–131

capturing materials, 120–129
Classroom in a Book training series, 1
clicking, to select multiple objects, 142–144
Cloudiness slider, 214, 221
Color Overlay layer style, 265–266
color picker, 261
Color Sampler icon, 172, 212
Colorize option, 36, 212, 214
colors

background, 26–27, 171–172, 261–262
correcting in images, 269
environment light, 36
material, 102
sampling, 182

Content Aware Fill, 216
Content panel, 27–28
contrast adjustments, 264
Create Environment Light option, 211
creating models. See building new models
Creative Cloud Libraries

importing models from, 81
saving materials to, 125, 129
saving models to, 84, 85, 162, 173, 190
searching Adobe Stock via, 84–85, 162
storing assets in, 82

Cube model, 226, 244–245
customizing

environment light, 210–212
materials on models, 255–256

Cylinder model, 227, 229, 231, 246



D
default preferences, 4
Depth Information layer, 268
depth-of-field simulation, 56–57
Deselect All command, 144, 150
Design mode, 21, 24–41

background color change in, 26–27
camera adjustments in, 37–38
lighting adjustments in, 35–37
materials application in, 33–34
moving objects in, 29–30
new project creation in, 26
review questions/answers on, 41
rotating and scaling objects in, 32–33
starter assets in, 27–29

Detail value, 123
Dimension

described, 8
filename extension, 27
help content, 22
installing, 2
modes, 21–22
preferences file, 4
resources, 4–5
starting, 2, 10
steps in using, 9

Disc model, 242, 243, 246–247, 257
DN files, 27, 41, 171
Dolly tool, 50, 52–53, 54, 58
dragging-and-dropping

graphic files, 169, 192
materials onto objects, 98–99
models into scenes, 87

Drop model, 237
Duplicate command, 236, 257

E
editing



backgrounds in Photoshop, 261–264
graphics in Illustrator, 170–171

educator resources, 5
environment light, 208–212

adjusting, 35–36
Adobe Stock for, 215
bitmap images for, 216
creating custom, 210–212
experimenting with, 208–210
file formats for, 217, 221
image-based, 215
rotating, 35, 212
using custom, 214–216
See also sunlight

Esc key
backing out of materials view using, 98
selecting parent groups using, 151

export formats, 69
EXR image files, 217
eyeball icon, 14, 97, 151

F
FBX file format, 85
file formats

environment lights and, 217
standard for 3D models, 85
supported for graphics, 163, 183

files
info about lesson, 2, 3
limit on opening, 11

Filter by Models icon, 75
Focus controls

depth-of-field simulation and, 56–57, 58
render speed and use of, 70

forums, Adobe, 4
Frame All command, 46, 84, 202
Frame Selection command, 84, 248
Frequency value, 123



G
geometric models, 224–225
glass properties, 105–106
Glow property, 219, 220
Glowing material, 217, 219
graphics, 160–183

adding background, 163–165
advanced techniques for, 173–182
applying additional, 165–169
background color for, 171–172
dragging and dropping, 169, 192
editing in Illustrator, 170–171
file formats supported for, 163, 183
fixing overlap of, 178–182
materials distinguished from, 183
modifying properties of, 169
placing overlapping semitransparent, 174–178
renaming in Scene panel, 167
review questions/answers on, 183
saved in DN files, 171

grid
ground plane, 20, 45
perspective, 196

Grid view, 96
ground plane, 18–20

adjusting properties of, 37
grid lines on, 20, 45
objects positioned below, 90
See also planes

Group icon, 98–99, 104
Group Select option, 149–151, 159
groups

creating object, 77, 78, 228, 240
extracting models from, 248–249, 252
renaming models in, 163
selecting parts of, 149–151, 159
viewing models in, 99, 246

H



Hand tool, 12
hardware factors, 70
HDR image files, 217
height, sunlight, 214, 221
help content, 22
Hollow Sphere model, 233
Home view, 18, 56, 191
horizon line, 52, 53, 55, 195, 199–200
Horizon tool, 51–55, 195–196, 199, 204
horizontal plane, 202

I
IBL file format, 217
Illustrator

artboards from, 167
editing labels in, 170–171

Image as Background option, 51
Image as Light option, 216
image icon, 127
images

color correcting, 269
importing as lights, 216
noise in low-quality, 40, 69, 71
See also background images

importing
3D models from other sources, 85–88
Adobe Stock models from CC Libraries, 81
images as backgrounds, 186–194
images as lights, 216
potential problems with, 89–90

installing
Adobe Capture, 120
Adobe Dimension, 2

Intensity value, 123, 213

J
JPEG files, 163, 183, 186, 216, 217



K
keyboard shortcuts

for Content panel, 77
for grouping/ungrouping models, 77
for Render Preview window, 65
for selecting/unselecting, 144
for tools in the Tools panel, 12
for zooming in/out, 17

L
layers

Background Color, 261, 262
Background Image, 262, 263
Depth Information, 268
Material Selection Masks, 266–268, 270
Object Selection Masks, 264–266, 267

Layers panel, 260, 263
Learn icon, 22
Lego brick model, 225–228
lesson files, 2, 3
libraries. See Creative Cloud Libraries
licensing assets, 84, 85
lights, 206–221

adjusting, 35–36
auto-generated, 188
environment, 35–36, 208–212
file formats for, 217
glowing materials as, 217–220
importing images as, 216
review questions/answers on, 221
sunlight, 36, 189, 212–214
types of, 208, 221

Lights icon, 214
linking/unlinking materials, 111–116

breaking a link, 112–113
en masse material application, 111–112
independent material application, 113–114
Paste commands and, 115–116



Sampler tool and, 114–115
summary points about, 116

List view, 34, 96
Lock icon, 87, 193, 197

M
Magic Wand tool, 11

partial model selections with, 106–109, 117
Photoshop post-processing with, 265, 267
surface selections with, 152–154, 155, 178–179, 183

marquee selections, 144–149
masks, selection, 264–266
Match Background Aspect Ratio icon, 193
Match Camera Perspective option, 51, 195, 199
Match Image command, 51, 187, 193, 

195–196, 199, 204
Match Sunlight option, 195, 199, 213
Material Definition Language (MDL), 94
Material Selection Masks layer, 266–268, 270
materials, 92–117

adjusting attributes of, 123–125
applying to objects, 33–34, 96–100
bitmap images added to, 105
borrowing from other models, 253–255
capturing with Adobe Capture, 120–129
changing properties of, 102–106, 131–138
customizing on models, 255–256
dragging and dropping, 98–99
en masse application of, 111–112
finding sources of, 94–96
fixing seams visible on, 133–134
glowing, used as lights, 217–220
graphics distinguished from, 183
independent application of, 113–114
metallic value adjusted for, 137–138
naming/renaming, 125
Paste commands for applying, 115–116
Photoshop adjustments to, 266–268
previewing in Render Preview, 100–101



render speed and use of, 70, 97, 117
review questions/answers on, 117, 139
rotation adjustments for, 132, 156–157
Sampler tool for applying, 114–115
sampling from other models, 99–100
scaling relative to model, 132–133
sub-selecting model faces for, 106–110
summary of linking rules for, 116
surface detail adjustments for, 134–136, 155–157
unlinking instances of, 102, 111, 112–113

Materials icon, 33, 95, 219
memory, render speed and, 70
Metallic value, 102, 123, 138, 139, 169
Model icon, 28, 219
models

Adobe Stock as source of, 79–85
borrowing materials from, 253–256
breaking apart components of, 247–250
creating in Dimension, 222–257
Dimension starter assets as, 74–79
dragging and dropping into scenes, 87
extracting parts from, 250–252, 257
graphics applied to, 160–183
importing from other sources, 85–88
materials applied to, 33–34, 92–117
render speed and complexity of, 70
saving to CC Libraries, 84, 85, 162, 173, 190
sub-selecting parts of, 106–110
See also 3D models; building new models

More icon, 34, 96, 125
Move to Ground command, 90, 91, 201, 230
moving objects, 29–30

N
naming/renaming

bookmarks, 44, 46, 163
graphics, 167
groups, 163
materials, 125



NASA 3D models, 87
New project option, 162, 173
New Selection icon, 144
noise, image, 40, 69, 71
normal map, 123, 134–136

O
OBJ models, 85, 86–88, 91
Object Selection Masks layer, 264–266, 267
objects

breaking apart, 247–250
moving, 29–30
rotating, 32, 33, 41
scaling, 32
selecting, 142–151

on-canvas rendering, 62–64
online content, 2–3
Orbit tool, 45–48, 54
overlapping graphics

fixing problems with, 178–182
placing semitransparent, 174–178

P
Pan tool, 48–50, 58
panels

Actions, 14, 51, 164, 210
Camera Bookmarks, 56
Content, 27–28
exploring, 13–15

panels (continued)
Layers, 260, 263
Properties, 14–15, 30, 102–104, 106
Scene, 13–14, 29–30, 75, 98
Tools, 11–12

panorama images, 216
Partial Marquee Select option, 145, 146, 148, 159
Paste as Instance command, 116
Paste command, 115



perspective
automatically matching, 187, 193
manually adjusting, 195–196, 199, 204

perspective lines, 51, 52, 187, 193
photographs

capturing materials from existing, 125–129
taking to capture materials, 122

Photoshop
2D backgrounds from, 198–200
3D models created in, 89
backgrounds edited in, 261–264
color correcting images in, 269
graphics edited in, 170
masks for making selections in, 264–266
materials adjusted in, 266–268
opening rendered scenes in, 260
post-processing with, 258–270
viewing rendered scenes in, 39–40

Pipe starter asset, 28
Pivot property, 237, 240
pixel dimensions, 162
Place Graphic on Model icon, 164, 165, 167, 175, 181
Plane model, 201–203, 242–244, 257
planes, 242–247

alternative to, 244–247
rotation of, 201, 244
vertical and horizontal, 202
working with, 242–244
See also ground plane

PNG files, 67, 68, 216, 217, 260, 270
Pointillize filter, 268
positioning

default, for starter assets, 29, 41
imported model problems with, 90
objects with Properties panel, 30

post-processing, 258–270
backgrounds edited in, 261–264
color correcting images in, 269
masks for making selections in, 264–266
materials adjusted in, 266–268



opening rendered scenes for, 260
review questions/answers on, 270

preferences file, 4
previews

lighting, 208
material, 100–101
render, 20–21, 62–65

Prism starter asset, 28
properties

graphic, 169
ground plane, 37
material, 102–106, 131–138
visual explanation of, 102

Properties panel, 14–15
changing material properties in, 102–104
increasing/decreasing numeric values in, 106
pixel dimensions adjusted in, 162
positioning objects using, 30

proportional scaling, 32, 176
PSD files, 39, 69, 183, 186, 260, 270
Publish to Web feature, 21

Q
quality, render, 68–69

R
ray tracing, 62, 71
Reflection Opacity slider, 37
Reflection Roughness slider, 37
reflections

on-canvas previews and, 62, 64, 71
render speed and use of, 70

renaming. See naming/renaming
Render mode, 21, 38, 66–71

export formats, 69
Quality settings, 68–69
review questions/answers, 71
steps for using, 66–68



Render Preview window, 20–21, 64–65, 100–101, 208
Render Status panel, 68
rendering, 38–40, 60–71

explanation of, 62
export formats for, 69
multiple camera views, 66
on-canvas preview of, 62–64, 208
quality settings for, 68–69
Render mode options for, 66–68
Render Preview window for, 20–21, 64–65, 100–101, 208
speed of, 68–69, 70, 97

Repeat value, 124
repositories of 3D content, 88
resizing. See sizing/resizing
resources, Dimension, 4–5
review questions/answers

on 3D models, 91
on backgrounds, 204
on building new models, 257
on the camera, 58
on Design mode, 41
on graphics, 183
on lights, 221
on making selections, 159
on materials, 117, 139
on post-processing, 270
on Render mode, 71

rigged models, 79
rotating

environment light, 35, 212
materials, 132, 156–157
objects, 32, 33, 41
planes, 201, 244
sunlight, 214

Rotation icon, 132
rotation widget, 32, 33
rotational step and repeat, 237–242

steps in process of, 237–239
workaround for non-model points, 239–242

Roughness value, 103, 123, 137, 169



S
Sample Color icon, 182
Sampler tool, 11

borrowing materials using, 254–255
materials applied with, 99–100, 

114–115, 117
saving

Adobe Stock models, 84, 85, 162, 173, 190
camera bookmarks, 44, 46, 58
captured materials, 125
stock images, 129

scale widget, 32, 33
scaling

graphics, 165, 176
imported models, 89
materials, 132–133
objects, 32, 33
proportional, 32, 176
See also sizing/resizing

Scene panel, 13–14
backing out of, 98
graphics in, 166, 169, 176
moving objects using, 29–30
naming/renaming items in, 167
open vs. closed groups in, 75
practice of referring to, 142

scenes
background images added to, 191–194
introduction to rendering, 38–40
models added to, 80–82, 87, 189–191, 196–197

scrubby sliders, 106
seams, fixing in materials, 133–134, 139
searching Adobe Stock, 84–85, 162, 173
Select and Move tool, 11, 12, 142–143, 144, 145, 147, 150
Select and Rotate tool, 11, 32, 33, 201, 212, 237, 240
Select and Scale tool, 11, 32, 33, 226, 227, 232
Selection Size slider, 153, 154
selection tools

changing options for, 144



selecting objects using, 142–151
selection widget, 164
selections, 140–159

clicking for multiple object, 142–144
Group Select option for, 149–151
Magic Wand tool for surface, 152–154, 155
marquee select for multiple object, 144–149
masks for making in Photoshop, 264–266
review questions/answers on, 159

semitransparent graphics, 174–178, 262, 270
Set Focus Point button, 57
Shift key

for property value changes, 106
for proportional scaling, 32, 176
for selecting/unselecting, 144, 154

shopping cart icon, 84, 85, 162, 173
simulations, depth-of-field, 56–57
sizing/resizing

canvas, 26, 41
selections, 153, 154
See also scaling

SKP file format, 85
Smart Filters, 269
Snapshot icon, 68
speckled appearance, 97, 117
speed, render, 68–69, 70, 97
Sphere model, 230, 231, 240
Star model, 108–110
Start screen, 4, 10
starter assets, 27–29, 74–78

examination of, 74–77
geometric models as, 224–225
modification of, 77–79
positioning of, 29, 41

step and repeat, 235–242
Dimension process for, 235–236, 257
rotational, 237–242

STL file format, 85
stock sources for 3D content, 88

See also Adobe Stock models



Studio Panels Light option, 215
submarine model, 229–232
Subtract from Selection icon, 143, 154
sunlight

adjusting, 36, 189, 213–214
experimenting with, 212–214
options for, 189, 213–214
rotating, 214
See also environment light

surfaces
adjusting detail of material, 134–136
changing materials applied to, 155–158
graphics applied to model, 160–183
selecting with Magic Wand tool, 

152–154, 155
SVG files, 94

T
Temperature slider, 269
textures, Adobe Stock, 127–128
TIFF files, 163, 183, 186
Toggle Fullscreen icon, 64, 208
Tools panel, 11–12
tooltips, 11
Translucence properties, 105–106
transparency, graphic, 173, 174, 262
Trash icon, 244, 249, 251
tutorials, 4

U
Undo command, 16
Undo Edit Graphic option, 164
Ungroup command, 242
Unlink icon, 102
unlinking materials. See linking/unlinking materials
updating camera bookmarks, 55

V



vertical plane, 202

W
Web Edition of book, 3
web resources, 4–5

X
X icon, 33
x-axis, 31

Y
y-axis, 31

Z
z-axis, 31, 41
zero point, 29
Zoom to Fit Canvas option, 162, 173
Zoom tool, 12, 17
zooming in/out, 17
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